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Production Note 
This book was produced with the VAX DOCUMENT electronic 
publishing system, a software tool developed and sold by 
DIGITAL. In this system, writers use an ASCII text editor to 
create source files containing text and English-like code; this code 
labels the structural elements of the document, such as chapters, 
paragraphs, and tables. The VAX DOCUMENT software, which 
runs on the VMS operating system, interprets the code to format 
the text, generate a table of contents and index, and paginate the 
entire document. Writers can print the document on the terminal 
or line printer, or they can use DIGITAL-supported devices, such 
as the LN03 laser printer and PostScript printers (PrintServer 
40 or LN03R ScriptPrinter ), to produce a typeset-quality copy 
containing integrated graphics. 
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About This Guide 

Purpose of This Guide 
This guide describes how to use the VMS DECwindows desktop 
applications. 

Who Should Use This Guide 
This manual is intended for all VMS DECwindows users. 

Structure of This Guide 
This guide covers the following topics: 

• Chapter 1 describes how to use the Bookreader. 

• Chapter 2 describes how to u~e the Calculator. 

• Chapter 3 describes how to use the Calendar. 

• Chapter 4 describes how to use the Card.filer. 

• Chapter 5 describes how to use the Clock. 

• Chapter 6 describes how to use the DDIF Viewer. 

• Chapter 7 describes how to use DECterm. 

• Chapter 8 describes how to use the Extensible VAX Editor 
(EVE). 

• Chapter 9 describes how to use Mail. 

• Chapter 10 describes how to use the Notepad editor. 

• Chapter 11 describes how to use Paint. 

• Chapter 12 describes how to use the Puzzle. 

xiii 



• Appendix A describes how to compose characters. 

• Appendix B illustrates the National Replacement Character 
Sets. 

For More Information 

Conventions 

mouse 

MBl, MB2, and MB3 

xiv 

Although VMS DECwindows users need not be familiar with 
the VMS operating system or DCL, they can increase their 
understanding of DECwindows by becoming familiar with some of 
the topics addressed in the VMS General User's Manual. For more 
information about using DECwindows, users should see the VMS 
DECwindows User's Guide, which explains basic DECwindows 
tools and covers such topics as File View, the Session Manager, 
how to print files, and running remote applications. 

Other associated documents for specific applications are as follows: 

• DECterm: 

DECterm Text Programming Manual 
DECterm Graphics Programming Manual 

• DDIF Viewer and Mail: 

VMS Compound Document Architecture Manual 

• EVE: 

VAX Text Processing Utility Manual 
Guide to VMS Text Processing 

• Mail: 

VMS Mail Utility Manual 

Refers to any pointing device, such as a mouse, a puck, or a 
stylus. 

MBl indicates the left mouse button. MB2 indicates the 
middle mouse button. MB3 indicates the right mouse button. 
(The buttons can be redefined by the user.) 

In procedures, a sequence such as I Ctrl/x I indicates that you 
must hold down the key labeled Ctrl while you press another 
key or a pointing device button. 

In procedures, a sequence such as IPFl I~ indicates that you 
must first press and release the key labeled PFl, then press 
and release another key or a pointing device button. 



blue-green ink 

boldface text 

In procedures, a key name is shown enclosed to indicate that 
you press a key on the keyboard. 

Blue-green ink indicates information that you must enter 
from the keyboard or a screen object that you must choose or 
click on. For online versions, user input is shown in bold. 

Boldface text represents the introduction of a new term. 
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1 
Using the Bookreader 

The Bookreader lets you read online documentation on your 
workstation screen. 

This chapter describes how to 

• Start the Bookreader 

• Open shelves and books 

• Navigate the table of contents and index 

• Read text and display :figures, tables, and examples 

• Exit from the Bookreader 

Starting the Bookreader 
To start the Bookreader, choose the Bookreader menu item from 
File View's Applications menu. 

The selection window opens, listing the library of shelves and 
books available from the Bookreader, as illustrated in Figure 1-1. 
Shelves contain groups of related books to make the process of 
locating the book you want simpler. To view a book that is on a 
shelf, you must first open that shelf. 
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Figure 1-1 Bookreader Library 
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Opening Shelves and Books 
To select a title, position the pointer on the desired title and click 
mouse button 1 (MBl). To open a shelf or book, select the title you 
want and choose the Open Shelf or Open Book menu item from 
the Control menu. Alternatively, you can double click MBl on a 
title to select and open that book or shelf. If you open a shelf, a 
list of the books on that shelf appears in the selection window. If 
you open a book, the table of contents for that book appears in the 
selection window. The title page for the book appears in a second 
window, called the topic window. The two windows, selection 
window and topic window, are illustrated in Figure 1-2. 
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Figure 1-2 Bookreader Selection and Topic Windows 
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Selecting Topics from the Table of Contents 
You can display a chapter or section from the table of contents 
by selecting the title and choosing the Topic menu item from the 
View menu. Or, you can point to the title you want and double 
click MBl. The text appears in the topic window. 

Selecting Topics from the Index 
To view the index, choose the Index menu item from the View 
menu or click on the Index button at the bottom of the selection 
window. The index replaces the table of contents in the selection 
window. (To return to the table of contents, choose the Table of 
Contents menu item from the View menu or click on the Contents 
button at the bottom of the selection window.) 

To view the section that corresponds to an index entry, select the 
entry from the index and choose the Topic menu item from the 
View menu. Alternatively, you can double click on the desired 
entry. The text appears in the topic window. 

If an entry applies to more than one section, the Bookreader 
displays a pop-up menu listing all the sections in which the entry 
appears. Click on the section you want to view. 
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Navigating the Table of Contents and Index 

0 

~ 

Reading Text 
Using the Bookreader 
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AllRi;htlF!e>MMd. 

Using the Bookreader 
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For easy navigation of the table of contents and index, use the 
vertical scroll bar on the selection window. The vertical scroll 
bar represents the entire table of contents or index. The slider 
represents: 

• The position in the table of contents or index relative to the 
entire table of contents or index 

• The relative portion of the table of contents or index that 
appears in the selection window 

There are several ways to use the scroll bar to navigate: 

• You can drag the scroll bar with MBl to navigate quickly up 
or down the table ·of contents or index. For example, if you 
drag the slider to the bottom of the scroll bar and release 
MBl, the end of the table of contents or index appears in the 
selection window. 
As you drag the slider, an index window displays the entries 
represented by that region of the scroll bar. Release MBl to 
bring that region into the selection window. 

• You can click MBl on the area above or below the slider to 
bring the previous or next window of entries into the selection 
window. 
For example, if you are looking at the table of contents entries 
for Chapter 2 and click MBl in the area above the scroll bar, 
the immediately preceding window of entries for Chapter 1 
will scroll into the window. 

• You can click on the stepping arrows to move one entry at a 
time up or down through the table of contents or index. 

When you select a text topic from the table of contents or index, 
it is displayed in the topic window. You can read forward and 
backward from that topic by clicking on the Next Topic and 
Previous Topic buttons at the bottom of the topic window, or by 
choosing the corresponding menu items from the View menu. 

The length of some topics is greater than the length of the window. 
Use the scroll bar, as in the selection window, to navigate up and 
down the topic. For example, click MB2 on the scroll bar to bring 
the line of text directly across from the pointer to the top of the 
topic window. 
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Displaying Figures, Tables, and Examples 
When you select a topic that is a figure, table, or example from 
the table of contents, it is displayed in a separate window. The 
window is sized according to the dimensions of that topic. If 
the topic is large-for example, if its dimensions exceed the 
dimensions of the screen-the window will have scroll bars to 
navigate the topic. 

The windows that figures, tables, and examples are displayed in 
must be explicitly closed by clicking on the Close Topic button or 
by choosing the Close Topic menu item from the Control menu. 
These windows can also be made into icons, allowing you to save a 
topic for as long as you need to refer to it. 

Using Cross-References and Footnotes 
Cross-references in text to figures, tables, and examples are "hot 
spots." That is, if you point at the reference and click MBl, the 
figure, table, or example is displayed in a separate window. For 
example, clicking on Figure 1-1 on the screen produces a display 
of that figure. 

Cross-references to other sections of text are similarly hot, except 
that the cross-referenced topic replaces the current topic in the 
topic window. For example, clicking on Chapter 1 on the screen 
causes that chapter to appear in the topic window. Footnotes are 
also hot spots. 

Closing Shelves and Books 
To close a book or shelf, click on the Close Book, Close Shelf, or 
Library button at the bottom of the selection window. Clicking on 
the Close Book button takes you back to the shelf from which that 
book was selected. Similarly, clicking on the Close Shelf button 
takes you back to the window from which that shelf was selected. 
When you are viewing a shelf, clicking on the Library button 
takes you back to the "top shelf," or in other words, the top level 
of the Bookreader library. 

Exiting from the Bookreader 
To exit from the Bookreader, click on the Quit button while 
viewing the library, or select the Quit menu item from the Control 
menu in the selection window. 

Using the Bookreader 1-5 









2 
Using the Calculator 

The Calculator performs simple arithmetic functions-addition, 
subtraction, multiplic~tion, division-and computes percentages 
and square roots. Unlike a handheld calculator, it has two 
displays. The top display is the accumulator, which shows the 
number being entered or the current result, and the bottom 
display is the memory. 

This chapter describes how to 

• Start the Calculator 

• Enter data 

• Perform arithmetic functions 

• Use the memory 

• Transfer data to or from other applications 

• Exit from the Calculator 

Starting the Calculator 
To start the Calculator, choose the Calculator menu item from 
File View's Applications menu. 

A small calculator is displayed on your screen. You can move and 
change the size of the Calculator window as you wish. 
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Operating the Calculator 
You can use Calculator with either the mouse or the keyboard. 

With the mouse, point to the appropriate button and click MBl. 

From the keyboard, enter the numbers 0 to 9 from the main 
keyboard or the keypad. Press the Shift key to enter the 
arithmetic functions(+,-,*, I,%,=) from the main keyboard. 
From the keypad, pressing. the following keys produces the 
corresponding functions: 

Press To Produce 

PFl I 

PF2 square root 

PF3 * 
PF4 % 

comma key + 
Enter or Do = 

F17 MC 
F18 MR 
F19 M+ 
F20 M-
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Clear Memo 

Change Sign 
of Accumulate 

Clear Accumulate 

Clear Last Entry 
from Accumulator 

Accumulator 

Subtract Contents 
of Accumulator 
from Memory 

Add Contents 
of Accumulator 
to Memory 

Replace Contents 
of Accumulator with 
Contents of Memory 
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When you enter data into the accumulator, notice that Calculator 
uses a decimal point to distinguish between random digits and an 
operand. See what happens as you enter the following data: 

Enter 1134 and notice that no decimal point appears in the 
accumulator. 

2 Enter a plus sign ( + ). Calculator inserts a decimal point after 
the digits 1134 to signify the completion of an operand. 

Depending on the contents of the accumulator, you can use one of 
the following methods to correct mistakes in computation: 

• Press the~ (Delete) key to erase the last digits entered in 
the accumulator. 

• Click on the CE button to void the last operand entered. 

• Choose the Undo menu item from the Edit menu to reverse 
the last operation, for example, to restore the last operand or 
to remove the previous paste operation. 

Performing Arithmetic Functions 
Calculator displays numbers in the range of plus or minus 
999,999,999. It performs all calculations in left to right order and 
treats operators with equal importance. 

For example, to evaluate the equation 6 + 5 * 3: 

Find the sum of 6 + 5. 
Calculator displays an 11. 
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2 Figure the product of 11 * 3. 
The result is 33. 

Also note the way Calculator computes percentages. For example, 
to determine 6 percent of 195: 

Enter 195. 

Calculator displays the digits in the accumulator. 

2 Enter * and Calculator inserts a decimal point. 

3 Enter 6. 

The number 6 is displayed in the accumulator. 

4 Enter%. 

The result, 11. 7, is displayed in the accumulator. 

Storing Values in Memory 
Use the memory display to store results and values for later 
computation. The figure in memory starts out as zero. You can 
add the contents of the accumulator to memory or subtract the 
contents of the accumulator from memory, using the M+ and 
M- buttons, respectively. To enter the contents of memory into 
the accumulator, click on the MR button. Clear the contents of 
memory with the MC button. 

Copying Text with the Calculator 

Undo 
Copy 

Paste 

You can copy numbers from other applications into the 
Calculator's accumulator and from the Calculator accumulator or 
memory into another application. 

Use the Copy menu item from the Edit menu to transfer data 
from the active display in the Calculator window to another 
application window. For example: 

1 Click on the accumulator display. 

2 Enter a number into the accumulator. 

3 Choose the Copy menu item from the Edit menu. Or, for 
greater speed, press and hold MB2 to display a pop-up menu 
and choose the Copy menu item. 

Now you can paste the data to another application window. 
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Use the Paste menu item from the Edit menu to copy data from 
another application. This data can be copied directly from another 
window, or it can be the result of an equation copied from another 
window. Calculator treats the contents of a paste operation just 
as if you typed in the data from the keyboard yourself. 

~Card: August_inventory mm 
File Edit Search Card 

Brand X 

~Calculator mm 
File Edit Help 

99537.6 

Hel 

6 

II====....---• I MC 11 tl.7 l Q 
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Exiting from the Calculator 
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To exit from the Calculator, choose the Quit menu item from the 
File menu. 
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3 
Using the Calendar 

The Calendar combines the functions of a desktop calendar and 
an appointment book to help you keep track of your meetings and 
plan your time. The Calendar enables you to look at a year or 
month display, or to review your scheduled appointments a day at 
a time. 

You can also create several different calendars to use for specific 
purposes. For example, you could create one calendar to keep 
track of your personal engagements, and another calendar to 
schedule conference room reservations. 

This chapter describes how to 

• Move around Calendar 

• Create and delete entries 

• Set alarms and repeat entries 

• Move entries 

• Use Calendar's clock 

• Mark special days 

• Print part of a calendar 

• Work with multiple calendars 

• Create, rename, and delete a calendar 

• Customize a calendar 

• Exit from Calendar 
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Starting the Calendar 
To start the Calendar, choose the Calendar menu item from 
File View's Applications menu. 

The month display appears on your screen. 

lrn C81endar:DISK$[JONES]DECW$CALENDAR FILE.DWC;Qlij] 

Fiie Edit View Timeslot Options Hebl 
.0 

April, 1990 

Wk Sun Mon Tue Wed Thu Fri Sat 

14 1 2 3 4 5 6 7 
15 8 9 10 11 12 13 14 
16 15 16 17 18. 20 21 

17 22 23 24 25 26 27 28 

18 29 30 ...., 

" 1 2 3 4 5 
Q 
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The month display shows the current month and year, with the 
days in the month arranged in weekly rows. The current day has 
a box around it. 

Moving Around Calendar 

0 

~ 
Calendar has three main displays: the month display, the day 
display, and the year display. The year display looks like 12 small 
month displays set out in a 4 by 3 matrix. 

Scroll bars allow you to move backwards and forwards within a 
display, for example, to look at a future or a previous month when 
you are in a month display. 

To move from one type of display to another, double click on the 
appropriate item in the current display. For example, double 
clicking on one of the days visible in the month display opens the 
day display. Alternatively, double clicking on a month name in the 
year display opens the display for that month. 

From the View menu, you can choose the Selected, Today, Day, 
Month, and Year menu items. Choosing the Today menu item 
displays the current day. To choose the Selected, Day, Month, and 
Year menu items, you must first select a day. 
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Creating an Entry 
By double clicking on a particular day, you can open a display that 
shows timeslots from 8:00 a.m. to 5:30 p.m. Use the scroll bars 
to display timeslots earlier or later than the times shown. You 
can type entries, such as appointments, directly into the timeslots. 
Or, by using the timeslot editor, you can type longer entries, 
set alarms to remind yourself of appointments, and broadcast 
appointment reminders to yourself at designated intervals. 

To record a short entry directly into a day display: 

Display the day in which you want to make the entry. 

llfil CALENDAR:WORK:[JONES]ANNA KLEIN CALDWC 10@: 
File Edit View Timeslot Options Help 

April, 1990 May,1990 
Wk Sun Mon Tue Wed Thu Fri Sat Wk Sun Mon Tue Wed Thu Fri Sat 
14 1 2 3 4 s 6 7 18 1 2 3 4 5 
15 8 9 10 11 12 13 14 19 6 7 8 9 10 11 12 
16 15 16 17 18 1111 20 21 20 13 14 15 16 17 18 19 
17 22 23 24 25 26 27 28 21 20 21 22 23 24 25 26 
18 29 30 22 27 28 29 30 31 

1¢ _J _J i>I 
Thursday the 19th of April, 1990 

8:00am 0 
-30- Breakfast meeting with accountants 
9:00 

-30-
10:00 
-30-
11:00 Leave for Heathrow - 12:05 flight 
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12:00..J!..m 
-30- I 
1:00 
-30-
2:00 
-30-

I 3:00 Meet with Mireille, Rue Ste. Germaine; bring receipts. ,., 
4:30 
5:00 ...... 
-30- Q 

I Previous Day I 12:21pm I I Next Day I 
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2 Click (and drag to resize, if necessary) on the desired time in 
the day display. 

3 Enter the text in the timeslot. 

4 Click on the time again. 

When a day has at least one entry in it, its day number 
changes from a normal font (nn) to an italic font (nn) 
wherever it is displayed. You can then distinguish between 
days containing appointments and free days in the month and 
year displays. 

To create a longer entry using the timeslot editor: 

Click on the desired timeslot in the day display. 

2 Choose the Edit... menu item from the Timeslot menu or 
double click on the desired timeslot. 

The timeslot editor is displayed. 

File Edit Help 

Thursday the 19th of April, 1990 
From: 8:30am To:9:00am 
I Breakfast meeting with accountants 0 

0 
0 

Alarms At: Ill Entry Time 

5 30 2 
Ill I IE I D ! [] D ! rn ! 

Minutes Minuh.~ Hours 
Before :Befon~ :Befm.·f: 

@None 

Repeat 
0 Daily 
0 Weekly 

Interval 0 Every Fortnight 
0 Every Four Weeks 

I OK I I Delete Entry I I Reset II Cancel I 
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3 Enter the text and adjust the alarms and repeat intervals as 
required (see the sections Setting Alarms and Making Repeat 
Entries).). 

The timeslot editor uses standard VMS DECwindows editing 
commands. 

4 Click on the OK button to confirm the entry and to dismiss 
the timeslot editor. 

If you exit from the editor without having entered any text or if 
you delete all the text describing a previous entry, the timeslot 
remains unscheduled. 

Changing the Size of a Timeslot 
To enlarge a timeslot, press MBl on the time you want to use as 
a starting point and drag the top edge of the timeslot up, or the 
bottom edge of the timeslot down. The timeslot is redrawn to the 
new size. 
You can also use this method to reduce an entry that occupies 
multiple timeslots. To reduce an entry that occupies multiple 
timeslots, you must first drag the pointer outside the border of 
the timeslot and then drag it back in. If you reduce the size of a 
timeslot, some text may no longer fit in the display, but it is not 
lost. The text reappears if you expand the timeslot again. 
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Setting Alarms 
By default, when you type an appointment entry in the timeslot 
editor, alarms ring and a message is displayed five minutes before 
the appointment and at the time of the appointment. You can 
disable these options by clicking on them. 

You can set alarms to ring at any combination of the following 
times: 

• At the time of the scheduled appointment (this is on by 
default) 

• 1 to 15 minutes before the time you specified for the entry 
(this is on by default, with 5 minutes as the preset option) 

• 1 to 60 minutes before the time you specified for the entry 

• 1 to 24 hours before the time you specified for the entry 

To set one or more alarms: 

1 Click on the desired timeslot in the day display. 

2 Choose the Edit... menu item from the Timeslot menu. The 
timeslot editor is displayed. 

3 Write the entry if you have not already done so. 

4 Click on the desired toggle button to set an alarm. 

Unless you specify otherwise, alarms ring 5 minutes before 
the entry time and at the entry time. 

5 Move the arrow in the scale to adjust to the time you want. 

6 Click on the OK button to save the settings and to dismiss the 
timeslot editor. 
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Deleting an Entry 
To remove or clear the contents of a timeslot: 

Click on the timeslot in the day display that contains the 
entry you want to delete. 

2 Choose the Edit... menu item from the Timeslot menu. The 
timeslot editor is displayed. 

3 Click on the Delete Entry button. 
A dialog box is displayed, asking you to confirm that you want 
to delete the entry. 

4 Click on Yes to confirm that you want to delete the entry. 

Making Repeat Entries 
Often, entries in a calendar are regular events. Calendar makes it 
easy to schedule these events by allowing you to specify the time 
interval at which the entry should be repeated. 

You can repeat an entry at the following intervals: 

• None 

• Daily 

• Weekly 

• Every fortnight (two weeks) 

• Every four weeks 

These settings are made from the timeslot editor. To set a repeat 
interval for an entry: 

Click on the timeslot in the day display that has the first 
occurrence of the entry. 

2 Choose the Edit... menu item from the Timeslot menu. The 
timeslot editor is displayed. 

3 Write the entry if you have not already done so. 

4 Choose the repeat interval you want by clicking on the 
appropriate option button. 

You can choose only one repeat interval at a time. The preset 
option is None. 

5 Click on the OK button to save the settings and to dismiss the 
timeslot editor. 
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If you change or delete an entry that is repeated, a dialog box is 
displayed, asking if you want to make the change or deletion in 
just this instance, from this point on, or every time, including past 
instances. 

Moving an Entry from One Timeslot to Another 

Cut 

Copy 

Paste 

Clear 

You can copy or move the entire contents of an entry, or just a 
piece of text, to another timeslot. If you select the time, then 
any alarms or repeat intervals associated with the entry are 
transferred, along with the text, to the new timeslot. Selecting 
just the text from the timeslot transfers just the text. 

To move an entry from one timeslot to another: 

Select All Display the day that has the timeslot you want to move. 

2 To select the entire entry from a timeslot, click on the time. 

To copy just a piece of text, select it by clicking and dragging 
the pointer over the portion of text you want. 

3 Choose the Cut or Copy menu item from the Edit menu. 
If you want the entry to remain in the original timeslot, 
choose the Copy menu item. If you want to delete the entry 
from the original timeslot, use the Cut menu item. 

4 If you are moving the entry to a different day, display the new 
day. 

5 Click on the time to which you want to move or copy the entry 
or text. 

6 Choose the Paste menu item from the Edit menu to insert the 
entry or text in the new location. 

If you are moving the whole entry (time and text) and you want 
to move it to the same time on a different day, you do not have to 
display the new day. After selecting the desired day in the month 
or year display, choose the Paste menu item from the Edit menu. 
This causes the entry to be inserted on that day, at the same time. 

Using the Clock in the Day Display 

I 2:21pm I The clock provides a digital display of the current time. When you 
click on the clock, the day display returns to the current day if you 
have been displaying a different day. Clicking on the clock also 
causes the timeslots visible in the day display to adjust so that 
the first timeslot contains the time in the current increment that 
directly precedes the actual time. For example, if the timeslots in 
the day display are set to be in half-hour intervals and you click 
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on the clock at 10:57, the day display will adjust so that the first 
timeslot contains the time 10:30. 

This adjustment is continuous; as a timeslot passes, it is scrolled 
off the top of the display. Thus the display is kept as current as 
possible. This is convenient if you significantly reduce the size of 
the day display, because it keeps the most immediate timeslots in 
view. 

To stop this automatic scrolling, move the timeslot by any other 
method, such as adjusting the scroll bar. 

If you are making an entry in a timeslot when it is due to be 
s~rolled, it does not disappear. The scroll mechanism waits until 
the next interval is over and then catches up. 

The Show AM/PM customizing option allows you to choose 
between a 12-hour and 24-hour clock. Whichever clock you choose 
is reflected by all times and clocks displayed by Calendar. 

Marking Special Days 

1!!!!!!!!!!!!!!!!!!!!!!6=EI Defimit 
Work Day 

Non-Work Day 

Special 

You can mark days of particular importance, such as major project 
milestones, holidays, or birthdays. Marking particular days alters 
the display font so that those days can be distinguished from 
other days in the various Calendar displays. 

To mark a day: 

Select the desired day from any of the Calendar displays. 

2 Pull down the Options menu and display the Mark submenu. 
Whichever menu item is currently in use for the selected day 
is dimmed in the submenu. 

3 Choose the desired menu item from the Mark submenu: 

Choose 

Work Day 

Non-Work Day 

Special 

Default 

To Produce 

Bold font. 

Standard Calendar font. 

Bold, larger font; on color workstations, displayed 
in red font. 

The standard Calendar font the day had before 
it was previously marked with the Work Day, 
Non-Work Day, or Special menu item. 

The day is marked in the specified manner. 
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Printing a Part of a Calendar 

Open ... 

Close 

Name As ••. 
Delete ... 

..... -..... -..... 
Print ... 

Include ••. 

Exit 

You can copy a timeslot entry or all of the entries in a day or a 
week to a printable file. 

To print a part of a Calendar display: 

2 

3 

Display the day that relates to the entry or entries you want 
printed. 
For example, if you are printing a timeslot, display the day 
that contains the timeslot. If you are printing the entries in 
a day, display the day itself; to print the entries in a week, 
display a day that falls in that week. You can also select the 
day or week number that you want to print from any display 
in which it appears. 

Click on the time, day number, or week number, as 
appropriate. 

Choose the Print... menu item from the File menu. 
Calendar displays a dialog box. 

Thursday the 19th of April, 1990 

From: 12:00pm To: 12:30pm 

Output Ale NamellDECW$CALENDAR.US 

• Create New Fiie 
0 Append to Ale 

10 
D Limit Lines per Entry l..___..[1 .... .L.._ ___ _.. 

lines per Entry 

II OK u 
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The dialog box shows the time period you have selected and 
provides a default name for the file you want to print. It also 
enables you to limit the number of lines you want printed 
per entry by clicking on the Limit Lines per Entry option and 
moving the arrow in the scale to set the desired limit. 

4 Change the default name provided by the dialog box if you 
want, and then confirm your request by clicking on the OK 
button. 

3-1 O Using the Calendar 



The requested section (timeslot, day, or week) is copied to the 
named file. You can then send the file to a printer. 

Working with Multiple Calendars 
LDWC b!I 

Aprll,1990 

_f!!!._EdllYlow-

Aprll,1990 
WI; Sun Mon Tue Wed Th.I Fri Sd: 

14 1 2 3 4 5 • 7 
15 8 • 10 11 12 13 14 

1s 1s 1• 11 1• 11 20 21 

17 22 23 24 25 26 rt 28 

18 29 30 

1 2 a • s 

You can create, open, save, print, and delete calendars. You 
can create different calendars to use for specific purposes. 
For example, you could designate one calendar for business 
appointments, and another for social engagements. 

Creating a New Calendar 
To create a new calendar: 

Choose the Open... menu item from the File menu. 
Calendar displays a dialog box. 

File Filter 

IISYS$LOGIN:*.DWC 

Files in DISK$:(JONES] 

:s)ANNA_KLEIN_CALDWC;1 

:S]ANTONIO_VIVALDl_CALDWC;1 

:S]DECW$CALENDAR_ALE.DWC;1 

¢1 I IJi> 

Selection 

6 

~ 
Q 

Filter I 
OK ~ 

I cancel I 
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2 Enter a unique file name (the default file type is DWC) for the 
new calendar in the Selection text entry field, and click on the 
OK button. 
A dialog box is displayed asking if the calendar currently 
being displayed should be replaced by the new calendar or if 
you want to keep both calendars on the screen at the same 
time. Click on Replace to display the new calendar in place of 
the old calendar, or on New to display both calendars at the 
same time. 
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3 Calendar asks if you want to create a new file. Click on Yes to 
create a new calendar. 

By default, the new calendar is presented in a month display 
containing the current day. 

The calendar file name can be changed later (see the section 
Renaming an Existing Calendar). 

Opening an Existing Calendar 
To open an existing calendar: 

Choose the Open... menu item from the File menu. 
Calendar displays a dialog box that prompts you for the name 
of the calendar you want to open. The file list box lists the 
names of any calendar files in the current directory; that is, 
files that have the type DWC. 

2 Select the name of the file you want to view and click on OK. 

If you want to open a calendar file that is not listed, enter 
the name of that file in the Selection text entry field and 
click on the OK button. Or, use the File Filter text entry 
field to list a subset of files that you can then select from. 
For example, to list all files in another directory with the 
file type DWC, enter the complete directory specification­
[JONES.STAFF]* .DWC-in the File Filter text entry field and 
click on the Filter button. Then double click on the file name 
of the calendar you want to open. 
A dialog box is displayed asking if the calendar currently 
being displayed should be replaced by the new calendar or if 
you want to keep both calendars on the screen at the same 
time. Click on Replace to display the new calendar in place of 
the old calendar, or on New to display both calendars at the 
same time. 

If you specify the name of a calendar that you are not allowed 
to read, the Open operation fails and a message box is 
displayed explaining the cause of the failure. 

3 The calendar is opened. 
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Renaming an Existing Calendar 
To rename the current calendar, choose the Name As... menu item 
from the File menu. 

A dialog box is displayed. 

New File Name r 
i.:;.._~~~~~~~-

II OK II I Cancel I 

ZK-0238A-GE 

Enter the new calendar name and click on OK. Calendar 
supplies the file type DWC by default. You can rename only 
those calendars in which you are allowed to write. 

Closing a Calendar 
Choose the Close menu item from the File menu to close the 
current calendar. 

Deleting a Calendar 
Choose the Delete... menu item from the File menu to delete 
a calendar. Calendar displays a dialog box asking whether you 
really want to delete the calendar. If you do not have sufficient 
privileges to. delete the specified calendar, an error message is 
displayed. 

Customizing a Calendar 

~hangeSettings ... 
~l~veSettlngs 

Restore Settings 

Use Defaults 

Many different features can be changed to customize the 
appearance and behavior of the various displays presented 
by the Calendar. All of these changes are made from the Options 
menu by displaying the Customize submenu and choosing the 
Change Settings ... menu item. 

Calendar displays a dialog box. 
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Calendar Settings [!i.l] 
Dav Disolav: First Day 

of Week 
Work 
Week Timeslot Size 

•.......... 
o ......... . 
0 ......... . 
0 ......... . 
o ......... . 
o ......... . 
0 ......... . 

D Sunday 
Ill Monday 
Iii Tuesday 
Iii Wednesday 
Iii Thursday 
Iii Friday 
D Saturday 

D Fill Blank Davs in 
Month Display 

First Display 

0 1 Hour 
• 30Minutes 
O 15Minutes 
0 5 Minutes 

Iii Show Months 
lil Show AM/PM 

Working Hours 

Start [!f§}am 

Finish @] §} pm 

Date for Week No. 1 
4 

•January 
0 February 
0 March 
0 April 
OMay 
OJune 
0 July 
0 August 
0 September 
0 October 
0 November 
0 December 

0 Year Display 
• Month Display 
0 Day Display 

D Start lconized lil Include Week Numbers 

ij OK Ill Apply 11 Reset 11 Cancel I 
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Shaded buttons indicate the current settings. Click MBl on a 
button or its label to change the setting. Click on the Apply 
button to apply your changes without closing the dialog box. Click 
on the Reset button to restore the dialog box defaults. Click on 
the OK button to apply your changes and close the dialog box. 

From this dialog box, you can modify any of the following calendar 
features: 

First Day of Week 
Unless you specify otherwise, the first day of the week is Sunday, 
as indicated by a shaded option button. You can designate another 
day as the first day of the week by clicking on it. 

Work Week 
Normally, Calendar designates Monday through Friday as the 
work week, as indicated by the shaded toggle buttons immediately 
to the left of the days. You can change the settings by clicking on 
the days you want to use for your work week. 

Fill Blank Days in Month Display 
Unless you specify otherwise, Calendar leaves the days not filled 
by the current month blank. When you turn on the Fill Blank 
Days in Month Display option, Calendar fills the blank days at 
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the beginning and end of the current month with the dates of the 
preceding and following months. 

First Display 
When you start Calendar, the month display appears on your 
screen by default. You can click on Year Display or Day Display to 
choose either of those options to be the first display you see when 
you start Calendar. 

Start lconized 
Normally, when you start Calendar you see a display of the 
current month. By turning on the Start Iconized option, you can 
cause Calendar to start as an icon. 

Day Display: Timeslot Size 
By default, the day display has timeslots broken up into 30-
minute intervals. You can choose 1-hour, 15-minute, or 5-minute 
intervals instead. 

Show Months 
Unless you specify otherwise, Calendar displays the current and 
next month at the top of a day display. You can disable this option 
by turning off the Show Months option. 

Show AM/PM 
By default, Calendar has a 12-hour time system that uses AM and 
PM in its day display to differentiate timeslots. If you disable the 
Show AM/PM option, Calendar uses a 24-hour time system in its 
day display, for example, 1 p.m. becomes 13:00, and so on. 

Working Hours 
Calendar uses the preset options 8:30 a.m. to 5:30 p.m. for 
working hours. A vertical line to the left of the day display 
indicates your current working hours. You can change these 
values by clicking on the appropriate box to set the time you want. 

Date for Week No. 1 
In every month display, the leftmost column lists the number of 
each week. This is in effect as long as the Include Week Numbers 
option is turned on. By default, weeks are numbered starting with 
the first week of January as week number 1. The following weeks 
are numbered accordingly, ending with the last week in December. 
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The Date for Week No. 1 option enables you to set the week you 
want to designate as the first week of the year by choosing the 
desired month and moving the arrow in the scale to the desired 
date. For example, if your fiscal year starts the first week of July 
and you want to designate that week as the first week of the year, 
choose July from the list of months and choose a date number that 
falls in the first week of July. To ensure that the date you choose 
falls in the first full week of the month, you may want to choose a 
date such as July 6. 

The date January 4 is the preset option, which ensures that the 
first full week in January is used as the first week of the year. 

Include Week Numbers 
Unless you specify otherwise, the leftmost column in every month 
display lists the number of each week, starting with the first week 
of January as week number 1. You can disable this feature by 
turning off the Include Week Numbers option. 

Saving Customized Features 
To save your customized features, pull down the Options menu, 
display the Customize submenu, and choose the Save Settings 
menu item. This causes your new settings to be used whenever 
you start a Calendar session. The size and placement of all 
displays are also saved. 

To restore your settings to the currently saved defaults, pull down 
the Options menu, display the Customize submenu, and choose 
the Restore Settings menu item. 

To restore your settings to the system defaults, pull down the 
Options menu, display the Customize submenu, and choose the 
Use Defaults menu item. 

Changing the Shape of a Display 
You can change the size of any Calendar display by using the 
window's size button. If you resize the display to be smaller than 
the elements inside it, Calendar will try to rearrange the elements 
to fit the new size, but some of the elements may not be visible. 
For example, if you resize the year display so that it is only big 
enough to display eight months, Calendar will display only the 
next eight months. 

To save the size settings from one session to the next, use the 
Save Settings menu item on the Customize submenu from the 
Options menu. 
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Exiting from the Calendar 
To exit from Calendar and close all open calendars, choose the 
Exit menu item from the File menu. 
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4 
Using the Cardfiler 

The Cardfiler lets you create an electronic box of index cards. This 
electronic file box is called a card file. Card files contain cards, 
which can hold any kind of information you like, such as names, 
addresses, and telephone numbers. For example, you could have 
a card file called Food filled with cards that contain recipes and 
names of restaurants. 

By organizing your index cards into sets (card files), you can keep 
one group of cards separate from another group, for example, your 
business cards and your personal cards. 

This chapter describes how to 

• Start the Cardfiler 

• Create and add cards to a card file 

• View topics in a card file 

• Search a card file for text 

• Edit a card 

• Incorporate graphics 

• Open an existing card file 

• Save a card file 

• Merge two card files 

• Exit from the Cardfiler 
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Starting the Cardfiler 
To start the Cardfiler, choose the Cardfiler menu item from 
File View's Applications menu. 

The Cardfiler displays an empty card file in the Cardfiler window. 
Initially, the card file is empty, but it fills up with index topics as 
you add cards. 

Cardfiler: untitled 

File Search Card Help 

0 
i-
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Opening a Card File 

I Open ... 

Merge ..• 

Save 

Save As ... 

Print 

Print ... 

Quit 

A card file is an electronic file box that contains cards. 

You can either create a card file first and then add cards to it, 
or you can create cards and then save them into a card file. For 
example, you could create a card file called Clients, and then fill it 
with cards that contain the names and telephone numbers of your 
clients. 

To create a new card file or open an existing card file: 

Choose the Open... menu item from the File menu. 
Cardfiler displays a dialog box. 
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Cardfiler: Open [!i] 
----------

File Filter 
11•.card 

File name:WORK:[JONES] 

IJAV3.CARD;5 

<it 
Selection 

11•.card 

6 

~ 
Q 

ti> 

I Filter 

II OK 

I cancelj 
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2 To create a new card file, click on the Selection text field 
and enter the name of the card file you want to create, for 
example, Clients. By default, card files have the file type 
CARD. 
Click on OK Card:fi.ler displays a message telling you the file 
was not found and that a new file is being opened. Click on 
Acknowledged. 
To open an existing card file, select the name of the file you 
want to open. 
Use the scroll bars to view a complete list of your card files. 
The card file name you select is displayed in the text field. 
The new card file is displayed. 

If you try to open another card file without first saving any 
changes you made to the current file, a dialog box is displayed, 
asking whether you want to save your changes. Click on the Yes 
button to save your changes. Click on the No button to discard 
your changes. 
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Creating Cards 
Cards contain units of information, such as a person's name and 
telephone number, and are organized into sets called card files. 
For example, you could have a card file called Accounts in which 
you have cards containing information about each of your business 
accounts. 

You can create a series of cards and save them into a card file, 
or you can open a card file and then add cards to it. As you add 
cards, they are sorted alphabetically according to the topic you 
enter in the card's index field. Very likely, this topic will be the 
name of something, such as a person or business. By displaying 
the topic of each index card, the card file window lists the contents 
of the card file. 

To create a card: 

Choose the Create Card... menu item from the Card menu. 

The Card:filer displays a blank index card in the Card window. 
The dialog box prompts you to enter the topic of the new index 
card. 

Create Card [!;] 

Index for this card: 

II OK II I cancel I 
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2 Enter the topic that belongs in the index field. 

3 Press I Return I or click on the OK button. 
The text you just entered is added to the title bar at the top of 
the Card window and to the contents of the Card:filer window. 
You can add information to the new card. 

4 Enter any information belonging on the index card, for 
example, an address. 

Enter the text as you want it to appear, using the Return key, 
space bar, and Tab key to format it. Cards can contain up to 
4000 characters, and up to 64K bytes of graphics. 

5 When you are :finished with the index card, choose the Close 
menu item from the Edit menu. 
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The Card window is closed and the contents of the index card are 
added to your card file. 

You can open another index card in the card file without closing 
the current card. When you choose the Create Card... menu 
item from the Card menu in the Cardfiler window, the Cardfiler 
automatically saves any changes you made to the current index 
card and returns it to the card file before it opens a new card in 
the file. 

If you create a series of cards before you have created the card file 
in which you want to place them, you can save them into a new 
card file. 

To save cards into a new card file: 

From the empty, untitled card file you see when you start the 
Card.filer, create your cards. 

2 Choose either Save or Save As... from the File menu. 
Card.filer displays a dialog box. 

3 In the Selection text field, enter the name of the card file you 
want to put your cards in. 
For example, if you created a series of cards about famous 
baseball players, you could create a card file called Baseball. 

4 Click on OK. 

The new card file name is displayed at the top of the Card.filer 
window with a list all of the index cards in that card file. 

Viewing the Contents of a Card File 
1!!§1 C&rdfller: PETS.CARD lb!liiJ 

Ale Search card Help 

~Darcy 
NaNa 
Udo 
Wad 

~ 

Although you can look at only one index card at a time, you can 
easily switch from one card to another by selecting a card from 
the card file window. When your card file contains too many cards 
to list in a window at a time, you can use the scroll bar to move 
through the file. You can also search the contents of a card file for 
a given text string. 

Opening a.n Existing Card 
To display the contents of a card you have already created, select 
the card from the card file window by pointing to its index line 
and clicking MBl. 

The card's index topic becomes shaded and the contents of the 
card are displayed in the Card window. 
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Scrolling Through a Card File 
As you accumulate cards, they cannot be listed all at once in the 
card file window. To scroll through the list of index cards in your 
file, press and hold MBl on the stepping arrow. 

Finding Text 
You can search a card file for any text string. The text can be a 
word, a number, or any other characters that you can type on your 
keyboard. Because the Cardfiler treats spaces as text, you can 
search for two or more words. 

The Cardfiler searches either the index topics or the contents of 
the index cards. 

To search the index topics in a card file for specific text: 

Choose the Search Index... menu item from the Search menu 
in the card file window. 

Cardfiler displays a dialog box. 

Search Index !;] 

Go To: 

I OK !I I cancel I 
ZK-0361A-GE 

2 Enter the text string you want located. 

3 Press I Return I or click on the OK button. 

The Cardfiler searches the topics of all index cards in the file and 
displays the first card in your file containing the text string. 

You can continue to search for a text string by choosing the Find 
Next menu item from the Search menu in the card file window. 
The Cardfiler continues to search the card file for the text and 
displays each card that contains the text in its index field. 

To search the contents of each card in the file for specific text: 
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Editing a Card 

Undo 

Copy 
cut 
Paste 

Clear Graphic 

Card.filer displays a dialog box. 

Search Card ~ 

Find: 

I OK I I cance1 I 
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2 Enter the text string you want located. 

3 Press I Return I or click on the OK button. 

The Cardfiler searches all index cards in the file and displays the 
first card in your file containing t:~1e text string. 

You can continue to search for a text string by choosing the Find 
Next menu item from the Search menu in the card file window. 
The Card.filer continues to search the card file for the text and 
displays each card that contains the text. 

The Card.filer editing commands let you copy, delete, and 
rearrange text on an index card. If you decide you do not want to 
save your edits, Cardfiler can restore the card to its original state. 

Renaming a Card 
To change the topic of an index card, you modify the index line: 

Select the card you want to rename from the card file window 
by pointing to it and clicking MBl. 

2 Choose the Rename ... menu item from the Card menu on the 
Card window. 

3 Use the arrow keys to move the text cursor and the <xi 
(Delete) key to erase unwanted text. 

4 Enter the new topic under which you want the card filed. 

5 Click on the OK button. 

The card is renamed and remains open. If you want to close the 
card, choose the Close menu item from the card's File menu. 
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Moving the Text Cursor 
When you create a new card, the text cursor appears in the upper 
left corner of the card window. When you open an existing card, 
the text cursor remains where it was when you last edited the 
card. 

If you are creating a new card and want to move the text cursor, 
use the Return key or place the pointer where you want the text 
cursor and click MBl. You can use this method to move the text 
cursor on an existing card, or you can use the arrow keys to move 
the text cursor anywhere in the existing text (except to the index 
line). 

Selecting Text 
In order to delete, move, or copy text, you must first select that 
text. Select the text by pressing and holding MBl, dragging the 
pointer over the text, and releasing MBl. This highlights the 
selected text. The Card:filer stores this text until you tell it what 
to do. 

~Card: Pundit !;JmJ 
File Edit Search Card Help 

Pundit Corporation, founded in 1986, provides • 
international marketing expertise for small 
manufacturers of technical products in the 
United States, Europe, and the Far East. 

I Previous I 

Deleting Text 

Next 
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To delete small amounts of text on your card, use the <Kl key. 
If you selected text for deletion, press any key to delete the 
highlighted text. 
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Moving Text 
Because the Cardfiler saves the last text you selected and deleted, 
you can move text from one location on a card to another or 
between cards. 

To move text on a card: 

Select the text you want moved to another location on the 
card. 

2 Choose the Cut menu item from the Edit menu. 

3 Move the text cursor to where you want the deleted text 
inserted by using the Return and arrow keys or by positioning 
the pointer and clicking MBl. 

4 Choose the Paste menu item from the Edit menu. 
The deleted text appears in the new location. 

To move text from one card to another: 

Select the text you want to move to another card. 

2 Choose the Cut menu item from the Edit menu. 

3 From the card file window, click on the card to which you want 
to move the text. 

The new card is opened. 

4 Move the text cursor to where you want the deleted text 
inserted by using the Return and arrow keys or by positioning 
the pointer and clicking MBl. 

5 Choose the Paste menu item from the Edit menu. 

The selected text is inserted in the new location. 

Copying Text 
Because the Cardfiler keeps track of your selected text, you can 
copy text from one location on a card to another and between 
cards. 

To copy text on a card: 

Select the text you want copied to another location on the 
card. 

2 Move the text cursor to where you want the selected text 
copied by using the Return and arrow keys or by positioning 
the pointer and clicking MBl. 

3 Click MB3. 
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The selected text is copied to the new location. 

To copy text from one card to another: 

Select the text you want copied to another card. 

2 Choose the Copy menu item from the Edit menu to store the 
copied text. 

3 From the card file window, click on the card to which you want 
to move the text. 
The new card is opened. 

4 Move the text cursor to where you want the selected text 
copied by using the Return and arrow keys or by positioning 
the pointer and clicking MBl. 

5 Choose the Paste menu item from the Edit menu. 
The text is copied to the new location. 

rncorporating Graphics 
You can add graphics, such as those you create with the Paint 
program, to index cards. The Card.filer places a graphic at the top 
of a card, keeping the picture's original size, and relocates text to 
the remaining space. Choose the Read Graphic... menu item from 
the Card window's File menu to incorporate a graphic. Choose the 
Clear Graphic menu item from the Card window's Edit menu to 
erase it. 

Saving a Card File 

Open .. . 

Merge .. . 

Save 

I Save As ... 

Print 

Print ... 

Quit 

Whether you create a new card file or make changes to an existing 
card file, such as adding or deleting a card or changing any 
information on a card, you need to save that card file when you 
are done working with it. 

To save a new card file or change the name of an existing one: 

Choose the Save As... menu item from the File menu in the 
card file window. 
Card.filer displays a dialog box, prompting you for the name of 
the file. 
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Cardfiler: Save As ~ 

File Filter 
IT*.card 

File name:WORK:[JONES] 

IJAY3.CARD;5 

¢L 
Selection 

11*.card 

Ji> 

0 Filter 

~ 
OK 

I Cancel I 

Q 
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2 Using the <Rl and arrow keys, delete any text in the Selection 
text field and enter the name of file. The default file type for 
card file names is CARD. 
Give the file a name that you can easily recognize. For 
example, if the card file contains the numbers of your business 
associates in Rome, you can name the file ROME.CARD. 

3 Press Return or click on the OK button. 
You are returned to the card file window. Ifyou saved a 
new card file, notice that the name of the card file in the · 
title bar has changed from Untitled to ROME.CARD. If you 
saved an existing .card file, the card file name is replaced by 
ROME.CARD. 

To save the current card file, choose the Save menu item from the 
File menu in the card file window. 

To save the current card file under a new file name: 

Choose the Save As... menu item from the File menu in the 
card file window. 

2 Using the <Rl and arrow keys, delete any text in the text field 
and enter the file's new name. 

3 Press I Return I or click on the OK button. 

You are returned to the card file window. Notice that the title bar 
contains the new card file name. 

Using the Cardfiler 4-11 



Merging Card Files 
You can merge the contents of the current file with another file, 
resulting in a card file that combines and sorts the contents of 
both files. The card file whose contents were merged with the 
current card file remains unchanged. 

Choose the Merge... menu item from the File menu on the 
card file window. 
Cardfiler displays a dialog box. 

Cardfiler: Merge [!;] 

File Filter 

l'f*.card 

File name:DISK$:[JONES] 

:!S]PEOPLE.CARD;2 

:!S]PETS.CARD;2 

<)[ J 

Selection 

II.card 

JJI> 

0 

~ 
Filter 

OK 

I cancel I 

Q 

D 
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2 Select the name of the file you want to merge with the current 
file. Use the scroll bars to view a complete list of your files. 

The file name you selected is displayed in the text field. 

3 Press I Return I or click on the OK button. 

The contents of the two card files are merged and sorted 
alphabetically. 

Exiting from the Cardfiler 
To exit from the Cardfiler, choose the Quit menu item from the 
File menu in the card file window. 

If you have not saved any changes or additions to the current file, 
Cardfiler displays a dialog box, asking whether you want to save 
your changes. 
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D 
Do you want to save the current data 

before exiting? 

II Yes 11 I No I I cancel I 
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Click on the Yes button to save your changes and exit from the 
Cardfiler or the No button to exit from the Cardfiler without 
saving your changes. To return to the Cardfiler window, click on 
the Cancel button. 
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5 
Using the Clock 

The Clock displays the time (in both analog and digital format) 
and the date. You can change this display to suit your needs. You 
can also set the Clock's alarm to remind you of appointments. 

This chapter describes how to 

• Start the Clock 

• Customize the Clock display 

• Set the alarm 

• Exit from the Clock 

Starting the Clock 
To start the Clock, choose the Clock menu item from File View's 
Applications menu. 

The Clock is displayed on your screen. You can move and change 
the size of the Clock as you wish. 

::~: Clock 

APR 
. . 

19 
THU..,......·_._. -it 

2:00pm 

~ · . • 
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Changing the Clock Display 
You can customize the Clock display to include any combination of 
the date and time regions. 

To change the Clock display: 

1 Place the pointer anywhere in the Clock display. 

2 Press and hold MB2. 
Clock displays a pop-up menu. 

Settings •.. 
Help H 

Quit 

3 Choose the Settings... menu item. 

Clock displays a dialog box. 

Clock Settings [!l] 

Components: 

Ill Analog Iii Digital Ill Date 

Alarm Settings 

D Alarm -~ 
e AM 
0 PM 

Alarm Message 

OK I cancel f 
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Shaded toggle buttons indicate the current settings. Click MBl on 
a toggle button or its label to change the setting. For example, if 
you want only the analog clock displayed and the Analog, Digital, 
and Date toggle buttons are shaded, click on the Digital and Date 
toggle buttons to disable those settings. 

Click on the OK.button to save any changed settings. Click on 
the Cancel button to return to the date and time display without 
changing any settings. 



You can also display the Settings... dialog box directly without 
first displaying the pop-up menu by double clicking MBl anywhere 
on the Clock display. 

Setting the Alarm 
You can set the alarm to remind you of an appointment-or lunch. 

To set the alarm from the Settings dialog box: 

Click MBl on the alarm toggle button to switch the alarm on. 

2 Move to the hours field and type the hour at which you want 
the alarm to go off. 

You can either use a 12-hour clock, in which case you need to 
specify AM or PM, or you can use a 24-hour clock (military 
time). 

Use the <RI (Delete) key to erase any number already entered 
or to correct typing mistakes. 

3 Move to the minutes field and finish entering the time you 
want the alarm to go off. 

4 If you are using a 12-hour clock or if the time you specify is 
less than 13:00, click on either the AM or PM option button. 

5 To display a message on your screen when the alarm goes 
off, move to the alarm message field and type your message. 
Alarm messages may contain up to 200 characters. 

6 Click on the OK button to save the settings. Click on the 
Cancel button to return to the date and time display without 
changing any settings. 

When the alarm goes off, click on the Acknowledged button to 
clear the alarm message from your screen. 

Exiting from the Clock 
To exit from the Clock, choose the Quit menu item from the 
Clock's pop-up menu. 
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6 
Using the DDIF Viewer 

The DDIF Viewer lets you view DDIF (Digital Document 
Interchange Format) files. DDIF is a standard format for the 
storage and interchange of compound documents. Compound 
documents contain multiple elements, for example, text and 
graphics. DDIF files cannot be viewed as ordinary text files. 

The DDIF Viewer displays only DDIF files. If you specify a file 
that is not a DDIF file, such as a text (ASCII) file, the file is 
converted to DDIF before it is displayed. 

This chapter describes how to 

• Start the DDIF Viewer 

• Display DDIF files 

• Change processing options 

• Exit from the DDIF Viewer 

Starting the DDIF Viewer 
To start the DDIF Viewer and view a file, choose the DDIF Viewer 
menu item from File View's Applications menu. 

The DDIF Viewer displays its main window, which is where you 
view DDIF files. 
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Viewing DOif Files 

I Open ... 

Close File 

Quit 

To view a DDIF file in the DDIF Viewer window, you must open 
it. To open a DDIF file: 

Choose the Open... menu item from the File menu. 

The Viewer displays a dialog box that prompts you for the 
name of the file you want to view. The file list box lists the 
names of any files that have the file type DDIF in the current 
directory. 
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File Filter 

II*.ddit 

Files in DISK$:[JONES] 

0 

~ 
0 

¢Di> D 
Open File 

File Format ..... IJ.o_o_IF ______ _ 

Options File 

Filter I 
OK II 

l cancel I 
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2 Type in the format of the file you want to view. 

Type TEXT if you want to view a TEXT file. Type DDIF if you 
want to view a DDIF file. DDIF is the default choice. 

3 Optionally, enter the name of a file containing the processing 
options to be applied as your file is loaded for viewing. 

If you do not specify an options file, default processing options 
are used. See the VMS Compound Document Architecture 
Manual for more information about using an options file if you 
want more control over the format of the file displayed. 

4 Double click on the name of the file you want to view. 

The DDIF Viewer displays the file you specified. 

If you want to view a DDIF or TEXT file that is not listed, type 
the name of that file in the Open File text field and click on the 
OK button. Or, use the File Filter text entry field to list a subset 
of files that you can then select from. For example, to list all files 
in another directory with the file type DDIF, type the complete 
directory specification-[JONES.PROJECT]*.DDIF-in the File 
Filter text entry field and click on the Filter button. Then double 
click on the name of the file you want to view. 

The DDIF Viewer displays the contents of the file you specified. 
The title bar contains the name of the file currently being viewed. 
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Changing Processing Options 

Closing a File 

You can change th~ processing options that the DDIF Viewer uses 
to display your file. By default, the DDIF Viewer uses automatic 
word wrapping and soft directives. Soft directives consist of 
formatting information inserted into the file by a text editor or 
converter. (Form feeds and carriage returns are two kinds of soft 
directives.) If the file you are viewing was created with a tool or 
converter that does not write soft directives, the default processing 
options may produce an unclear display. By turning soft directives 
on or off, you may make an unclear displ~y more readable. 

To change the processing options: 

Choose the Options... menu item from the Customize menu. 
The Viewer displays a dialog box. 

Options ~ 

Ii] Word Wrap 
Ii] Soft Directives 

II OK, Apply Next 111 OK, Apply Now 11 Cancel 
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2 Click on the toggle buttons to change either processing option. 

3 Click on OK, Apply Next or OK, Apply Now. 
Clicking on OK, Apply Next causes the DDIF Viewer to save 
the options and apply them to future files, but not the current 
file. Clicking on OK, Apply Now causes the current file to be 
closed and reopened with the new processing options, with the 
display starting at the beginning of the file. 

When you have finished viewing a file, close it by choosing the 
Close File menu item from the File menu. This keeps the DDIF 
Viewer active for you to open another file. If you open another 
file without closing the current one, the DDIF Viewer closes the 
current file before opening the next one. 
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Exiting from the DDIF Viewer 
To exit from the DDIF Viewer, choose the Quit menu item from 
the File menu. If you did not close the last file you viewed, the 
DDIF Viewer closes it before exiting. 
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7 
Using DECterm 

DECterm creates a window that emulates a VT320 terminal. 

This chapter describes how to 

• Create a terminal window 

• Customize terminal window operating features 

• Copy information within or between terminal windows 

• Clear and resize terminal windows 

• Compose special characters 

• Exit from a terminal window 

In addition to these features, you can program DECterm text 
features and ReGIS and Sixel Graphics. See the DECterm Text 
Programming Manual and the DECterm Graphics Programming 
Manual for detailed information about using these features. 

Creating a Terminal Window 

Terminal Window 

FileView Window 

Choose the Terminal Window menu item from the Session 
Manager's Create menu to create a terminal window. 
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Give the DECterm window input focus by pointing to it and 
clicking MBl. 

Customizing DECterm 

7-2 Using DECterm 

Once you have created a DECterm window, you can choose the 
operating features you want the terminal to have and then save 
these features by using the DECterm Customize menu. 

Window .. . 

Display .. . 

General .. . 

Keyboard ... 

7-bit NRCS Selection ... 

Use Last Saved Settings 

Use Defaults 

Use Saved Settings from ... 
·································· 
Save Current Settings 

Save Current Settings as ... 
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Customizing a Terminal Window 
Choose the Window... menu item from the Customize menu to 
change terminal window features. DECterm displays a dialog box. 

Window !iJ 
D Record lines off top 
D Vertical scroll bar 
D Horizontal scroll bar 

Iii Vertical cursor coupling 
D Horizontal cursor coupling 
D Auto resize terminal 
Iii Auto resize window 

0 Bigfont 
<i> Little font 

0 Normal font (SO columns) 

Terminal size 

~Rows Isa· Columns 

0 Condensed font (132 columns) II OK II I I I I 
<i> Normal/SO, Condensed/132 ,· ... Apply Dismiss 
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Shaded buttons indicate the current settings. Click MBl on a 
button or its label to change the setting. Click on the Apply 
button to view your changes without closing the dialog box. Click 
on the OK button to apply your changes and close the dialog box. 

From the Terminal Window dialog box, you can customize any of 
the following features: 
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Record Lines Off Top 
Normally, lines that are scrolled off the top of the DECterm 
display are saved. To disable this option, click on Record Lines Off 
Top. 

To view the lines that are scrolled off the top of the display, use 
the vertical scroll bar. 

Vertical Scroll Bar 
By default, DECterm windows display vertical scroll bars. If you 
do not want vertical scroll bars, click on Vertical Scroll Bar to 
disable this option. 

Horizontal Scroll Bar 
Normally, DECterm.windows do not display horizontal scroll bars. 
Click on Horizontal Scroll Bar to display a horizontal scroll bar at 
the bottom of your DECterm window. 

Vertical Cursor Coupling 
By default, when you change the size of your window or terminal 
vertically, the cursor remains visible. For example, if the display 
contains 24 rows and you shrink it to 5 rows, the cursor remains 
visible and allows you to enter text. You can disable this option by 
clicking on it. 

Horizontal Cursor Coupling 
By default, when you change the size of your window or terminal 
horizontally (for example, from 132 columns to 80 columns), the 
cursor does not remain visible. You can change this default by 
turning on the Horizontal Cursor Coupling option. 

Auto Resize Terminal 
By default, when you modify the terminal size, the window 
size also changes. Clicking on Auto Resize Terminal causes the 
terminal size to change to conform to the window size whenever 
you change the window size. 

Auto Resize Window 
By default, when you modify the terminal size, the window 
size also changes. Disabling Auto Resize Window causes more 
characters to be displayed than your current window size can 
accommodate; these characters do not appear in the window. 

Big Font 
Unless you specify otherwise, the Little Font (14 points) option 
is enabled. Clicking on the Big Font option displays an 18-point 
font. 



Little Font 
Unless you specify otherwise, the Little Font option is enabled. 
This causes DECterm to display a 14-point font. 

Normal Font (80 Columns) 
Clicking on the Normal Font option causes the normal 80 column 
font to be used. The preset option for font size is Normal Font/80, 
Condensed/132. 

Condensed Font (132 Columns) 
Clicking on the Condensed Font option causes the Condensed Font 
(132 columns) to be used. The default font size is Normal Font/80, 
Condensed/132. 

Normal Font/SO, Condensed/132 
The default font size is Normal Font/80, Condensed/132. This 
causes the font size to adjust to match the terminal width. 

Terminal Size 
Normally, the terminal size is set to 24 rows and 80 columns. By 
clicking on the size you want, you can change the row setting 
to 48 or 72 and the column setting to 132. You can also set the 
column and row to be any number from 1 to 132 by clicking on the 
text entry field, deleting any existing numbers, and entering the 
new settings. 

Customizing a Terminal Display 
Choose the Display... menu item from the Customize menu to 
modify DECterm display features such as the type of cursor. 
DECterm displays a dialog box. 

Display [!i] 
~~~~~~~~~~~~~~~~~~ 

Ill Auto wrap 
Ill Display cursor 
Iii Cursor blink 

<i> Block cursor 
0 Underline cursor 

<i> Dark text, light background 
0 Light text, dark background 

<i> No status display 
0 Host status display 

I OK II I Apply 11 Dismiss I 
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From the Terminal Display dialog box, you can customize any of 
the following display features: 
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Auto Wrap 
Normally, when the cursor reaches the right margin it stops. 
This causes each new character to delete the existing character. 
Clicking on Auto Wrap causes the cursor to move, start a new 
line, and display new characters. 

Display Cursor 
Unless you specify otherwise, a cursor is displayed in your 
terminal window. Disabling Display Cursor causes the cursor to 
become invisible. 

Cursor Blink 
Unless you specify otherwise, the cursor blinks. Disabling Cursor 
Blink causes a steady cursor to be displayed. 

Block Cursor 
Unless you specify otherwise, the cursor displayed in your 
DECterm window is block shaped. 

Underline Cursor 
The default cursor for DECterm is block shaped. Click on the 
Underline Cursor option to get an underline cursor. 

Dark Text, Light Background 
Unless you specify otherwise, DECterm displays dark text and a 
light screen background. 

Light Text, Dark Background 
Change the default of dark text with a light background by 
clicking on the Light Text, Dark Background option. 

No Status Display 
Unless you specify otherwise, you do not receive host status 
messages. Host status messages, when activated, appear on the 
bottom line of your terminal window display. 

Host Status Display 
To receive host status messages, turn on the Host Status Display 
option. This causes the messages to appear on the bottom line of 
your terminal window. You can set Host Status Display only on 
VT300-series terminals. 



Customizing General Terminal Features 
Choose the General... menu item from the Customize menu to 
change general terminal features such as the terminal type. 
DECterm displays a dialog box. 

General ~ 

D Newline 
D LockUDKs 
D Lock user features 

<I> Normal cursor keys 
0 Appl cursor keys 

Terminal ID 
<I> DECterm ID 
0 VT3401D 
0 VT3201D 
0 VT240 ID 
0 VT2201D 
0 VT125 ID 
0 VT102 ID 
0 VT101 ID 
0 VT100 ID 

<I> Numeric keypad 
0 Application keypad 

<I> UPSS DEC Supplemental 
0 UPSS ISO Latin 1 

<I> 8-Bit multinational charaters 
0 7-Bit NRCS characters 

0 VT300 mode, 8-bit controls 
<I> VT300 mode, 7-bit controls 
0 VT100mode 
0 VT52mode 

OK II I Apply I I Dismiss I 
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From the General dialog box, you can set any of the following 
terminal features: 

Newline 
Normally, pressing the Return key does not start a new line. 
Clicking on Newline causes the cursor to start a new line when 
you press the Return key. 

Lock UDKs 
Your keyboard contains keys you can define for your own use. 
Unless you specify otherwise, the host system can change the 
function of the key you have defined back to the default. Clicking 
on Lock UDKs sets the user-defined keys so that the host system 
cannot change your definitions. 

Lock User Features 
DECterm lets you change the Auto Repeat option and the 
Foreground and Background Display option. The host system 
can change these options to the default unless you click on the 
Lock User Features option. 
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Normal Cursor Keys 
Unless you specify otherwise, the Normal Cursor Keys option is 
on. This causes the arrow keys to move the cursor up, down, left, 
and right. 

Appl Cursor Keys 
By clicking on the Application Cursor Keys option, you can 
override the Normal Cursor Keys default and set the arrow keys 
to application-specific functions. 

Terminal ID 
You can let the host system know specific operating attributes of 
the terminal by clicking on the Terminal ID option. The default is 
DECterm ID. 

You can choose the following terminal IDs: 

DECterm ID 

VT340 ID 

VT320 ID 

VT240 ID 

VT220 ID 

VT125 

Numeric Keypad 

VT102 ID 

VT101 ID 

VTlOO ID 

Unless you specify otherwise, the Numeric Keypad option is set. 
This means that pressing a numeric key displays the characters 
that appear on that key. 

Application Keypad 
Choose the application keypad by clicking on the Application 
Keypad option. This causes the keypad to display the user-defined 
key characters. 

UPSS DEC Supplemental 
Unless you specify otherwise, the UPSS DEC Supplemental option 
is on, causing the DEC Multinational Character Set to be used. 

The ASCII character set comprises the first half of the DEC 
Multinational Character Set. Figure 7-1 illustrates the ASCII 
character set (characters with decimal values 0 through 127). 
The first half of each of the numbered columns identifies the 
character as you would enter it on a VT300-, VT200-, or VTl 00-
series terminal or as you would see it on a printer (except for 
the nonprintable characters). The remaining half of each column 
identifies the character by the binary value of the byte; the value 
is stated in three radixes-octal, decimal, and hexadecimal. For 
example, the letter uppercase A has, under ASCII conventions, a 
storage value of hexadecimal 41 (a bit configuration of 01000001), 
equivalent to 101 in octal notation and 65 in decimal notation. 



Figure 7-1 DEC Multinational Character Set, Part I 

8 9 10 11 12 13 14 15 Column 

1 1 1 1 1 1 1 1 b8 Bits 
0 0 0 0 1 1 1 1 b7 

0 0 1 1 0 0 1 1 bS 
0 1 0 1 0 1 0 1 b5 

b4 b3b2b1 Row 
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~g~ 223 243 263 
A ~~ 6 

323 343 363 
STS 147 £ 163 3 179 211 i 227 0 242 0 0 1 1 3 

83 93 A3 B3 C3 03 E3 F3 

~g~ 224 244 264 ~g~ 6 ~~~ ~: 
364 

IND CCH 148 164 180 A a 6 244 0 1 0 0 4 
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~~ 231 ~~~ ~~ E 
311 

(I m g~ 1r~ HTS 1S3 © , 
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213 ~~~ m ~~~ E 
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214 234 ~~~ ~~~ i 

314 
0 
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SS3 
217 
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Figure 7-2 illustrates the second half of the DEC Multinational 
Character Set (characters with decimal values 128 through 255). 
The first half of each of the numbered columns identifies the 
character as you would see it on a VT300- or VT200-series 
terminal or printer (these characters cannot be output on a 
VTl 00-series terminal). 
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Figure 7-2 DEC Multinational Character Set, Part II 

Column 0 1 2 3 4 5 6 7 
b8 Bits 0 0 0 0 0 0 0 0 

b7 0 0 0 0 1 1 1 1 
b6 0 0 1 1 0 0 1 1 

bS 0 1 0 1 0 1 0 1 
Row b4b3 b2 b1 
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UPSS ISO Latin 1 
You can override the DEC Multinational Character Set by clicking 
on the UPSS ISO Latin 1 option. This causes the International 
Standards (ISO) Latin 1 Character Set to be used. Figure 7-3 
illustrates the ISO Character Set. 



Figure 7-3 International Standards (ISO) Character Set 
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Note To use these character sets, the Character Set mode menu item 
must be set to 8-bit Characters. 

8-Bit Multinational Characters 
Unless you specify otherwise, the character mode is set to 8 bits 
for use with the DEC Supplemental Character Set. 

7-bit NRCS Characters 
To use the National Replacement Character Sets, click on the 
7-Bit Character Mode option. The default is the 8-bit Multinational 
Character set. 

VT300 Mode, 8-bit Controls 
Unless you specify otherwise, the terminal option is VT300 
Terminal Mode, 8-bit Controls. This causes DECterm to emulate 
a VT300 with 8-bit control characters. 
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Note With each new DECterm window, you can choose to emulate the 
same terminal or different terminals. 
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VT300 Mode, 7-bit Controls 
You can change the VT300 Terminal Mode, 8-bit Controls default 
option by clicking on the VT300 Terminal Mode, 7-bit Controls 
option. This causes DECterm to emulate a VT300 with 7-bit 
control characters. 

VT100 Mode 
You can change the VT300 Terminal Mode, 8-bit Controls default 
option by clicking on the VTl 00 Mode option. This causes 
DECterm to emulate a VTlOO terminal. 

VT52Mode 
You can override the VT300 Terminal Mode, 8-bit Controls default 
option by clicking on the VT52 Terminal Mode option. This causes 
DECterm to emulate a VT52 terminal. 

Customizing a Keyboard 
Choose the Keyboard... menu item from the Customize menu to 
set keyboard features. DECterm displays a dialog box. 

Keyboard [!i.i 
-------------~- --

Ill Waming Bell 

D Margin Bell 
Ill Auto Repeat 
Iii Ctrl-Q, Ctrl-S = Hold 

<I <X] Delete 
0 <X] Backspace 

<I Comma key sends ,, 
O Comma key sends ,< 

<I Tilde key sends ' -
O Tilde key sends ESC 

<I Angle bracket key sends <> 

O Angle bracket key sends ·-

I OK I I Apply 11 Dismiss I 
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From the Keyboard dialog box, you can set the following keyboard 
features: 

Warning Bell 
Unless you specify otherwise, the keyboard warning bell is set to 
ring when errors occur. You can disable this function by clicking 
on the Warning Bell option. 



Margin Bell 
By default, the margin bell does not ring when the cursor reaches 
the right margin. You can cause it to ring by clicking on Margin 
Bell. 

Auto Repeat 
By default, continuing to press a key causes the character to 
repeatedly be displayed. You can disable this function by turning 
off the Auto Repeat option. 

Note The host system can change the Auto Repeat setting. Click on the 
Lock User Feature option to permanently set this option. 

Ctrl-Q, Ctrl-S = Hold 
Unless you specify otherwise, pressing Ctrl/S causes your screen 
display to stop scrolling, and pressing Ctrl/Q causes it to resume 
scrolling. 

<RI Delete 
By default, the Delete option is set, which causes the <RI key to 
function as a delete key. 

<RI Backspace 
You can override the <RI Delete default by clicking on the 
Backspace option. This causes the <RI key to function as a 
backspace key. 

Comma Key Sends ,, 
By default the Comma Key Sends ,, option is set. This causes a 
comma (, ) to be displayed when you press the comma key. (This 
applies to a North American or Dutch keyboard dialect.) 

Comma Key Sends ,< 
You can override the Comma Key Sends ,, default by clicking on 
the Comma Key Sends ,< option. This causes a comma ( , ) to 
be displayed when you press the comma key shifted, and a left 
angle bracket ( <) to be displayed when you press the comma key 
unshifted. (This applies to a North American or Dutch keyboard 
dialect.) 

Tilde Key Sends·-
Unless you specify otherwise, the Tilde Key Sends '- option is set. 
This causes the ' - key to display a left single quotation mark (' ) 
when unshifted and a tilde ( - ) when shifted. (This applies to a 
North American or Dutch keyboard dialect.) 
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Tilde Key Sends ESC 
You can override the Tilde Key Sends',.., default by clicking on the 
Tilde Key Sends ESC option. This causes the',.., key to function as 
an escape (ESC) key. (This applies to a North American or Dutch 
keyboard dialect.) 

Angle Brackets Key Sends <> 
Normally, the Angle Bracket Key Sends <> option is set. This 
causes the angle bracket key to display a left angle bracket ( < ) 
when unshifted and a right angle bracket ( > ) when shifted. (This 
applies to a North American or Dutch keyboard dialect.) 

Angle Brackets Key Sends'-
You can override the Angle Bracket Key Sends <> default by 
clicking on the Angle Brackets Key Sends',..,. This causes the<> 
key to function as an escape (ESC) key. (This applies to a North 
American or Dutch keyboard dialect.) 

Choosing a National Replacement Character Set 
Choose the 7-Bit NRCS Selection ... menu item from the 
Customize menu to pick a National Replacement Character 
Set (NRCS) that corresponds to the specified keyboard dialect. 
DECterm displays a dialog box. 



7-Bit NRCS Selection [!;] 

North American ~ 
Flemish 

Canadian (French) 

British 

Danish 

Finnish 

Austrian/German 

Dutch 

Italian 

Swiss (French) 

M 

II OK II 

I Apply I 
I Dismiss! 

ZK-0182A-GE 

You can select the following character sets: 

North American 

Flemish 

Canadian (French) 

British 

Danish 

Finnish 

Austrian/German 

Dutch1 

Italian 

Swiss (French) 

Swiss (German) 

Swedish 

Norwegian 

Belgian/French 

Spanish 

Portuguese 

1 Use of the Dutch national character set is discouraged, and it may not be 
supported in future versions of DECterm. Dutch users should use the ISO Latin 1 
character set instead. 

See Appendix B for the keyboard illustrations. 

Saving and Restoring Customized Features 
Once you modify DECterm settings, you can save your changes. 
When you save your changes, DECterm uses these settings each 
time you create a DECterm window. If you change your mind 
and want to use the settings that came with your system, you can 
restore the defaults. 
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To save customized settings: 

• Choose the Save Current Settings menu item from the 
Customize menu for routine saving of customized features. 

• Choose the Save Current Settings As... menu item from 
the Customize menu when you want to save the current 
customized features with a new or different file name. 
DECterm displays a dialog box. 

File Filter 

I DECW$USER_;DEFAULTS:DECW$TERMINAL_ *.DAT( 

Select name for configuration file:DISK$:[JONES] 

I Filter I 6 

~ 
Q 

¢1 I pl) 

Selection 

I DISK$:[JONES]DECW$TERMINAL DEFAULT.DAT;! 
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The dialog box prompts you for the name of the file you want 
to use to save your customized features. The file list box 
displays the names of any files in the current directory that 
contain customized features. By default, these files have the 
type DAT. 
To use a file name that is not listed, enter the name of that 
file in the Selection text field and click on the OK button. 

To restore customized settings: 

• Choose the Use Last Saved Settings menu item from the 
Customize menu to restore an existing file. 

• Choose the Use Defaults menu item from the Customize menu 
to restore the system defaults. 



• Choose the Use Saved Settings From... menu item from 
the Customize menu to restore previously saved settings. 
DECterm displays a dialog box. 

Used saved settings from [!,ij 

File Filter 

I DECW$USER_DEFAUL TS:DECW$TERMINAL_*.DATI 

Select Configuration File:DISK$:[JONES] 

¢1 I IJ~ 

Selection 

6 

~ 
0 
D 

1.--Fi-lte-r .... , 

I OK I 
I cancel I 

I DISK$:[JONES]DECW$TERMINAL DEFAULT.DAT;I . 
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The dialog box prompts you for the name of the file you want 
to use to save your customized features. The file list box 
displays the names of any files in the current directory that 
contain customized features. By default, these files have the 
type DAT. Double click on the file name of the file you want to 
use. 

Or, use the File Filter text field to list a subset of files you can 
then select from. For example, to display all files in another 
directory with the file type DAT, type the complete directory 
specification-[JONES.CUSTOMIZE]* .DAT-in the File Filter 
text field and click on the Filter button. Then double click on 
the name of the file you want to use. 

Copying Information 
Choose the Edit Menu to copy information within or between 
terminal windows. 
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Paste 

Select all 
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To copy information: 

Select the information you want to copy by pressing and 
holding MBl, dragging the pointer over the information, and 
releasing MBl. Or, choose the Select All menu item from the 
Edit menu to copy the entire display. 

The selected area is highlighted. 

2 Choose the Copy menu item from the Edit menu to store the 
copied information. 

S Click on the area you want to place the information. 

4 Choose the Paste menu item from the Edit menu. 

The selected information is copied to the new location. 

Clearing and Resizing Terminal Windows 
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From the Commands menu, you can clear or resize the terminal 
window. 

Clear lines off top 

Clear Display 

Resize Window 

Clear Communications 

Reset Terminal 

Quit 
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Clear Lines Off Top 
You can erase information stored in the transcript by choosing 
the Clear Lines Off Top menu item. The transcript is an area of 
memory that contains the last 100 lines of your screen display, 
and it can be read by using the scroll bars. The transcript exists 
as long as the Record Lines Off Top option in the Window dialog 
box is in effect. Record Lines Off Top is turned on by default. 

Clear Display 
You can clear all information displayed in a terminal window by 
choosing the Clear Display menu item. 

Resize Window 
Choose the Resize Window menu item to change the size of the 
terminal window. 

Clear Communications 
Choose the Clear Communications menu item to reset the 
communication buffers. 

Reset Terminal 
Choose the Reset Terminal menu item to restore the currently 
saved defaults. 

Choosing Reset Terminal also restores the default color map. On 
a 4-plane system such as the VS2000/GPX, displaying ReGIS 
or sixel graphics causes DECterm to create and load its own 
hardware color map, so that other windows do not display in 
their true colors when the DECterm window has input focus. To 
restore the default hardware color map, first erase the graphics 
from the window by choosing the Clear Display menu item from 
the Commands menu, and then reset the terminal with the Reset 
Terminal menu item. 

Composing Characters 
Use compose sequences to create special characters. A compose 
sequence is a series of keystrokes that creates characters that 
do not exist as standard keys on your keyboard. You can create 
any character from the character set DECterm is currently using. 
(For more information on choosing a character set, see the section 
Customizing DECterm.) 

For more information about composing characters, see 
Appendix A. 
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Exiting from DECterm 
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Choose the Quit menu item or enter the LOGOUT command to 
exit from DECterm and close the DECterm window. 







8 
Using EVE 

The Extensible VAX Editor (EVE) is a powerful, general-purpose 
editor based on the VAX Text Processing Utility (VAXTPU). Using 
EVE, you can create and edit text files such as business letters, 
technical documents, and program source files. EVE is also 
compatible with the EDT and WPS keypads. 

There are three ways to execute EVE commands-menus, typed 
commands, and defined keys. This chapter focuses on executing 
commands from menus. For more information about defining keys 
and using typed commands, see online help in EVE, the VAX Text 
Processing Utility Manual, or the Guide to VMS Text Processing. 

If you are already familiar with EVE on character cell terminals, 
you can use the same editing methods with EVE on VMS 
DECwindows. For example, you can type commands and use 
defined keys, as well as using the mouse and menus. The only 
EVE commands that do not work on DECwindows are ATTACH, 
SPAWN, and SPELL. Also, on DECwindows, VAXTPU does 
not provide journal files; therefore, you should save your edits 
frequently so that in case of a system failure you will not lose your 
work. For more information, see EVE help on New Features. 

This chapter describes how to 

• Begin an editing session 

• Enter text, execute EVE commands, and get online help 

• Move the cursor 

• Edit text 

• Search for and replace text 

• Format text 
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• Save your edits 

• View and edit two or more files in the same session 

• Define keys, including setting the EDT or WPS keypad, and 
save definitions in a section file 

• Set editing preferences and customize EVE 

Beginning ·vour Editing Session 
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To begin an EVE editing session: 

Select the file in File View you want to edit. 
If you do not select a file before starting EVE, EVE creates an 
empty buffer called MAIN. 

2 Choose the Edit menu item from File View's Files menu. 
File View displays a dialog box. 

3 Click on OK to specify EVE as your editor, because EVE is the 
default choice. 
If you have not selected a file in File View, you can enter the 
name of the file you want to edit in the Files text entry field. 
Click on Hide This Dialog if you do not want the dialog box to 
appear when you start EVE from File View. 
After you click on OK, FileView displays the VAXTPU dialog 
box. 

4 Modify the settings if you like, and click on OK. 
This dialog box contains options that are primarily of interest 
to users writing VAXTPU procedures. You do not need to 
modify these options to use EVE. For more information about 
the VAXTPU dialog box, see the section Setting VAXTPU 
Preferences. 
Click on Hide Dialog if you do not want this dialog box to 
appear when you start EVE from File View. 

The EVE screen layout is displayed on your screen in its own 
window. 



Main Window' 

Command Window 
Message Window 

0End of File] 

• •• I Write I Insert I Forward 
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The main window shows the buffer you are editing. A buffer 
is an area of computer memory for storing or manipulating 
data-in other words, a buffer comprises your workspace. If you 
are creating a new file or if you did not specify a file when you 
invoked EVE, the buffer is empty and you see the [End of File] 
marker in the upper left comer. You can split the main window 
into two or more smaller windows to view or edit different files or 
different parts of the same file. 

The status line shows information about the buffer you are 
viewing or editing-the name of the buffer, its status (Read-only 
or Write), the mode for entering text (Insert or Overstrike), 
and the direction for searches and other operations (Forward or 
Reverse). Each field in the status line can be changed by clicking 
on it with MBl. For example, clicking MBl on the buffer name 
returns to your next buffer. Clicking on the mode or direction 
toggles that setting. 

The command window is a single line where you type EVE 
commands. Pressing the Do key moves the cursor to the command 
window, and EVE then prompts you to type a command. The 
command window appears just below the status line when you 
press the Do key. 

The message window is a single line where some EVE messages 
appear, such as a confirmation message when you set the margins. 
It is the bottom line in the EVE screen. 
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Save File 
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Opening a File 
When you begin an editing session, you can select the name of the 
file you want to edit in File View or type the file name in the dialog 
box you get when you choose the Edit menu item from File View's 
Files menu. If you do not supply a file name, EVE creates an 
empty buffer named MAIN. You can then begin typing and specify 
the file name on writing the buffer or on exiting. 

If you did not specify a file when you invoked EVE, or if you want 
to edit a different file in the same session, do the following steps: 

Choose the Open... menu item from the File menu. 
EVE displays a dialog box, asking you for the name of the file 
you want to edit or create. 

File Filter 

Open File: 

0 Filter 

~ 
OK 

I Cancel I 

0 
<i I Ii> D 
Enter New File Name 
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2 Type the name of the file-for example, TESTFILE.TXT and 
press I Return I or click on OK. 

EVE copies the specified file into a buffer and displays it in the 
main window. The buffer has the same name as the file, unless a 
buffer already exists that has the same name, in which case EVE 
prompts you to enter a new name. 

For more information about specifying files for editing, see the 
section Viewing and Editing More Than One File. 



Entering Text 
To enter text, type characters from the keyboard. The cursor 
marks the current insertion point-the location at which the next 
character will appear or where an editing operation will occur. If 
you make a typing :piistake, press the <XJ (Delete) key to erase the 
previous character. 

With EVE, you can use two different modes for entering text­
insert mode and overstrike mode. 

With insert mode, as you type, new characters push existing text 
to the right. This is the default setting. 

With overstrike mode, each character you type replaces the 
character at the current position; using the <RI key replaces the 
previous character with a space. Overstrike mode is useful for 
correcting spelling errors or for editing column-aligned text. 

The current mode of the buffer is always shown in the status 
line. To change the mode of the buffer, click MBl on Insert or 
Overstrike in the status line (you can also press Fl 4 or Ctrl/ A). 

Moving the Cursor and Scrolling 
You can move the cursor by pointing with the mouse and clicking 
MBl or by using the scroll bars. You can also move the cursor by 
pressing the arrow keys. Holding down an arrow key moves the 
cursor continuously in the direction of the arrow. 

There are two types of cursor motion you can use-free cursor 
and bound cursor. A free cursor enables you to move anywhere 
in the buffer and insert text regardless of whether characters are 
already there. This is the default setting. 

By contrast, a bound cursor follows the shape or flow of your text, 
as in the EDT and WPS editors. For example, if you are at the 
end of a line and press the right arrow key, the cursor moves to 
the start of the next line. 

For information about setting the type of cursor motion, see the 
section Setting Global Preferences. 

You can use invisible markers to mark your current position 
in a buffer so you can return to that location later on. This is 
particularly useful when you are making revisions to a lengthy 
document. 

To mark your current position: 

Pressing MB2 anywhere in the main window, choose the 
Mark... menu item from the pop-up menu. 
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Note that you cannot do this while you have a selection active. 
EVE displays a dialog box. 

Mark name: II 

I OK n 
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2 Type the name of the marker-for example, CHAP ONE, and 
press I Return I or click on OK. 

Later, to return to this location: 

Using MB2, choose the Go To... menu item from the pop-up 
menu. 
EVE displays a dialog box. 

Goto: II 

II OK II 
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2 In the dialog box, type the marker name. 

Entering EVE Commands 
There are three ways to execute EVE commands-menus, typed 
commands, and defined keys. For more information about typed 
commands, see online help in EVE, the VAX Text Processing 
Utility Manual, or the Guide to VMS Text Processing. 

To type a command: 

Press !Q21. 



The cursor moves to the command window and EVE prompts 
you to type a command. 

2 Type a command, such as Set Keypad EDT or Erase Line. 
You can abbreviate the command by .using, in most cases, 
the first letter of the command. EVE is not case sensitive 
in interpreting commands. You can use any combination of 
uppercase and lowercase characters in the command line. 

3 Press [Q2I or I Return I to complete the command. 
EVE executes the command or prompts you for further action. 

Getting Help 
EVE provides extensive online help for all menu items, commands, 
and keypad functions. 

To get help, choose one of the following items from the Help menu: 

• List of Topics 
Displays the list of all EVE commands and other topics. You 
can then type the name of a topic you want help on. 

• Keypad 
Draws a keypad diagram. You can then press a key you want 
help on. Gold key combinations are shown in reverse video. 

• Keys 
Lists all the current key definitions, including control keys 
and Gold key combinations. You can then press a key you 
want help on. 

You can also get help by typing the HELP command and specifying 
a topic. For example, the following command gets help on the Find 
command: 

Command: HELP FIND 

Most help topics have a list of the related commands or other 
topics and a list of any key bindings, including any EDT or WPS 
keypad bindings. If you are viewing help on one topic and want 
to get help on another topic, simply type the name of that topic 
and press Return. If you want to view the list of topics, type a 
question mark (?) and press Return. 

To scroll through a lengthy help topic, press the Next Screen and 
Prev Screen keys. To exit from help and resume editing, press the 
Return key. 
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EVE lets you enter, modify, copy, delete and restore text. In 
addition to the Edit menu, you can use pop-up menus to display 
menu items that let you perform different editing operations. 

Pressing MB2 anywhere in the main window displays a pop-up 
menu appropriate to your particular context. For example, if you 
have selected text, the pop-up menu contains the following menu 
items for operations that involve a select range: 

Reset 
Change Case 
Find Next 
Fill Range 
Cut 
Copy 
Open Selected 
Find Selected 

If there is no text selected, the pop-up menu contains these menu 
items, which do not require a select range: 

Select 
Select All 
Restore 
Find Next 
Fill Paragraph 
Center Line 
Paste 
Replace 
Mark 
Go To 
Include 

Selecting Text 
Selecting text in the buffer lets you perform an editing operation 
on or with that text alone, such as changing the case of letters, 
reformatting a block of text according to new margins, or copying 
a block of text so you can insert it elsewhere. 

To select text, you can choose the Select and Select All menu items 
from the pop-up menu, or you can use mouse clicks as follows: 

• Press MBl and drag the mouse to select a block of text. 

• Click MBl to select an amount of text, as follows: 

2 clicks selects the current word 



Restore 
················· 
Cut 

Copy 

Paste 

Replace ... 
················· 
Select All 

3 clicks selects the current line 
4 clicks selects the current paragraph 
5 clicks selects all of the current buffer 

To cancel a selection done with mouse clicks, simply move the 
cursor out of the select range. To cancel any selection, choose the 
Reset menu item from the pop-up menu or press the Select key. 

After you select text, use MB2 to display a pop-up menu that 
contains the menu items you can use on or with the select range. 
Some of these menu items also appear in the Edit menu, Format 
menu, and other menus. The following is a list of the commands 
and menu items you can use with a select range. For more 
information about these commands, see online help. 

Capitalize, Word 
Copy or Store Text 
Cut or Remove Text 
Fill Paragraph or Fill Range 
Find Selected 
Lowercase Word 
Open Selected 
Reset 
Uppercase Word 

You can also use some EDT and WPS keypad functions with 
selected text, such as the EDT Append key, and you can use 
pending delete. See the section Setting Global Preferences for 
more information about pending delete. 

Moving Text to Another Location 
You can move a select range by cutting it or copying it and then 
pasting the text elsewhere. To cut and paste text: 

Select the text you want to cut by choosing the Select or Select 
All menu item from the pop-up menu or by using mouse clicks. 

2 Choose the Cut menu item from the Edit menu. 

3 Put the cursor where you want to reinsert the text and choose 
the Paste menu item from the Edit menu. 

Copying text works the same way as cutting, except the selected 
text is not removed from its original location. To copy text, select 
the text you want to copy, choose the Copy menu item from the 
Edit menu, place the cursor where you want to insert the text, 
and choose Paste from the Edit menu. 
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l;§j:b& .. ~ Restore Word 
Cut 

Copy 

Paste 

Replace ... 
··············· 
Select All 

Restore Selection 

Restore Line 

Restore Character 

Restore Sentence 

Text you cut or copy is stored in the Insert Here buffer. If you 
want to transfer text between EVE and other VMS DECwindows 
applications, you must first enable the clipboard. See the section 
Customizing EVE for more information about enabling the 
clipboard. 

Erasing and Restoring Text 
To erase text, you can use the <XI key or select and cut a block 
of text. There are also several typed EVE commands that delete 
text: 

Delete 
Erase Character 
Erase Line 
Erase Start Of Line (Ctrl/U) 
Erase Previous Word 
Erase Word 

To erase the current word, press the F13 key or Ctrl/J, each of 
which is defined as Erase Word. For more information about 
Erase commands, use online help. 

To put back what you erased, pull down the Edit menu, display 
the Restore submenu, and choose the desired menu item on the 
submenu. You can choose one of the following menu items: 

Restore Word 
Restore Selection 
Restore Line 
Restore Character 
Restore Sentence 

Searching for and Replacing Text 

Find Next 

Find ... 

Wildcard Find ... 

Find Selected 

Replace ... 
························ 
Show Wlldcards 

Set Whitespace C7 

·s~i \v1id~~~ci~· · · · · · i::,; 
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To find a string of text in your document: 

Choose the Find... menu item from the Search menu. 
EVE displays a dialog box. 



Foiward Find: ._I d.....::ig __ it_a~::...: ___ _ 

II OK II I cancel I 
ZK-0196A-GE 

2 In the dialog box, type the text string you want to find. 

Use all lowercase to find any occurrence of the string. Use mixed 
case or uppercase to find an exact match. For example: 

You Type EVE Finds 

digital digital 
Digital 
DIGITAL 

Digital Digital 

DIGITAL DIGITAL 

EVE begins the search in the current direction of the buffer 
(forward or reverse), shown in the status line. You can change 
the direction of the buffer by clicking MBl on Forward or Reverse 
in the status line. If the text is found only in the other direction, 
EVE asks if you want to change direction and go there. 

If the text is found, EVE puts the cursor at the beginning of the 
string and highlights the found text. You can then use most of the 
same commands, menu items, and keypad functions on the found 
text that you use on a select range: 

• Case changes, such as Capitalize Word, Lowercase Word, and 
Uppercase Word 

• Copy or Store Text 

• Cut or Remove 

• Fill or Fill Range 

• Open Selected 
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For example, using Cut removes the found text and stores it in 
the Insert Here buffer or the clipboard, depending on your setting. 
To cancel the highlighting, move the cursor off the found text or 
choose the Re~et menu item from the pop-up menu. 

To find another 'occurrence of the same string, choose the Find 
Next menu item from the Search menu. 

Replacing Strings of Text 
To search for and replace text: 

Choose the Replace menu item from the Search menu. 

EVE displays a dialog box. 

Old String: ~I b_u_tt_er .... 'f ___ _ 

New String: I margarinE{ 

D All 

II OK II I Cancel I 
ZK-0198A-GE 

2 Type the old string (the text you want to find and replace), 
press the Tab key to move to the New String field, and then 
enter the new string (the text you want to insert in place of 
the old string). 

EVE searches for the old string, starting first in the current 
direction of the buffer. If it is found, EVE highlights the string 
and asks you whether you want to replace it. You respond with 
one of the following by clicking on the appropriate button in the 
dialog box: 

Response 

Yes 

No 

Effects 

Replace this one and search for the next one. (Default 
choice; you need only press the Return key.) 

Skip this one and search for the next one. 



Response Effects 

All Replace all the occurrences. No further prompting unless 
the search finds the old string in the opposite direction. 

Last 

Quit 

Replace this one and stop here. 

Cancel (skip this one and stop here). 

The case of the old and new strings determines not only what 
EVE searches for (as with the Find command), but also what 
replacement text is used. If both strings are in all lowercase, 
EVE finds any occurrence of the old string, regardless of case, and 
replaces it with the new string, matching the case appropriately. 
For example, if EVE finds a capitalized version of the old string, 
it is replaced by a capitalized version of the new string. If the old 
string contains any uppercase letters, the search and replacement 
are exact (case sensitive). 

Handling Whitespace Characters 
You can modify EVE so that Find commands treat spaces and 
tabs the same (that is, as "whitespace"), and span a line break 
for strings of two or more words. For example, searching for the 
string "Mark Twain" causes EVE to find all occurrences of the 
string if there is one or more spaces or tabs between the words, or 
if "Mark" is at the end of a line and "Twain" is at the start of the 
next line. 

To cause a search operation to treat both spaces and tabs as 
"whitespace," pull down the Search menu and display the Set 
Whitespace submenu. Choose the Set Find Whitespace menu 
item. The default is Set Find Nowhitespace. 

Searching with Wildcards 
Wildcard searches let you find a pattern of text. For example, you 
may want to find a string only when it appears at the start of a 
line or find a combination of letters only when they are followed by 
a vowel. You can use either VMS or ULTRIX wildcards, depending 
on your setting. The default setting is VMS. You can modify the 
setting from the Set Wildcards submenu on the Search menu. 

To do a wildcard search: 

Choose the Wildcard Find... menu item from the Search menu. 
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EVE displays a dialog box. 

Forward Wildcard Find: I August\>31 

(Currently using VMS-style wildcards.) 

II OK II I Cancel I 
ZK-0197A-GE 

2 Type the pattern of text you want to find, using both wildcards 
and literal text. 

To get a list of the available wildcard patterns, choose the Show 
Wildcards menu item from the Search menu. 

The following examples show different search patterns, mostly 
using VMS wildcards: 

Pattern 

b%t 

b*t 

August**31 

August\>31 

Matches 

B or b followed by any single character and a T or 
t, as in: "batch," "between," or "rabbit." A percent 
sign ( % ) matches any single character on a line. 
The ULTRIX equivalent is the period, for example, 
b.t. 

B or b followed by any characters and a T or t on 
the same line, as in: ''blast," "butler," "be still," or 
the strings found by b%t. An asterisk ( *) matches 
any number of characters on the same line. 

August 31 separated by any amount of text-tabs, 
spaces, line breaks, or other text characters. 

August 31 split by a line break-that is, "August" 
at the end of one line and "31" at the start of the 
next line. A backslash and right angle bracket 
(\ >) match end-of-line; backslash and left angle 
bracket (\ <) match start-of-line. The ULTRIX 
equivalent uses the caret and dollar sign, for 
example, August$31. 

If a matching pattern is found, EVE highlights the found text. 
You can then use commands such as Copy, Fill, Open Selected, 
Remove, and Uppercase Word, just as you would with a found 
range. 



To find another occurrence of the pattern, choose the Find Next 
menu item from the Search menu. 

To set the type of wildcards: 

Choose the Set Wildcards menu item from the Search menu. 

2 Choose either Set Wildcards VMS or Set Wildcards ULTRIX. 

You can also choose the type of wildcards and choose Set 
Whitespace or Set N owhitespace from the Search Preferences 
submenu, which is accessible from the Customize menu. 

Formatting Text 

Fill Paragraph 

Fill Range 

Centerline 

Change Case 

Paginate 

Set Margins ... 

Set Paragraph Indent ... 

To format text, you can set the left and right margins, paragraph 
indent, and tab stops. You ·can also fill text and insert page 
breaks. Margins, paragraph indent, and tab stops are buffer­
specific settings. In other words, you can specify different settings 
for each of your buffers or files. 

From the Format menu, you can perform simple formatting 
operations such as centering the line the cursor is on by choosing 
the Center Line menu item. You can also change the case of 
text by displaying the Change Case submenu and choosing 
the Capitalize Word, Uppercase, or Lowercase menu item. 
Change-case operations work as follows: 

1 On the current select range 

2 On the current found range 

3 On the current word 

According to this hierarchy, a select range has precedence over a 
found range, which in turn has precedence over the current word. 
For example, if you have an active select range consisting of five 
words and you choose the Uppercase menu item, every word in 
the select range becomes uppercase-not just the word the cursor 
is currently on. 

Setting Margins 
To set the margins of the buffer: 

Choose the Set Margins... menu item from the Format Menu. 
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EVE displays a dialog box. 

Set Margins !I] 

Set Left Margin To: '"""I~ ...... :------

Set Right Margin To: l._1_..q _____ _ 

II OK II Apply I cancel I 
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2 Click MBl on Set Left Margin or Set Right Margin. 

3 Type the margin setting you want. 

For example, you can set the left margin at column 5 and the 
right margin at column 70. Then, as you type, EVE wraps text 
at the right margin of the buffer and starts new lines at the left 
margin. Existing text is not affected. The default left margin is 1, 
and the default right margin is 79. 

Filling Text 
Filling text causes the maximum number of words to fit on a line, 
based on the current margins of the buffer. This is particularly 
useful to rewrap text after you have erased words or pasted text, 
or if you change the margins. You can fill text that you have 
selected or found or fill the current paragraph. 

To fill a select range or found text: 

Select or find the text you want to fill. 

2 Choose the Fill Range menu item from the Format menu. 

To fill the current paragraph: 

Put the cursor anywhere on the· paragraph you want to fill. 
"Paragraphs" in EVE are bounded by blank lines, the top 
or bottom of the buffer, page breaks, or DSR or DSRPLUS 
commands (such as .Blank). 

2 Choose the Fill Paragraph menu item from the Format menu. 



Setting the Paragraph Indent 
Paragraph indent is the number of spaces you want added to 
or subtracted from the first line of each paragraph you create or 
reformat. For example, in writing a letter, you may want to have 
each paragraph indented five spaces or you may want to use a 
negative indent to create lists. 

To set the paragraph indent: 

Choose the Set Paragraph Indent... menu item from the 
Format menu. 
EVE displays a dialog box. 

Set Paragraph Indent [g 

Set Paragraph Indent: lo.::..I ------

OK Apply I Cancel I 

ZK-0188A-GE 

2 Type the number of spaces you want to indent new 
paragraphs. 

The paragraph indent is relative to the left margin. For example, 
if you set the left margin to 5 and the paragraph indent to 4, then 
the first line of each paragraph will start at column 9 and the 
remaining lines at column 5. The default is 0, or no indent. 

If you want a "hanging" paragraph, such as for making bulleted 
lists, use a negative number. For example; to format lists so that 
the counter or bullet is to the left of the text, you can set the left 
margin to 4 and the paragraph indent to -3. Make each list item 
a separate paragraph (by using blank lines between each item). 
The counter or bullet at the start of each list item will be 3 spaces 
to the left of the left margin; the other lines of a list item will 
begin in column 4. 

If you want no paragraph indent-that is, if you want paragraphs 
to start at the left margin-set the paragraph indent to zero ( 0 ), 
which is the default setting. 
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Setting Tabs 
To set tab stops: 

Choose the Buffer Preferences... menu item from the 
Customize menu. 
EVE displays a dialog box. 

2 Type the tab stops you want. 

3 Click MBl on Set Tabs At or Set Tabs Every. 

With Set Tabs At, you can specify the tabs you want at different 
intervals, for example, 5, 9, 16, 24, 31. With Set Tabs Every, you 
specify a single interval for every tab stop. The default tab stops 
are every 8 columns. Setting tab stops changes existing tabs in 
the buffer you are editing. 

You can also set the way tabs appear in the buffer and the tab 
mode, which determines the effects of pressing the Tab key. These 
are global settings, which apply to all buffers. By default, the Tab 
function inserts a tab character, which appears simply as blank 
space, and moves the cursor and any existing text to the right 
until the next tab stop. Setting the tab mode lets you make tab 
characters visible or makes the Tab function insert spaces instead 
of a tab character or move the cursor without inserting anything. 

To set the tab modes: 

Choose the Global Preferences... menu item from the 
Customize menu. 
EVE displays a dialog box. 

2 Click MBl on the tab mode you want-Insert, Movement, or 
Spaces. 
Tab mode does not affect tabs you have already entered. For 
example, setting the tab mode to Spaces does not convert 
existing tab characters to spaces. 

3 Choose either Invisible or Visible tabs. 
By default, the Tabs Visible option is turned off, which causes 
tabs to be invisible. Click on it to make your tabs visible. 
Visible tabs appear as a small Jt. Setting tabs visible affects 
only tabs entered in with the tab mode set to Insert-that is, 
actual tab characters. 



Setting the tab mode to Movement makes Tab a cursor-moving 
function only, so that pressing the Tab key puts the cursor at 
the next tab stop, without moving your text. Setting the tab 
mode to Spaces makes the Tab function insert the appropriate 
number of spaces rather than a tab character. This is useful if 
you are going to print or display the text on devices that have 
different tab stops, because on most devices the space character 
is a uniform size. If you set the tab.mode to Insert, which is the 
default setting, the Tab function inserts a tab character. 

Setting Soft Page Breaks 
You can insert a "soft" page break every 54 lines of a file to 
produce 54-line pages. A soft page break is a form feed followed 
by the null character. It appears as a small ~ and small ~ . 

To insert soft page breaks: 

Choose the Paginate menu item from the Format menu. 
This causes EVE to move back from the current cursor 
position to the previous page break (if any) and check ahead 
for page breaks within the next 54 lines. If soft breaks are 
found within the 54 lines, EVE erases them, then moves down 
54 lines (if there are that many), inserts a soft break, and puts 
the cursor on the next line. 

Note You can manually insert soft page breaks from the WPS keypad 
by pressing Gold IP. 

2 Choose the Paginate menu item again to continue paginating 
the buffer. 
If a "hard" page break is found, EVE stops on the line after 
that page break, in case you want to erase it. A hard page 
break is a form feed only, and it can be inserted with the 
Insert Page Break command or Ctrl/L. 
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New 

Open Selected 

Open ... 

Include ... 
················· I Save File 

Save File As ... 

Exit 

Quit 

8-20 Using EVE 

You can save your edits either when you exit from EVE or by 
choosing the Save File menu item from the File menu. The new 
file has the same name as the file you are editing, with a version 
number one higher or with. a version number of 1 if you are 
creating a new file. 

If you are editing a buffer that does not have a file in it, for 
example, if you invoked EVE without specifying an input file, EVE 
prompts you for the name of the output file. 

To save your edits under a different file name: 

Choose the Save File As... menu item from the Edit menu. 
EVE displays a dialog box. 

Save File As l!iJ 

Save File As:II ...._ ______ _ 

II OK II Apply I Cancel I 

ZK-0190A-GE 

2 In the dialog box, type the name of the file. 

For example, if you are editing a file called ROUGH.DAT, you 
may want to save it as FINAL.TXT. 

To end the editing session, do either of the following steps: 

• Choose the Exit menu item from the File menu. 
This saves your edits, creating a new file or new version of an 
existing file. 

• Choose the Quit menu item from the File menu. 
This discards your edits. If you made any changes to the 
buffer, EVE asks you to confirm that you want to quit so that 
you will not accidentally discard your work. 

If you have made no changes to the buffer or no changes since you 
last saved the file, then exiting and quitting are the same. No 
duplicate files are created. 



Viewing and Editing More Than One File 
During your editing session, you can create or edit more than 
one file, and you can view two or more files at the same time 
or different parts of the same file. This is useful if you want to 
compare different versions of a draft, cut and paste between files, 
or refer to a section of a long document while editing another 
section. 

Editing Another File 
To edit or create another file during your editing session: 

Choose the Open... menu item from the File menu. EVE 
displays a dialog box. 

2 Type the name of the file you want to open. 

You can also open a file selected in EVE or in another VMS 
DECwindows application you are running concurrently. To 
open a selected file, choose the Open Selected menu item from 
the File menu. 

Once you open a file, EVE creates a buffer with the same name as 
the file you specified. If the file exists, EVE copies it into the new 
buffer where you can edit the text. If no file of the specified· name 
exists, that is, if you are creating a new file, the buffer is empty. 

You can also create another buffer, without opening a file. 
For example, you may want to create additional buffers as 
"scratchpads" or temporary storage areas. To create a new buffer, 
choose the New menu item from the File Menu. EVE then creates 
a buffer named MAIN. If there is already a buffer named MAIN, 
EVE prompts you to type a different name for the new buffer. 
EVE puts the new buffer in the current window. 

If you want to save the edits you make in this buffer, choose the 
Save File As... menu item from the File menu and specify the 
output file you want to create, or specify the output file when you 
exit from EVE. 

Moving Between Buffers 
You can move between buffers, for example, to cut text from one 
buffer and paste it in another or to search for the same string in 
another buffer. 

To move between buffers, click MBl on the buffer name in the 
status line. EVE then puts your next buffer in the current window 
and moves the cursor to your last position in that buffer. 

Using EVE 8-21 



8-22 Using EVE 

To move to a nonconsecutive buffer: 

Choose the Show Buffers menu item from the Display menu. 
EVE shows a list of all the buffers you have created and puts 
the cursor in this list. 

2 Move the cursor to the name of the buffer you want to view 
and choose the Select menu item from the pop-up menu. The 
buffer is displayed. 

Deleting a Buffer 
To delete a buffer: 

Choose the Show Buffers menu item from the Display menu. 

2 Put the cursor on the name of the buffer you want to delete. 

3 Press the Remove key or choose the Cut menu item from the 
Edit menu. 

If the buffer has been modified, EVE displays a dialog box 
prompting you to click on the button to indicate your choice: 

Response 

Delete_only 

Write_first 

Quit 

Effects 

Deletes the specified buffer. 

Saves (writes out) that buffer, then deletes it. 

Cancels the operation-buffer is not deleted. 
(Default choice; you can simply press the Return 
key.) 

Viewing Multiple Files 
If you are editing two or more files in the same session, you can 
split the EVE main window into smaller windows so you can 
view the different files at the same time. You can also use split 
windows to view different parts of the same file, such as when 
editing a very long document, or to view the message buffer, which 
is useful when you are compiling VAXTPU procedures. 

To split the main window into two windows, choose the Two 
Windows menu item from the Display menu. To split the window 
into three or more windows: 

Choose the Split Window... menu item from the Display menu. 



EVE displays a dialog box. 

Split Window [!I] 

Number of Windows: I ...... [------

II OK II Apply 
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2 Type the number of windows you want. 

EVE then divides the main window into smaller, equal-sized 
windows, each with its own status line. The cursor appears in 
the lower or bottommost window. Each window shows the same 
buffer. 

To put a different file or buffer in the current window, use any of 
the following commands: 

Buffer 
New 
Next Buffer 
Open or Get File 
Open Selected 

To move between windows, click MBl where you want to put the 
cursor in another window. 

Note that your position in each window can be different even 
if the same buffer or file appears in different windows. This is 
useful if you want to view different parts of the same buffer or 
file, such as in editing a long document. 

To delete a window, do either of the following: 

• Choose the Delete Window menu item from the Display menu. 
EVE then deletes the current window and resizes the 
remaining window or windows accordingly. 

• Choose the One Window menu item from the Display menu. 

EVE then deletes all the windows except the current window. 

Deleting windows does not delete the buffers that were in the 
windows. 
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EVE lets you define keys using the Define Key command. You can 
define keys to execute commands you use frequently or define keys 
that you are accustomed to using in another editor or application. 

For example, the following command defines the F20 key as 
Center Line: 

Command: DEFINE KEY=F20 CENTER LINE 

Some keys cannot be defined, such as the Return key. For more 
information about defining keys, see online help for Define Key 
and Names For Keys. 

To show the definition of a key, use the Show Key command. You 
can specify the key by name on the command line, or you can let 
EVE prompt you to press the key you want to show. To undefine a 
key you have defined, use the Undefine Key command. 

Setting the Gold Key 
The Gold key is a key you specify for use with other keys so 
that you double the number of possible key definitions. For 
example, you can define F20 to execute one command and define 
the combination of Gold and F20 to execute a different command. 
The Gold key is like a shift key in that it enables a key to perform 
a secondary function in addition to its primary function. Unlike 
a shift key, however, which you use· by holding down, you press 
and release the Gold key before pressing the key whose secondary 
function you want to use. 

Both the EDT and WPS keypads use several Gold key 
combinations. For example, EDT defines the PF4 key to delete a 
line and defines the Gold-PF4 combination to restore (or undelete) 
the line. 

To set the Gold key, use the SET GOLD KEY command. You 
can type the key name on the command line or let EVE prompt 
you to press the key you want to set. For example, the following 
command sets PFl as the Gold key: 

Command: SET GOLD KEY PFl 

You can then define a Gold key combination, using a function key, 
control key, or typing key. For example, the following command 
defines the combination of Gold and the letter F as the Fill 
command: 

Command: DEFINE KEY=GOLD-F FILL 



For more information about setting the Gold key, see online help 
for Set Gold Key. For a list of Gold key combinations that are 
automatically enabled when you set the Gold key or the EDT or 
WPS keypad, see online help for Gold keys. 

Creating a Learn Sequence 
A learn sequence is a series of keystrokes or commands or both 
that you assign to a single key. This is useful for performing a 
series of editing operations or for entering frequently used text. 

To create a learn sequence: 

Choose the Learn menu item from the Customize menu. 

2 Make the edits you want EVE to learn. 

You can type commands, text, or both, including pressing keys 
already defined. For example, you may want to find a string of 
text or move a certain number of lines and then perform some 
editing operation, such as pasting text or reformatting the 
paragraph. Note that mouse operations, such as using menus, 
are not learned. 

3 To end or "remember" the learn sequence, press Ctrl/R. 

EVE then prompts you to press the key you want to use for the 
learn sequence. You can press a function key, control key, or 
Gold key combination, so long as that key has not been used 
in the learn sequence you are creating. If you do not want to 
remember the learn sequence, press the Return key, which cannot 
be redefined. 

Thereafter, to replay the learn sequence, you need only press that 
one key. EVE then replays the series of keystrokes in a kind of 
"player piano" fashion. 

Before replaying a learn sequence, you may want to check the 
definitions of any keys used within the sequence or any settings 
that apply to them. Learn sequences record keystrokes, rather 
than the key definitions at the time the sequence was created. 
Therefore, if any key definitions or settings used by the learn 
sequence are different from when the sequence was created, the 
sequence will fail or not work as expected. 
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Setting the Keypad 
If you are accustomed to the EDT or WPS editor, or if you are 
accustomed to using EVE on VTlOO-series terminals, you can set 
the keypad accordingly. 

For example, to set the EDT keypad, use the Set Keypad EDT 
command. This defines the numeric keypad and some other keys 
to emulate EDT. For example, PFl is set as the Gold key, PF4 is 
defined to delete a line, and Gold-PF4 is defined as Restore Line. 

To set the WPS keypad, use the Set Keypad WPS command. This 
defines the numeric keypad and some other keys to emulate WPS. 
For example, PFl is set as the Gold key and Gold-R is defined as 
the WPS Ruler key. Also, setting the WPS keypad automatically 
sets the cursor as bound. The WPS keypad functions do not use 
the clipboard. 

If you define keys that otherwise are defined by EDT or WPS, 
your definitions override the EDT or WPS definitions. If you 
subsequently undefine your keys, the EDT or WPS definitions 
are reactivated. Setting the EDT or WPS keypad does not fully 
implement all the EDT or WPS commands or features. For 
example, you cannot type EDT line-mode commands. For more 
information, see the following help topics: 

EDT Differences 
EDT Conversion 
WPS Differences 

Saving Key Definitions in a Section File 
To save your key definitions for future editing sessions, you 
can put the Define Key commands in an initialization file (as 
explained in the section Using Initialization Files) or you can 
create a section file. A section file is a binary file that stores key 
definitions and other extensions (such as any VAXTPU procedures 
you have compiled). Effectively, the section file you create is your 
own customized version of EVE. 

To create a section file: 

Pull down the Customize menu, display the Extend submenu, 
and choose the Save Extended EVE... menu item. 



EVE displays a dialog box. 

Save Extended EVE [!;] 

File to save in: .... If ______ _ 

II OK I Apply I cancel I 
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2 Type the name of the section file you want to create. 

The default file type for section files is TPU$SECTION. For 
example, if you type MYEVE, you create a section file called 
MYEVE.TPU$SECTION in your current (default) directory. 

A section file is cumulative, saving your latest key definitions and 
compiled procedures and any that were saved in the section file 
you are currently using. You use one section file at a time. 

To use a section file when you invoke EVE, use the /SECTION 
qualifier or define the logical name TPU$SECTION. You must 
specify the disk and directory as well as the name of the 
section file; otherwise, VAXTPU assumes the section file is in 
SYS$SHARE. For example, the following commands invoke 
VAXTPU using a section file called MYEVE.TPU$SECTION in 
your top-level (or login) directory: 

$ DEFINE TPU$SECTION sys$login:myeve 
$ SPAWN/NOWAIT/INPUT=NL: EDIT/TPU/DISPLAY=DECWINDOWS 

You may want to put the definition in your LOGIN.COM file. 

A section file saves key definitions (such as if you set the EDT 
keypad or created a learn sequence) and any VAXTPU procedures 
you compile. However, a section file does not save settings such 
as margins, tabs, and other editing values. Typically, you use 
an initialization file for these settings. See the section Using 
Initialization Files. 

Customizing EVE 

Learn 

Extend H 

Global Preferences .. . 

Buffer Preferences .. . 

Search Preferences r~ 

Set Width ... 

You can customize EVE by setting preferences for different kinds 
of editing or by extending the editor with VAXTPU procedures. 
During an editing session, you can set preferences by using the 
Customize menu and other menus or by executing an initialization 
file. You can also set private defaults by using an initialization file 
when you invoke EVE. 
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Some editing values are global settings, applying to the editor 
or to all buffers; others are buffer-specific settings, applying to 
particular buffers. For example, tab modes and wildcard patterns 
are global settings; margins and tab stops are buffer-specific 
settings. For more information, see online help for Defaults. 

Some other menus besides Customize also let you set preferences. 
For example, you can set the margins of the buffer by choosing 
the Set Margins... menu item from the Format menu and you can 
set search preferences (such as the type of wildcards) by using the 
Search menu. 

Setting Buffer Preferences 
From the buffer in which you are currently working, you can set 
buffer preferences, such as tab settings or paragraph indent, that 
apply only to that buffer. You can specify different buffer settings 
for each individual buffer during an EVE session. Note that EVE 
does not save these settings from one session to another unless 
you put the corresponding commands in an initialization file. 

To set buffer preferences, choose the Buffer Preferences... menu 
item from the Customize menu. EVE displays a dialog box. 

Settings For Buffer: MAIN 

Set Left Margin To:Li_ Set Right Margin To: I 79. 

Iii Set Wrap (i) Set Tabs Every I a.· 
Iii Set Buffer Modifiable 0 Set Tabs At 

D Set Buffer Read Only 

Set Paragraph Indent: I a· 

II OK II I Cancel I 
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Shaded buttons indicate the current settings. Click MBl on a 
button or its label to change the setting. Click on the OK button 
to apply your changes and close the dialog box. 

From the Buffer Preferences dialog box, you can customize any of 
the following features: 



Set Leff Margin To 
Unless you specify otherwise, the left margin (leftmost column) is 
set to 1. To change the setting, click on the text entry field next to 
Set Left Margin To and type the left margin you want. 

Set Right Margin To 
By default, the right margin is one column less than the width of 
the EVE screen display. For example, if the screen display is 80 
columns, the default right margin is 79. To change the setting, 
click on the text entry field next to Set Right Margin To and type 
the right margin you want. 

Set Wrap 
Normally, word wrap is set, which means that as your text reaches 
the right margin of the buffer, EVE automatically wraps the text, 
starting a new line, without your having to press the Return key. 
To disable Set Wrap, click on it. 

Set Buffer Modifiable 
Unless you specify otherwise, you can modify your buffers during 
an EVE session. If you are working with a buffer that contains 
text you do not want to change inadvertently, you can disable 
the Set Buffer Modifiable option. This overrides the mode of the 
buffer (insert or overstrike) and makes it impossible for you to 
modify the buffer. Turning Set Buffer Modifiable on again restores 
the previous mode of the buffer. 

Set Buffer Read Only 
Normally, when you make changes to a buffer during an EVE 
session and then exit, the buffer is saved (written out). If you turn 
on the Set Buffer Read Only option, the buffer will not be saved 
when you exit, even if you have modified it. This is useful if you 
just want to use the buffer as a scratchpad. Turning on Set Buffer 
Read Only also sets the buffer as unmodifiable, but you can then 
turn on Set Buffer Modifiable to produce a buffer that is both read 
only and modifiable. 

Set Paragraph Indent 
By default, the paragraph indent is set to 0. To change the 
setting, click on the text entry field next to Set Paragraph Indent 
and type the value you want. For more information about setting 
the paragraph indent, see the section Setting the Paragraph 
Indent, which describes how to set the paragraph indent from the 
Format menu. 
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Set Tabs Every 
By default, the tab stops are set to be at· every 8 columns. You can 
change the interval for tab stops by typing the interval you want 
and clicking on the text entry field next to Set Tabs Every. For 
more information about setting tabs, see the section Setting Tabs. 

Set Tabs At 
You can override the default of tab stops being set at regular 
intervals by typing the intervals at which you want tab stops to 
be used in your buffer (for example, 3, 5, 11, 35, 49), and then 
clicking on Set Tabs At. For more information about setting tabs, 
see the section Setting Tabs. 

The preferences you choose apply only to the current editing 
session. If there are settings you want all the time, for example, 
if you always want to have a bound cursor or particular tab 
settings, use an initialization file, as explained in the section 
Using Initialization Files. 

Setting Global Preferences 
You can make global changes to EVE, such as setting the cursor 
as free or bound, that will apply to all of your EVE buffers. Note 
that EVE does not save these settings from one session to another 
unless you put the corresponding commands in an initialization 
file. 

To set global preferences, choose the Global Preferences... menu 
item from the Customize menu. EVE displays a dialog box. 



D Set Find Case Exact Set Cursor: <I Free 
0 Bound 

D Set Clipboard 

D Set Tabs Visible Set Tabs: <I Insert 
0 Movement 

D Set Pending Delete o Spaces 

OK I cancel I 
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From the Global Preferences dialog box, you can customize any of 
the following features: 

Set Find Case Exact 
Normally, when you specify a text string that is all lowercase 
in a search operation, EVE finds every occurrence of the string, 
including those that are uppercase or have mixed case. When you 
turn on Set Find Case Exact, however, even when you specify a 
lowercase text string EVE finds only those strings that match it 
exactly. 

Set Clipboard 
By default, the clipboard is not enabled. Turning it on allows you 
to transfer text between EVE and another VMS DECwindows 
application. Alternatively, you can use the Insert Here buffer, 
which is where EVE stores text when you use the Copy or Cut 
menu item from the Edit menu, unless the clipboard is enabled 
(in which case EVE stores the text in the clipboard). Using the 
Insert Here buffer can be faster, depending on the amount of text 
involved and the number of other applications you are running 
concurrently. WPS keypad functions do not use the clipboard. 

Set Pending Delete 
Pending delete, which is disabled by default, means that if you 
select text and then press the <XI key or type new text, the 
select range is deleted. This can be useful for quickly erasing or 
replacing a block of text. 
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Set Tabs Visible 
Unless you specify otherwise, the tab characters inserted in your 
buffer are invisible. Turning on Set Tabs Visible causes tabs to 
appear as a small l;\i. See the section Setting Tabs for more 
information about setting tabs. 

Set Tabs 
Normally, the tab mode is set to Insert. This causes the Tab 
function to insert a tab character, which appears as a blank space, 
and move the cursor and any existing text to the right until the 
next tab stop. You can also set the tab mode to Movement, which 
makes the Tab a cursor-moving function only, or Spaces, which 
makes the Tab function insert the appropriate number of spaces 
rather than a tab character. See the section Setting Tabs for more 
information. 

Set Cursor 
Unless you specify otherwise, EVE uses a free cursor. A free 
cursor lets you move anywhere in the buffer and insert text 
regardless of whether characters are already there. Pressing the 
up and down arrow keys moves the cursor in the same column on 
the screen, regardless of whether there is text in those columns. 

By contrast, a bound cursor follows the shape or flow of your text, 
as in the EDT and WPS editors. For example, if you are at the 
end of a line and press the right arrow key, the cursor moves to 
the start of the next line. 

Setting Width 
You can modify the width of your EVE screen layout. This does 
not affect how many characters you can put on a line (which is 
determined by the right margin), but only how many characters 
are visible. For example, if you have a file that is 132 columns 
wide, setting the screen layout width to 132 lets you view the file 
without shifting the window horizontally. 

To modify the width of your screen layout: 

Choose the Set Width... menu item from the Customize menu. 
EVE displays a dialog box. 

2 In the text entry field, type the width you want. 

3 Click on Apply or OK. 



Setting VAXTPU Preferences 
From the VAX Text Processing Utility (VAXTPU) dialog box you 
see when you start EVE from FileView, you can set VAXTPU 
preferences. Many of these options are primarily of interest to 
users writing VAXTPU procedures, and you do not need to modify 
them to use EVE. If you do not want to see this dialog box when 
you start EVE from File View, click on the Hide Dialog option. 
Once you hide the dialog box, you can cause it to appear again 
by pressing and holding the Shift key while you choose the Edit 
menu item from File View's Files menu. 

VAXTPU is a programmable text processing utility that includes a 
high-level procedural language, a compiler, an interpreter, and an 
editing interface. EVE is an editing interface written in VAXTPU 
that is layered on VAXTPU. By setting VAXTPU preferences, you 
can modify the behavior of EVE. 

These modifications to EVE are called extensions, which can 
be implemented with a VAXTPU command file (VAXTPU source 
code), a VAXTPU section file (compiled VAXTPU code in a binary 
form), or with an initialization file (an ASCII file containing 
commands that are processed by EVE when you start an editing 
session). See the sections Saving Key Definitions in a Section File 
and Using Initialization Files for more information on section and 
initialization files. For more information about VAXTPU, see the 
section Using VAXTPU Procedures to Extend EVE and the VAX 
Text Processing Utility Manual. 

When you start EVE from File View, the second dialog box you see 
is the VAXTPU dialog box. 

From the VAXTPU dialog box, you can customize any of the 
following features: 

FILE: 
Allows you to specify the input file in the text entry field you want 
to use in your editing session. 

Create 
By default, if EVE does not find the input file you specified, EVE 
creates a file. You can disable this option by clicking on Create, 
which causes EVE to abort the editing session if you specify a file 
that does not exist. 
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Display 
Unless you specify otherwise, EVE uses terminal functions such 
as the screen display and the keyboard. You can disable this 
option by clicking on it. This would be useful, for example, if 
you were running VAXTPU procedures in a batch job or using 
VAXTPU on an unsupported terminal. 

Modify 
By default, EVE makes the first user buffer in an editing session 
modifiable, which means that you can make changes to it. You 
can disable this option by clicking on it. Note that any buffers 
you create in the editing session after the first user buffer will be 
modifiable. You can set subsequent buffers as unmodifiable from 
the Buffer Preferences dialog box which is accessible from the 
Customize menu. 

Write 
Unless you specify otherwise (or quit rather than exit the editing 
session), EVE creates an output file from the current buffer if the 
contents are modified. You can disable this option by clicking on 
it. 

Start Position 
Normally, when you start EVE the cursor is positioned in the first 
row and the first column. You can specify where you want the 
cursor to be when you start an editing session by entering the 
appropriate numbers. 

Command 
By default, EVE looks for a command file (VAXTPU source code) 
with the logical name TPU$COMMAND. You can disable this 
option by clicking on Command, or you can enter the name of your 
own command file. 

Debug 
Unless you specify otherwise, when you start EVE you enter 
an editing session. If you would like to start out in the debugger, 
however, (for example, if you are debugging a VAXTPU procedure), 
you can turn on Debug by clicking on it. Once you turn on Debug, 
EVE looks for a debugger·with the logical name TPU$DEBUG, 
but you can specify your own debugger· in the text entry field. 

Initialization 
By default, EVE looks for an initialization file (an ASCII file 
containing commands that are processed by EVE when you start 
an editing session) when you begin an editing session. You can 



disable this option by clicking on it. In the text entry field next 
to Initialization, you can enter the name of the initialization file 
you want EVE to execute for your editing session. See the section 
Using Initialization Files for more information. 

Section 
By default, EVE looks for a section file (compiled VAXTPU code 
in a binary form) with the logical name TPU$SECTION. You can 
disable this option by clicking on Section, or you can enter the 
name of your own section file. 

Output 
Unless you specify otherwise, EVE uses the same name for the 
output file that you specified for the input file. When you modify 
a buffer and then exit from EVE, EVE writes the buffer to a file 
with the same name as the input file and assigns the new file 
a version number that is one higher than the highest existing 
version of the input file. You can either specify a different output 
file name in the text entry field next to Output, or you can disable 
the Output option by clicking on it, which means that no output 
file will be created. 

Hide Dialog 
If you do not want to see this dialog box when you start EVE 
from File View, you can suppress it by clicking on the Hide Dialog 
option. To cause it to appear again, press and hold the Shift key 
while you choose the Edit menu item from File View's Files menu. 

Using Initialization Files 
An initialization file contains EVE commands, typically to 
set margins, tab stops, and other preferences without having to 
type every command again for each editing session. You can use 
an initialization file when you invoke EVE or you can execute 
initialization files during your editing session. 

Example 8-1 is a sample initialization file, containing commands 
for setting editing values and key definitions. 

When you start an editing session, .EVE first. searches your 
current (default) directory and then SYS$LOGIN for a file called 
EVE$INIT.EVE. EVE uses the first initialization file it finds, 
if any. If you want to use a different initialization file, you can 
define the logical name EVE$INIT or use the /INITIALIZATION 
qualifier. For example, the following command invokes EVE using 
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Example 8-1 Sample EVE Initialization File 

EVE Initialization file 

Settings 

SET CLIPBOARD 
SET CURSOR BOUND 
SET FIND WHITESPACE 
SET LEFT MARGIN 5 
SET PARAGRAPH INDENT 4 
SET RIGHT MARGIN 70 
SET TABS EVERY 5 
SET TABS VISIBLE 

! Key definitions 

SET KEYPAD EDT 
DEFINE KEY= F20 SHOW BUFFERS 
DEFINE KEY= GOLD-F20 DELETE BUFFER 
DEFINE KEY= GOLD-E2 CENTER LINE 
DEFINE KEY= GOLD-C CAPITALIZE WORD 
DEFINE KEY= CTRL/N NEXT BUFFER 
DEFINE KEY= GOLD-CTRL/L PAGINATE 

! Define a key to use the WPS Ruler 

DEFINE KEY= GOLD-KP7 WPS GOLD-R 

an initialization file called MYEVE.EVE in your current (default) 
directory: 

$ EDIT/TPU/DISPLAY=DECWINDOWS/INITIALIZATION=myeve 

If there is an initialization file you want for all or most sessions, 
you may want to define the logical name EVE$INIT, particularly 
if you keep the initialization file in a directory different from the 
files you edit. If you put the definition in your LOGIN.COM file, 
EVE will use that initialization file for all editing sessions. 

If you are defining only a few keys-such as if you simply want 
the EDT keypad-you can put Define Key commands in an 
initialization file. If you are defining several keys, you should save 
the key definitions in a section file. A section file is in binary form 
and therefore is faster than an initialization file. See the section 
Saving Key Definitions in a Section File for more information 
about section files. 

To execute an initialization file during an editing session: 

Pull down the Customize menu, display the Extend submenu, 
and choose the @EVE file... menu item. 
EVE displays a dialog box. 



@EVE File [5j 

EVE initialization file to execute: ~II __ _ 

ll OK II Apply I cancel I 
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2 Type the name of the initialization file you want to execute, 
for example, MYEVE.EVE. 

When you execute an initialization file during a session, 
commands for buffer settings apply to the current buffer. This 
is effectively the same as typing the commands that the file 
contains. For example, you may want to create initialization files 
to reset the left and right margins for editing letters or other 
kinds of documents. 

Using VAXTPU Procedures to Extend EVE 
You can extend or modify EVE by writing code in the VAXTPU 
language. The VAXTPU programming language is a structured 
language designed for creating text-processing applications, 
such as the EVE editor. You can write procedures to add new 
commands to EVE, to customize the editor, or to create your own 
application. 

Example 8-2 is a sample VAXTPU procedure to insert the current 
date. 

For more information about VAXTPU programming, see the VAX 
Text Processing Utility Manual. 

To compile a VAXTPU procedure during your editing session: 

Put the cursor anywhere on the procedure you want to 
compile. 

2 Pull down the Customize menu and display the Extend 
submenu. 
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Example 8-2 Sample VAXTPU Procedure 
PROCEDURE date_only 

Inserts the current date only (no ti~e) and reformats 
the text; restores overstrike mode if necessary. 

LOCAL save_mode, 
come_back; 

save mode .- GET_INFO (CURRENT_BUFFER, "mode"); 
IF save mode OVERSTRIKE 

THEN 
SET (INSERT, CURRENT_BUFFER); ! Make sure of insert mode 

ENDIF; 

COPY TEXT (FAO (' !11%D', 0)); 
come_back := MARK (NONE); 
MOVE_HORIZONTAL (-5); 
EVE_ERASE_CHARACTER; 
COPY_TEXT (II II); 

MOVE_HORIZONTAL (-5); 
EVE_ERASE_CHARACTER; 
COPY_TEXT (" "); 
MOVE_HORIZONTAL (+1); 
EVE_CAPITALIZE_WORD; 
POSITION (come_back); 
SET (save_mode, CURRENT_BUFFER); 

ENDPROCEDURE; 

Insert the date only. 

Move cursor back and 
erase dash between month 
and year and between day 
and month, replacing it each 
time with space. Make sure 
cursor is on month and then 
capitalize it (first character 
uppercase, others lowercase) . 

Restore previous mode 

3 Choose the Extend This menu item from the Extend submenu 
or, if you have more than one VAXTPU procedure in the 
current buffer and you want to compile every one, choose the 
Extend All menu item. 
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You can also choose the Extend EVE menu item to compile a 
VAXTPU procedure in the current buffer. 

To execute a VAXTPU procedure you have compiled, or to execute 
a built-in procedure, use the TPU command. For example, the 
following command executes a compiled procedure called DATE_ 
ONLY: 

Command: TPU date_only 

To save your compiled procedures for future editing sessions, use 
Save Extended EVE to create a section file. 







Starting Mail 

9 
Using Mail 

Mail allows you to exchange messages with other computer users. 
You can use Mail to send messages, read messages sent to you, 
and print, file, delete, reply to, and forward messages. 

This chapter describes how to 

• Send messages 

• Read messages 

• Reply to messages 

• Forward messages 

• Print messages 

• Create files from messages 

• Work with drawers and folders 

• Customize your Mail environment 

• Exit from Mail 

To start Mail, choose the Mail menu item from File View's 
Applications Menu. Mail displays the main window. 
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File Edit Pick Create-Send Read Maintenance customize 

~MAIL 

€sl INBOX - 5 messages 

8 1 8-APR-1990 MIASMA: :SMITH 
8 2 27-APR-1990 SOIREE::JONES 
8 3 4-MAY-1990 DARCY::BROWN 
~ 4 16-MAY-1990 UDO::WHITE 
~ 5 18-MAY-1990 BRONTE: :BLACK 

Ll MAIL 

Ll WASTEBASKET 

~ STATUSREPORTS 

Ll REPORTS 
Ll WASTEBASKET 

Deliver Mall I Read New Maull Create-Send I Reply 

Team Meeting, 1:00 
lunch invitation 
RE: review schedule 
poetry reading 
dog class canceled 

Help 

ZK-0294A-GE 

Note You can choose an alternate display style for the main window. 
See the section Using a Paned Style Main Window for more 
information. 

The main window lists your Mail drawers, folders, and messages. 
Drawers and folders help you organize your mail messages. You 
use Mail drawers and folders as you would use drawers and 
folders in your office filing cabinet. You might file all messages 
on a related topic in one folder, and group related folders in one 
drawer. You can create as many drawers and folders as you need. 

Drawers and folders can be opened to reveal their contents, and 
closed to conceal their contents. To open a drawer or folder, double 
click MBl on the drawer or folder name. To close a drawer or 
folder, double click MBl on the name of an open drawer or folder. 

When you enter Mail for the first time, a drawer named MAIL 
is automatically created and opened. The two folders in the 
MAIL drawer, INBOX and WASTEBASKET, are listed below 
and indented to the right of the drawer name. The INBOX 
folder contains messages that have been sent to you. The 
WASTEBASKET folder contains messages that you have deleted. 

The INBOX folder is also automatically opened when you enter 
Mail, as indicated by the open folder icon in front of INBOX. 
If there are any messages in the INBOX folder, they are listed. 
Messages are chronologically arranged by date received. 



Drawers, folders, and messages are identified by unique icons. 
These icons also indicate whether the object is open or closed. 

Note If you have used the VMS Mail Utility, Mail will automatically 
change the names of your Mail folders to correspond to VMS Mail 
folders. See the section Making Mail Perform Like the VMS Mail 
Utility for more information. 

Near the bottom of the window is a row of push buttons. These 
buttons allow you to execute the tasks you most commonly 
perform with messages. Many of the push buttons are disabled 
when you first start Mail and remain so until you select a specific 
message. 

Pressing MB2 on an object in a Mail window displays a pop-up 
menu. Pop-up menus contain many commonly performed tasks. 
The items on a pop-up menu vary according to the type of object 
(drawer, folder, or message) on which you are positioned, and act 
on the object on which you are positioned. 

Pop-up menu items and push buttons duplicate pull-down menu 
items. Where you can choose among a push button, pop-up menu, 
or pull-down menu to execute a task, instructions in this chapter 
list one way to accomplish the task. Depending on your working 
style, you may prefer to use one of the other methods once you are 
familiar with Mail. 

The vertical scroll bar in Mail's main window contains top and 
bottom stepping buttons and a navigation window, which are not 
present in standard VMS DECwindows scroll bars. The top and 
bottom stepping buttons, located at the top and bottom of the 
scroll bar, scroll the window to the next drawer or folder in the 
direction indicated. The navigation window is displayed in the 
upper right corner of the main window when you drag the vertical 
slider through the scroll region of the scroll bar. This window 
shows the drawer or folder that would appear at the top of the 
index if you released the slider. 

Sending Messages 

I- Create-Send 
I You can create and send a mail message or an existing file to one 

user or many users with Mail. 
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Sending a Message 
To send a mail message to any user on your system or another 
system, click on the Create-Send button in the main window. A 
Create-Send window opens. You can have multiple Create-Send 
windows open at one time. 

~ Mail:Create !ilm 
File Edit Cha~Editor Help 

From: THACKER ITimoth~ Thackerf 

To: ll 
CC: ITHACKERT 

Subject: [f 

0 
.-, 

'-' 
Q 

ll Quit H Reset J l Save As ..• J l Send J 
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The Create-Send window is divided into an envelope area and a 
message area. The envelope area contains the following items: 

Field 

From: 

Description 

Your user name. 

If you specified a personal name in your mail profile, it 
will be displayed to the right of your user name. Your 
mail profile, available from the main window's Customize 
menu, allows you to customize specific features in Mail. 
See the section Customizing Your Mail Environment for 
more information about specifying a personal name. You 
can alter your personal name for the current message by 
entering a change in this field. 



Field 

To: 

CC: 

Subject: 

Description 

The name of the user or users receiving the message. If 
you are sending mail to people on your node, specify only 
their user names. If you are sending mail to people on 
another node, you must enter their node names and user 
names using the following format: nodename::username. 
If you are using a message router, enter the address in 
the appropriate format for your router. 

You can send the same message to several users by 
separating their user names with commas. Press the 
Return key if you need more space. 

For information about sending a message to a 
distribution list, see the section Sending a Message to 
a Distribution List. 

The name of the user or users you want to receive a copy 
of the message (optional). If you have set the Copy Self 
on Send option in your mail profile, your user name is 
displayed. 

For information about sending a copy to a distribution 
list, see the section Sending a Message to a Distribution 
List. 

The subject of the message (optional). Press the Return 
key if you need more space. 

To enter text in a field, point to the field and click MBl. Use the 
Tab key to advance to the next field and use Shifttrab to move to 
the previous field. Use the built-in editing commands, described 
in the VMS DECwindows User's Guide, to correct mistakes. 
When the envelope is complete, press the Tab key to move to the 
message area. 

In the message area, enter the text of your message. 

By default, you can use the built-in editing commands described in 
the VMS DECwindows User's Guide to edit your message. If there 
is more than one editor available on your system, you can use a 
different editor. See the section Changing Editors for information 
about changing editors. 

To send the message, click on the Send button. Mail displays a 
message box informing you of the progress of the send operation. 

To close the window, click on the Quit button. This deletes all text 
in the window and closes the window. 

To clear the window without closing it, click on the Reset button. 
The text in the Create-Send window is erased and the window can 
be used to send another message. 
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Saving a Draft of a Message 
Saving a draft of a message allows you to begin composing 
a message now, and continue working on it later. If you are 
creating a long mail message, it is advisable to save the message 
occasionally. To save a draft of a message: 

Click on the Save As ... button. 

Mail displays a dialog box. 

Draft: 

OK II I cancel I 
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2 Enter the draft message name, which can be no longer than 
39 characters. 
By default, the type DRAFT is appended to the file name and 
the file is stored in your default draft directory. If you specify 
a different file type or directory, Mail will not list this file 
when you request a list of your draft files. 

3 Click on the OK button to save the draft message. 

The message can still be sent or canceled after it has been saved. 

Saved draft messages are VMS files and cannot be deleted through 
Mail. You can delete draft messages by choosing the Delete menu 
item from File View's Files menu. 

Resuming Work on a Draft Message 
You can continue working on a draft of a message that you 
previously saved. 

To resume work on a draft message: 

Choose the Include Draft File... menu item from the Create­
Send window's File menu. Mail displays a dialog box. 



File Filter 

l"f SYS$DISK:D* .DRAFT 

Files in DISK$:[MORRIS] 

l]CLASS.DRAFT;1 

l]REPORT.DRAFT;1 

IJSARAH.DRAFT;1 

¢I I 
Selection 

0 .... 

Q 
IJO D 

Filter f 

OK II 
I cancel f 

ZK-0298A-GE 

The dialog box prompts you for the name of the draft file you 
want to continue working on. The file list box lists the names 
of any draft files in your default draft directory. 

2 Double click on the name of the draft file you want. 

The draft message is displayed in the Create-Send window, 
where you can continue working on it. 

If you want to work on a draft file that is not listed, enter the 
name of that file in the Selection text entry field and click on the 
OK button. Or, use the File Filter text entry field to list a subset 
of files that you can then select from. For example, to list all files 
in another directory with the file type DRAFT, enter the complete 
directory specification-[JONES.LETTERS]* .DRAFT-in the File 
Filter text entry field and click on the Filter button. Then double 
click on the name of the file you want to continue working on. 
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Including a File in a Message 
You can insert an existing file into a mail message. 

To include a file in a message: 

Choose the Include File ... menu item from the Create-Send 
window's File menu. Mail displays a dialog box. 

File Filter 

I)'*.* 

Files in DISK$:[JONES] 

IJACCOUNTS.DAT;4 ~ Filter 

IJAGENDA.TXT;2 OK 
IJDEBUG.LOG;1 

IJDECW$CAPTURE.TMP;1 
I cancel I 

IJDECW$DECTERM_ERROR.LOG;5 

IJDECW$MAILDAT;4 

IJELISE.TXT;3 

IJSETH.DRAFT;1 
...... 

<i [ ] _pc) D 
Selection 

ZK-0297 A-GE 

The dialog box prompts you for the name of the file you want 
to include. The file list box lists the names of all files in the 
current directory. 

2 Double click on the name of the file you want to include. 
The contents of the file are displayed in the Create-Send 
window. You can edit the file if desired. 
You can also use the File Filter text entry field to list 
a subset of files that you can then select from. For 
example, to list all files in another directory with the file 
type TXT, enter the complete directory specification­
[JONES.MESSAGES]*.TXT-in the File Filter text entry 
field and click on the Filter button. Then double click on the 
name of the file you want to include. 

3 Click on the Send button to send the message. 



Sending a Message to a Distribution List 
If you need to send one message to many users, you can create 
a file, called a distribution list, that contains a list of users. You 
then specify an at sign (@) and the file name in the To: field when 
you send the message (for example, @PROJECT). 

Distribution lists are not created within Mail. Use an editor, 
such as Notepad (see Chapter 10), to create your distribution 
lists. When creating distribution lists, enter one user name 
per line. You can also include the names of other distribution 
lists by specifying an at sign (@) followed by the name of the 
distribution list. For example, a distribution list file could contain 
the following: · 

MIASMA::FORD 
YONKIN 
TUTTLE 
DARCY::MORRIS 
@PROJECT 

When naming distribution list files, use a DIS file type because 
that is what Mail looks for by default. 

To send mail to the users in a distribution list: 

Move to either the To: or CC: field in the envelope area of the 
Create-Send window and press MB2. 

A pop-up menu is displayed. 

2 Choose the Distribution List... menu item from the pop-up 
menu. 

Mail ·displays a dialog box. 
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File Fiher 

l°f SYS$DISK:D*.DIS 

Files in DISK$:(MORRIS] 

IJDOGCLASS.DIS;3 ~ Filter 

IJPROJECT.DIS;1 OK 
IJSTAFF.DIS;1 I cancel I 

Q 
¢1 I IJ i> 
Selection 

ZK-0299A-GE 

The dialog box prompts you for the name of the distribution 
list file you want to use. The file list box lists the names of 
any distribution list files (files that have the type DIS) in your 
default directory. 

3 Double click on the file name of the distribution list you want 
to use. 
The distribution list file name is displayed in the To: or CC: 
field in the Create-Send window's envelope area. 

If you want to use a distribution list file that is not listed, enter 
the name of that file in the Selection text entry field and click 
on the 0 K button. Or, use the File Filter text entry field to list 
a subset of files that you can then select from. For example, to 
list all files in another directory with the file type DIS, enter the 
complete directory specification-[JONES.STAFF]*.DIS--in the File 
Filter text entry field and click on the Filter button. Then double 
click on the name of the file you want to use. 



DECwindows EVE 
DECterm EVE 

Changing Editors 
The built-in editor described in the VMS DECwindows User's 
Guide is the default editor used to create messages. If more than 
one editor is available on your system, you can choose a different 
editor to create a message. 

To change editors: 

Choose the desired editor from the Create-Send window's 
Change Editor menu. 

A new window opens, containing any text you may have 
already entered in the message. 

2 Click on the new window to make it the active window. 

3 Enter the text of the message, using editing commands 
appropriate for your chosen editor. 

4 Exit from the editor. 
You cannot edit the message after exiting from the editor. You 
cannot extract the message to a file or create a draft of the 
message. You can edit the message envelope by clicking on a 
field in the Create-Send window. 

5 To send the message, click on the Send button in the Create­
Send window. 

To send another message, click on the Reset button. The 
built-in editor is once again the default, and all Create-Send 
options become available. 

To change editors before displaying a Create-Send window, select 
an editor from the submenu of the main or Read window's Create­
Send menu. A Create-Send window and an editor window are 
opened. Enter address information in the Create-Send window 
and enter the text of the message in the editor window. 

When you include an existing file in a mail message, you can 
choose the No Editor menu item from the submenu of the main or 
Read window's Create-Send menu. This menu item allows you to 
send a nontext message, or a file that has been formatted by an 
editor that does not exist on your system. If No Editor is chosen, 
the message will not be displayed in a window and cannot be 
edited. 
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Selecting Messages 
Before you work with a message, drawer, or folder, you have to 
select the desired object. 

To select a message, folder, or drawer, move to the object in the 
main window and click MBl. 

To select multiple objects, press and hold the Shift key while 
clicking MBl on each desired object. 

To select a range of drawers, folders, or messages, press MBl in 
the blank space to the left of the icon on the first object to be 
selected, drag the mouse over the icon of the last object to be 
selected, and release MBl. 

To select all messages in the open folder, choose the Select All 
menu item from the main window's Edit menu. 

To cancel the selection of one object, select another object by 
clicking MBl, or point to the selected object and press and hold 
the Shift key and click MBl. 

Reading Messages 
eJ INBOX 

~ 

~ 2 

~ 3 

~ 4 
~ 5 
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You can use Mail to read an old or new mail message. New 
messages are added to the INBOX folder; old messages (messages 
that have been read) are held in the INBOX folder until you move 
them elsewhere. (This default can be changed in your mail profile. 
See the section Customizing Your Mail Environment for more 
information about your mail profile.) 

Reading a New Message 
When you receive new mail, a message is displayed in your 
Session Manager window. To read a new message, start the Mail 
application if it is not already running. The messages in the 
INBOX folder are listed; unread messages are identified by an 
icon resembling an addressed envelope. Double click MBl on the 
message to be read. Mail displays the message in a Read window. 



~ Mail:Read-1[0] MAIL INBOX #4 [pJ]m 
File Edit Create-Send Read Help 

Date: 26-APR-1990 10:56:34.67 
From: SOIREE: :JONES 
Subj: luncheon· 
To: @Staff 
CC: 

- Q 
rlease make sure there are 1500 lbs. of ice for today's luncheon. 

Close ]~I Forward n Print JI Move II Delete II Previous II Next I 
ZK-0300A-GE 

If Mail is running on your system when you receive new mail, the 
Mail icon in your icon box darkens and the Read New Mail and 
Deliver Mail buttons in the main window become active. To read 
a new message, click on the Read New Mail button. This adds 
new messages to the INBOX folder, opens the INBOX folder, and 
displays the first message received since the INBOX folder was 
last opened. 

You cannot use the Read New Mail button if a message in the 
INBOX folder is being read in a Read window other than the 
default Read window or if you are replying to a message in the 
INBOX folder. (For a description of default Read windows, see the 
section Multiple Read Windows.) 

A Read window is divided into an envelope pane and a message 
pane. 

The envelope pane displays the name of the person who sent the 
message and other address information. Use the scroll bar to 
display additional information about the message, such as text 
indicating that the message is marked or has been replied to, 
the message size, message ID, and whether the message is in a 
foreign format. 
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The message pane displays the mail message. Use the scroll bar 
to display any text that does not fit in this pane. 

The small black square on the pane dividing line is called a pane 
adjustment knob. Using this knob you can adjust the relative 
size of the panes. Making one pane smaller makes the other pane 
larger. This allows you to view more text in either pane without 
resizing the window. To use the pane adjustment knob, move to 
the knob, press MBl, drag the pane dividing line to the desired 
location, and release MBl. 

If you receive a message whose contents are not text (such as 
a file containing spreadsheet data), the file cannot be viewed in 
Mail. Mail displays a message informing you of the problem. 
You can print, forward, extract, or reply to the message. See the 
appropriate sections of this chapter for information about printing, 
forwarding, extracting, and replying to messages. 

A message that you have read remains in the INBOX folder until 
you move it to another folder or delete it. You can specify that 
messages be automatically placed in another folder once they are 
read. See the section Customizing Your Mail Environment for 
more information. 

To continue to read new messages, click on the Next or Previous 
button to read the next or previous message in the folder. 

If you receive new mail while reading messages in the INBOX 
folder, choose the Read New Mail menu item on the pop-up menu 
in the Read window's message pane. This displays the first 
message received since the INBOX folder was last opened. 

To close a Read window, click on the Close button. 

Displaying a List of New Messages 
You can add new messages to your INBOX folder and update 
the list of new messages without reading a message. To update 
the INBOX folder, click on the Deliver Mail button in the main 
window. 

If you click on the Deliver Mail button while reading a message 
in the INBOX folder, Mail will close the Read window before 
delivering your mail. If you are reading a message in the 
INBOX folder in a Read window other than the default Read 
window, Mail will not be able to deliver your messages, and will 
display a message. (See the section Multiple Read Windows for a 
description of default Read windows.) 



Read In Default 
Read In New 
Reply Using This Message 

Forward with Header 
Print 

Move ... 
Delete 
Undo Move/Delete 

Full lnfonnatlon ••• 
Extract ••• 

Mail cannot be delivered if you are replying to a message in the 
INBOX folder. 

Reading an Old Message 
To read an old message (one that has already been read), open the 
drawer and folder containing the message and double click on the 
appropriate message. The message is displayed in a Read window. 

From the Read window, you can click on the Previous and 
Next buttons to read the messages before and after the current 
message. 

To read a series of old messages that are in different folders or are 
not consecutive: 

Select the messages to be read. 

2 Move to one of the selected messages, press MB2, and choose 
the Read In Default or Read In New menu item from the 
pop-up menu. 

3 In the Read window, choose the Next Selected or Previous 
Selected menu item from the pop-up menu in the message 
pane to display the next or previous selected message. 

Multiple Read Windows 
You can open more than one Read window at one time. This 
allows you to read multiple messages at once, or to read new mail 
without disrupting the message you are currently reading. 

The first Read window you open is your default Read window. It is 
identified by the symbol [D] in the window's title bar. Additional 
Read windows are identified by the number in their title bar, for 
example, Read-2, Read-3, and so on. 

The default Read window is used to display messages unless you 
specify another window. For example, clicking on the Read New 
Mail button or double clicking on a message in the main window 
will display the message in your default Read window. 

To read new mail in another Read window, choose the New Mail 
In New menu item from the main window's Read menu. A new 
Read window is opened and the first message received since 
the INBOX folder was last opened is displayed. This option is 
available only if the default Read window is displaying a message 
from a folder other than the INBOX folder. 
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To read an old message in another Read window, select the 
message and choose the In New menu item from the main 
window's Read menu. 

If you have already opened multiple Read windows, you can 
specify the window in which to read the selected message by 
pulling down the main window's Read menu, displaying the In 
Window submenu, and choosing one of the listed Read windows. 

To use a different window as the default Read window, choose the 
Make Default Window menu item from the Read window's File 
menu. The [D] default symbol will be displayed in the window's 
title bar, and will be removed from the previous default window's 
title bar. 

Replying to Messages 

Reply 
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You can reply to a selected message or to the message currently 
displayed in a Read window. 

To reply to the first selected or currently displayed message, click 
on the Reply button in the main or Read window. 

To reply to the selected or currently displayed message using a file 
or the text of the message: 

Pull down the Create-Send menu in the main or Read window 
and display the Reply submenu. 

2 Display the Using a File... or Using Selected Message 
submenu. 

3 Choose the editor you want to use to create this reply. 

Replying to a message opens a Create-Send window. In the To: 
field, Mail inserts the name of the sender of the original message. 
In the Subject: field, Mail inserts the subject of the original 
message preceded by RE:. 

Enter text and make any desired edits. 

To include the original message in your reply, choose the Include 
Original menu item from the Create-Send window's File menu. 

To send the reply, click on the Send button. To close the Create­
Send window, click on the Quit button. 



Forwarding Messages 

I Forward] 

DECWlndows EVE 

DEClennEVE 

No Editor 

You can forward the selected message or the message currently 
displayed in a Read window to another user. 

To forward the selected or currently displayed message, click on 
the Forward button in the main or Read window. 

The header (the address information) is included in the forwarded 
message in most cases. Headers are not included in messages 
created with editors that do not produce ASCII files, such as files 
created with the Paint application. 

To forward the selected or currently displayed message without 
including the header in the body of the message: 

Pull down the Create-Send menu in the main or Read window 
and display the Forward submenu. 

2 Display the Without Header submenu. 

3 Choose the editor you want to use to send the forwarded 
message. 

Forwarding a message opens a Create-Send window. In the 
Subject: field, Mail inserts the subject of the forwarded message 
preceded by FWD:. In the message area, Mail inserts the 
forwarded message. 

Enter the address information, and make any desired changes to 
the text. If you change the original message and want to include 
the unedited version in your forwarded message, choose the 
Include Original menu item from the Create-Send window's File 
menu. 

Click on the Send button to send the message. Click on the Quit 
button to close the window. 

Printing Messages 
You can print selected messages or the message currently 
displayed in a Read window. Messages can be printed using your 
default print settings or you can modify the print settings for the 
messages being printed. 
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I Print ... 

Print 
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Elevate [~ 

Deliver Man 

Exit 
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To print the selected or currently displayed message using your 
default print settings, click on the Print button in the main or 
Read window. 

To print the selected or currently displayed message using altered 
print settings: 

Choose the Print... menu item on the File menu in the main 
or Read window. 
Mail displays a dialog box. 

183] Mail:Printing "staff meeting ... " !i] 
------~ 

<e Include message header and contents 
0 Include message contents only 

Cancel 

I Options ... I 
ZK-0301 A-GE 

The Include Message Header and Contents button is set to 
indicate that the header (the sender's name, date, subject, and 
so on) and the contents of the message are to be printed. To 
exclude the header information, click on the Include Message 
Contents Only button. 

If you are printing a nontext message, such as a message 
created with the Paint application or a message containing 
special formatting commands (such as a PostScript file), you 
must click on the Include Message Contents Only button. 

2 To change additional print settings, click on the Options ... 
button. 

You must also click on the Options... button to specify an 
appropriate print format and printer if you are printing a 
nontext message or a message containing special formatting 
commands, such as a PostScript file. 
Mail displays a dialog box. 



lE8] Mail: Printing "staff meeting" [5j 
------

Number of Copies: [___ 

Page Range: From IL__ To IL__ 
OK 

Print Format 

Text I 

Line Printer 
Terminal 

ANSl2 

ANSI 

PostScript(R) 

cancel 

Printer lo I .--------T"":-6""' ptions ... 

ARNO$UAO ~ 
ARNO$LN03A 

ARNO$DRANG 

ARN0$STURM 
CLUSTER_PRINT 0 

ANSl_PS40 

Orientation I Default .... II n_o_w __ 
Print After 
Iii Delete File When Printed 
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See the VMS DECwindows User's Guide for more information 
about the Print Defaults dialog box. 

3 Click on the OK button to print the messages. 

Creating a File from a Mail Message 

Move .. . 

Copy .. . 

I Extract. .. 

Print. .• 

Print 

Open-Close H 

E~evate [7 

Deliver MaH 

Exit 

You can create files from mail messages. You can select existing 
messages to be copied to a file, or you can create a file from a 
message you are readlng or creating. 

To create a file from the selected or currently displayed message: 

Choose the Extract... menu item from the File menu in the 
main, Create-Send, or Read window. Mail displays a dialog 
box. 
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IE8] Mail:Extracting "sales report" iPJ] 

Iii Include Header Information 

D Append to Existing File 

File:...._I ___________ _ 

Input Format: I 
'"'"";::::==::::::::._....., 

Output Format: I.__ ___ ~ 
Conversion Options File: ....__ ________ 

11 

II OK II I Cancel I 
ZK-0302A-GE 

The Include Header Information button is set to indicate 
that the message's header will be included in the file you are 
creating. You can disable this feature by clicking on it. 

If you want to append the extracted message to an existing 
file, turn on the Append to Existing File option by clicking on 
it. By default, this option is turned off. 

2 Enter the name of the file to be created. If you want to append 
the message to an existing file, enter the name of that file. 

The default file type for text files is TX.T and for DDIF files is 
DDIF. You may enter a different file type. 

3 To select a different format for the file being created, move to 
the Output Format field, press MBl, and choose one of the 
listed file formats. The input format is determined by the 
editor used to create the message. The output format is the 
same as the input format by default. 

4 To use a conversion options file, enter the name of the 
file. Conversion options files contain special processing 
commands. They are not created within Mail. Refer to the 
VMS Compound Document Architecture Manual if you require 
more information about conversion options files. 

5 Click on the OK button to create the file. 

If the selected messages have different data types, non-ASCII 
messages will be converted to ASCII if possible. If they cannot be 
converted to ASCII, the messages will not be extracted. 



Deleting and Retrieving Messages 

Delete You can delete mail messages, and retrieve deleted messages. 

To delete selected messages or the message currently displayed in 
the Read window, click on the Delete button in the main or Read 
window. 

The index is updated to show which messages have been marked 
for deletion. Messages are not actually deleted until the folder is 
closed. You can still perform many Mail functions on messages 
that are marked for deletion, such as moving, copying, and 
printing. When the folder is closed, the messages are deleted and 
reference to them is removed. 

Once the folder is closed, deleted messages are moved to the 
WASTEBASKET folder in the drawer from which the message 
was deleted. 

Deleted messages collect in the WASTEBASKET folder until 
you empty it. To empty the WASTEBASKET, select the drawer 
in which the WASTEBASKET resides and choose the Empty 
WASTEBASKET menu item from the main window's Maintenance 
menu. (An option in your mail profile allows you to specify that 
the WASTEBASKET be emptied whenever the drawer is closed.) 
Once the WASTEBASKET is emptied, the deleted messages are 
irretrievable. 

You can also delete entire folders and drawers of messages. See 
the section Deleting Drawers and Folders for more information. 

To reverse the delete operation in the main window, before the 
folder is closed select the messages to be retrieved, pull down the 
Edit menu, and choose the Undo Move/Delete menu item. 

To reverse the delete operation in a Read window, press MB2 in 
the message pane of the deleted message and choose the Undo 
Move/Delete menu item from the pop-up menu. 

To update the index of messages to reflect that the messages 
have been moved to the WASTEBASKET folder, either select 
the Update Folder menu item from the Maintenance menu in 
the main window or reopen the folder that contains the deleted 
message. 

Once a message has been moved to the WASTEBASKET folder, 
you can retrieve the message by moving it to another folder. See 
the section Moving and Copying Messages to Another Folder for 
more information about moving messages between folders. 
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You can create and delete drawers and folders, add and remove 
drawers in your index, move and copy messages between folders, 
and reclaim unused space in drawers. 

Creating New Drawers and Folders 
To create a new drawer or folder: 

Choose the Create Drawer... or Create Folder... menu item 
from the main window's Maintenance menu. 
Mail displays a dialog box. 

2 In the dialog box, enter the name of the new drawer or folder 
to be created. 

Drawer and folder names are limited to 39 characters. They 
must begin with a letter or number, and can contain letters, 
numbers, underscores, hyphens, and dollar signs. In addition, 
folder names can contain spaces and periods. 

Drawer and folder names are case sensitive. That is, the 
folder names INBOX and Inbox are not the same. 
The prefix MAIL$ is reserved by Mail and should not be used 
as a prefix for drawer names. 
All drawer names must be unique, but folders in different 
drawers may share the same name. 

3 Click on the OK button to create the drawer or folder. 

You can also create a new drawer or folder when you move or copy 
a message. If you specify a destination drawer or folder that does 
not exist, the drawer or folder will be created. 

When you create new drawers, a WASTEBASKET folder is 
automatically included in each new drawer. 

Empty folders are automatically deleted by Mail. 

Deleting Drawers and Folders 
To delete drawers or folders: 

1 Select the drawers or folders to be deleted. 

2 Choose the Delete Drawer ... or Delete Folder ... menu item on 
the main window's Maintenance menu. 



Mail displays a dialog box. 

Drawer: STATUSREPORTS 

Folder: REPORTS 

REPORTS contains 5 items. 
Press OK to delete. 

OK II cancel 11 
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3 Click on the OK button to delete the drawer or folder, or click 
on the Cancel button to cancel the delete request. 
If multiple drawers or folders are selected, you must confirm 
or cancel the delete request for each drawer and folder 
separately. 

You cannot delete an open folder or drawer. 

When you delete a drawer, any folders that existed in the drawer 
are deleted and the messages in them cannot be retrieved. If you 
attempt to delete the MAIL drawer, all folders except INBOX and 
WASTEBASKET are deleted, but the drawer itself is not deleted. 

When you delete a folder, any messages that existed in the folder 
are placed in the WASTEBASKET folder and can be retrieved 
until the WASTEBASKET is emptied. If you attempt to delete the 
INBOX or WASTEBASKET folder, all messages in those folders 
are deleted but the folders are not deleted. 

If you delete all messages in a folder, the folder is automatically 
deleted when you close the drawer. 

Adding and Removing Drawers in the Index 
When you create a drawer in VMS DECwindows Mail, the drawer 
is automatically created in your default mail directory and is 
listed in your main window. If you create drawers with the VMS 
Mail Utility or if you create drawers in a different directory, they 
are not automatically added to the list in your main window. To 
access these drawers you must specifically add them to the main 
window. 

To add drawers created with the VMS Mail Utility in your default 
mail directory, choose the Scan Mail Directory for Mail Drawers 
menu item from the main window's Maintenance menu. All 
drawers in your default Mail directory will be added to the main 
window. 
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To add drawers created in a different directory: 

Choose the Add Drawer to Index... menu item from the main 
window's Maintenance menu. 

File Filter 

H*.MAI 

Files in DISK$:[SMITH] 

l]MAIL$000400915C3D4025.MAl;1 0 Display Name .... H ___ "-F-ilt_er __ 

l]MAIL$00040091680959C1 .MAl;1 

~ 
OK 

l]MAIL.MAl;1 

I Cancel I 
Q 

<a J w> 
Selection 

I 
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A file selection dialog box displays all files in your default 
directory that have a type of MAI. Ignore the files beginning 
with the prefix MAIL$. These are messages. Drawer names 
do not have this prefix. 

2 Double click on the file name of the drawer you want to add. 

If you want to add a drawer whose file name is not listed, 
enter the name of that file in the Selection text entry field 
and click on the OK button. Or, use the File Filter text entry 
field to list a subset of files that you can then select from. 
For example, to list all files in another directory with the 
file type MAI, enter the complete directory specification­
[JONES.JUNKMAIL]* .MAI-in the File Filter text entry field 
and click on the Filter button. Then double click on the name 
of the drawer you want to add. 

3 In the Display Name field, enter the name to be displayed in 
the main window. If you do not enter a name, the name of the 
drawer is used by default. 

To remove a drawer from the main window, select the drawer and 
choose the Remove Drawer from Index menu item from the main 
window's Maintenance menu. 



Removing a drawer from the index does not delete the drawer. 
You can retrieve it by choosing the Scan Mail Directory for Mail 
Drawers... menu item or the Add Drawer to Index... menu item 
from the Maintenance menu. 

Moving and Copying Messages to Another Folder 
You may move or copy a message or group of messages from one 
folder to a different folder. Moving messages to another folder 
removes them from the original folder. Copying messages to 
another folder does not remove them from the original folder. . 

You can move and copy messages from either the main or Read 
windows. 

To move selected messages or the message currently displayed in 
the Read window: 

Click· on the Move button. 

If a folder is selected, the messages are moved to the selected 
folder. If no folder is selected, Mail displays a dialog box. 

Enter destination drawer and folder. 

Drawer: l._M_A_ILI_.___ __________ _ 

Folder: l' ....__ ____________________ __ 
I cancel I 
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Initially, MAIL is inserted in the drawer name field. If you 
subsequently enter text, however, the drawer and folder fields 
contain whatever was last entered in these fields. 

2 Enter the name of the drawer and folder to receive the 
message. 

If you specify a drawer or folder that does not exist, it will be 
created. 

3 Click on the OK button. 

A message is displayed in the message pane of a Read window, 
or in the index entry in a main window, to show which 
messages have been marked for moving. Messages are not 
actually moved until the folder is closed. You can still perform 
many Mail functions on messages that are marked for moving, 
such as deleting, copying, and printing. When the folder is 
closed, the messages are moved. 
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To reverse the move operation in the main window, select the 
messages to be retrieved and choose the Undo Move/Delete menu 
item from the main window's Edit menu. 

To reverse the move operation in a Read window, in the message 
pane of the moved message press MB2 and choose Undo 
Move/Delete·from the pop-up menu. 

To copy the selected messages or the message currently displayed 
in the Read window: · 

Choose the Copy menu item from the File menu in the main 
or Read window. 
Mail displays a dialog box. 

Enter destination drawer and folder. 

Drawer: l._M_Al_t.I ____________ _ 

Folder: 

II OK II I cancel I 
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Initially, MAIL is inserted in the drawer name field. If you 
subsequently enter text, however, the drawer and folder fields 
contain whatever was last entered in these fields. 

2 Enter the name of the drawer and folder to receive a copy of 
the message. 
If you specify a drawer or folder that does not exist, it will be 
created. 

3 Click on the OK button. 
The message is displayed in the destination folder when the 
destination folder is next opened. 

An alternate method for moving or copying messages is to select 
the messages, move to the destination folder, press MB2, and 
choose Move Selected Here, Copy Selected Here, Move Read 
Message Here, or Copy Read Message Here from the pop-up 
menu. The read message is the message currently displayed in 
your default Read window. 



Updating Folders 
Messages are deleted and moved when a folder is closed. If you 
have deleted or moved several messages from a folder and would 
like to have your changes take effect without leaving the folder, 
Mail can automatically close and reopen the folder for you. 

To close and reopen a folder, completing all pending delete and 
move operations, move to the folder name, press MB2, and choose 
the Update Folder menu item from the pop-up menu. 

To update several folders at once, select the folders and choose the 
Update Folder menu item from the main window's Maintenance 
menu. 

If a folder is updated while a message in that folder is being read 
in your default Read window, the window will be closed when 
the folder is closed. The window will not be reopened. (For a 
description of default Read windows, see the section Multiple 
Read Windows.) 

Compressing Drawers 
When you delete messages and folders, empty space is left in 
the drawer from which the messages or folders were deleted. 
To make this space available for reuse, select the drawer to be 
compressed and choose the Compress Drawer menu item from the 
main window's Maintenance menu. 

If multiple drawers are selected, the first selected drawer will be 
compressed. 

You cannot compress an open drawer. Close the drawer before 
choosing the Compress Drawers menu item. 

When a drawer is compressed, the original (uncompressed) drawer 
is saved in a file. A message is displayed indicating that this file 
has been created and showing the name of the file. Once you 
have used the compressed drawer, the uncompressed file should 
be deleted. The file cannot be deleted within Mail; delete it from 
File View. 
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Marking and Unmarking Messages 

Undo Move/Delete 
Delete 

Copy To Clipboard 

Select All 
····················· 
I Mark 

Unmark 

Full Information ... 

Marking messages allows you to identify messages of particular 
importance to you. For example, you might mark the messages 
you want to print at the end of the day, or the messages you want 
to reread or reply to at another time. 

When a message is marked, an ast.erisk is displayed in the index 
entry for this message. The message itself is unaffected. 

To mark selected messages or the currently displayed message, 
choose the Mark menu item from the main or Read window's Edit 
menu. 

To unmark the currently displayed or selected messages, choose 
the Unmark menu item from the main or Read window's Edit 
menu. 

Picking Messages 

Pick from selected folder ... 
Pick from open folder ... 
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Mail can search the open or selected folder for messages that have 
something in common. For example, you could pick messages 
that were sent by a specific user on a specific day, or messages 
containing a specific word in the subject field. 

Once it finds messages that meet your criteria, Mail displays 
a list of these messages. You can then perform functions such 
as copying, moving, extracting, or reading on this set of picked 
messages. 

To pick messages: 

Open or select the folder containing the messages. If multiple 
folders are selected, the first folder is used for the pick. 

2 Choose the Pick from Open Folder... or Pick from Selected 
Folder... menu item from the main window's Pick menu. 
Mail displays a dialog box. 



l83] Mail:Pick from folder:INBOX ~ 

From: 

To: 

CC: 

Subject: .... 'f __________ _ 

In Text: .... '! __________ _ 

On:~ 
Before: 

After: 

D Replied To D Marked D Opened D Selected 

0 Yes 
0 No 

0 Yes 
0 No 

0 Yes 0 Yes 
ONo ONo 

OK i l Cancel I 
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The dialog box allows you to specify the criteria for picking 
messages. Each field in the Pick dialog box is described in the 
table below. 

3 Click on the field to be used and enter the pick criteria. 

4 Click on the OK button to pick the designated messages, or 
the Cancel button to cancel the pick. 

The following table describes the fields in the Pick dialog box. 

Field 

From: 

To: 

CC: 

Subject: 

Description 

The user name of the sender whose messages 
you want to pick. 

The user name of the addressee or the name 
of a distribution list whose messages you 
want to pick. 

The user name of the addressee (or the name 
of a distribution list) who received courtesy 
copies of messages you want to pick. 

Text included in the subject field of messages 
you want to pick. 
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Field 

In text: 

On: 

Before: 

After: 

Replied to 

Marked 

Opened 

Selected 

Description 

Any text string included in the body of 
messages you want to pick. 

The date on which messages you want to pick 
were received. Click MBl to display the Date 
dialog box. To specify the day, month, or year, 
click MBl on the appropriate box, then click 
on the up arrow or down arrow to specify the 
date. Click on the OK button to enter this 
date in the field or click on the Clear button 
to clear the date in the Pick dialog box. The 
time is ignored for this field. 

The date and, if desired, the time before 
which messages you want to pick were 
received. Click MBl to display the date 
dialog box. See the description of the On: 
field for information about the Date dialog 
box. The time can be used as a criterion in 
this field. 

The date and, if desired, the time, after which 
messages you want to pick were received. 
Click MBl to display the Date dialog box. 
See the description of the On: field for 
information about the Date dialog box. The 
time can be used as a criterion in this field. 

Messages to which you have or have not 
replied. You activate this option by clicking 
on Replied to and choosing Yes or No. 

Messages that you have or have not marked. 
You activate this option by clicking on Marked 
and choosing Yes or No. 

Messages that you have or have not read. You 
activate this option by clicking on Opened and 
choosing Yes or No. 

Messages that you have or have not selected. 
You activate this option by clicking on 
Selected and choosing Yes or No. 

Text fields (the first five fields in the dialog box) search for 
matching text anywhere in the field and are not case sensitive. 
For example, entering the text John in the From: field might pick 
messages from Jane Johnson, John Doe, Olav Bejohnesson, and 
JOHN::Smith. 

Once a set of messages has been picked, the message index is 
updated to list only the picked messages. When the folder is 
closed, the picking criteria are lost and all messages are again 
available. 



A pick operation cannot be performed if a folder is open in 
multiple windows and contains messages to be moved or deleted. 
Close the folder in all additional windows to complete the move or 
delete operation before performing a pick operation. 

Displaying Additional Index Information 

Undo Move/Delete 
Delete 

Copy To Clipboard 

Select All 

Mark 

Unmark ..................... 
I Full Information... I 

The main window's message index lists one line of information 
about each message. This line contains the message number, the 
date it was received, the name of the sender, and the subject of 
the message. 

To display additional information about messages, select the 
messages and choose the Full Information... menu item from the 
main window's Edit menu. The following is displayed: 

• The message number . 

• The envelope of the message. 

• The relative size of the message. For ASCII messages, the size 
is shown in records. For non-ASCII messages, such as those 
in DDIF format, the size is shown in blocks. 

• The external message ID if one exists. External message IDs 
are assigned to non-ASCII files and to messages too large to 
be stored within the Mail file. 

• The attributes of the message, which would be Replied if you 
replied to the message, Marked if you marked the message, 
New if you have not read the message, and the message type 
(DDIF) for DDIF messages. 

Opening a New Main Window 
Open 

I Open in New 

Elevate in New 

U!Xiate f'o!d&r 

Mo11e Se1ected HerG 

Copy Se:ect1fti Herl.' 

Move Reoid f.;Je::;::;..,,gr; He~e 

Copy Re~d M€;s:~-ag~ H~m 

c=~ 

Opening folders containing numerous messages often fills the 
window, leaving no room to display other folders and messages. 
You can display additional messages by creating multiple main 
windows. You can create a new main window in which all of your 
drawers and folders are present, or by elevating a particular 
drawer or folder to a new window, you can restrict the contents of 
that window to only the drawer or folder you elevated. 

To create a new main window, point to the folder or drawer to be 
opened in the new window, press MB2, and choose the Open in 
New menu item from the pop-up menu. A new main window is 
displayed, and the current folder or drawer is opened. 

You can perform all Mail functions on the drawer, folders, and 
messages displayed in this window. 
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You can also create a new main window by elevating a folder or 
drawer to a new window. Elevating a folder or drawer allows you 
to work with that folder or drawer in the new window, but all 
other folders and drawers are unavailable in the new window. 
To elevate a folder or drawer, move to the folder· or drawer to be 
elevated, press MB2, and choose the Elevate in New menu item 
from the pop-up menu. 

Sending and Receiving DDIF Formatted Messages 
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Some applications, such as Paint, create files in DDIF data 
format. Mail allows you to send and receive DDIF formatted 
messages. 

If the recipient of a DDIF message is using a configuration that 
does not support VMS DECwindows (such as a character cell 
terminal), the recipient will receive a message indicating that the 
mail message is in a foreign format. The recipient can view the 
mail envelope (address, sender, subject), or forward, file, reply to, 
extract, or delete the message, but may not be able to view the 
message. 

If you attempt to mail a DDIF message to a user whose mail 
system does not support DDIF format, the message will not 
be sent. You will be notified that the transmission cannot be 
completed. You can create a copy of the DDIF message in another 
format and send that file. 

You can create and send a non-DDIF version of a DDIF message. 
To create a non-DDIF version of a DDIF message: 

Choose the Extract... menu item from the Create-Send 
window's File menu. 

2 Enter appropriate information in all fields, as described in the 
section Creating a File from a Mail Message. 

3 In the Output Format field, press MBl, move to an output 
format that would be supported by the receiving system, such 
as Text, and release MBl. 

4 Click on the OK button to extract the message to a file. 

To send the file in the new format: 

Choose the Include File... menu item from the Create-Send 
window's File menu. 

2 Choose the file to be sent, as described in the section Including 
a File in a Message. 



3 Click on the OK button to include the file. 

4 Click on the Send button to send the message. 

Customizing Your Mail Environment 

Modify Mail Profile .•• 

Modify Print Defaults ..• 

You can customize certain Mail features to suit your working 
environment. Modifying your default print settings allows you to 
alter the way your messages are printed. Modifying your mail 
profile allows you to alter the way your messages are sent, stored, 
a:qd displayed. 

Modifying Your Default Print Settings 
To modify your default print settings, choose the Modify Print 
Defaults... menu item from the main window's Customize menu. 
Mail displays a dialog box. 

W Mail: Changing Print Defaults IPJl 
Number of Copies: ll__ 
Page Range: From ll__ To II__ 

OK 

Print Format 

Text 

Line Printer 

Terminal 

ANSl2 

ANSI 

PostScript(R) 

cancel 

Printer I I .....------,...,
0

l"'"I Options ... 
ANSl_PS40 

ARNO$LIAO ~ 
ARNO$LN03A 

ARNO$DRANG 

ARNO$STURM 

CLUSTER_PRINT 0 

Orientation I Default ...... ff n_o_w __ 

Print After 

Ii] Delete File When Printed 

ZK-0567 A-GE 

Refer to the VMS DECwindows User's Guide for a description of 
the fields in this dialog box. 

Changing your print defaults affects the way messages are printed 
during the current Mail session only. When you exit from Mail 
the print defaults revert to their original settings. 
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Customizing Your Mail Profile 
Your mail profile allows you to specify how messages are to be 
sent, stored, and displayed. 

To change the default settings for your mail profile, choose 
the Modify Mail Profile... menu item from the main window's 
Customize menu. Mail displays a dialog box. 

[ffi] Mail:User Profile ~ 

.... t;J~'!l.~r .~f. ~!1.~~!iy~r~~ .f!l~~~~~-~~: ~- ....................................................... . 
User Name: ..._IIBE_UTL_E_R ___ _ 

Personal Name:jl ..... s ..... y_st_em_· _M_an_a .... ge_r ____________ _ 

Forwarding Address: ..... I _________________ _ 

Mail Directory: l"!NABOB$DUAO:[BEUTLER] 

Mail Tranport: 

Name of folder to deliver to: ..... Hl_NB_o_x _______ _ 

• Deliver mail when the deliver folder is opened 

D Automatically refile opened messages to MAIL folder 

Name of folder for deleted mail: _l"f W_A_S_T_EB_A_S_K_ET _____ _ 

Ill Empty wastebasket upon closing drawer 

MAIN WINDOW STYLE 

OPaned •outline 

SEND DEFAULTS 

D Courtesy Copy Option 

D Copy Self on Send 

D Copy Self on Forward 

D Copy Self on Reply llfu!JI I Cancel I 
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An option is on when the corresponding square or button is 
shaded. To turn an option on or off, click on the appropriate 
square or button, or its label. 

Note If you have used the VMS Mail Utility on your system, some of 
your VMS Mail defaults are displayed. See the section Making 
Mail 1?erform Like the VMS Mail Utility for more information. 

The first line in the mail profile displays the current number 
of undelivered messages. The following table describes the 
remaining fields in the mail profile dialog box. 



Option 

User Name: 

Personal name: 

Forwarding address: 

Mail directory: 

Mail transport: 

Name of folder to deliver to: 

Deliver mail when the deliver 
folder is opened 

Description 

Your VMS user name, which cannot be 
modified. 

A field of optionally specified text that is 
appended to the From: field of messages 
you send. Your personal name can be 
your full name or any other information, 
and must start with a letter. 

The node and user name to which 
your messages are sent. This option 
is frequently used when you want to 
read your mail in a different account. 

The directory where your mail is being 
stored. It cannot be modified in Mail. 
Refer to Changing Your Mail Directory 
for more information. 

The transport mechanism you want 
to use, if any. A transport mechanism 
is a product that affects when and 
how your messages are sent. Mail 
does not use a transport mechanism by 
default. Messages are sent immediately. 
Products such as Message Router or VAX 
PSI are optional. The default is none. 

The name of the folder to which new 
messages should be delivered. (If the 
folder does not exist, it will be created.) 
By default, the INBOX folder is specified. 

This option, which is set by default, 
causes new mail to be delivered 
whenever the delivery folder (INBOX 
by default) is opened. If you disable this 
option, mail is delivered only when you 
click on the Deliver Mail or Read New 
Mail buttons. 
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Option 

Automatically refile opened 
messages to MAIL folder 

Name of folder for deleted 
mail: 

Empty WASTEBASKET upon 
closing drawer 

MAIN WINDOW STYLE 

Description 

This option, which is normally disabled, 
causes a message to be moved to the 
MAIL folder once it is read. If the MAIL 
folder does not exist, it will be created. 

This option causes messages to be moved 
immediately. If you delete or move the 
message, the delete or move operation 
will not be completed until the deliver 
folder is closed. The message will be 
held in the MAIL folder until the deliver 
folder is closed and the MAIL folder is 
reopened. 

The name of the folder to which deleted 
messages are moved in new drawers you 
create. By default, the WASTEBASKET 
folder is specified. Existing drawers are 
unaffected by changing this setting. 

This option, which is set by default, 
causes the WASTEBASKET folder to be 
emptied when you close the drawer. 

The window style, either Outline or 
Paned, used to display the index of 
messages in the main window. The 
default index style is Outline. Refer to 
the section Using a Paned Style Main 
Window for information about the Paned 
option. 



Option 

SEND DEFAULTS 

Description 

You can turn on the following Send 
Defaults options, which are disabled 
unless you specify otherwise: 

• Courtesy copy option. Prompts you 
with a courtesy copy prompt when 
using VMS Mail. This option does 
not affect VMS DECwindows Mail. 

• Copy Self on Send. Includes your 
name as an addressee in Create­
Send windows when sending a new 
message. You can edit out your 
name in the Create-Send window if 
you desire. 

• Copy Self on Forward. Includes your 
name as an addressee in the Create­
Send window when you forward 
a message. You can edit out your 
name in the Create-Send window if 
you desire. 

• Copy Self on Reply. Includes your 
name as an addressee in the Create­
Send window when you reply to 
a message. You can edit out your 
name in the Create-Send window if 
you desire. 

Click on the Save button to save the profile settings. Click on the 
Cancel button to reinstate the original profile settings. 

Changes made to the Name of Folder to Deliver to and MAIN 
WINDOW STYLE fields will not take effe'ct until you exit from 
and reenter Mail. 

Making Mail Perform Like the VMS Mail Utility 
This section is intended for users who use both the VMS Mail 
Utility and VMS DECwindows Mail. 

If you use VMS Mail and VMS DECwindows Mail to access the 
same mail messages, Mail will automatically set certain options in 
your mail profile to make Mail perform like VMS Mail. 
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VMS DECwindows Mail will automatically set the following 
options in your mail profile: 

• Name of folder to deliver to 
Mail specifies NEWMAIL in this field. 

• Automatically refile opened messages 
Mail turns on this option. 

Set the remaining options to match your VMS Mail settings. 

Once these options have been set, you will find using Mail 
very similar to using VMS Mail. Mail provides most VMS Mail 
functions with the exception of SPAWN, ATTACH, EDIT, and 
DEFINE/KEY. These functions are unnecessary in the VMS 
DECwindows environment. 

Using a Paned Style Main Window 
Mail's default main window displays your drawers, folders, and 
messages in Outline style. When an object is opened, its contents 
are revealed directly beneath it, similar to the format of a table of 
contents. 

You can choose an alternate style, called Paned style, for 
displaying the objects in your main window. A Paned style 
main window uses two panes to display your drawers, folders, and 
messages. The top pane lists your folders or drawers. The bottom 
pane lists the messages in the open folder. 

To use the Paned style, choose the Modify Mail Profile... menu 
item from the Customize menu and click on the Paned option in 
the User Profile dialog box. The Paned style main window will 
take effect when you exit and reenter Mail. 



~ Mai1 !ilm 

Folders 1n MAIL Drawer 

t:sJ INBOX L:l WASTEBASKET 
0 

0 
Q 

181 1 8-APR-1990 NABOB::SMITH Team Meeting, 1:00 
181 2 27-APR-1990 SOIREE::JONES lunch invitation 
181 3 4-MAY-1990 DARCY::MORRIS RE: review schedule 
181 4 16-MAY-1990 UDO::GREEN poetry reading 
~ 5 18-MAY-1990 BRONTE::BLACK dog class canceled 
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In a Paned style main window, the names of your folders are 
always displayed, regardless of the number of messages in the 
open folder. (In Outline style, opening a folder frequently fills the 
window with the contents of that folder, pushing all other drawer 
and folder names out of the display.) Having folder names readily 
available is useful for certain Mail functions, such as moving and 
copying messages. 

The Paned style main window differs from the Outline style 
window in the following ways: 

• The main window is divided into two panes. The top pane 
contains the Drawer/Folder index. The folders in the open 
drawer are listed in this pane. To display a list of drawers, 
click on the Display Drawers button near the bottom of the 
Drawer/Folder index. Double clicking MBl on a drawer name 
opens the drawer and displays its folders. 

The bottom pane of the main window contains the Message 
index, which is a list of messages in the currently open folder. 

• Only one folder may be opened at one time when using Paned 
style. To view messages in multiple folders simultaneously, 
open multiple main windows. 
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• You cannot elevate a single drawer or folder to a new main 
window when using a Paned style window. Multiple main 
windows can be opened with the Open Folder in New and 
Open Drawer in New menu items on the File menu. 

• You cannot select a range of drawers, folders, or messages 
by clicking, dragging, and releasing MBl over the range of 
objects in a Paned style window. 

• The vertical scroll bar in a Paned style main window is a 
standard VMS DECwindows scroll bar. It does not contain the 
top and bottom stepping arrows and navigation window. 

Changing Your Mail Directory 
Mail stores your mail messages in the same directory used by 
the VMS Mail Utility. If you have not specified a directory to 
be used by the VMS Mail Utility, your default directory is used. 
Depending on the number of mail messages you receive and keep, 
this directory may become cluttered with mail messages. 

Using the VMS Mail Utility, you can specify a different directory 
as your Mail directory. Refer to the VMS Mail Utility Manual for 
information on the SET/SHOW MAIL_DIRECTORY command. 

Changing Directories for Drafts and Distribution Lists 
When you save a draft of a message, Mail stores the draft in your 
default directory. To specify a different directory for storage of 
draft files: 

Note The following procedures assume familiarity with your 
LOGIN.COM file. If you are unfamiliar with this file, ask your 
system manager for more information before following these 
procedures. 

1 From the Session Manager window, create a DECterm window. 

2 Edit your LOGIN.COM file and enter the following command: 

$DEFINE DECW$MAIL_DRAFTS directoryspec 

where directoryspec is the name of the directory in which 
drafts are to be stored. 

You can also change the default directory for distribution lists. 
When you display a list of your distribution lists, Mail lists all 
files in your default directory with a DIS file type. To specify a 
different directory to be searched for DIS files: 

From the Session Manager window, create a DECterm window. 



2 Edit your LOGIN.COM file and enter the following command: 

$DEFINE DECW$MAIL_DISTRIBUTIONLISTS directoryspec 

where directoryspec is the name of the directory in which 
distribution lists are stored. 

Exiting from Mail 
To exit from the Mail application, choose the Exit menu item 
from the main window's File menu. The main window and any 
open Read or Create-Send windows are closed. Open folders and 
drawers are closed. Wastebaskets may be emptied, if specified in 
your mail profile. 

If multiple main windows are open, the File menu contains the 
Close menu item rather than Exit. Choosing Close closes only the 
main window from which Close is chosen. When there is only one 
remaining main window, its File menu contains the Exit menu 
item. 
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10 
Using the Notepad Editor 

The Notepad is an editor that lets you do everyday tasks such as 
recording messages, writing letters, and building data files. 

The Notepad editor saves your notes in files, which you can store 
for later revision or incorporation into other files. 

This chapter describes how to 

• Start the editor 

• Enter and format text 

• Edit a file 

• Name a file 

• Open a second notepad 

• Open an existing file 

• Merge files 

• Find and replace text 

• Exit from an editing session 

Starting the Notepad Editor 
To start the Notepad editor, choose the Notepad menu item from 
File View's Applications menu. 

Notepad displays an empty editing window in which you can 
type text from the keyboard or copy in an existing file for editing. 
Notepad is interactive, so you see the changes to a file as you 
make them. 
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Typing Text 
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To enter text in the Notepad window, give the window input focus 
and begin typing text from the keyboard. Notepad enters the 
text at the position marked by the cursor. Initially, the cursor is 
displayed in the upper left comer, but it moves right as you type. 

The Notepad inserts text into a temporary holding area called a 
buffer. The contents of the buffer appear in the Notepad window. 
At the beginning of an editing session, the buffer may contain very 
little text, but the buffer grows longer as you add information. 

A buffer exists only during the editing session. When you end an 
editing session, you direct the Notepad editor to save or discard 
the contents of the buffer. 

Formatting Text 
Use the Tab key, the space bar, and the Return key to arrange 
text in the Notepad window as you want it to appear. 

You can also size the Notepad window so it has the line width you 
want. Notepad wraps text lines at the right margin automatically 
so you do not have to press the Return key at the end of every 
line. 
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Scrolling the Buffer 

Editing a File 
am 

Goto Top 

Goto Bottom 

Go to Selected Line Number 

Goto Line ... 

As your text buffer grows, it extends beyond the frame of the 
Notepad window. To view text at the beginning or end of the 
buffer, use the vertical scroll bar along the right side of the 
window. The position of the slider indicates your position in the 
buffer. When the slider is at the top of the scroll bar, you are at 
the beginning of the buffer. When the slider is at the bottom of 
the scroll bar, you are at the end of the buffer. 

The Notepad navigation and editing commands let you move 
within a text buffer quickly and easily, adding or modifying 
information. 

Moving the Cursor 
When you insert text in the buffer, Notepad ·adds the text at 
the current cursor position, pushing existing text to the right. 
Therefore, the cursor is normally positioned at the spot where you 
last entered text. 

To move the cursor, position the pointer anywhere in the Notepad 
window or on your workstation screen where there is text or 
spaces and click MBl. 

Pressing the Shift key and the right arrow key at the same time 
moves the cursor one word to the right. Pressing the Shift key 
and the left arrow key at the same time moves the cursor one 
word to the left. 

With a long buffer, reposition the cursor using menu items from 
the Navigate menu. Choose the Go to Top menu item to move to 
the top of the buffer. Choose the Go to Bottom menu item to move 
to the bottom of the buffer. 

To reposition to a specific line in the buffer: 

Choose the Go to Line... menu item from the Navigate menu. 

Notepad displays a dialog box. 

2 Enter the line number. 

3 Press I Return I or click on OK. 

Notepad repositions the cursor to the specified line. 
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Another method of placing the cursor on a certain line is to select 
a line number in text anywhere on your workstation and choose 
the Go to Selected Line Number menu item from the Navigate 
menu. For example, if you are reading an error listing file in a 
DECterm window that contains the line number 1019 and you 
want to look at line number 1019 in a program source file you are 
editing in Notepad, select 1019 in DECterm and choose the Go to 
Selected Line Number menu item from Notepad's Navigate menu. 
The cursor is placed on line 1019 in your Notepad file. 

Note If you are correcting a program source file, you may want to start 
from the bottom and work your way up so that your edits do not 
affect how the line numbers in your source file correspond to the 
line numbers in your error listing file. 

Selecting Text 
In order to delete, move, or copy text in a buffer, you must first 
select it. Select text by pressing and holding MBl, dragging the 
pointer over the text, and releasing MBl. This highlights the 
selected text. Notepad stores this text until you tell it what to do. 

You can select text by using mouse clicks. Double clicking MBl 
selects the current word. Clicking MBl three times selects the 
current line; four clicks selects the entire document. 

You can also perform an extended selection, which lets you 
select blocks of text that extend beyond the screen. To perform an 
extended selection, place the cursor at one end of the range you 
want to select. Scroll the file to the other end of the range you 
want to select, hold down the Shift key, and click MBl. The range 
of text is selected from the original cursor position to the specified 
insertion point, and the cursor is placed at the new insertion 
point. 

If you already have an active select range, Notepad starts at the 
insertion point (the place where you click MBl as you hold down 
the Shift key) and selects text from the insertion point up to the 
existing active select range. Notepad places the cursor at the 
insertion point. 

Deleting Text 
Use the <XI (Delete) key to erase a few characters. To delete a line 
or a section of text, select the text and press the <XI key or begin 
inserting new text. Inserting new text causes the selected text to 
be deleted and the new text to take its place. 
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Canceling an Edit 
To cancel your most recent edit, choose the Undo ... menu item 
on the Edit menu. For example, if you remove text with the Cut 
menu item, you can restore the text to its former location with the 
Undo menu item. 

Notepad keeps a detailed record of all your edits so you can undo 
a series of edits. To cancel a series of edits: 

Choose the Undo ... menu item from the Edit menu. 

Notepad displays the Undo dialog box. 

2 Click on the Undo screen button to cancel the last editing 
operation. 

Each time you click on the Undo button, Notepad cancels 
another editing operation. 

3 If you undo an editing operation by mistake, reinstate the 
edits by clicking on the Redo screen button. 

4 To complete the operation, click on the Cancel screen button. 

You can cancel all the edits of an editing session in one step by 
choosing the Revert menu item from the File menu. Notepad 
restores the buffer to the state it was in when you first opened the 
file. 

Moving Text 
Because Notepad saves the last text you selected and deleted, 
you can move text from one location in the text buffer to another 
location. 

To move text in a buffer: 

1 Select the text you want moved to another location. 

2 Choose the Cut menu item from the Edit menu. 

3 Move the cursor to where you want the deleted text inserted 
by positioning the pointer and clicking MBl. 

4 Choose the Paste menu item from the Edit menu. 

The deleted text is moved to the new location. 
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Copying Text 
Because Notepad keeps track of your selected text, you can copy 
text from one location in a text buffer to another location. To copy 
text in the text buffer: 

Select the text you want copied to another location. 

2 Choose the Copy menu item from the Edit menu to store the 
copied text. 

3 Move the cursor to where you want the selected text copied by 
positioning the pointer and clicking MBl. 

4 Choose the Paste menu item from the Edit menu. 

The selected text is copied to the new location. 

Including an Existing File 
You can include an existing file in the text buffer that you are 
currently editing. 

To include an existing file: 

Move the cursor to where you want the included file inserted. 

2 Choose the Include... menu item from the File menu. 
Notepad displays a dialog box. 

3 Either select the file from the files listed in the dialog box or 
type the name of the file you want to include. 

4 Click on the OK button. 

The contents of the included file are inserted in the editing 
window at the current cursor position. 
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Saving Text in a File 

New 

Open ... 

Open Selected 

Include ... 

Save 

I Save As ... 

Revert 

Quit 

Exit 

When you add text to Notepad, the editor records the information 
in the buffer. Because a text buffer exists only for the editing 
session, if you want to save the contents of the buffer you must 
direct Notepad to write your text to a file. 

To save the text in your buffer as a file: 

Choose the Save As... menu item from the File menu. 
Notepad displays a dialog box that prompts you for the name 
of the file. 

Save As... [5l 

Save As ,__! __________ _ 

I cancel I 
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2 Enter the name of the file, assigning a name that corresponds 
to the contents of the file so that you can easily recognize 
it. Use the <X1 and arrow keys to make any necessary 
corrections. 

3 Press I Return I or click on the OK button. 

Notepad writes the contents of the buffer to the new file and posts 
the file name in the title bar of the editing window. 

When you make changes to an existing file, it is also necessary 
to save the changes. Once a file has a name, use the Save menu 
item to update the file. 

Opening a Second Notepad 
You can open a second Notepad window without closing the first 
window. To create a second Notepad window, choose the New 
menu item from the File menu. A second Notepad window opens. 

The editing you do in the second Notepad window can be 
completely independent of the first Notepad window, or you can 
copy and paste text from one Notepad window to the other. 
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Opening an Existing File 
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When you want to edit an existing file, you direct Notepad to open 
the file and read its contents into the Notepad buffer. 

To open an existing file: 

Choose the Open... menu item from the File menu. 
Notepad displays the Open File dialog box. 

File Filter 
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2 Either select the file from the files listed in the dialog box or 
enter the file name. 

You can select a file by double clicking on it or by clicking on 
it once and then clicking on OK. 

3 Press I Return I or click on the OK button. 

The contents of the file appear in the editing window and Notepad 
displays the file name in the title bar. 

You can also open an existing file by selecting a file name in 
any other window (for example, DECterm or FileView) and then 
choosing the Open Selected menu item from the File menu. 
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Merging Files 

Undo 
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Undo ... 
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Whether you are writing a letter or a computer program, you can 
often save time by combining pieces of information from other 
letters or programs that you have written. 

Copying Text from One Notepad Window to Another 
To copy text from one Notepad window to another: 

l Select the text that you want to copy. 

2 Choose the Copy menu item from the Edit menu. 

3 Position the pointer in the other Notepad window at the point 
you want to insert the copied text. 

4 Choose the Paste menu item from the Edit menu. 

Notepad inserts the copied text at the desired location, leaving the 
text in the other window intact. 

Searching for Text 

Next Selected 

Previous Selected 

Next ... 

Previous ... 

Next Incremental ••• 

Previous Incremental ... 

Replace Once ••• 

Replace Within Selected Area .•• 

Replace All ••. 

You can search a text buffer for any text, such as a word, a 
number, or any other character that you can type on your 
keyboard. Because Notepad treats spaces as text, you can search 
for two or more words. Notepad searches the buffer from the 
current cursor position and highlights the first occurrence of the 
text string. 

Choose the Next... menu item from the Search menu. 
Notepad displays a dialog box. 

Next... rJ 

Previous I Cancel 
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2 Enter the text string you want to locate. 

3 Click on the Next screen button to initiate a search from the 
current position to the end of the file. 

You can continue to search for the text string by clicking on the 
Next screen button in the dialog box. 
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Replacing Text 

Next Selected 
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I Replace All ... 

If the string you want to search for is visible anywhere on your 
workstation screen, you can also perform a search by selecting 
that word and then choosing the Next Selected or Previous 
Selected menu item from the Search menu. 

By default, Notepad performs a case-sensitive search. Choose the 
Set Search Options... menu item from the Options menu to make 
searches insensitive to case. A highlighted case-sensitive button 
indicates that a case-sensitive search is in effect. 

Notepad can also search a text buffer for a character pattern. You 
can add characters or delete characters from the search string 
during the search operation, and Notepad returns to the initial 
search position in the buffer and looks again for the modified 
pattern. Choose the Next Incremental... menu item to search for 
patterns. 

The Notepad editor can replace one text string with another 
text string. This is especially useful if you have spelled a word 
incorrectly throughout a long file and you want to fix every 
occurrence of the misspelled word. 

To replace a text string: 

Choose the Replace All... menu item from the Search menu. 

Notepad displays a dialog box. 
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2 Enter the old text that you want Notepad to replace and press 
the Tab key to move the cursor to the next text entry field. 

3 Enter the new text that you want substituted. 

4 Click on the OK button or press I Return I to initiate the 
replacement. 
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To perform individual replacements, choose the Replace Once ... 
menu item from the Search menu. Notepad searches the 
buffer from the current cursor position and highlights the first 
occurrence of the text. Click on the Yes button to replace the old 
string with the new string. To avoid a replacement, click on the 
No button. To replace text in a selected range, select the text you 
want to perform a replace operation on and choose the Replace 
Within Selected Area... menu item from the Search menu. 

Exiting from an Editing Session 
To end an editing session, choose the Exit menu item from the File 
menu. If you have modified text in the current buffer, Notepad 
produces a new version of the edited file and closes the Notepad 
window. The new version of the file has the same file name 
and file type as the original version, with the version number 
incremented by one. For example, if you use the EXIT command 
after modifying a file named STRATEGIES.DAT;!, the output file 
is named STRATEGIES.TXT;2. 

To discard the edits from a session and close the editing window, 
choose the Quit menu item from the File menu. 

Using Journal Files 
The Notepad editor keeps a record of changes made to a file 
so it can reconstruct any editing session that is interrupted 
because of a system failure. (Failures occur, for example, when a 
thunderstorm interrupts the electrical power.) 

The record, called a journal file, usually exists only while an 
editing session is active. However, the file remains if the session 
ends abnormally. 

/ 

When you attempt to edit a file that has a journal file associated 
with it, Notepad displays the Recover dialog box and asks you 
whether you want the previous edits restored. 

D 
Resume from crashed session? 

Yes No {Delete old journal file) 
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If a session is interrupted before you create a file, Notepad still 
saves your keystrokes in a journal file and assigns the untitled 
buffer a file name. The file name has the format nnnnnnnn.JNL, 
where nnnnnnnn is a process number that uniquely identifies the 
file. 

To recover the editing session: 

Choose the Open... menu item from the File menu. 

2 Look at the list of files in your current directory .. Find a file 
with the nnnnnnnn.JNL format created on the appropriate 
day, and enter the process number (nnnnnnnn) in the 
Selection text entry field. Do not include the JNL file type in 
the file name. 
Notepad displays a Recover dialog box asking you to confirm 
that you want to perform the recovery. 

3 Click on the Yes button. 
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Using Paint 

Paint is a graphics program that lets you create any kind of 
simple picture, such as a sketch, an illustration, or a map. From 
an assortment of art tools, you can choose those that enhance your 
picture, adding any details and accents it requires. 

The Paint program can save your pictures for later use, print them 
on different kinds of printers, or copy them to other applications. 
You can also display these pictures on your terminal screen with 
the DDIF Viewer (see Chapter 6). 

This chapter describes how to 

• Start Paint 

• Select tools and menu items 

• Erase 

• Draw lines and shapes 

• Introduce patterns into paintings 

• Use the paintbrush 

• Edit paintings 

• Insert text 

• Size and scroll the canvas 

• Print paintings 

• Exit from Paint 
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Starting Paint 
To start Paint, choose the Paint menu item from File View's 
Applications menu. 

The Paint program displays a drawing window with a tool palette 
on the left side. 
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The Paint window frames a portion of the canvas. Horizontal and 
vertical scroll bars indicate the percentage of the canvas displayed 
in the Paint window. 

Learning the Basics 

11-2 Using Paint 

Paint is a bitmap graphics program, which means that it treats 
pictures as a collection of dots called pixels. Different drawing 
tools, such as the pencil, the paintbrush, and the text tool, edit the 
color of the pixels to either the foreground color or the background 
color to create a pattern. Because the Paint canvas has so many 
pixels in every square inch, you do not actually see patterns of 
dots. Instead you see a collection of lines, shapes, and text. 

You can begin to understand Paint by modifying a sample picture 
called the Clock Tower. To display the Clock Tower: 

In the Paint window, choose the Open... menu item from the 
File menu. 



The Open Picture dialog box displays the names of any 
graphics files in the current directory. 
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2 Enter the picture file name, DECW$EXAMPLES:CLOCK.DDIF. 

DDIF is the standard format of a Paint file. 

3 Click on the OK button or press I Return I. 

Paint displays the Clock Tower picture. You can use the Clock 
Tower picture to practice selecting tools and to experiment with 
some of the Paint menu items. Figure 11-1 illustrates the Clock 
Tower. 
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Figure 11-1 The Clock Tower 
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Picking Out Tools 
The tool palette offers a variety of art tools and basic shapes. You 
can work with a pencil, a paintbrush, a can of spray paint, or 
a paint bucket. The shapes on the tool palette let you compose 
pictures quickly and easily. 

Notice that when you first start Paint, the paintbrush tool is 
highlighted, indicating it is the current default. Only one tool on 
the tool palette is active at a time and that tool remains active 
until you make another selection. 

Try changing the time on the Clock Tower. First, select the eraser 
to delete the current time. To use the eraser: 

Place the pointer in the tool palette, position it on the eraser 
tool, and click MBl. 

2 Move the pointer into the drawing window, position it in the 
center of the clock face, and press and hold MBl. 

The eraser is now active in the window. 

3 Gently drag the eraser along each hand. of the clock, 
eliminating the current time. 

Now, draw in the current time, using the straight line tool: . 

Point to the straight line tool on the tool palette and click 
MBl. 

2 Position the pointer in the center of the clock face and press 
MBl. 
The straight line tool is now active, and one end of the line is 
anchored at the center of the clock. You can stretch and swing 
the line from the center point by moving the mouse. Try it. 

3 Drag the pointer from the center of the clock to the current 
hour position. Once the line points to the correct time, release 
MBl. 

4 Add a second line in the same manner for the minute hand. 

If you make a mistake, choose the Undo menu item from the Edit 
menu. 
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11-6 Using Paint 

Using Menu Items 
You can use different menu items to create special effects in a 
painting. 

For example, the Invert menu item on the Edit menu creates a 
negative image of a painting. The Paint program can reverse the 
tones of the Clock Tower, switching the foreground color and the 
background color. 

Click on the selection box tool. 

2 Move the pointer into the drawing window and select the 
Clock Tower by positioning the pointer in one corner of the 
area to be selected and dragging the pointer over the desired 
area. 

3 Choose the Invert menu item from the Edit menu. 

Paint repaints the Clock Tower, making a negative of the original 
image. 

Saving a Painting 
To save your version of the Clock Tower: 

Choose the Save As... menu item from the File menu. 

Paint displays a dialog box and prompts you for a file name. 
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Erasing 

2 Type a file name using the form SYS$LOGIN :filename.DD IF 
so that Paint saves the picture in your login directory. 

3 Click on the OK button or press I Return I. 

Printing a Painting 
To print the Clock Tower, choose one of the Print menu items 
from the File menu. The Print menu item sends the painting to 
the default printer, whereas the Print... menu item displays the 
print dialog box. Complete the dialog box as described in the VMS 
DECwindows User's Guide. 

Paint supports output to both PostScript printers and sixel 
printers such as the LA50 and LAl 00. When printing on an LA50 
printer, set an aspect ratio of 2:1. All other printers have a 1 :1 
ratio. 

There are several ways to erase in Paint: 

• Use the eraser tool. 

• Select the area using the selection box tool or the scissors tool. 
Or, select the entire canvas using the Select All menu item 
from the Edit menu. Then choose the Clear menu item from 
the Edit menu. 

• Choose the Undo menu item from the Edit menu to erase the 
last Paint operation. 

Drawing Lines and Shapes 
The bottom half of the tool palette, shown in Figure 11-2, contains 
a collection of line and shape tools that you use in a similar way. 
Whenever you draw a straight line or a shape, the point where 
you press MBl becomes its reference point. That is, you can 
stretch and swing the line or shape from this reference point by 
dragging the pointer. When the shape is correct, anchor it in place 
by releasing MBl. Figure 11-2 illustrates the tools for creating 
lines and shapes. 
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Figure 11-2 Tools for Lines and Shapes 
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For example, to draw a rectangle: 

1 Click on the rectangle tool. 

2 Position the pointer in the drawing window where you want 
one corner of the rectangle to be. Press MBl and drag the 
pointer diagonally across the drawing surface until the 
rectangle has the desired width and height. (Notice how 
you can stretch and shrink the rectangle, even flip it over.) 

3 Release MBl to anchor the shape. 
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If you want to line up a series of shapes or draw them equidistant 
to each other, choose the Grid On menu item from the Options 
menu. It superimposes a horizontal and vertical pattern of dots 
on the drawing window, as shown in Figure 11-3, that serves as a 
guide, yet does not become part of your picture. One advantage of 



using a grid is that it causes lines to "snap in place" on the dots, 
which makes drawing geometric figures easier. 

Figure 11-3 Using a Grid 
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Varying Line Width 
Lines drawn with the shape tools can be thick or thin. To change 
the current line width: 

Choose the Line Width... menu item from the Options menu. 
Paint displays a dialog box. 
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2 Click on the line thickness you want. 

For example, to draw polygons with different kinds of borders, 
choose the line width you want and then do the following: 

Click on the polyline tool to make it active. 

2 After positioning the pointer in the drawing window, drag the 
pointer to create one side of the polygon. Drag and click to 
create additional sides, and double click on the final corner. 

Most of the time, geometric shapes or figures are opaque, so you 
cannot see what lies behind them. Using the Transparent menu 
item from the Options menu, you can let background images show 
through foreground images. 
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Lines and shapes do not need to be a solid color. They can be 
striped, speckled, woven, dotted, and so on. 

The line and shape tools, the spray can tool, and the paintbrush 
tool can paint patterned lines and borders. The default outline is 
solid. To use patterned lines: 

Choose the Patterns... menu item from the Options menu. 

Paint displays the Patterns palette, which provides a selection 
of designs. Figure 11-4 illustrates the Patterns palette. 
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Figure 11-4 
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2 Click on the outline pattern button. 

3 Click on any pattern. 
Notice that the pattern you click on is displayed in the outline 
pattern button, indicating it is the active pattern. 

4 Click on the shape tool you want to use. 

5 After positioning the pointer in the drawing window, drag the 
pointer to create a patterned line or border. 

To create shapes with patterned centers: 

Choose the Patterns... menu item from the Options menu. 
Paint displays the Patterns palette (illustrated in Figure 11-4). 

2 Click on the fill pattern button. 

3 Click on any pattern on the palette. 
Notice that the pattern you click on is displayed in the fill 
pattern button, indicating it is the current default pattern. 

4 Click on any tool you want to use. The geometric shape tools 
and the paint bucket tool use the current fill pattern. 

5 After positioning the pointer in the drawing window, drag the 
pointer to create a shape with a patterned center. 



You can fill existing shapes with the paint bucket tool by 
clicking MBl inside the shape you want to fill. The shape 
must be enclosed; any opening in the border causes the paint 
to spill out onto the canvas. You can reverse filling a shape 
by choosing the Undo Flood menu item from the Edit menu. 
Figure 11-5 shows examples of patterns. 

Figure 11-5 

• '\o 
~~ .. ' A ffl ,, 
DD 
oo 
o~ 

Examples of Patterns 

ZK-0315A-GE 

Creating Your Own Patterns 
With Paint, you can create your own patterns and store them 
on the pattern palette during a Paint session. You create your 
own pattern from any of the patterns on the palette except 
the solid foreground, solid background, and None patterns (see 
Figure 11-4). 

To create your own pattern: 

Decide whether you want an outline or a fill pattern, then 
click on the appropriate button on the Pattern palette. 

2 Choose a pattern from the palette that is closest to what you 
want and click on it. Paint also provides a few blank patterns 
at the end of the palette so that you can create your own 
patterns from scratch. 

3 Choose the Edit Pattern... menu item from the Options menu. 
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Paint displays a dialog box. 
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Notice that this dialog box contains two boxes. In the left­
hand box you see the pattern you chose from the palette. In 
the right-hand box you see the same pattern magnified. 
While you are editing a pattern, the Edit Pattern dialog box 
has input focus, and the pointer assumes the shape of a pencil. 

4 In the Edit Pattern dialog box, edit the magnified version of 
the pattern to create the effect you want. 

Use the pencil to draw over pixels or click on individual pixels. 
The pencil tool turns a background pixel to the foreground 
color and a foreground pixel to the background color. 

Refer to the pattern shown in the left-hand box to see how the 
magnified pattern looks under normal conditions. 

5 Click on the OK button to complete the pattern and return to 
the drawing window. 

The edited pattern is available on the Pattern palette for the rest 
of the session, replacing the original pattern. 

Using the Paintbrush 

11-14 Using Paint 

For an elegant stroke, one that creates a calligraphic effect, use 
the paintbrush. The paintbrush tool applies paint along the path 
of the pointer. Initially, the paintbrush has a solid stroke, but you 
can choose a patterned stroke by changing the outline pattern on 
the Patterns palette, as described in the section Using Patterns. 

To shape the tip of the paintbrush: 

1 Click on the paintbrush tool. 

2 Choose the Brush Shape... menu item from the Options menu. 



Paint displays a dialog box. 
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3 Click on the brush shape you want. 

4 Move the pointer into the drawing window and try out the 
new brush stroke. 

Editing Paintings 

Undo Select 

Cut 

Copy 

Paste 

Clear 

Invert 

Crop 

Scale ... 

Select All 

With Paint's electronic canvas, you can easily rearrange images 
in the drawing window. You can delete images entirely, move 
them to another part of the window, or copy them. Paint can size 
selected images, shrinking them or enlarging them as you wish. 
It can also crop a painting, retaining one section of the canvas 
while discarding the rest. For further effect, Paint can invert the 
foreground and background colors in a selected area. 

Selecting Images 
Two selection tools, the box and the scissors, mark a portion of the 
drawing window for a graphics operation. The selection box tool 
marks a rectangular area, while the selection scissors tool marks 
an area with an arbitrary shape. You can select the entire canvas 
with the Select All menu item on the Edit menu. 

To use the selection box tool, position the pointer in one corner 
of the area to be selected and drag the pointer over the desired 
image. 

To use the selection scissors tool, drag the pointer around the 
boundary of the desired object until you reach the starting point. 
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You can cancel a selection by clicking in another part of the 
window or by selecting another tool. 

Paint stores the selected image until you tell it what to do. 

Moving Images 
You can move an image from one location in the Paint window to 
another. To move an image: 

1 Select the image. 

2 Position the pointer inside the selected area and drag the 
image to the desired location. 
You can cancel the selection by clicking in another part of the 
window or by selecting another tool. 

Copying Images 
Once you select an image on the canvas, you can copy the image, 
leaving the original image intact. Then paste the image onto the 
canvas. Paint can paste graphic images, but it cannot paste text. 

To copy an image: 

Select the image. 

2 Choose the Copy menu item from the Edit menu. 
Paint copies the image. 

3 Choose the Paste menu item from the Edit menu. 
Paint puts the image on the canvas, leaving it selected. 

4 Position the pointer in the selected image and drag it to the 
proper location on the screen. 
You can cancel the selection by clicking on another tool or by 
selecting another image. 

Resizing Images 
You can also modify the proportions of selected images. Use the 
Scale... menu item from the Edit menu to enlarge or shrink a 
selected image. To scale an image: 

Select the image. 

2 Choose the Scale... menu item from the Edit menu. 
Paint displays a dialog box. 



3 Click on one of the percent buttons to change the scale. If 
you want to specify your own percentage, enter a number less 
than 100 to shrink the figure by the desired percentage or a 
number greater than 100 to expand the figure. 
For example, clicking on 10% reduces the selected area to 10% 
of the original size, while clicking on 200% makes it twice as 
large as the original. 
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4 Click on the OK button to complete the operation. 
To reverse the process and return to your original picture, 
choose the Undo Scale menu item from the Edit menu. 

Cropping a Picture 
Many times, one section of a painting develops so well that you 
decide to keep it but discard the rest of the canvas .. Use the Crop 
menu item to extract a portion of the picture. To crop a picture: 

Select the section of the picture you want to keep. 

2 Choose the Crop menu item from the Edit menu. 
Paint repositions the cropped picture in the upper left corner 
of the window and discards the rest of the painting. You can 
restore the original picture with the Undo Crop menu item. 
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11-18 Using Paint 

Editing in Detail 
Not only does Paint magnify patterns in the Edit Patterns dialog 
box so you can see them better, it also magnifies portions of the 
canvas with the Zoom On menu item. The Zoom magnifying frame 
acts like a magnifying glass in the drawing window, enlarging an 
image to eight times its original size. 

To magnify a portion of a painting: 

Ill 
t:J 
fiil 

T 

" D 
0 

0 

Choose the Zoom On menu item from the Options menu. 

The Zoom window opens beside the Paint window and a 
magnifying frame is displayed in the Paint window itself. 
The magnifying frame in the Paint window demonstrates the 
size of the image that Paint magnifies in the Zoom window. 
You can resize the Zoom window to edit a larger area of the 
canvas. 

'\o 
~ 
J 
!:> 

' D 
0 
~ 

. ...................... . ..... . . . . . . . . . . . . . . . . . . . 
I •.=.•.=.=.=.=.•.1.1.1.1.1.1.1.1.1.1.1.1. 

1===~:::::::::::::::::::::::::::8:::::::~ 
=·········································· 

ZK-0145A-GE 

2 Place the pointer inside the magnifying frame and drag the 
frame over the image that you want to edit. 

Notice that the Zoom window contains an enlarged version 
of the image that is defined by the magnifying frame in the 
,Paint window. 

3 Select the pencil tool from the tool palette. 

4 Bring the pointer into the Zoom window and use the pencil to 
add fine details to the image. Either click on individual pixels 
or draw over them. 



Inserting Text 

A 

Notice that the image in the drawing window changes as you 
edit in the Zoom window, so you can see how the modified 
figure looks in normal proportions. Continue editing pixels 
until you are satisfied with the overall effect. 

5 To edit other areas of the drawing window, drag the 
magnifying frame to the next location. 

Edit the pixels in the Zoom window as before. Note that to 
edit sections of the drawing window that are under the Zoom 
window, you have to move the Zoom window out of the area 
even though the magnifying frame may be positioned correctly. 

To close the Zoom window, display the Options menu and click on 
the Zoom Off menu item. 

You can insert text anywhere in the Paint window. The text 
can be different fonts, sizes, and styles. You can change the 
appearance of text in the drawing window up until the moment 
you click to complete the text entry. After that, Paint incorporates 
the text into the graphic image. 

To insert text: 

1 Select the text tool. 

2 Position the pointer in the Paint window where you want to 
insert text and click MBl. 

Paint inserts a left corner bracket to mark the left margin of 
the text entry and displays the text insertion cursor next to it. 

3 Type in text from the keyboard, formatting it with the Tab 
and Return keys. 

4 To modify the text font, pull down the Font menu and drag 
the pointer to the submenu icon next to the Family menu item 
to view the submenu. Release MBl over the type of font that 
you want. 

5 To change the text from normal to bold face, pull down the 
Font menu and drag the pointer to the submenu icon next to 
the Style menu item to view the submenu. Release MBl over 
the Bold menu item. 

6 To adjust the size of the text, pull down the Font menu and 
drag the pointer to the submenu icon next to the Size menu 
item to view the submenu. Release MBl over the pica size 
that you want. 
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Paint applies the selections you make to the text you have 
already entered. 

7 To complete the entry with its current characteristics, either 
move the pointer to another part of the window and click MBl 
or select another tool. 

The inserted text becomes part of the picture. You can no longer 
erase text with the~ (Delete) key or change its characteristics 
with items from the Font menu. Figure 11-6 illustrates how you 
can add text to a picture. 

Figure 11-6 
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Sizing the Canvas 

11-20 Using Paint 

The default Paint window shows only a portion of the canvas. The 
scroll bars along the right side and the bottom of the window let 
you view the entire canvas. The position of the slider indicates 
your position in the canvas. When the slider is at the top of the 
scroll bar, you are at the beginning of the canvas. When the slider 
is at the bottom of the scroll bar, you are at the end of the canvas. 

You can resize the Paint window to frame the entire canvas by 
clicking on the resize button. 



You can also tailor the size of a Paint canvas. To alter the canvas: 

Choose the Picture Size... menu item from the Customize 
menu. 

Paint displays a dialog box. 

Picture Size [!i] 

Size I Letter 

Width: l'fsoo 

Height: l'f1so 

II OK II 

Ci> Pixels 
0 Inches 

0 Centimeters 

I cancel I 
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The Picture Size dialog box shows the current canvas size 
with its dimensions converted to pixels, inches, or centimeters. 

2 In the dialog box, you can set the dimensions to be in pixels, 
inches, or centimeters by clicking MBl on the appropriate 
option button. You can also type in the height and width you 
desire. 

3 Click on the OK button. 

Exiting from Paint 

Tool Summary 

r-- ... 
I I 
I I .. __ .. 

To exit from Paint, choose the Quit· menu item from the File 
menu. If you try to exit without saving your picture, Paint asks if 
you want to save the picture before exiting. Click on Yes, No, or 
Cancel to state your choice. 

The following list summarizes the tools available on the Paint 
palette. 

Box 
Selects a rectangular area for editing. 

Scissors 
Selects a shape for editing. 
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Spray can 
Applies paint in the current outline pattern. (The slower you drag J 

the tool, the darker the coat.) 1 

Pencil 
Draws a thin line. 

Eraser 
Deletes the image in the path of the pointer. 

Paintbrush 
Paints a free stroke. 

Text 
Prints what is typed at the keyboard. 

Paint bucket 
Fills a closed shape with the current fill pattern. 

Line 
Draws a straight line. You can shift click for a 45-degree or a 
90-degree line. 

Arc 
Sketches a horizontal or vertical arc, depending on the initial 
movement after the click. 

Rectangle 
Draws a rectangle. You can shift click for a square. 

Square 
Draws a square. 

Ellipse 
Draws an oval shape. You can shift click for a circle. 

Circle 
Draws a circle. 

Free-hand stroke 
Draws a free-hand line in the selected line width and pattern. 

Polyline , 
Draws a multisided figure. You specify a corner by clicking, and 
you double click to complete a shape. You can shift click for 
45-degree or 90-degree angles. 







12 
Puzzling 

The Puzzle is a video version of a number puzzle with slidable 
squares. 

Starting the Puzzle 

New View 

Layout ... 

Privileges ... 

Menu Bar ... 

Logical Names ... 

Work in Progess ... 

Quit 

To start the Puzzle: 

Choose the Menu Bar ... menu item from FileView's Control 
menu. File View displays a dialog box. 

2 Click on Games. 

3 Click on OK or Apply to add Games to FileView's menu bar. 

4 Choose the Puzzle menu item from the Games menu you 
added to File View's menu bar. 
The Puzzle is displayed. 
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Playing Around with the Puzzle 

Settings ... 

12-2 Puzzling 

The puzzle squares are scrambled. The trick is to arrange them 
in ascending order in the fewest possible moves. The Puzzle keeps 
track of the number of moves you make. 

Click on the square you want to move. Although you can move 
only those squares that are adjacent to the blank square, you can 
slide an entire row at a time. 

To make the Puzzle easier or more challenging, choose the 
Settings... menu item from the Customize menu and change the 
settings. 

4 
I-ti 

Squares per Side 

OK I cancel I 
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Try increasing the number of squares displayed per side. To 
change the number of squares on each side, place the pointer on 
the number in the slider and drag to the left or right. Click on 
the OK button to change the settings, or on the Cancel button to 
return to the Puzzle without changing any settings. 



Starting a New Game 
You do not have to win one game to start another. To start a new 
game and rescramble the squares, choose the New Game menu 
item from the File menu. 

Exiting from the Puzzle 
To exit from the Puzzle, choose the Quit menu item from the File 
menu. 

Puzzling 12-3 





A 
Composing Characters 

In a DECterm window, you can use compose sequences to create 
special characters. A compose sequence is a series of keystrokes 
that creates characters that do not exist as standard keys on your 
keyboard. You can create any character from the character set 
DECterm is currently using. (For more information on choosing a 
character set, see Chapter 7.) 

Depending on the keyboard type, you compose characters in either 
of the. following ways: 

• Using three-stroke sequences on a VT320 keyboard 
including the North American/United Kingdom, Dutch, and 
Norwegian/Danish keyboards. 

• Using two-stroke sequences on other keyboards. 

To compose a character: 

1 Find the character you want to create in column 1. 

2 To compose a three-stroke sequence, press I Compose I and the 
space bar, and then type the two characters in column 2. 

To compose a two-stroke sequence, type the two characters in 
column 3. The desired character is displayed. 

Press the Compose key and space bar, <RI key, Tab key, Return 
key, or Enter key to cancel a compose sequence. 

Note The North American, United Kingdom, and Dutch keyboards.do 
not have diacritical marks. If you use a diacritical mark, DECterm 
will use an equivalent character. 
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Table A-1 Composing Characters in Multinational Character 
Mode 

Three-Stroke Two-Stroke 
Character Sequence Sequence 

II quotation mark ··space bar ··space bar 

# number sign ++ 

apostrophe 'space bar 'space bar 

@ commercial at AA 

[ opening bracket ( ( 

\ backslash I I or I< 

] closing bracket ) ) 

A circumflex accent A space bar A space bar 

grave accent 'space bar 'space bar 

opening brace ( -
I vertical line /A 

} closing brace ) -
tilde - space bar - space bar 

inverted! !! 

¢ cent sign CI or CI 

£ pound sign L- or L= 

¥ yen sign Y- or Y= 

§ section sign SO or S! or SO 

a currency sign XO or XO 

© copyright sign CO or CO 
~ feminine ordinal A_ 

« open angle brackets << 

degree sign QA 

± plus or minus sign +-
2 superscript 2 2A 

3 superscript 3 3A 

µ micro sign /U 

«JI paragraph sign P! 

(continued on next page) 
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Table A-1 (Cont.) Composing Characters in Multinational 
Character Mode 

Three-Stroke Two-Stroke 
Character Sequence Sequence 

middle dot A 

1 superscript 1 1 A 

masculine ordinal 0 -
» closed angle >> 

brackets 

* fraction one- 1 4 
quarter 

112 fraction one-half 1 2 

;, inverted? ?? 

A A grave A' 'A 

A A acute A' 'A 

A A circumflex AA AA 

A A tilde A- -A 

A A umlaut A 11 or·A ""A 

A Aring A* or A A 

(degree sign) 

lE A E diphthong AE 

9 C cedilla c, 
:E E grave E' 'E 

E E acute E' 'E 

E E circumflex EA AE 

E E umlaut E 11 or··E ""E 

t I grave r 'I 

f I acute I, - 'I 

i I circumflex IA AI 

I I umlaut I 11 or ""I ""I 

:N N tilde N- -N 

0 0 grave O' 'O 
6 0 acute 0' '0 

(continued on next page) 
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Table A-1 (Cont.) Composing Characters in Multinational 
Character Mode 

Three-Stroke Two-Stroke 
Character Sequence Sequence 

6 0 circumflex QA AQ 

6 0 tilde Q .... .... o 

6 0 umlaut 0" or··o "O 

CE 0 E diphthong OE 

0 0 slash o/ 

ir U grave U' 'U 

u U acute U' 'U 

u U circumflex UA AU 

u U umlaut U" or"U "U 
y Yumlaut Y11 or"Y "Y 

13 German small SS 
sharps 

a a grave a' 'a 

a a acute a' 'a 

a a circumflex aA Aa 

a a tilde a- -a 

a a umlaut a" or"a .. a 

a a ring a* or a0 oa 

(degree sign) 

re a e diphthong ae 

~ c cedilla c, (comma) 

e e grave e ' ' e 

e e acute e' 'e 

e e circumflex eA Ae 

e e umlaut e" or "e "e 

i grave i' 'i 

i acute i I 'i 

i i circumflex iA Ai 

1 i umlaut i" or "i "i 

(continued on next page) 

A-4 Composing Characters 



Table A-1 (Cont.) Composing Characters in Multinational 
Character Mode 

Character 

fi n tilde 

0 o grave 

6 o acute 

0 o circumflex 

0 o tilde 

0 o umlaut 

re o e diphthong 

fij o slash 

u u grave 

u u acute 

fr u circumflex 

ii u umlaut 

y y umlaut 

ISO Latin 1 Characters1 

no break space 

broken vertical bar 

- logical not 
' 

SHY soft (syllable) 
hyphen 

RO registered 
trademark 

macron 

3/4 three quarters 

-: division sign 

xx multiplication sign 

acute accent 

cedilla 

Three-Stroke 
Sequence 

n ...... 
' 0 

O' 

0A 

o ...... 

o" or .. o 

oe 

of 

u' 

u' 
UA 

u" or .. u 

y" or··y 

sp sp 

I I or! A 

- * 
' 

RO 

A 

34* 

xx 

' ' 

'' 

Two-Stroke 
Sequence 

......n 

'o 

'O 

AO 

......o 

.. 0 

'u 

'u 
AU 

.. u 

·y 

1In the ISO Latin 1 mode, the characters re, CE, and Y are not available. 

(continued on next page) 
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Table A-1 (Cont.) 

Character 

diereses 

Y' Y acute 

y' y acute 

TH capital Icelandic 
thorn 

th small Icelandic 
thorn 

-D capital Icelandic 
Eth 

Composing Characters in Multinational 
Character Mode 

Three-Stroke Two-Stroke 
Sequence Sequence 

··space bar 

yr 'Y 
Y' 'Y 
TH 

th 

-D 

-d small Icelandic Eth -d 

TableA-2 Composing Characters in National Replacement 
Mode Using Typewriter Keys 

Character 

British 

£ pound sign 

grave accent 

Danish 

# 

@ 

number sign 

apostrophe 

commercial at 

grave accent 

A-6 Composing Characters 

Three-Stroke 
Sequence 

L- or L= 

'space bar 

++ 

' space bar 

AA 

'space bar 

Two-Stroke 
Sequence 

(continued on next page) 



Table A-2 (Cont.) 

Character 

Dutch 

£ pound sign 

apostrophe 

1A one quarter 

1h one half 

3/4 three quarters 

ij i j sign 

fl Florin 

grave accent 

acute accent 

diereses 

Finnish 

# number sign 

apostrophe 

Composing Characters in National 
Replacement Mode Using Typewriter Keys 

Three-Stroke 
Sequence 

L- or L= 

' space bar 

14 

12 

34 

ij 

f-

'space bar 

fl /\ 

++ 

' space bar 

Two-Stroke 
Sequence 

Flemish and French/Belgian 

£ pound sign 

apostrophe 

grave accent 

French Canadian 

a. 
a. 

apostrophe 

a grave 

a circumflex 

L- or L= 

' space bar 

'space bar 

' space bar 

'a 

A a 
'a 

A a 

(continued on next page) 
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Table A-2 (Cont.) Composing Characters in National 
Replacement Mode Using Typewriter Keys 

Three-Stroke Two-Stroke 
Character Sequence Sequence 

e e grave ' e ' e 

e e circumflex Ae Ae 

i i circumflex A' 1 Ai 

0 o circumflex AO AO 

u u grave ' u ' u 

u u circumflex AU AU 

German/Austrian 

apostrophe ' space bar 

grave accent 'space bar 

Italian 

apostrophe ' space bar 

Norwegian 

apostrophe ' space bar 

grave accent 'space bar 

Portuguese 

apostrophe ' space bar 

grave accent 'space bar 

A. A tilde -A 

6 0 tilde .... o 
a. a tilde ,., a 

0 o tilde ,., 0 

(continued on next page) 
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Table A-2 (Cont.) 

Character 

Spanish 

£ pound sign 

apostrophe 

§ section sign 

grave accent 

- tilde 

Swedish 

# number sign 

apostrophe 

:E E acute 

e e acute 

Composing Characters in National 
Replacement Mode Using Typewriter Keys 

Three-Stroke 
Sequence 

L- or L= 

' space bar 

!Sor OS or OS 

'space bar 

- space bar 

++ 

' space bar 

'E 
' e 

Two-Stroke 
Sequence 

Swiss (French) and Swiss (German) 

apostrophe ' space bar 

e e circumflex " e " e 
1 i circumflex /\ . 

1 
/\ . 

1 

0 o circumflex /\ 0 /\ 0 

u u grave u u 

u u circumflex /\ u /\ u 
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TableA-3 Composing Characters in National Replacement 
Mode Using Data Processing Keys 

Character 

II quotation mark 

# number sign 

apostrophe 
@ commercial at 

[ opening bracket 

\ backslash 

] closing bracket 

apostrophe 

opening brace 

I vertical bar 

} closing brace 

tilde character 

A-1 O Composing Characters 

Three-Stroke 
Sequence 

11 space bar 

++ 

' space bar 

aa or AA or aA 

( ( 

I< 

"space bar 

' space bar 

( -

" I 
) -
- space bar 



B 
National Replacement Character Sets 

In DECterm, you can pick a National Replacement Character 
Set (NRCS) that corresponds to the chosen keyboard dialect by 
choosing the 7-bit NRCS Selection... menu item from DECterm's 
Customize menu. 

The following National Replacement Character Sets. are available: 

North American 

Flemish 

Canadian (French) 

British 

Danish 

Finnish 

Austrian/German 

Dutch1 

Italian 

Swiss (French) 

Swiss (German) 

Swedish 

Norwegian 

Belgian/French 

Spanish 

Portuguese 

1 Use of the Dutch national character set is discouraged, and it may not be 
supported in future versions of DECterm. Dutch users should use the ISO Latin 1 
character set instead. 

The following figures illustrate these character sets. 

Figure B-1 illustrates the North American Character Set. 

Figure B-2 illustrates the Flemish Character Set. 

Figure B-3 illustrates the Canadian (French) Character Set. 

Figure B-4 illustrates the British Character Set. 

Figure B-5 illustrates the Danish Character Set. 

Figure B-6 illustrates the Finnish Character Set. 

National Replacement Character Sets B-1 



Figure B-7 illustrates the Austrian/German Character Set. 

Figure B-8 illustrates the Dutch Character Set. 

Figure B-9 illustrates the Italian Character Set. 

Figure B-10 illustrates the Swiss (French) Character Set. 

Figure B-11 illustrates the Swiss (German) Character Set. 

Figure B-12 illustrates the Swedish Character Set. 

Figure B-13 illustrates the Norwegian Character Set. 

Figure B-14 illustrates the Belgian/French Character Set. 

Figure B-15 illustrates the Spanish Character Set. 

Figure B4 6 illustrates the Portuguese· Character Set. 

B-2 National Replacement Character Sets 
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A 

Alarm setting, 3-6, 5-3 
ASCII file 

displaying, 6-1 

B 
Bookreader 

book 
selecting, 1-2 

cross-reference, 1-5 
example 

displaying, 1-5 
exiting from, 1-5 
figure 

displaying, 1-5 
footnote, 1-5 
hot spots, 1-5 
index, 1-3 
index window, 1-4 
navigating, 1-4 
selection window, 1-2 
shelf 

selecting, 1-2 
starting, 1-1 
stepping arrows, 1-4 
table 

displaying, 1-5 
table of contents, 1-3 

Index 

Bookreader 
table of contents (cont'd.) 

displaying graphics, 1-5 
topic 

selecting, 1-3 
topic window, 1-2, 1-3, 1-4 
using scroll bars in, 1-4 

Buffer, 10-2 

c 
Calculator 

accumulator display, 2-1 
copying text to other applications, 

2-4 
correcting mistakes, 2-3 
exiting from, 2-5 
memory display, 2-1 
order of precedence, 2-3 
pasting to another application, 2-4 
starting, 2-1 
using, 2-2 

Calendar 
alarm 

repeat intervals, 3-7 
clock, 3-9 
closing, 3-13 
creating entry, 3-3 
creating new, 3-11 
creating printable file in, 3-1 O 

lndex-1 



Calendar (cont'd.) 
customizing, 3-13 to 3-16 
day view, 3-2 
deleting, 3-13 
deleting entry, 3-7 
displaying, 3-2 
exiting from, 3-17 
marking special days in, 3-9 
moving entry, 3-8 
multiple, 3-11 
opening a, 3-12 
option 

Date for Week No. 1, 3-15 
Day Display: Timeslot Size, 

3-15 
Fill Blank Days in Month Display, 

3-14 
First Day of Week, 3-14 
First Display, 3-15 
Include Week Numbers, 3-16 
Show AM/PM, 3-15 
Show Months, 3-15 
Start Iconized, 3-15 
Working Hours, 3-15 
Work Week, 3-14 

renaming a, 3-13 
repositioning, 3-16 
resizing, 3~16 

resizing timeslot, 3-5 
setting alarms, 3-6 
starting, 3-2 
timeslot editor, 3-4 

Card 
copying text in, 4-9 
creating, 4-4 
deleting text from, 4-8 
editing, 4-7 
moving text in, 4-9 
opening existing in card file, 4-5 
renaming in card file, 4-7 
selecting in card file, 4-5 
selecting text in, 4-8 

Card file 
creating new, 4-3 
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Card file (cont'd.) 
merging with another, 4-12 
opening existing, 4-3 
opening new, 4-2, 4-3 
renaming, 4-10 
saving existing, 4-11 
saving new, 4-10 
searching, 4-6 
viewing contents of, 4-5 

Cardfiler 
exiting from, 4-12 
starting, 4-2 

Character composing, 7-19, A-1 
Clock 

D 

Calendar 
See Calendar 

changing display, 5-2 
exiting from, 5-3 
setting alarm, 5-3 
starting, 5-1 

DDIF (Digital Document Interchange 
Format) 

definition, 6-1 
DDIF file 

closing, 6-4 
displaying, 6-2 

DDIF Viewer 
changing processing options, 6-4 
closing files with, 6-4 
exiting from, 6-5 
starting, 6-1 
viewing files with, 6-2 

DECterm 
composing characters, 7-19, A-1 
copying information, 7-17 
customizing, 7-2 
display 

customizing, 7-5 
exiting from, 7-20 
general features 

customizing, 7-7 



DECterm (cont'd.) 
keyboard 

customizing, 7-12 
National Replacement Character Set, 

B-1 
choosing, 7-14 

option 
Angle Brackets Key Sends <>, 

7-14 
Angle Brackets Key Sends'-, 

7-14 
Appl Cursor Keys, 7-8 
Application Keypad, 7-8 
Auto Repeat, 7-13 
Auto Resize Terminal, 7-4 
Auto Resize Window, 7-4 
Auto Wrap, 7-6 
Big Font, 7-4 
8-Bit Multinational Characters, 

7-11 
7-bit NRCS Characters, 7-11 
Block Cursor, 7-6 
Comma Key Sends,,, 7-13 
Comma Key Sends,<, 7-13 
Condensed Font, 7-5 
Ctrl-Q, Ctrl-S =Hold, 7-13 
Cursor Blink, 7-6 
Dark Text, Light Background, 

7-6 
Delete Key, 7-13 
Delete Key Backspace, 7-13 
Display Cursor, 7-6 
Horizontal Cursor Coupling, 7-4 
Horizontal Scroll Bar, 7-4 
Host Status Display, 7-6 
Light Text, Dark Background, 

7-6 
Little Font, 7-5 
Lock UDKs, 7-7 
Lock User Features, 7-7 
Margin Bell, 7-13 
Newline, 7-7 
Normal Cursor Keys, 7-8 
Normal Font, 7-5 

DECterm 
option (cont'd.) 

Normal Font/80, Condensed/132, 
7-5 

No Status Display, 7-6 
Numeric Keypad, 7-8 
Record Lines Off Top, 7-4 
Terminal ID, 7-8 
Terminal Size, 7-5 
Tilde Key Sends ESC, 7-14 
Tilde Key Sends'-, 7-13 
Underline Cursor, 7-6 
UPSS DEC Supplemental, 7-8 
UPSS ISO Latin 1, 7-10 
Vertical Cursor Coupling, 7-4 
Vertical Scroll Bar, 7-4 
VTlOO Mode, 7-12 
VT300 Mode, 8-bit Controls, 

7-11 
VT300 Terminal Mode, 7-bit 

Controls, 7-12 
VT52 Mode, 7-12 
Warning Bell, 7-12 

restoring customized settings, 7-16 
restoring system settings, 7-16 
saving customized settings, 7-16 

DECterm window 
creating, 7-1 
customizing, 7-3 

options, 7-3 

E 
EDIT/TPU command 

See EVE 
Editor 

EVE, 8-1 
Notepad, 10-1 

EVE, 8-1 to 8-38 
bound cursor motion, 8-5, 8-32 
buffer preferences 

setting, 8-28 
buffers 

deleting, 8-22 
moving between, 8-21 
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EVE (cont'd.) 
commands 

typing, 8-6 
customizing, 8-27 to 8-38 
Do key, 8-6 
EDITtrPU command, 8-2 

/INITIALIZATION qualifier, 
8-35 

erasing text, 8-10 
exiting from, 8-20 
Extend This command, 8-38 
filling text, 8-16 
formatting text, 8-15 to 8-19 
free cursor motion, 8-5, 8-32 
getting help, 8-7 
global preferences 

setting, 8-30 
Gold key, 8-24 
initialization file, 8-35 to 8-37 
input file, 8-4 
insert mode, 8-5 
invoking, 8-2 to 8-4 
keys 

defining, 8-24 
learn sequence, 8-25 
main window, 8-3 
moving text, 8-9 
opening file, 8-4 
option 

Command, 8-34 
Create, 8-33 
Debug, 8-34 
Display, 8-33 
FILE:, 8-33 
Hide Dialog, 8-35 
Initialization, 8-34 
Modify, 8-34 
output, 8-35 
Section, 8-35 
Set Buffer Modifiable, 8-29 
Set Buffer Read Only, 8-29 
Set Clipboard, 8-31 
Set Cursor, 8-32 
Set Find Case Exact, 8-31 
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EVE 
option (cont'd.) 

Set Left Margin To, 8-28 
Set Paragraph Indent, 8-29 
Set. Pending Delete, 8-31 
Set Right Margin To, 8-29 
Set Tabs, 8-32 
Set Tabs At, 8-30 
Set Tabs Every, 8-29 
Set Tabs Visible, 8-31 
Set Wrap, 8-29 
Start Position, 8-34 
Write, 8-34 

overstrike mode, 8-5 
paragraph indent, 8-17 
pending delete, 8-9 
replacing text, 8-10, 8-12 
restoring text, 8-10 
saving a file, 8-20 
searching for text, 8-10 to 8-15 
section file, 8-26 
selecting text, 8-8 
setting keypad, 8-26 
setting margins, 8-15 
setting tabs, 8-18 
setting width, 8-32 
soft page break, 8-19 
starting editing session, 8-2 
status line, 8-3 
TPU command, 8-38 
VAXTPU preferences 

setting, 8-33 
VAXTPU procedures to extend, 8-37 
whitespace characters, 8-13 
wildcards, 8-13 
windows 

deleting, 8-23 
moving between, 8-23 
splitting, 8-22 

working with multiple files, 8-21 to 
8-23 

EVE$INIT logical name, 8-35 
EVE$SECTION logical name, 8-27 



Extensible VAX Editor 
See EVE 

F 
File 

ASCII 
displaying, 6-1 

DDIF 
displaying, 6-1 

Files 
editing 

with EVE, 8-1 
with Notepad, 10-1 

INBOX folder, 9-12 
Index 

selecting topics from, 1-3, 1-4 
Index topic 

changing, 4-7 

K 
Key 

defining in EVE, 8-24 to 8-27 
Keyboard 

choosing NRCS, 7-14, B-1 

M 
Mail 

changing default settings, 9-34 
changing directory, 9-40 
Create-Send window, 9-4 

opening, 9-4 
customizing, 9-33 to 9-41 
drawers and folders, 9-2 

adding from a different directory, 
9-23 

compressing, 9-27 
creating, 9-22 
deleting, 9-22 
updating, 9-27 

exiting from, 9-41 

Mail (cont'd.) 
interaction with VMS Mail Utility, 

9-37 
Mail Profile, 9-34 
main window 

illustrated, 9-1 
opening a new, 9-31 
Paned style, 9-38 to 9-40 

Read window, 9-12, 9-13 
closing, 9-14 
default, 9-15 
illustrated, 9-12 
multiple, 9-15 
opening, 9-13 

starting, 9-1 
Mail message 

changing editors, 9-11 
copying, 9-25 
creating, 9-4 

including a draft, 9-6 
including a file, 9-8 

creating a file from a, 9-19 
creating subset of, 9-28 
DDIF format, 9-32 
deleting, 9-21 
displaying additional index 

information, 9-31 
extracting, 9-19 
forwarding, 9-1 7 
marking, 9-28 
moving, 9-25 
new, 9-12 
old, 9-12 
picking, 9-28 
printing, 9-1 7 

changing default settings, 9-33 
reading, 9-12 

new, 9-12 
nontext, 9-14 

replying to, 9-16 
resuming work on draft, 9-6 
retrieving deleted, 9-21 
selecting, 9-12 
sending, 9-3, 9-5 
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Mail message 
sending (cont'd.) 

changing editors, 9-11 
nontext, 9-11 
using a distribution list, 9-9 

unmarking, 9-28 
Memory display 

Calculator, 2-4 
storing value in, 2-4 

N 
Notepad 

p 

canceling edits, 10-5 
copying text, 10-6 
deleting text, 10-4 
editing file, 10-3 
exiting from, 10-11 
formatting text, 10-2 
including existing file, 10-6 
merging files, 10-9 
moving text, 10-5 
navigating, 10-3 
opening existing file, 10-8 
opening new, 10-7 
recovering lost edits, 10-11 
replacing text, 10-1 O 
saving text, 10-7 
scrolling, 10-3 
searching for text, 10-9 
selecting text, 10-4 
starting, 10-1 
typing text, 10-2 
using journal file, 10-11 

Paint 
basic functions, 11-1 to 11-5 
bitmap, 11-2 
changing line width, 11-8 11-10 
changing scale, 11-16 ' 
clearing window, 11-7 
copying images, 11-16 
creating your own, 11-14 
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Paint (cont'd.) 
cropping picture, 11-17 
DDIF file type, 11-3 
erasing, 11-7 
exiting from, 11-21 
inserting text, 11-19 
inverting colors, 11-6 
magnifying, 11-18 
moving images, 11-16 
opening graphics file, 11-3 
paintbrush tool, 11-15 
patterns, 11-11 to 11-14 

creating your own, 11-14 
pixel, 11-2 
printing, 11-7 
saving painting, 11-6 
selecting images, 11-15 
sizing the canvas, 11-21 
starting, 11-2 
tool, 11-5 

drawing lines and shapes, 11-5 
tool palette, 11-2, 11-5 

summary, 11-21 
transparent background, 11-1 O 
using grid, 11-9 
using pattern, 11-12 
window 

scrolling the canvas, 11-20 
Zoom, 11-18 

Painting 
editing, 11-15 to 11--19 

Pattern 
adding to painting, 11-12 
using in Paint, 11-8, 11-12 

Puzzle 

s 

changing settings, 12-2 
exiting from, 12-3 
starting, 12-1 · 

Scroll bar 
using in the Bookreader, 1-4 
using in the Cardfiler, 4-6 



Selection window 
library of books, 1-2 

T 

Table of contents 
selecting topics from, 1-3 

Terminal emulator 
creating, 7-1 

Text 
copying in card file, 4-9, 4-10 
copying to another application, 2-4 
deleting in card file, 4-8 
editing with EVE, 8-1 
editing with Notepad, 10-1 
finding in card file, 4-6 
in a painting, 11-20 
moving in card file, 4-9 
selecting in card file, 4-8 

Text cursor 
moving in card file, 4-8 

Timeslot 
changing size of, 3-5 
creating entry in, 3-3 
deleting entry in, 3-7 
moving entry between, 3-8 

Timeslot editor 
creating entry with, 3-4 

Tool 
choosing in Paint, 11-5 
summary of Paint palette, 11-21 
using shapes in Paint, 11-8 

Topic 
reading, 1-4 

v 
VAX Text Processing Utility 

See VAXTPU 
VAXTPU 

section file, 8-26 

w 
WASTEBASKET folder, 9-21 

Window 

y 

creating DECterm, 7-1 
customizing DECterm, 7-2 

Year display, 3-2 

z 
Zoom window, 11-18 
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How to Order Additional Documentation 

Technical Support 
If you need help deciding which documentation best meets your needs, call 800-343-4040 
before placing your electronic, telephone, or direct mail order. 

Electronic Orders 

To place an order at the Electronic Store, dial 800-DEC-DEMO (800-332-3366) using 
a 1200- or 2400-baud modem. If you need assistance using the Electronic Store, 
call 800-DIGITAL (800-344-4825). 

Telephone and Direct Mail Orders 

Your Location 

Continental USA, 
Alaska, or Hawaii 

Puerto Rico 

Canada 

International 

lnternal1 

Call 

800-DIGITAL 

809-754-7575 

800-267-6215 

Contact 

Digital Equipment Corporation 
P.O. Box CS2008 
Nashua, New Hampshire 03061 

Local DIGITAL subsidiary 

Digital Equipment of Canada 
Attn: DECdirect Operations KA02/2 
P.O. Box 13000 
100 Herzberg Road 
Kanata, Ontario, Canada K2K 2A6 

Local DIGITAL subsidiary or 
approved distributor 

SDC Order Processing - WMO/E15 
or 
Software Distribution Center 
Digital Equipment Corporation 
Westminster, Massachusetts 01473 

1 For internal orders, you must submit an Internal Software Order Form (EN-01740-07). 





Reader's Comments VMS DECwindows Desktop 
Applications Guide 

AA-MG19A-TE 

Please use this postage-paid form to comment on this manual. If you require a written 
reply to a software problem and are eligible to receive one under Software Performance 
Report (SPR) service, submit your comments on an SPR form. 

Thank you for your assistance. 

I rate this manual's: Excellent 

Accuracy (software works as manual says) D 
Completeness (enough information) D 
Clarity (easy to understand) D 
Organization (structure of subject matter) D 
Figures (useful) D 
Examples (useful) D 
Index (ability to find topic) D 
Page layout (easy to find information) D 

I would like to see more/less 

What I like best about this manual is 

What I like least about this manual is 

I found the following errors in this manual: 
Page Description 

Good 

D 
D 
D 
D 
D 
D 
D 
D 

Additional comments or suggestions to improve this manual: 

I am using Version ___ of the software this manual describes. 
Name/Title Dept. 

Company 

Mailing Address 

Phone 

Fair Poor 

D D 
D D 
D D 
D D 
D D 
D D 
D D 
D D 

Date 
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Report (SPR) service, submit your comments on an SPR form. 

Thank you for your assistance. 

I rate this manual's: Excellent 

Accuracy (software works as manual says) D 
Completeness (enough information) D 
Clarity (easy to understand) D 
Organization (structure of subject matter) D 
Figures (useful) D 
Examples (useful) D 
Index (ability to find topic) D 
Page layout (easy to find information) D 

I would like to see more/less 

What I like best about this manual is 

What I like least about this manual is 

I found the following errors in this manual: 
Page Description 

Good 

D 
D 
D 
D 
D 
D 
D 
D 

Additional comments or suggestions to improve this manual: 

I am using Version ___ of the software this manual describes. 
Name/Title Dept. 

Company 

Mailing Address 

Phone 

Fair Poor 

D D 
D D 
D D 
D D 
D D 
D D 
D D 
D D 

Date 
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