
AA-MG 198-TE 

VMS 
DECwindows Desktop Applications 
Guide 

October 1989 

This guide describes how to use DECwindows desktop applications under 
the VMS Version 5.3 operating system. 

Revision/Update Information: This is a revised manual. 

Software Version: VMS Version 5.3 

digital equipment corporation 
maynard, massachusetts 



October 1989 

The information in this document is subject to change without notice 
and should not be construed as a commitment by Digital Equipment 
Corporation. Digital Equipment Corporation assumes no responsibility 
for any errors that may appear in this document. 

The software described in this document is furnished under a license and 
may be used or copied only in accordance with the terms of such license. 

No responsibility is assumed for the use or reliability of software on 
equipment that is not supplied by Digital Equipment Corporation or its 
affiliated companies. 

Restricted Rights: Use, duplication, or disclosure by the U.S. 
Government is subject to restrictions as set forth in subparagraph 
(c)(l)(ii) of the Rights in Technical Data and Computer Software clause 
at DFARS 252.227-7013. 

©by Digital Equipment Corporation 1989. 

All Rights Reserved. 
Printed in U.S.A. 

The postpaid Reader's Comments forms at the end of this document 
request your critical evaluation to assist in preparing future 
documentation. 

The following are trademarks of Digital Equipment Corporation: 

CDA 
DDIF 
DEC 
DECnet 
DECUS 
DECwindows 
DECwriter 
DEQNA 
DIGITAL 
GIGI 

LiveLink 
LN03 
MASSBUS 
MicroVAX 
PrintServer 40 
Q-bus 
ReGIS 
ULTRIX 
UNIBUS 
VAX 

The following is a third-party trademark: 

VAXcluster 
VAX RMS 
VAXserver 
VAXstation 
VMS 
VT 
XUI 

PostScript is a registered trademark of Adobe Systems, Inc. 
ZK4729 

This document was prepared using VAX DOCUMENT, Version 1.1 



Contents 

About This Guide. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xiii 

1 Using the Bookreader 
Starting the Bookreader . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-1 
Opening Shelves and Books.............................. 1-2 

Selecting Topics from the Table of Contents . . . . . . . . . . . . . . . 1-3 
Selecting Topics from the Index . . . . . . . . . . . . . . . . . . . . . . . . 1-3 

Navigating the Table of Contents and Index . . . . . . . . . . . . . . . . . 1-4 
Reading Text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-5 

Displaying Figures, Tables, and Examples . . . . . . . . . . . . . . . . 1-5 
Using Cross-References and Footnotes . . . . . . . . . . . . . . . . . . . 1-5 

Customizing the Bookreader . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-6 
Closing Shelves and Books . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-6 
Exiting fr~m the Bookreader . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-6 

2 ·Using the CDA Viewer 
Starting the CDA Viewer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-1 
Viewing DDIF Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-2 
Closing a File . . . . . . . . . . . . . . . . . . . . . ; . . . . . . . . . . . . . . . . . . . 2-5 
Exiting from the CDA Viewer . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-5 

iii 



3 Using the Calculator 
Starting the Calculator . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-1 
Operating the Calculator . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-2 
Performing Arithmetic Functions . . . . . . . . . . . . . . . . . . . . . . . . . . 3""'.'5 
Storing Values in Memory . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-5 
Performing Special Functions . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-5 
Copying Text with the Calculator................. . . . . . . . . . 3-7 
Saving Customized Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-8 
Exiting from the Calculator . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-8 

4 Using the Calendar 
Starting the Calendar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-2 
Moving Around Calendar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-2 
Creating an Entry . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-3 

Changing the Size of a Timeslot. . . . . . . . . . . . . . . . . . . . . . . . 4-6 
Setting Alarms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-6 
Deleting an Entry . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-8 
Moving an Entry from One Timeslot to Another . . . . . . . . . . . 4-9 
Creating Overlapping Entries . . . . . . . . . . . . . . . . . . . . . . . . . 4-9 

Using the Clock in the Day Display . . . . . . . . . . . . . . . . . . . . . . . . 4-10 
Entering Day Notes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-10 
Marking Special Days . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-11 
Sending and Receiving Calendar Entries Through Mail . . . . . . . . 4-12 
Printing a Part of a Calendar . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-12 
Working with Multiple Calendars . . . . . . . . . . . . . . . . . . . . . . . . . 4-13 

Creating a New Calendar . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-13 
Opening an Existing Calendar . . . . . . . . . . . . . . . . . . . . . . . . . 4-14 
Renaming an Existing Calendar . . . . . . . . . . . . . . . . . . . . . . . 4-15 
Closing a Calendar ..................... · . . . . . . . . . . . . . 4-15 
Deleting a Calendar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-15 

Customizing a Calendar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-16 
Customizing General Features . . . . . . . . . . . . . . . . . . . . . . . . . 4-16 
Customizing the Day Display ................. ~ . . . . . . . . 4-19 
Customizing Calendar Icons . . . . . . . . . . . . . . . . . . . . . . . . . . 4-22 
Saving Customized Features . . . . . . . . . . . . . . . . . . . . . . . . . . 4-24 
Changing the Shape of a Display . . . . . . . . . . . . . . . . . . . . . . . 4-24 

Exiting from the Calendar........................ . . . . . . . 4-24 

Iv 



5 Using the Cardfiler 
Starting the Card:filer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-2 
Opening a Card File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-2 
Creating Cards . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-4 
Viewing the Contents of a Card File . . . . . . . . . . . . . . . . . . . . . . . 5-5 

Opening an Existing Card . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-5 
Scrolling Through a Card File . . . . . . . . . . . . . . . . . . . . . . . . . 5-6 
Finding Text . . . . . . . . . . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . 5-6 

Editing a Card . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-7 
Renaming a Card . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-7 
Moving the Text Cursor . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-8 
Selecting Text. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-8 
Deleting Text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-8 
Moving Text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-9 
Copying Text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-9 
Incorporating Images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-10 

Saving a Card File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-11 
Merging Card Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-13 

Saving Customized Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-13 
Exiting from the Card:filer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-14 

6 Using the Clock 
Starting the Clock . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-1 

Changing the Clock Display ..... ~ . . . . . . . . . . . . . . . . . . . . . · 6-2 
Setting the Alarm . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-3 

Exiting from the Clock . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-4 

7 Using DECterm 
Creating a DECterm Window. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7-1 
Customizing DECterm.................................. 7-2 

Customizing a DECterm Window....................... 7-3 
Customizing a Display . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7-5 
Customizing General Features............... . . . . . . . . . . 7-7 
Customizing a Keyboard . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7-14 
Choosing a National Replacement Character Set. . . . . . . . . . . 7-16 
Customizing Graphics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7-17 
Saving and Restoring Customized Features . . . . . . . . . . . . . . . 7-18 

Copying Information . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7-20 
Clearing and Resizing Terminal Windows . . . . . . . . . . . . . . . . . . . 7-21 
Composing Characters.................................. 7-22 
Exiting from DECterm . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7-23 

v 



8 Using EVE 
Beginning Your Editing Session . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-2 

Opening a File . . .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-4 
Entering Text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-5 
Moving the Cursor and Scrolling . . . . . . . . . . . . . . . . . . . . . . . 8-5 
Entering EVE Commands . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-6 
Getting Help . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-7 

Editing Text ......................... ·. . . . . . . . . . . . . . . . . 8-8 
Selecting Text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-8 
Moving Text to Another Location . . . . . . . . . . . . . . . . . . . . . . . 8-9 
Erasing and Restoring Text . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-10 

Searching for and Replacing Text. . . . . . . . . . . . . . .. . . . . . . . . . . . 8-10 
Replacing Strings of Text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-12 
Performing Case-Exact Searches . . . . . . . . . . . . . . . . . . . . . . . 8-13 
Handling Whitespace Characters . . . . . . . . . . . . . . . . . . . . . . . 8-13 
Searching with Wildcards ........................ : . . . 8-14 

Formatting Text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-15 
Setting Margins . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-16 
Filling Text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-16 
Setting the Paragraph Indent . . . . . . . . . . . . . . . . . . . . . . . . . 8-17 
Setting Tabs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-18 
Setting Soft Page Breaks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-19 

Saving Your Edits . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-20 
Buffer Change Journaling . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-21 
Viewing and Editing More Than One File . . . . . . . . . . . . . . . . . . . 8-22 

· Editing Another File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-23 
Moving Between Buffers ............. , . . . . . . . . . . . . . . . 8-23 
Deleting a Buffer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-24 
Viewing Multiple Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-24 

Defining Keys . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-25 
Setting the Gold Key . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-26 
Creating a Learn Sequence . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-27 
Setting the Keypad . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-27 
Saving Key Definitions in a Section File . . . . . . . . . . . . . . . . . 8-28 

Customizing EVE . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-29 
Customizing Menus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-30 
Setting Buffer Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-31 
Setting Global Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-33 
Setting Width . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-35 
Setting VAXTPU Preferences . . . . . . . . . . . . . . . . . . . . . . . . . . 8-35 
Using Initialization Files . . . . . . · . . . . . . . . . . . . . . . . . . . . . . . 8-38 
Using VAXTPU Procedures to Extend EVE . . . . . . . . . . . . . . . 8-40 
Saving Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8-41 

vi 



9 Using Mail 
Starting Mail ........................................ . 
Sending Messages .................................... . 

Sending a Message ................................. . 
Saving a Draft of a Message ......................... . 
Resuming Work on a Draft Message ................... . 
Including a File in a Message ........................ . 
Using an Existing File in a Message ................... . 
Sending a Message to a Distribution List ............... . 
Changing Editors .................................. . 

Selecting Messages ................................... . 
Reading Messages .................................... . 

Reading a New Message ............................ . 
Displaying a List of New Messages .................... . 
Reading an Old Message ............................ . 
Multiple Read Windows ............................. . 

Replying to Messages .................................. . 
Forwarding Messages .................................. . 
Printing Messages .................................... . 
Creating a File from a Mail Message ...................... . 
Deleting and Retrieving Messages ........................ . 
Working with Drawers and Folders ..................... , .. . 

Creating New Drawers .............................. . 
Creating New Folders .............................. . 
Modifying Drawer Names ............ · ............... . 
Deleting Drawers and Folders ........................ . 
Adding and Removing Drawers in the Index ............. . 
Moving and Copying Messages to Another Folder ......... . 
Updating Folders .................................. . 
Compressing Drawers .............................. . 

Marking and Unmarking Messages ....................... . 
Picking Messages ..................................... . 
Displaying Additional Index Information ................... . 
Opening a New Main Window ........................... . 
Sending and Receiving CDA Documents .................... . 
Customizing Your Mail Environment ...................... . 

Modifying Your Default Print Settings .................. . 
Customizing Your Mail Profile ........................ . 

Modifying Your User Attributes ............. ~ ... . 
Modifying Your Send Attributes ................. . 
Modifying Your Deliver Attributes ............... . 
Modifying Your Window Attributes .............. . 
Saving and Restoring Attributes ................ . 

Making Mail Perform Like the VMS Mail Utility ......... . 
Using a Paned Style Main Window .................... . 

9-1 
9-4 
9-4 
9-6 
9-7 
9-8 

9-10 
9-10 
9-12 
9-12 
9-13 
9-13 
9-15 
9-16. 
9-16 
9-17 
9-17 
9-18 
9-20 
9-22 
9-23 
9-23 
9-24 
9-24 
9-25 
9-26 
9-27 
9-29 
9-30 
9-30 
9-30 
9-33 
9-33 
9-34 
9-35 
9-35 
9-36 
9-37 
9-38 
9-40 
9-41 
9-41 
9-42 
9-42 

vii 



Changing Your Mail Directory . . . . . . . . . . . . . . . . . . . . . . . . . 9-44 
Changing Directories for Drafts and Distribution Lists . . . . . . 9-44 

Exiting from Mail. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9-45 
Using Accelerators . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9-45 

1 0 Using the Notepad Editor 
Starting the Notepad Editor ............................ . 
'fyping Text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 
Formatting Text ...................................... . 
Scrolling the Buffer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 
Editing a File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 

Moving the Cursor ..................... : ........... . 
Selecting Text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 
Deleting Text ..................................... . 
Canceling an Edit ................................. . 
Moving Text ...................................... . 
Copying Text ..................................... . 
Changing Your Font ................................ . 
Including an Existing File ........................... . 
Splitting the Screen ................................ . 

Saving Text in a File .................................. . 
Opening a Second Notepad ............................. . 
Opening an Existing File ............................... . 
Merging Files ........................................ . 

Copying Text from One Notepad Window to Another ....... . 
Searching for Text .................................... . 
Replacing Text ....................................... . 
Exiting from an Editing Session ......................... . 
Using Journal Files ................................... . 

10-1 
10-2 
10-2 
10-3 
10-3 
10-3 
10-4 
10-5 
10-5 
10-5 
lQ-6 
lQ-6 

10-7 
10-7 
10-8 
10-8 
10-9 

10-10 
10-10 
10-10 
10-11 
10-12 
10-12 

11 Using Paint 
Starting Paint . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-2 
Learning the Basics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-2 

Picking Out Tools.. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-5 
Inverting Images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-5 
Saving a Painting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-6 
Printing a Painting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-7 

Erasing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . • . . . . . . . . . . 11-7 
Drawing Lines and Shapes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-7 

Varying Line Width . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-10 
Using Patterns . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-11 
Creating Your Own Patterns . . . . . . . . . . . . . . . . . . . . . . . . . . 11-13 

viii 



Using the Paintbrush . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-15 
Editing Paintings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-16 

Selecting Images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-16 
Moving Images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-17 
Copying Images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-17 
Resizing Images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-18 
Cropping a Picture . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-19 
Working with Full Views . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-19 
Editing in Detail . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-20 

Inserting Text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-22 
Sizing the Canvas . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-23 
Using Accelerators ..... · . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-25 
Exiting from Paint . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-26 
Tool Summary . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11-26 

12 Puzzling 
Starting the Puzzle . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12-1 
Playing Around with the Puzzle . . . . . . . . . . . . . . . . . . . . . . . . . . . 12-2 
Starting a New Game . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12-2 
Exiting from the Puzzle . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12-2 

A Composing Characters 

B Keyboards 

Index 

Examples 

8-1 
8-2 

Sample EVE Initialization File ........................... . 
Sample VAXTPU Procedure .............................. . 

8-38 
8-40 

ix 



Figures 
1-1 
1-2 
7-1 
7-2 
7-3 
7-4 
11-1 
11-2 
11-3 
11-4 
11-5 
11-6 
B-1 
B-2 
B-3 
B-4 
B-5 
B-6 
B-7 
B-8 
B-9 
B-10 
B-11 
B-12 
B-13 
B-14 
B-15 
B-16 

Tables 
8-1 
8-2 
8-3 
9-1 

x 

Bookreader Library .................................... . 
Bookreader Selection and Topic Windows ................... . 
DEC Multinational Character Set, Part I ................... . 
DEC Multinational Character Set, Part II ................... . 
ISO Latin 1 Supplemental Character Set ................... . 
National Replacement Character Sets ...................... . 
The Clock Tower ...................................... . 
Tools for Lines and Shapes ............................... . 
Using a Grid ......................................... . 
Patterns Palette ....................................... . 
Examples of Patterns ................................... . 
Adding Text .......................................... . 
The North American Keyboard ......................... .' .. . 
The Flemish Keyboard .................................. . 
The Canadian (French) Keyboard ......................... . 
The British Keyboard .. ~ ................................ . 
The Danish Keyboard .................................. . 
The Finnish Keyboard .................................. . 
The Austrian/German Keyboard .......................... . 
The Dutch Keyboard ................................... . 
The Italian Keyboard ................................... . 
The Swiss (French) Keyboard ............................ . 
The Swiss (German) Keyboard ............................ . 
The Swedish Keyboard .................................. . 
The Norwegian Keyboard ................................ . 
The Belgian/French Keyboard ............................ . 
The Spanish Keyboard .................................. . 
The Portuguese Keyboard ............................... . 

EVE Commands for Buffer Change Journaling and Recovery .... . 
EVE Commands for Saving Attributes ...................... . 
EVE Commands for Saving Attributes ...................... . 
Using Accelerators ..................................... . 

1-2 
1-3 

7-10 
7-11 
7-12 
7-13 
11-4 
11-8 
11-9 

11-12 
11-13 
11-23 

B-3 
B-4 
B-5 
B-6 
B-7 
B-8 
B-9 

B-10 
B-11 
B-12 
B-13 
B-14 
B-15 
B-16 
B-17 
B-18 

8-21 
8-41 
8-42 
9-45 



A-1 Composing Characters in Multinational Character Mode . . . . . . . . A-2 
A-2 Composing Characters in National Replacement Mode Using 

fypewriter Keys . . . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . . . . A-6 
A-3 Composing Characters in National Replacement Mode Using Data 

Processing Keys . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . A-9 

xi 





About This Guide· 

Purpose of This Guide 
This guide describes how to use the VMS DECwindows desktop 
applications. 

Who Should Use This Guide 
This manual is intended for all VMS DECwindows users. 

Structure of This Guide 
This guide covers the following topics: 

• Chapter 1 describes how to use the Bookreader. 

• Chapter 2 describes how to use the CDA Viewer. 

• Chapter 3 describes how to use the Calculator. 

• Chapter 4 describes how to use the Calendar. 

• Chapter 5 describes how to use the Card.filer. 

• Chapter 6 describes how to use the Clock. 

• Chapter 7 describes how to use DECterm. 

• Chapter 8 describes how to use the Extensible VAX Editor 
(EVE). 

• Chapter 9 describes how to use Mail. 

• Chapter 10 describes how to use the Notepad editor. 

• Chapter 11 describes how to use Paint. 

• Chapter 12 describes how to use the Puzzle. 

xiii 



• Appendix A describes how to compose characters. 

• Appendix B illustrates keyboards that correspond to the 
National Replacement Character Sets. 

For More Information 

Conventions 

mouse 

MBl, MB2, and MB3 

xiv 

Although VMS DECwindows users need not be familiar with 
the VMS operating system or DCL, they can increase their 
understanding of DECwindows by becoming familiar with some 
of the topics addressed in the VMS User's Manual. For more 
information about using DECwindows, users should see the VMS 
DECwindows User's Guide, which explains basic DECwindows 
tools and covers such topics as File View, the Session Manager, 
how to print files, and running remote applications. 

Other associated documents for specific applications are as follows: 

• DECterm: 

DECterm Text Programming Manual 
DECterm Graphics Programming Manual 

• CDA Viewer and Mail: 

CDA Reference Manual 

• EVE: 

VAX Text Processing Utility Manual 
Guide to VMS Text Processing 

• Mail: 

VMS Mail Utility Manual 

Refers to any pointing device, such as a mouse, a puck, or a stylus. 

MB 1 indicates the left mouse button. MB2 indicates -the middle 
mouse button. MB3 indicates the right mouse button. (The buttons 
can be redefined by the user.) 

In procedures, a sequence such as ICtrl/xl indicates that you must hold 
down the key labeled Ctr! while you press another key or a pointing 
device button. 

In procedures, a sequence such as IPFl I~ indicates that you must first 
press and release the key labeled PFl, then press and release another 
key or a pointing device button. 



blue-green ink 

boldface text 

In procedures, a key name is shown enclosed to indicate that you 
press a key on the keyboard. 

Blue-green ink indicates information that you must enter from the 
keyboard or a screen object that you must choose or click on. For 
online versions, user input is shown in bold. 

Boldface text represents the introduction of a new term. 

xv 









1 
Using the Bookreader 

The Bookreader lets you read online documentation on your 
workstation screen. 

This chapter describes how to 

• Start the Bookreader 

• Open shelves and books 

• Navigate the table of contents and index 

• Read text ·and display figures, tables, and examples 

• Exit from the Bookreader 

Starting the Bookreader 
To start the Bookreader, choose Bookreader from File View's 
Applications menu. 

The selection window opens, listing the library of shelves and 
books available from the Bookreader, as illustrated in Figure 1-1. 
Each title has an icon to the left of it to indicate whether it is a 
book or a shelf. 

Shelves contain groups of related books to make the process of 
locating the book you want simpler. To view a book that is on a 
shelf, you must first open that shelf. 
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Figure 1-1 Bookreader Library 
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Opening Shelves and Books 
To select a title, position the pointer on the desired title and click 
mouse button 1 (MBl). To open a shelf or book, select the title you 
want and choose Open Shelf or Open Book from the Control menu. 
Alternatively, you can double click MB 1 on a title to select and 
open that book or shelf. If you open a shelf, a list of the books on 
that shelf appears in the selection window. If you open a book, the 
table of contents for that book appears in the selection window. 
The title page for the book appears in a second window, called 
the topic window. The two windows, selection window and topic 
window, are illustrated in Figure 1-2. 
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Figure 1-2 Bookreader Selection and Topic Windows 

l•I Bookreacler IQlliL 11111 Usl'!9_ the Bookreader llJ!lil 
Control View He!I!_ Control View Hel~ 

Usin_g_ the Bookreader Using the Bookreader 
CONTENTS 6 6 ,... 
1 The Bookreader 

,..., 
Copyright © 1989 Digital Equipment Corporation 

1.1 Starting the Bookreader 
1.2 Opening Shelves and Books 

All Rights Reserved. 

1.2.1 Selecting Topics from the Table of 
Contents 

1.2.2 Selecting Topics from the Index 
1.3 Navigating the Table of 

Contents and Index Using the Bookreader 
1.4 Reading Text 
1.4.1 Displaying Figures, Tables, and 

Examples 
1.4.2 Using Cross-References and 

Footnotes 

October 1989 
This document describes how to use the Bookreader 
to read online documentation. 

1.5 Closing Shelves and Books Q 

¢ L JI) Software Version: VMS Version 5.3 

I Close Book 11 Library II Index I 

.... 
Q 

¢[ JI) 

I Go Back 11 Pre\'iOU$ Topic 11 Next Topic II More I 
ZK-0585A-GE 

. Selecting Topics from the Table of Contents 
You can display a chapter or section from the table of contents' by 
selecting the title and choosing Topic from the View menu. Or, 
you can point to the title you want and double click MBl. The 
text appears in the topic window. 

You can also display lists of figures, tables and exam pl es by 
choosing the appropriate menu item from the View menu. 
Pointing to a title and double clicking MBl causes the desired 
figure, table or example to be displayed in the topic window. 

Selecting Topics from the Index 
To view the index, choose Index from the View menu or click 
on the Index button at the bottom of the selection window. The 
index replaces the table of contents in the selection window. (To 
return to the table of contents, choose Table of Contents from the 
View menu or click on the Contents button at the bottom of the 
selection window.) 

To view the section that corresponds to an index entry, select 
the entry from the index and choose Topic from the View menu. 
Alternatively, you can double click on the desired entry. The text 
appears in the topic window. 
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If an entry applies to more than one section, the Bookreader 
displays a list box containing all the sections in which the entry 
appears. Double click on the section you want to view. 

Navigating the Table of Contents and Index 

0 

~ 
For easy navigation of the table of contents and index, use the 
vertical scroll bar on the selection window. The vertical scroll 
bar represents the entire table of contents or index. The slider 
represents: 

• The position in the table of contents or index relative to the 
entire table of contents or index 

• The relative portion of the table of contents or index that 
appears in the selection window 

There are several ways to use the scroll bar to navigate: 

• You can drag the scroll bar with MBl to navigate quickly up 
or down the table of contents or index. For example, if you 
drag the slider to. the bottom of the scroll bar and release 
MB 1, the end of the table of contents or index appears in the 
selection window. 
As you drag the slider, an index window displays the entries 
represented by that region of the scroll bar. Release MBl to 
bring that region into the selection window. 

• You can click MBl on the area above or below the slider to 
bring the previous or next window of entries into the selection 
window. 
For example, if you are looking at the table of contents entries 
for Chapter 2 and click MBl in the area above the scroll bar, 
the immediately preceding window of entries for Chapter 1 
will scroll into the window. 

• You can click on the stepping arrows to move one entry at a 
time up or down through the table of contents or index. 
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Reading Text 

_o,,...,.... __ 

Uolng the Bookrellder 

When you select a text topic from the table of contents or index, 
it is displayed in the topic window. You can read forward and 
backward from that topic by clicking on the Next Topic and 
Previous Topic buttons at the bottom of the topic window, or by 
choosing the corresponding menu items from the View menu. 

The Go Back button and the corresponding Go Back menu item 
on the View menu enable you to go back to the last section you 
selected. This is helpful if you opened entries from the Table of 
Contents or Index, or followed a hotspot reference. 

The length of some topics is greater than the length of the window. 
Use the scroll bar, as in the selection window, to navigate up and 
down the topic. For example, click MB2 on the scroll bar to bring 
the line of text directly across from the pointer to the top of the 
topic window. 

The More Button and the corresponding More menu item on the 
View menu scroll the current topic to the next windowful of text. 
If the end of the current topic is already visible, it causes the next 
topic to be opened. 

Displaying Figures, Tables, and Examples 
When you select a topic that is a figure, table, or example from 
the table of contents, it is displayed in a separate window. The 
window is sized according to the dimensions of that topic. If 
the topic is large-for example, if its dimensions exceed the 
dimensions of the screen-the window will have scroll bars to 
navigate the topic. 

The windows in which figures, tables, and examples are displayed 
must be explicitly closed by clicking on the Close Topic button or 
by choosing Close Topic from the Control menu. These windows 
can also be made into icons, allowing you to save a topic for as 
long as you need to refer to it. 

Using Cross-References and Footnotes 
Cross-references in text to figures, tables, and examples are 
"hotspots." That is, if you point at the reference and click MBl, 
the figure, table, or example is displayed in a separate window. 
For example, clicking on Figure 1-1 on the screen produces a 
display of that figure. 
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Cross-references to other sections of text are similarly hot, except 
that the cross-referenced topic replaces the current topic in the 
topic window. For example, clicking on Chapter 1 on the screen 
causes that chapter to appear in the topic window. Footnotes are 
also hotspots. 

Customizing the Bookreader 
You can cause hotspots, which are normally highlighted only when 
you point to them, to be continuously highlighted by choosing Hot 
Spot from the topic window's View menu. A shaded toggle button 
to the left of the Hot Spot menu item on th~ View menu indicates 
that continuous highlighting of hotspots is enabled. 

By default, extensions to languages (such as nonstandard 
language constructs) are highlighted in the Bookreader. To disable 
this highlighting, choose Extensions from the View menu. When 
a shaded toggle button appears to the left of the Extensions 
menu item on the View menu, highlighting is enabled. When no 
toggle button appears to the left of Extensions on the View menu, 
language-extension highlighting is disabled. 

Closing Shelves and Books 
To close a book or shelf, click on the Close Book, Close Shelf, or 
Library button at the bottom of the selection window .. Clicking on 
the Close Book button takes you back to the shelf from which that 
book was selected. Similarly, clicking on the Close Shelf button 
takes you back to the windpw from which that shelf was selected. 
When you are viewing a shelf, clicking on the Library button 
takes you back to the "top shelf," or in other words, the top level 
of the Bookreader library. 

Exiting from the Bookreader 
To exit from the Bookreader, click on the Quit button while 
viewing the library, or select Quit from the Control menu in the 
selection window. 
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2 
Using the CDA Viewer 

The CDA Viewer lets you view DDIF (Digital Document 
Interchange Format) files. DDIF is a standard format for the 
storage and interchange of compound documents. Compound 
documents contain multiple elements, for example, text and 
graphics. DDIF files cannot be viewed as ordinary text files. 

The CDA Viewer displays only DDIF files. If you specify a file 
that is not a DDIF file, such as a text (ASCII) file, the file is 
converted to DDIF before it is displayed. 

This chapter describes how to 

• Start the CDA Viewer 

• Display DDIF files 

• Change processing options 

• Exit from the CDA Viewer 

Starting the CDA Viewer 
To start the CDA Viewer and view a file, choose CDA Viewer from 
File View's Applications menu. 

The CDA Viewer displays its main window, which is where you 
view DDIF files. 
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Viewing DDIF Files 

I open ... 
Document Information ... 
Diagnostic Information ... ............................. 
Close File 
Quit 

To view a DDIF file in the CDA Viewer window, you must open it. 
To open a DDIF file: 

1 Choose Open... from the File menu. 
The Viewer displays a dialog box that prompts you for the 
name of the file you want to view. The file list box lists the 
names of any files that have the file type DDIF in the current 
directory. 
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2 Click on the format of the file you want to view. 
DDIF is the default choice. If you want to specify a format 
that is not listed but for which your system has a front-end 
converter, type in that format. 

3 Optionally, click on the Options File... button to display the 
Options File dialog box. Enter the name of a file containing 
the processing options to be applied as your file is loaded for 
viewing. 
If you do not specify an options file, default. processing options 
are used. See the CDA Reference Manual for more information 
about using an options file if you want more control over the 
format of the file displayed. , 

4 Optionally, click on the Paper Size... button to display the 
Paper Size dialog box, which allows you to specify a paper size 
to be used when formatting the document. 
You can select a paper size from the available list or supply 
your own values, and then click on the Characters1 , Inches, 

1 The Characters unit corresponds to the size of a character in the 12-point Courier font, 
which is the CDA Viewer's default font and which is also very close to the standard font 
used by most printers. In 12-point Courier, and in the character unit as interpreted by the 
CDA Viewer, there are 10 columns per inch (0.1 inch per character horizontally) and 6 rows 
per inch (0.167 inch per character vertically). 

Using the CDA Viewer 2-3 



or mm (millimeter) option to display your page size in the 
desired unit. When you click on a particular option, the values 
are converted to that unit. 
The paper size you specify is used only when the document 
has no inherent format (page size), or if you choose to override 
the document's format. Click on the Override Document 
Format if you want to override the existing format with your 
own. 
The processing options, paper size, and override format choice 
apply only to the next file you open. They do not immediately 
change the appearance of the document currently displayed. 

5 Double click on the name of the file you want to view. 
The CDA Viewer displays the file you specified. 

If you want to view a file that is not listed, type the name of that 
file in the Open File text field and click· on the OK button. Or, 
use the File Filter text entry field to list a subset of files from 
which you can then select. For example, to list all files in another 
directory with the file type DDIF, type the complete directory 
specification-[JONES.PROJECT]* .DD IF-in the File Filter text 
entry field and click on the Filter button. Then double click on the 
name of the file you want to view. 

The CDA Viewer displays the contents of the file you specified. 
The title bar contains the name of the file currently being viewed. 
To move through the document you are viewing, you can· click 
on the inner aµow buttons at the bottom of the window to move 
forward or backward one page, or on the outer arrow buttons 
to move to the beginning or end of the document. You can also 
specify a page number by clicking on the Page... button and 
entering the desired page number in the Page dialog box. 

To display information about the file you are currently viewing, 
choose Document Information... from the File menu. The CDA 
Viewer displays the product name, title, author, version, and date 
the file was created. 

To display diagnostic information about the file you are viewing, 
such as warnings and errors that occurred while you were 
formatting the file, choose Diagnostic Information... from the File 
menu. 
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Closing a File 
When you have finished viewing a file, close it by choosing the 
Close File menu item from the File menu. This keeps the CDA 
Viewer active for you to open another file. If you open another 
file without closing the current one, the CDA Viewer closes the 
current file before opening the next one. 

Exiting from the CDA Viewer 
To exit from the CDA Viewer, choose Quit from the File menu. If 
you did not close the last file you viewed, the CDA Viewer closes it 
before exiting. 
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3 
Using the Calculator 

The Calculator performs simple arithmetic functions-addition, 
subtraction, multiplication, division-and computes percentages 
and square roots. In addition, it also performs trigonometric and 
inverse trigonometric functions, generates random numbers, and 
performs other more advanced operations. 

Unlike a hand.held calculator, the Calculator has two displays. 
The top display is the accumulator, which shows the number 
being entered or the current result, and the bottom display is the 
memory. 

This chapter describes how to 

• Start the Calculator 

• Enter data 

• Perform arithmetic functions 

• Use the memory 

• Transfer data to or from other applications 

• Exit from the Calculator 

Starting the Calculator 
To start the Calculator, choose Calculator from File View's 
Applications menu. 

The Calculator is displayed on your screen. You can move and 
change the size of the Calculator window as you wish. 
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Operating the Calculator 
You can use Calculator with either the mouse or the keyboard. 

With the mouse, point to the appropriate button and click MBl. 

From the keyboard, enter the numbers 0 to 9 from the main 
keyboard or the keypad. Press the Shift key to enter the 
arithmetic functions(+,-,*, I,%,=) from the main keyboard. 
From the keyboard and keypad respectively, pressing the following 
keys produces the corresponding functions: 

Press from 
Keyboard 

* 
I 

+/­

% 

Do 

I 
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Press from 
Keypad 

PFl 
PF2 
PF3 
PF4 

Enter 

Fl 
F2 

F3 

To Produce 

* 
I 

+/-

% 

+ 

Clear 

Clear Entry 

Inv 



Press from Press from 
Keyboard Keypad ·ro Produce 

s F4 sin 

0 F5 cos (or arccosine if Inverse is 
on) 

T F6 tan (or arctangent if Inverse is 
on) 

LO F7 log (or 10 to x if Inverse is on) 

LN FS ln (ore to x if Inverse is on) 

Q F9 square root 
A FlO yAx (or y to the 1/x if Inverse is 

on) 

D Fll deg 

F12 x! 

F13 1/x 

R F14 Rnd 

MC F17 MC 

MR F18 MR 

M+ F19 M+ 

M- F20 M-

p PI 
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Accumulator 

Memory 
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of Accumulator 
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Replace Contents 
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of Accumulator 
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When you enter data into the accumulator, notice that Calculator 
uses a decimal point to distinguish between entered digits and an 
operand. See what happens as you enter the following data: 

Enter 1134 and notice that no decimal point appears in the 
accumulator. 

2 Enter a plus sign ( + ). Calculator inserts a decimal point after 
the digits 1134 to signify the completion of an operand. 

Depending on the contents of the accumulator, you can use one of 
the following methods to correct mistakes in computation: 

-• Press the <XI (Delete) key to erase the last digits entered in 
the accumulator. 

• Click on the CE button to void the last operand entered. 

• Choose Undo from the Edit menu to reverse the last operation, 
for example, to restore the last operand or to remove the 
previous paste operation. 
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Performing Arithmetic Functions 
Calculator displays numbers in the range of plus or minus 
999,999,999,999,999. It performs all calculations in left to right 
order and treats operators with equal importance. 

For example, to evaluate the equation 6 + 5 * 3: 

Find the sum of 6 + 5. 
Calculator displays an 11. 

2 Figure the product of 11 * 3. 
The result is 33. 

Also note the way Calculator computes percentages. For example, 
to determine 6 percent of 195: 

Enter 195. 

Calculator displays the digits in the accumulator. 

2 Enter * and Calculator inserts a decimal point. 

3 Enter 6. 
The number 6 is displayed in the accumulator. 

4 Enter%. 
The result, 11. 7, is displayed in the accumulator. 

Storing Values in Memory 
Use the memory display to store results and values for later 
computation. The figure in memory starts out as zero. You can 
add the contents of the accumulator to memory or subtract the 
contents of the accumulator from memory, using the M+ and 
M- buttons, respectively. To enter the contents of memory into 
the accumulator, click on the MR button. Clear the contents of 
memory with the MC button. 

Performing Special Functions 
Calculator performs trigonometric and inverse trigonometric 
functions, as well as other special functions. 
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The special-function keys are as follows: 

Key 

deg 

x! 

1/x 

Rnd 

Inv 

sin 

cos 

tan 

log 

In 

square 
root 

y"x 
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Description 

Degree key. Selects the units for angular measurement. By 
default, Calculator is in degree mode. Clicking on the deg key 
once places Calculator in the radian mode, which is indicated 
by the key label changing to "rad." Clicking on the key again 
places Calculator in gradian mode, which is indicated by the 
key label changing to "grad." The angular mode has no effect 
on Calculator unless the trigonometric functions are being 
used. 

Factorial key. Calculates the factorial (z)(z - l)(z - 2) ... (2)(1) 
of the value x in the display for integers O~z~l7.0! = 1 by 
definition. 

Reciprocal key. Divides the displayed value x into 1, if x is 
not 0. 

Random number generator key. Generates a random number 
between 1 and the integer of the display. It does not generate 
negative numbers or numbers less than 1. 

Inversion key. By default, Calculator performs noninverted 
trigonometric functions. When you activate the inversion 
key by clicking on it (which is indicated by the key becoming 
darkened), Calculator performs inverted trigonometric, log,. 
and exponent functions. 

Sine key. Instructs Calculator to find the sine (or arcsine if 
Inverse is on) of the displayed value. 

Cosine key. Instructs Calculator to find the cosine (or 
arccosine if Inverse is on) of the displayed value. 

Tangent key. Instructs Calculator to find the tangent (or 
arctangent if Inverse is on) of the displayed value. 

Common logarithm key. Calculates the common logarithm 
(base 10) of the number x in the display, if x is greater than 0. 
If Inverse is on, calculates 10 to x. 

Natural logarithm key. Calculates the natural logarithm (base 
e) of the number x in the display, if x is greater than 0. If 
Inverse is on, calculates e to x. 

Square root key. Calculates the square root of the number 
x (or y to the minus x if Inverse is on) in the display. The x 
value cannot be negative. 

y to the xth power key. Raises the displayed value y to the xth 
power (or y to the 1/x power if Inverse is on). Order of entry is 
y y"x x. The y value cannot be negative, but both x and y can 
be fractionals. 



• 
Copying Text with the Calculator 

UndoAlt/Z 

CopyAlt/C 

PasteAlt/V 

You can copy numbers from other applications into the 
Calculator's accumulator and from the Calculator accumulator or 
memory into another application. 

Use Copy from the Edit menu to transfer data from the active 
display in the Calculator window to another application window. 
For example: 

1 Click on the accumulator display. 

2 Enter a number into the accumulator. 

3 Choose Copy from the Edit menu. Or, for greater speed, press 
and hold MB2 to display a pop-up menu and choose the Copy 
menu item. 

Now you can paste the data to another application window. 

Use Paste from the Edit menu to copy data from another 
application. This data can be copied directly from another 
window, or it can be the result of an equation copied from another 
window. Calculator treats the contents of a paste operation just 
as if you typed in the data from the keyboard yourself. 

mJ Calculator ~Ifill 

File Edit Help 

99537.6 

••1111 11.71 
[M£][Mfil[M±]00 

l~WOO~I 
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Saving Customized Settings 
If you change the screen placement and size of the Calculator 
during your session and would like to save those settings, choose 
Save Geometry from the Exit menu. The next time you start 
Calculator, it will have the size and placement you specified. 

To restore the default size and placement of the Calculator, choose 
Restore Default from the File menu. 

Exiting from the Calculator 
To exit from the Calculator, choose Quit from the File menu. 
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4 
U~ing the Calendar 

The Calendar combines the functions of a desktop calendar and 
an appointment book to help you keep track of your meetings and 
plan your time. The Calendar enables you to look at a year or 
month display, or to review your scheduled appointments a day at 
a time. 

You can also create several different calendars to use for specific 
purposes. For example, you could create one calendar to keep 
track of your personal engagements, and another calendar to 
schedule conference room reservations. 

This chapter describes how to 

• Move around Calendar 

• Create and delete entries 

• Enter day notes 

• Set alarms and repeat entries 

• Move entries 

• Use Calendar's clock 

• Mark special days 

• Print part of a calendar 

• Work with multiple calendars 

• Create multiple entries 

• Create, rename, and delete a calendar 

• Send and receive Calendar entries through Mail 
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• Customize a calendar 

• Exit from Calendar 

Starting the Calendar 
To start the Calendar, choose Calendar from File View's 
Applications menu. 

The month display appears on your screen. 

Ifill Cslendar T2.0:DISK$[JONES]DECW$CALENDAR FILE.ct!lii] 

File Edit View Customize He!Q_ 
.0 

April, 1990 

Wk Sun Mon Tue Wed Thu Fri Sat 

14 1 2 3 4 5 6 7 

15 8 9 10 11 12 13 14 
16 15 16 17 18. 20 21 

17 22 23 24 25 26 27 28 .... 
18 29 30 1-1 

" 1 2 3 4 5 
0 
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The month display shows the current month and year, with the 
days in the month arranged in weekly rows. The current day has 
a box around it. 

Moving Around Calendar 

0 

~ 
Calendar has three main displays: the month display, the day 
display, and the year display. The year display looks like 12 small 
month displays set out in a 4 by 3 matrix. 

Scroll bars allow you to move backwards and forwards within a 
display, for example, to look at a future or a previous month when 
you are in a month display. 

To move from one type of display to another, double click on the 
appropriate item in the current display. For example, double 
clicking on one of the days visible in the month display opens the 
day display. Alternatively, double clicking on a month name in the 
year display opens the display for that month. 

From the View menu, you can choose the Selected, Today, Day, 
Month, and Year menu items. Choosing Today displays the 
current day. To choose Selected, Day, Month, and Year, you must 
first select a day. 
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Creating an Entry 
By double clicking on a particular day, you can open a display 
that shows timeslots for that day. Use the scroll bars to display 
timeslots earlier or later than the times shown. You can type 
entries, such as appointments, directly into the timeslots. Or, by 
using the entry editor, you can type longer entries, set alarms 
to remind yourself of appointments, and broadcast appointment 
reminders to yourself at designated intervals. 

To record a short entry directly into a day display: 

Display the day in which you want to make the entry. 

l!ill Calendar T2.0:WORK:[JONES]ANNA KLEIN CALDWC lb!jlfil] 
File Edit View En!!Y_ customize Help 

April, 1990 May, 1990 
Wk Sun Mon Tue Woo Thu Fri Sat Wk Sun Mon Tue Woo Thu Fri Sat 
14 1 2 3 4 5 6 7 18 1 2 3 4 5 
15 8 9 10 11 12 13 14 19 6 7 8 9 10 11 12 
16 15 16 11 18 m 20 21 20 13 14 15 16 17 18 19 
17 22 23 24 25 26 27 28 21 20 21 22 23 24 25 26 
18 29 30 22 27 28 29 30 31 

l<i[ i>I 
Thursday the 19th of April, 1990 

I /I I 
8:00arn 0 

-30- Breakfast meeting with accountants n~ 
9:00 

-30- ~ 10:00 ~ -30-
11:00 Leave for Heathrow - 12:05 night ~ -30-
12:00...J!.m 
-30-
1:00 
-30- ~\ 

2:00 
-30-

~ ~ 3:00 Meet with Mireille, Rue Ste. Germaine; bring receipts. n~ ~ ~ 4:30 
5:00 ... ~ 
-30- 0 

I Previous Day I 12:21pm I I Next Day I 
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2 Click (and drag to resize, if necessary) on the desired timeslot 
in the day display. 

3 Enter the text in the timeslot. 

4 Click on the timeslot again. 
When a day has at least one entry in it, its day number 
changes from a normal font (nn) to an italic font (nn) 
wherever it is displayed. You can then distinguish between 
days containing appointments and free days in the month and 
year displays. 

To create a longer entry using the entry editor: 

1 Click on the desired timeslot in the day display. 

2 Choose Edit... from the Entry menu or double click on the 
desired timeslot. 
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To use Edit ... you must first select the entry. 
The entry editor is displayed. 



Entry Editor [!i]~ 
File Edit Help 

Thursday the 19th of April, 1990 
From: 8:30am To: 9:00am 
\I I Breakfast meeting with accountants 

;Q, At Entry Time 

;Q, 0 Fri 19th Apr 6:30 

5 

Minutes 

;Q,• 8:25pm ;Q,o s:sopm 

;Q,o Fri 19th Apr s:so 

~ H ~ ~ ~ ~ 8 ~ / I 
•II+$ i ! ? ~i::i o 
Repeat I None ..... I _on_t_h_e _19t_h ______ _. 

D But. Itta Non-Work Day I ...... ~_th_en_S_-k_.ip ____ _. 

Ill Flag Day 

OK I I Delete Entry I I Reset I I cancel 

0 .-

'-
Q 
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3 Enter the text and adjust the alarms and repeat intervals as 
required (see the section Setting Alarms). 
The entry editor uses standard VMS DECwindows editing 
commands. 

4 Click on any icon that you want to associate with your entry. 
These icons are symbols that act as a remJnder for the 
contents of the entry. Calendar attaches no particular 
meaning to them. 
The icons you select will appear in the handle of your entry. 
The handle is the area in an entry between the timeslot and 
the vertical resize bar. 
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5 Click on the OK button to confirm the entry and to dismiss 
the entry editor. 

If you exit from the editor without having entered any text or if 
you delete all the text describing a previous entry, the timeslot 
remains unscheduled. 

Changing the Size of a Timeslot 
To enlarge or reduce a timeslot, press MB 1 on the resize bar and 
drag the top edge of the timeslot up, or the bottom edge of the 
timeslot down. The timeslot is redrawn to the new size. 

If you reduce the size of a timeslot, some text may no longer fit 
in the display, but it is not lost. The text reappears if you expand 
the timeslot again. 

Settir-g Alarms 
By default, when you type an appointment entry in the entry 
editor,. alarms ring and a message is displayed 5 minutes before 
the appointment and at the time of the appointment. You can 
disable these options by clicking on them. 

You can set alarms to ring at any combination of the following 
times: 

• At the time of the scheduled appointment (this is on by 
default) 

• 1 to 15 minutes befote the time you specified for the entry 
(this is on by default, with 5 minutes as the preset option) 

• 1 to 60 minutes before the time you specified for the entry 

• 1 to 24 hours before the time you specified for the entry 

• 1to14 days in advance 

To set one or more alarms: 

1 Click on the desired timeslot in the day display. 

2 Choose Edit ... from the Entry menu. The entry editor is 
displayed. 

3 Write the entry if you have not already done so. 

4 Click on the bell of the alarm you wish to set. 
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This makes it possible for you to set the alarm by clicking on 
its corresponding toggle button. Clicking on a toggle button 
causes the Days scale to adjust to provide the correct intervals 
for the alarm being set. 



Unless you specify otherwise, alarms ring 5 minutes before 
the entry time and at the entry time. 

5 Move the arrow in the scale to adjust to the time you want. 

6 Click on the OK button to save the settings and to dismiss the 
entry editor. 

You can also set alarms to ring at any of the following times 
by displaying the Repeat option menu and choosing the desired 
option from the following list: 

Daily 
Weekly 
Every two weeks 
Every four weeks 
Monthly 
Every two months 
Every three months 
Every four months 
Every six months 
Annually 

Once you choose an option, you can further customize when the 
alarm will ring. By enabling the But option and displaying the 
corresponding option menus, you can cause the alarms to skip 
or move forward or backward according to whether the day in 
question is a work day. 

If you change or delete an entry that is repeated, a dialog box is 
displayed, asking if you want to make the change or deletion in 
just this instance, from this point on, or every time, including past 
instances. 

You can also modify the default intervals for all alarms by 
choosing Alarms... from the Customize menu and making the 
desired changes in the Alarms dialog box. 
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II At Entry Time 

5 

II ffi 
Minutes Before 

30 
~ [" ......................................... ltf ............................................... i 

Minutes Before 

2.0 

1.0 

Days Before 

II OK II I Apply I I Reset I I eanceif 
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By clicking on the appropriate bell and moving the slide in the 
scale, you can set alarms up to 14 days in advance and adjust 
the number of minutes and hours alarms will ring before an 
entry. If you change the defaults, you can save them for future 
Calendar sessions by choosing Save Settings from the Customize 
menu. Choosing Restore Settings causes Calendar to revert to the 
previous settings; Use Defaults causes Calendar to revert to the 
system defaults. 

Deleting an Entry 
To remove or clear the contents of a timeslot: 

Click on the timeslot in the day display that contains the 
entry you want to delete. 

2 Choose Edit... from the Entry menu. The entry editor is 
displayed. 

3 Click on the Delete Entry button. 
A dialog box is displayed, asking you to confirm that you want 
to delete the entry. 

4 Click on Yes to confirm that you want to delete the entry. 
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Cut 

Copy 

Paste 

Clear 

Select All 

Mark H 

Moving an Entry from One Timeslot to Another 
You can copy or move the entire contents of an entry, or just a 
piece of text, to another timeslot. If you select the time, then 
any alarms or repeat intervals associated with the entry are 
transferred, along with the text, to the new timeslot. Selecting 
just the text from the timeslot transfers just the text. 

To move an entry from one timeslot to another: 

1 Display the day that has the timeslot you want to move. 

2 To select the entire entry from a timeslot, click on the handle. 
By pressing and dragging MBl in the handle, you can move 
an entry up and down through the day display to the desired 
timeslot. 
To copy just a piece of an entry, select it by pressing and 
dragging the pointer over· the portion of the entry you want. 

3 Choose Cut or Copy from the Edit menu. 
If you want the entry to remain in the original ti_meslot, 
choose the Copy menu item. If you want to delete the entry 
from the original timeslot, use the Cut menu item. 

4 If you are moving the entry to a different day, display the new 
day. 

5 Click on the time to which you want to move or copy the entry 
or text. 

6 Choose Paste from the Edit menu to insert the entry or text in 
the new location. 

If you are moving the whole entry (time and text) and ·you want 
to move it to the same time on a different day, you do not have to 
display the new day. After selecting the desired day in the month 
or year display, choose the Paste menu item from the Edit menu. 
This causes the entry to be inserted on that day, at the same time. 

Creating Overlapping Entries 
You can create an entry in a timeslot partially or completely 
occupied by an existing entry by clicking or pressing MBl and 
dragging on the timeslot. Calendar opens a new entry for you at 
the specified time. You can overlap as many entries as you like. 

Normally, overlapping entries are stacked so that the left side of 
each entry is always visible. 
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To cause Calendar to stack overlapping entries so that the first 
line of each entry is visible, choose Day View... from the Customize 
menu to display the Day View dialog box. Then choose Show Text 
from the Stacking option menu. With Show Text enabled, even if 
you have two entries starting at the same time, Calendar leaves a 
gap to display at least some of the text associated with the hidden 
entry. 

Clicking on the handle of an entry that is, overlapped makes it pop 
to the front. 

Using the Clock in the Day Display 

12:21pm I The clock provides a digital display of the current time. When 
you click MB 1 on the clock, the day display returns to the current 
day if you have been displaying a different day. Clicking on 
the clock also causes the timeslots visible in the day display to 
adjust so that the first timeslot contains the time in the current 
increment that directly precedes the actual time. For example, if 
the timeslots in the day display are set to be in half-hour intervals 
and you click on the clock at 10:57, the day display will adjust so 
that the first timeslot contains the time 10:30. 

This adjustment is continuous; as a timeslot passes, it is scrolled 
off the top of the display. Thus the display is kept as current as 
possible. This is convenient if you significantly reduce the size of 
the day display, because it keeps the most immediate timeslots in 
view. 

To stop this automatic scrolling, move the timeslot by any other 
method, such as adjusting the scroll bar. 

If you are making an entry in a timeslot when it is due to be 
scrolled, it does not disappear. The scroll mechanism waits until 
the next interval is over and then catches up. 

The Show AM/PM customizing option allows you to choose 
between a 12-hour and 24-hour clock. Whichever clock you choose 
is reflected by all times and clocks displayed by Calendar. 

Entering Day Notes 
Information that is specific to a particular day, but not to a 
particular time, can be entered in a day note. Day notes are 
identical to ordinary Calendar entries, except that they are not 
associated with a particular time. They are useful for denoting 
occasions like birthdays. 
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To enter a brief day note, click on the entry box below the date 
in the day display. The day note becomes highlighted, indicating 
that you can enter text in the text area. To complete your entry, 
click on the day note. The highlighting disappears. 

To enter a longer day note, double click on the day note to display 
the entry editor. You can then enter text, modify an existing entry, 
or adjust the alarm settings and repeat intervals. 

Marking Special Days 

Cut 

Copy 

P!ii>te 

Clear 

Select All 

Nonnal 

Special 

You can mark days of particular importance, such as major project 
milestones, holidays, or birthdays. Marking particular days alters 
the display font so that those days can be distinguished from 
other days in the various Calendar displays. 

To mark a day: 

1 Select the desired day from any of the Calendar displays. 

2 Pull down the Edit menu and display the Mark submenu. 

3 

Whichever menu item is currently in use for the selected day 
is dimmed in the submenu. 

Choose the desired menu item from the Mark submenu: 

Choose 

Default 

Work Day 

Non-Work Day 

Normal 

Special 

To Produce 

The font a day had before it was marked with the 
Work Day or Non-Work Day menu item. 

Bold font. 

Once you choose the Work Day menu item, the 
marked days continue to be displayed as Work 
even if you change the setting for that day of 
the week to Non-Work in the dialog box of the 
General... menu item on the Customize menu. 

Standard Calendar font. 

Once you choose the Non-Work menu item, the 
marked days continue to be displayed as Non­
Work even if you change the setting for that 
day of the week to Work in the dialog box of the 
General... menu item on the Customize menu. 

The font a day had before you marked it with the 
Special menu item. 

Bold, larger font; on color workstations, displayed 
in red font. 

The day is marked in the specified manner. 
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The style already in use for the selected day is dimmed in the 
submenu. 

Sending and Receiving Calendar Entries Through Mail 
You can send and receive calendar entries through electronic mail. 
To do so, you must display both the Calendar entry (or just the 
correct day view if you are receiving the entry) and a Create-Send 
window in DECwindows Mail. 

To send an entry through electronic mail, open a Create-Send 
window in Mail. Use MBl to select the entry from the Calendar, 
and then use MB3 to paste the entry into the Mail window. 

To receive an entry through electronic mail, open the day view and 
then use MBl to select the text from an existing mail message. 
The entry is automatically pasted into the Calendar at the correct 
time. 

Printing a Part of a Calendar -----. Open ... 

Open in New ... 

Include ... 

Close 

Name As ••• 

Delete ••• .................. 
Print ••• J 
Exit 

You can copy a. timeslot entry or all of the entries in a day or a 
week to a printable file. 

To print a part of a Calendar display: 

1 Display the day that relates to the entry or entries you want 
printed. 
For example, if you are printing a timeslot, display the day 
that contains the timeslot. If you are printing the entries in 
a day, display the day itself; to print the entries in a week, 
display a day that falls in that week. You can also select the 
day or week number that you want to print from any display 
in which it appears. 

2 Click on the time, day number, or week number, as 
appropriate. 

3 Choose Print... from the File menu. 
Calendar displays a dialog box. 
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Calend~r: Print_ _______ ~ 

Thursday the 19th of April, 1990 

oltO 
Lines Limit 

D Send Fiie To Printer 

IJDECW$CALENDAR.PS 

II OK II I cancer! Options ... I 
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The dialog box shows the time period you have selected and 
provides a default name for the file you want to print. It also 
enables you to limit the number of lines you want printed 
per entry by clicking on the Limit Lines per Entry option and 
moving the arrow in the scale to set the desired limit. 

4 Change the default name provided by the dialog box if you 
want, and then confirm your request by clicking on the OK 
button. 
The requested section (timeslot, day, or week) is copied to the 
named file. You can then send the file to a printer. 

Working with Multiple Calendars 

Aprl~11190 

Wt SUn Mon TU8 Wed Th.I Fri &i ................. ~ 

li'!l1-l2.g,DISKS· DWC 
__ flt __ edll_l!!!!. 

Aprtl,19911 
Wk Sun Mon Tue Wed nu Frt Sat 

14 1 I 3 ' 5 8 7 
15 8 • 10 11 12 13 t4 

18 15 18 17 t• 11 .20 21 

17 22 H al 21 18 %7 28 

18 2B 30 
1 2 3 .. 5 

You can create, open, save, print, and delete calendars. You 
can create different calendars to use for specific purposes. 
For example, you could designate one calendar for business 
appointments, and another for social engagements. 

Creating a New Calendar 
To create a new calendar: 

Choose Open... from the File menu. 
Calendar displays a dialog box. 
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Files in DISK$:[JONES] 
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~ 
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OK 
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I Cancel I 

Q 
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Selection 
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2 Enter a unique file name (the default file type is DWC) for the 
new calendar in the Selection text entry field, and click on the 
OK button. 
A dialog box is displayed asking if the calendar currently 
being displayed should be replaced by the new calendar or if 
you want to keep both calendars on the screen at the same 
time. Click on Replace to display the new calendar in place of 
the old calendar, or on New to display both calendars at the 
same time. 

3 Calendar asks if you want to create a new file. Click on Yes to 
create a new calendar. 

By default, the new calendar is presented in a month display 
containing the current day. 

The calendar file name can be changed later (see the section 
Renaming an Existing Calendar). 

Opening an Existing Calendar 
To open an existing calendar: 
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Choose Open... from the File menu. 
Calendar displays a dialog box that prompts you for the name 
of the calendar you want to open. The file list box lists the 
names of any calendar files in the current directory; that is, 
files that have the type DWC. 



2 Select the name of the file you want to view and click on OK. 
A dialog box is displayed asking if the calendar currently 
being displayed should be replaced by the new calendar or if 
you want to keep both calendars on the screen at the same 
time. Click on Replace to display the new calendar in place of 
the old calendar, or on New to display both calendars at the 
same time. 

If you specify the name of a calendar that you are not allowed 
to read, the Open operation fails and a message box is 
displayed explaining the cause of the failure. 

3 The calendar is opened. 

Renaming an Existing Calendar 
To rename the current calendar, choose Name As... from the File 
menu. 

A dialog box is displayed. 

New File Name I 
=-~~~~~~~-

OK l Cancel I 
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Enter the new calendar name and click on OK. Calendar 
supplies the file type DWC by default. You can rename only 
those calendars in which you are allowed to write. 

Closing a Calendar 
Choose Close from the File menu to close the current calendar. 

Deleting a Calendar 
Choose Delete... from the File menu to delete a calendar. 
Calendar displays a dialog box asking whether you really want 
to delete the calendar. If you do not have sufficient privileges to 
delete the specified calendar, an error message is displayed. 
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Customizing a Calendar 

General ... 

Day View .. . 

Icon Box .. . 

Alarms ... 

Save Settings 

Restore Settings 

Use Defaults 

Many different features can be changed to customize the 
appearance and behavior of the various displays presented by 
the Calendar. All of these changes are made from the Customize 
menu. 

Customizing General Features 
To customize general features of the Calendar, choose General ... 
from the Customize menu. 

Calendar displays a dialog box. 

General ~-
- --~ - - --- -- --- - - - - - --- ----- --- -~--- -- ----

Work Week 

D Sunday 
Ill Monday 
Ill Tuesday 
Ill Wednesday 
Ill Thursday 
Ill Friday 
D Saturday 

• Show Week Numbers ~ Ill Show AM/PM 
4 : 
If! I ~ D 'Live' Scrolling 

Date for Week No. 1 D Right to Left 

I January I 

First View I Month I 

D Fill Blank Days 

Ill Print Blank Days 

Ill Box Current Day 

First Day of Week D Start lconized 
I Sunday I 

I Don't Mark Past Days I 

OK 111 Apply 11 Reset 11 cancel I 
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Shaded buttons indicate the current settings. Click MBl on a 
button or its label to change the setting. To choose an option from 
an option menu, press and hold MBl on the current option and 
drag the pointer. Release MBl over the desired option. 

Click on the Apply button to apply your changes without closing 
the dialog box. Click on the Reset button to restore the dialog box 
defaults. Click on the OK button to apply your changes and close 
the dialog box. 

From this dialog box, you can modify any of the following 
Calendar features: 
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Work Week 
N orrnally, Calendar designates Monday through Friday as the 
work week, as indicated by the shaded toggle buttons immediately 
to the left of the days. You can change the settings by clicking on 
the days you want to use for your work week. 

First Day of Week 
The first day of the week is Sunday, which is displayed as the 
current option on the First Day of Week option menu. You can 
designate another day as the first day of the week by displaying 
the option menu and choosing the desired option. 

Show Week Numbers 
Normally, the leftmost column in every month display lists the 
number of each week, starting with the first week of January as 
week number 1. You can disable this feature by turning off the 
Include Week Numbers option. 

Date for Week No. 1 
In every month display, the leftmost column lists the number of 
each week. This is in effect as long as the Include Week Numbers 
option is turned on. By default, weeks are numbered starting with 
the first week of January as week number 1. The following weeks 
are numbered accordingly, ending with the last week in December. 

The Date for Week No. 1 option enables you to set the week you 
want to designate as the first week of the year by choosing the 
desired month and moving the arrow in the scale to the desired 
date. For example, if your fiscal year starts the first week of July 
and you want to designate that week as the first week of the year, 
choose July from the list of months and choose a date number that 
falls in the first week of July. To ensure that the date you choose 
falls in the first full week of the month, you may want to choc;>se a 
date such as July 6. 

The date January 4 is the preset option, which ensures that the 
first full week in January is used as the first week of the year. 

First View 
When you start Calendar, the month display· appears on your 
screen by default, as indicated by the First View option menu, 
which shows Month as the current option. You can designate Year 
Display or Day Display as the first display you see when you start 
Calendar by displaying the option menu and choosing the desired 
option. 
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Start lconized 
Normally, when you start Calendar you see a display of the 
current month. By clicking on the Start Iconized ·option, which 
causes the toggle button to become shaded, you can cause 
Calendar to start as an icon. 

Show AM/PM 
Normally, Calendar has a 12-hour time system that uses AM 
and PM in its day display to differentiate timeslots, as indicated 
by the shaded toggle button. If you disable the Show AM/PM 
option, Calendar uses a 24-hour time system in its day display. 
For example, 1 p.m. becomes 13:00, and so on. 

'Live' Scrolling 
Normally, when you move the slider on the scroll bars in the day, 
month, and year displays, the displays do not move until after you 
have moved the slider. When you enable this option by clicking on 
it, the displays change dynamically when you move the slider. 

Right to Left 
Normally, the timeslots appear on the left side of the day view and 
the vertical scroll bar appears on the right side. 

You can reverse the position of these elements, including the 
timebars, by enabling the Right to Left option. 

Fill Blank Days 
Normally, Calendar leaves the days not filled by the current 
month blank. When you turn on the Fill Blank Days in Month 
Display option, Calendar fills the blank days at the beginning 
and end of the current month with the dates of the preceding and 
following months. 

Print Blank Days 
Normally, when you print out a week from your calendar, all days 
are printed out whether or not you have entries in them. 

You can disable the Print Blank Days option by clicking on it, 
which causes only those days that have entries in them to be 
printed out. 

Box Current Day 
Normally, Calendar puts a box around the current day in the day 
display, as indicated by the shaded toggle button. You can disable 
this feature by clicking on it. 
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Mark Past Days 
Normally, Calendar does not distinguish past days from future 
days, as indicated by the Mark Past Days option menu, which has 
Don't Mark Past Days as the default option. 

You can direct Calendar to cross out or strike out past days by 
choosing the appropriate option from the Mark Past Days option 
menu. 

Customizing the Day Display 
You can customize the day display by choosing Day View ... from 
the Customize menu. 

Calendar displays a dialog box. 
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From this dialog box, you can modify any of the following day 
display features: 

Timeslot Size 
Normally, the day display has timeslots broken up into 30-minute 
intervals. You can change the interval by choosing the desired 
option from the Timeslot Size option menu. 
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Increment 
The resize bar lets you create a· Calendar entry that is larger or 
smaller than the timeslot size. Normally, the resize bar expands 
or contracts a timeslot in 5-minute increments. 

You can change this increment by choosing a different option from 
the Increment option menu. 

The Resize bar time increment is always smaller than the timeslot 
size. For example, if your timeslot size is 30 minutes, the Hour 
option on the Increment option menu is dimmed because you can 
only resize the entry in increments smaller than or equal to the 
timeslot itself. 

Font Size 
Normally, Calendar uses a medium font size for timeslots and 
entries. You can choose a large or small font size by clicking on 
the button that corresponds to the desired option. 

Icon size 
Normally, Calendar displays medium-sized icons in the handles 
of Calendar entries. You can choose a large or small icon size by 
clicking on the button that corresponds to the desired option. 

Working Hours 
Normally, Calendar uses 8:30 a.m. to 5:30 p.m. for working hours. 
You can change these values by clicking on the appropriate box to 
set the time you want. 

Lunch Hours 
Normally, Calendar uses 12:00 p.m. to 1:00 p.m. for lunch hours. 
You can change these values by clicking on the appropriate box to 
set the time you want. 

Flag 
Normally, when you create a day note or entry, the corresponding 
day is flagged. This means that the font of the specified day is 
changed in the month view to make it stand out. 

You can disable flagging for day notes or entries by clicking on the 
corresponding button. 

Icon 
Normally, the meeting icon appears in the handle of a Calendar 
entry. The pencil icon is normally associated with the day note. 
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You can choose a different default icon to be associated with 
either the Entry option or the Day Notes option by clicking on the 
corresponding icon to the right of each option, and then choosing 
the desired icon from the box. 

You can also associate multiple icons with a particular entry by 
using the entry editor. For more information, see the section 
Creating an Entry. 

Vertical Spacing 
This option allows you to set the height of a timeslot entry. Larger 
values tend to be more readable, smaller values allow more 
timeslots to be displayed in the same space. 

To modify the timeslot height, press and drag MBl to move the 
arrow in the scale to the desired value. 

Horizontal Spacing 
This option allows you to adjust the width of the timeslots. 

To modify the timeslot width, press and drag MBl to move the 
arrow in the scale to the desired value. 

Timebar Width 
This option controls the thickness of the two timebars. A greater 
value will produce a thicker timebar. A value of 0 will remove 
them completely. 

To modify the timebar width, press and drag MBl to move the 
arrow in the scale to the desired value. 

Stacking 
Normally, overlapping entries are stacked so that the left side of 
each entry is always visible. This is the effect of the Show Length 
option on the Stacking option menu. 

To cause Calendar to stack overlapping entries so that the first 
line of each entry is visible,· choose Show Text from the Stacking 
option menu. With Show Text enabled, even if you have two 
entries star;ting at the same time, Calendar leaves a gap to 
display at least some of the text associated with the hidden entry. 

Calendar does not save any changes you make to the stacking 
order for a given set of entries. 

Times on the Line 
Normally, the starting time of a timeslot is centered between the 
top and bottom lines of the timeslot. 
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You can cause the starting time of a timeslot to be centered in the 
top line of the timeslot by enabling the Times on the Line option. 

Show Full Times 
Normally, timeslots that are not on the full hour are displayed 
as the number of minutes after the full hour. For example, the 
timeslot for 2:00 would be displayed as 2:00, but the timeslot for 
2:30 would be displayed as 30. 

To cause Calendar to display the hour as well as the minutes for a 
timeslot that does not occur at the full hour, enable the Show Full 
Times option. This would cause 2:30 to be displayed as 2:30. 

Show Day Notes 
Normally, the day note entry box appears below the date in the 
day display. 

To remove the day note entry box, disable the Show Day Notes 
option by clicking on it. Old day notes are not deleted if you 
disable day notes; they are just not visible. 

Show Months 
Normally, Calendar displays the current and next month at the 
top of a day display. You can disable this option by clicking on the 
Show Months option. 

Autoclick on Clock 
Normally, Calendar requires you to start autoscrolling by clicking 
on the clock when you display the day view. By enabling the 
autoclick option, autoscrolling will happen automatically when 
you first open the day view. 

Customizing Calendar Icons 
You can customize the Calendar icon that appears in the 
DECwindows icon box by choosing Icon Box... from the Customize 
menu. 

Calendar displays a dialog box. 
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From this dialog box, you can modify any of the following 
Calendar icon features: 

text entry field 
The text entry field in the upper left comer of the dialog box 
allows you to enter text that will appear on the top line of the icon 
box. 

If you enable the top New Line option, the text you enter will 
appear above the day of the week in the icon box. 

If you do not enable the top New Line option, the text you enter 
will appear to the left of the day of the week in the icon box. 

New Line 
The two New Line buttons in the Calendar icon dialog box allow 
you to customize the layout of the Calendar icon. 

The top New Line toggle button can be enabled only after you 
click on the toggle button corresponding to the text entry field. 
Enabling the top New Line button causes the text you type into 
the text entry field to appear on the top line in the icon box. 

The second New Line item causes the time of day to appear on 
a line below the day of the week. It is enabled by default as 
indicated by the shaded toggle button, but you can disable it by 
clicking on it. 

Show Day Name 
Normally, the day of the week appears in the icon, as indicated by 
the shaded toggle button. You can disable this option by clicking 
on it. 

Full Day Name 
Normally, the day of the week that appears in the icon is in 
an unabbreviated form. You can cause day names to become 
abbreviated by disabling this option. 
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Show Time 
Normally, the time appears in the icon. You can disable this 
option by clicking on it. 

Saving Customized Features 
To save your customized features, choose Save Settings from 
the Customize menu. This causes your new settings to be used 
whenever you start a Calendar session. The size and placement of 
all displays are also saved. 

To restore your settings to the currently saved defaults, choose 
Restore Settings from the Customize menu. 

To restore your settings to the system defaults, choose Use 
Defaults from the Customize menu. 

Changing the Shape of a Display 
You can change the size of any Calendar display by using the 
window's size button. If you resize the display to be smaller than 
the elements inside it, Calendar will try to rearrange the elements 
to fit the new size, but some of the elements may not be visible. 
For example, if you resize the year display so that it is only big 
enough to display eight months, Calendar will display only the 
next eight months. 

To save the size settings from one session to the next, choose Save 
Settings from the Customize menu. 

Exiting from the Calendar 
To exit from Calendar and close all open calendars, choose Exit 
from the File menu. 

4-24 Using the Calendar 







5 
Using the Cardfiler 

The Cardfiler lets yqu create an electronic box of index cards. This 
electronic file box is called a card file. Card files contain cards, 
which can hold any kind of information you like,· such as names, 
addresses, and telephone numbers. For example, you could have 
a card file called Food filled with cards that contain recipes and 
names of restaurants. 

By organizing your index cards into sets (card files), you can keep 
one group of cards separate from another group, for example, your 
business cards and your personal cards. 

This chapter describes how to 

• Start the Cardfiler 

• Create and add cards to a card file 

• View topics in a card file 

• Search a card file for text 

• Edit a card 

• Incorporate images 

• Open an existing card file 

• Save a card file 

• Merge two card files 

• Exit from the Cardfiler 
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Starting the Cardfiler 
To start the Carclfiler, choose Carclfiler from File View's 
Applications menu. 

The Carclfiler displays an empty card file in the Cardfiler window. 
Initially, the card file is empty, but it fills up with index topics as 
you add cards. 

11!§1 cardfiler: untitled IEtllfil 
File Search carc1 Help 
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Opening a Card File 
A card file is an electronic file box that contains cards. 

You can either create a card file first and then add cards to it, 
or you can create cards and then save them into a card file. For 
example, you could create a card file called Clients, and then fill it 
with cards that contain the names and telephone numbers of your 
clients. 

To create a new card file or open an existing card file: 
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Choose Open... from the File menu. 
Cardfiler displays a dialog box. 
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2 To create a new card file, click on the Selection text field 
and enter the name of the card file you want to create, for 
example, Clients. By default, card files have the file type 
CARD. 
Click on OK. Cardfiler displays a message telling you the file 
was not found and that a new file is being opened. Click on 
Acknowledged. 
To open an existing card file, select the name of the file you 
want to open. 
Use the scroll bars to view a complete list of your card files. 
The card file name you select is displayed in the text field. 
The new card file is displayed. 

If you try to open another card file without first saving any 
changes you made to the current file, a dialog box is displayed, 
asking whether you want to save your changes. Click on the Yes 
button to save your changes. Click on the No button to discard 
your changes. 
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Creating Cards 
Cards contain units of information, such as a person's name and 
telephone number, and are organized into sets called card files. 
For example, you could have a card file called Accounts in which 
you have cards containing information about each of your business 
accounts. 

You can create a series of cards and save them into a card file, 
or you can open a card file and then add cards to it. As you add 
cards, they are sorted alphabetically according to the topic you 
enter in the card's index field. Very likely, this topic will be the 
name of something, such as a person or business. By displaying 
the topic of each index card, the card file window lists the contents 
of the card file. 

To create a card: 

Choose Create Card... from the Card menu. 
The Card.filer displays a blank index card in the Card window. 
The dialog box prompts you to enter the topic of the new index 
card. 

Index for this card 

I! OK II I canceq 
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2 Enter the topic that belongs in the index field. 

3 Press I Return I or click on the OK button. 
The text you just entered is added to the title bar at the top of 
the Card window and to the contents of the Card.filer window. 
You can add information to the new card. 

4 Enter any information· belonging on the index card, for 
example, an address. 
Enter the text as you want it to appear, using the Return key, 
space bar, and Tab key to format it. Cards can contain up to 
4000 characters, and up to 64K bytes of images. 

5 When you are finished with the index card, choose Close from 
the Edit menu. 
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The Card window is closed and the contents of the index card are 
added to your card file. 

You can open another index card in the card file without closing 
the current card. When you choose Create Card... from the Card 
menu in the Cardfiler window, the Cardfiler automatically saves 
any changes you made to the current index card and returns it to 
the card file before it opens a new card in the file. 

If you create a series of cards before you have created the card file 
in which you want to place them, you can save them into a new 
card file. 

To save cards into a new card file: 

From the empty, untitled card file you see when you start the 
Cardfiler, create your cards. 

2 Choose either Save or Save As... from the File menu. 
Cardfiler displays a dialog box. 

3 In the Selection text field, enter the name of the card file you 
want to put your cards in. 

For example, if you created a series of cards about famous 
baseball players, you could create a card file called Baseball. 

4 Click on OK. 

The new card file name is displayed at the top of the Cardfiler 
window with a list all of the index cards in that card file. 

Viewing the Contents of a Card File 
~ Cerdflter: PETS.CARD IQlii: 
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Although you can look at only one index card at a time, you can 
easily switch from one card to another by selecting a card from 
the card file window. When your card file contains too many cards 
to list in a window at a time, you can use the scroll bar to move 
through the file. You can also search the contents of a card file for 
a given text string. 

Opening an Existing Card 
To display the contents of a card you have already created, select 
the card from the card file window by pointing to its index line 
and clicking MBl. 

The card's index topic becomes shaded and the contents of the 
card are displayed in the Card window. 
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Scrolling Through a Card File 
As you accumulate cards, they cannot be listed all at once in the 
card file window. To scroll through the list of index cards in your 
file, press and hold Min on the stepping arrow. 

Finding Text 
You can search a card file for any text string. The text can be a 
word, a number, or any other characters that you can type on your 
keyboard. Because the Cardfiler treats spaces as text, you can 
search for two or more words. 

The Cardfiler searches either the index topics or the contents of 
the index cards. 

To search the index topics in a card file for specific text: 

Choose Search Index... from the Search menu in the card file 
window. 
Cardfiler displays a dialog box. 
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2 Enter the text string you want located. 

3 Press I Return I or click on the OK button. 

The Cardfi.ler searches the topics of all index cards in the file and 
displays the first card in your file containing the text string. 

You can continue to search for a text string by choosing the Find 
Next menu item from the Search menu in the card file window. 
The Cardfiler continues to search the card file for the text and 
displays each card that contains the text in its index field. 

To search the contents of each card in the file for specific text: 
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Editing a Card 
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2 Enter the text string you want located. 

3 Press I Return I or click on the OK button. 

The Card.filer searches all index cards in the file and displays the 
first card in your file containing the text string. 

You can continue to search for a text string by choosing the Find 
Next menu item from the Search menu in the card file window. 
The Card.filer continues to search the card file for the text and 
displays each card that contains the text. 

The Cardfiler editing commands let you copy, delete, and 
rearrange text on an index card. If you decide you do not want to 
save your edits, Cardfiler can restore the card to its original state. 

Renaming a Card 
. To change the topic of an index card, you modify the index line: 

Select the card you want to rename from the card file window 
by pointing to it and clicking MBl. 

2 Choose Rename ... from the Card menu on the Card window. 

3 Use the arrow keys to move the text cursor and the <XI 
(Delete) key to erase unwanted text. 

4 Enter the new topic under which you want the card filed. 

5 Click on the OK button. 

The card is renamed and remains open. If you want to close the 
card, choose Close from the card's File menu. 
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Moving the Text Cursor 
When you create a new card, the text cursor appears in the upper 
left corner of the card window. When you open an existing card, 
the text cursor remains where it was when you last edited the 
card. 

If you are creating a new card and want to move the text cursor, 
use the Return key or place the pointer where you want the text 
cursor and click MBl. You can use this method to move the text 
cursor on an existing card, or you can use the arrow keys to move 
the text cursor anywhere in the existing text (except to the index 
line). 

Selecting Text 
In order to delete, move, or copy text, you must first select that 
text. Select the text by pressing and holding MBl, dragging the 
pointer over the text, and releasing MBl. This highlights the 
selected text. The Cardfiler stores this text until you tell it what 
to do. 

I Previous I I Next 

ZK-011 SA-GE 

Deleting Text 
To delete small amounts of text on your card, use the ~ key. 
If you selected text for deletion, press any key to delete the 
highlighted text. 
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Moving Text 
Because the Cardfiler saves the last text you selected and deleted, 
you can move text from one location on a card to another or 
between cards. 

To move text on a card: 

Select the text you want moved to another location on the 
card. 

2 Choose Cut from the Edit menu. 

3 Move the text cursor to where you want the deleted text 
inserted by using the Return and arrow keys or by positioning 
the pointer and clicking MBl. 

4 Choose Paste from the Edit menu. 

The deleted text appears in the new location. 

To move text from one card to another: 

Select the text you want to move to another card. 

2 Choose Cut from the Edit menu. 

3 From the card file window, click on the card to which you want 
to move the text. 
The new card is opened. 

4 Move the text cursor to where you want the deleted text 
inserted by using the Return and arrow keys or by positioning 
the pointer and clicking MBl. 

5 Choose Paste from the Edit menu. 
The selected text is inserted in the new location. 

Copying Text 
Because the Card.filer keeps track of your selected text, you can 
copy text from one location on a card to another and between 
cards. 

To copy text on a card: 

Select the text you want copied to another location on the 
card. 

2 Move the text cursor to where you want the selected text 
copied by using the Return and arrow keys or by positioning 
the pointer and clicking MBl. · 
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3 Click MB3. 
The selected text is copied to the new location. 

To copy text from one card to another: 

1 Select the text you want copied to another card. 

2 Choose Copy from the Edit menu to store the copied text. 

3 From the card file window, click on the card to which you want 
to move the text. 
The new card is opened. 

4 Move the text cursor to where you want the selected text 
copied by using the Return and arrow keys or by positioning 
the pointer and clicking MBl. 

5 Choose Paste from the Edit menu. 
The text is copied to the new location. 

Incorporating Images 
You can add images, such as those you create with Paint, 
PrintScreen, and VAXimage Services to index cards. The Cardfiler 
places an image at the top of a card, keeping the picture's original 
size, and relocates text to the remaining space. 

To incorporate an image that has been saved as a file into a card: 

1 Open a card. 

2 Choose Include Image... from the Card window's File menu. 
Cardfiler displays a dialog box that lists all files in the current 
directory that have the type IMG. 

3 Select one of the listed files, display a different set of files 
using the File filter, or type the name of the file you want in 
the Selection text entry field. 
The image is displayed on your card. If it is larger than the 
current size of your index card, you can display the entire 
image by enlarging the card with the resize button. 

To copy part or all of an image directly from the Paint application: 

Display the image you want to use in the Paint window. 

2 Select the portion of the image you want to copy to your open 
card. 
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3 Choose Cut or Copy from Paint's Edit menu. Cut causes the 
image to disappear from the Paint window, whereas Copy 
simply makes a copy of it. 

4 Give your open index card input focus by clicking on it, and 
choose Paste from the Edit menu. 
The image is displayed on your card. If it is larger than the 
current size of your index card, you can display the entire 
image by enlarging the card with the resize button. 

You can also copy images from a card to Paint and between cards 
by selecting the image, copying it to the clipboard, and pasting it 
in the new location. 

To erase an image from your card: 

Select the image by clicking on it. 
You can cancel the selection of an image by clicking in the text 
portion of the card. 

2 Choose Clear from the Edit menu. 
Card.filer erases the image. You can restore it by choosing 
Undo from the Edit menu. 

Saving a Card File 
Whether you create a new card file or make changes to an existing 
card file, such as adding or deleting a card or changing any 
information on a card, you need to save that card file when you 
are done working with it. 

To save a new card file or change the name of an existing one: 

Choose Save As... from the File menu in the card file window. 
Card.filer displays a dialog box, prompting you for the name of 
the file. 
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2 Using the~ and arrow keys, delete any text in the Selection 
text field and enter the name of file. The default file type for 
card file names is CARD. 
Give the file a name that you can easily recognize. For 
example, if the card file contains the phone numbers of 
your business associates in Rome, you can· name the file 
ROME.CARD. 

3 Press I Return I or click on the OK button. 
You are returned to the card file window. If you saved a 
new card file, notice that the name of the card file in the 
title bar has changed from "untitled" to ROME.CARD. If you 
saved an existing card file, the card file name is replaced by 
ROME.CARD. 

To save the current card file, choose Save from the File menu in 
the card file window. 

To save the current card file under a new file name: 

1 Choose Save As ... from the File menu in the card file window. 

2 Using the ~ and arrow keys, delete any text in the text field 
and enter the file's new name. 

3 Press I Return I or click on the OK button. 

You are returned to the card file window. Notice that the title bar 
contains the new card file name. 
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Merging Card Files 
You can merge the contents of the current file with another file, 
resulting in a card file that combines and sorts the contents of 
both files. The card file whose contents were merged with the 
current card file remains unchanged. 

Choose Merge... from the File menu on the card file window. 
Cardfiler displays a dialog box. 
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2 Select the name of the file you want to merge with the current 
file. Use the scroll bars to view a complete list of your files. 
The file name you selected is displayed in the text field. 

3 Press I Return I or click on the OK button. 

The contents of the two card files are merged and sorted 
alphabetically. 

Saving Customized Settings 
If you change the size or screen position of Cardfiler and would 
like to save these settings, choose Save Geometry from the File 
menu. This causes the new settings to be used in future sessions. 
To restore the system defaults, choose Use System Defaults from 
the File menu. 
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Exiting from the Cardfiler 
To exit from the Card.filer, choose Quit from the File menu in the 
card file window. 

If you have not saved any changes or additions to the current file, 
Cardfiler displays a dialog box, asking whether you want to save 
your changes. 
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Click on the Yes button to save your changes and exit from the 
Card.filer or the No button to exit from the Card.filer without 
saving your changes. To return to the Card.filer window, click on 
the Cancel button. 
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6 
Using the Clock 

The Clock displays the time (in both analog and digital format) 
and the date. You can change this display to suit your needs. You 
can also set the Clock's alarm to remind you of appointments . 

This chapter describes how to 

• Start the Clock 

• Customize the Clock display 

• Set the alarm 

• Exit from the Clock 

Starting the Clock 
To start the Clock, choose Clock from File View's Applications 
menu. 

The Clock is displayed on your screen. You can move and change 
the size of the Clock as you wish. 

:;.-:: Clock 6!)~ 
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6-2 Using the Clock 

Changing the Clock Display 
You can customize the Clock display to include any combination of 
the date and time regions. 

To change the Clock display: 

1 Place the pointer anywhere in the Clock display. 

2 Press and hold MB2. 
Clock displays a pop-up menu. 

Settings ... 

Save Settings 

Use System Settings 

Help H 

Quit 

3 Choose the Settings... menu item. 

Clock displays a dialog box. 
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Shaded toggle buttons indicate the current settings. Click MBl on 
a toggle button or its label to change the setting. For example, if 
you want only the analog clock displayed and the Analog, Digital, 
and Date toggle buttons are shaded, click on the Digital and Date 
toggle buttons to disable those settings. If you want the Clock to 
display 24-hour digital time, for example 15:32, you can enable 
that setting by clicking on it. 



Click on the OK button to use any changed settings. Click on 
the Cancel button to return to the date and time display without 
changing any settings. 

You can also display the Clock Settings... dialog box directly 
without first displaying the pop-up menu by double clicking MBl 
anywhere on the Clock display. 

To save your customized settings and the size and placement of 
the Clock on the screen if you have made changes: 

Make any desired changes to the size, position, and settings of 
the Clock. 

2 Press and hold MB2 to display the pop-up menu. 

3 Choose Save Settings. 
To restore the system defaults, choose Use System Settings 
from the pop-up menu. 

Setting the Alarm 
You can set the alarm to remind you of an appointment-or lunch. 

To set the alarm from the Clock Settings dialog box: 

Click MBl on the Alarm toggle button to switch the alarm on. 

2 Move to the hours field and type the hour at which you want 
the alarm to go off. 
You can either use a 12-hour clock, in which case you need to 
specify AM or PM, or you can use a 24-hour clock (military 
time). 
Use the <Kl (Delete) key to erase any number already entered 
or to correct typing mistakes. 

3 Move to the minutes field and finish entering the time you 
want the alarm to go off. 

4 If you are using a 12-hour clock or if the time you specify is 
less than 13:00, click on either the AM or PM option button. 

5 To display a message on your screen when the alarm goes 
off, move to the Alarm Message field and type your message. 
Alarm messages may contain up to 200 characters. 

6 Click on the OK button to save the settings. Click on the 
Cancel button to return to the date and time display without 
changing any settings. 
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When the alarm goes off, click on the Acknowledged button to 
clear the alarm message from your screen. 

Exiting from the Clock 
To exit from the Clock, choose Quit from the Clock's pop-up menu. 
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7 
Using DECterm 

DECterm is a VT300-series terminal emulator. 

This chapter describes how to: 

• Create a DECterm window 

• Customize DECterm operating features 

• Copy information 

• Clear and resize DECterm windows 

• Compose special characters 

• Exit from DECterm 

In addition to using these features, you can program DECterm 
text features and ReGIS and sixel graphics. See theDECterm Text 
Programming Manual and the DECterm Graphics Programming 
Manual for detailed information about using these features. 

Creating a DECterm Window 

DECterm 

File View 

To create a DECterm window, do one of the following: 

• Choose DECterm from the Session Manager's Application 
menu. 

• From the DCL command line, enter: 

$ CREATE/TERMINAL 

For a complete description of the CREATEtrERMINAL 
command, see the VMS Thrsion 5.3 New Features Manual. 
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A DECterm window is displayed. 

~ DECterm 1 ~ m 
Commands Edit Customize Help 

.... 
0 
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Give DECterm input focus by pointing to it and clicking MBl. 

Customizing DECterm 

7-2 Using DECterm 

Once you have created a DECterm window, you can choose 
operating features and then save these features by using the 
DECterm Customize menu. 

Window ••• 

Display .. . 

General .. . 

Keyboard ... 

7-Bit NRCS Selection ... 

Graphics ... 

Use Last Saved Settings 

Use System Defaults 

Use Saved Settings From ... .................................. 
Save Current Settings 

Save Current Settings As ... 
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Customizing a DECterm Window 
Choose Window... from the Customize menu to change DECterm 
window features. DECterm displays a dialog box. 

DECterm: Window !!J 11 
D Auto Resize Terminal 
Ill Auto Resize Window 
• Terminal Driver Resize 

0 Big Font 
(f) Little Font 

0 Normal Font (80 Columns) 
0 Condensed Font (132 Columns) 
(f) Normal/80, Condensed/132 

I DECterm 1I 
Window Title 

- - -

Terminal Size 

I 241 Rows I sci Columns 

I DECterm 1I 
._lc_o_n-Na_m__,e.__ _____ l[Oi(JI I Apply I I Cancel· I 
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On DECterm, shaded buttons indicate the current settings. 

To change these settings: 

1 Click MBl on a button or·its label to change the setting. 

2 Click on the Apply button to view your changes without 
closing the dialog box. 

3 Click on the OK button to apply your changes and close the 
dialog box. 

4 Click on the Cancel button to cancel your changes. 

From the Window dialog box, you can customize the following 
features: 

Auto Resize Terminal 
Normally, changing the window size does not change the size of 
DECterm. Clicking on Auto Resize Terminal causes the size of 
DECterm to match the window size, if you resize the window. 

Auto Resize Window 
Normally, changing the size of DECterm (the number of rows 
and columns) automatically changes the window size. Clicking 
on Auto Resize Window lets you change the size of DECterm 
without changing the window size. If DECterm is larger than the 
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window, information may be outside the window boundary; this 
information is not displayed. 

Terminal Driver Resize 
Normally, when you modify the terminal driver, the terminal size 
also changes. Clicking on Terminal Driver Resize disables this 
option. 

Big Font 
Normally, DECterm displays a 14-point font (10-point font on 100 
dots-per-inch systems). Clicking on the Big Font option causes 
DECterm to display an 18-point font. 

Little Font 
Normally, DECterm displays a 14-point font. Clicking on the Big 
Font option causes DECterm to display a larger font. 

Normal Font (80 Columns) 
Clicking on the Normal Font (80 Columns) option causes the 
80-column font to be used, regardless of the number of columns. 
The default option is Normal/80, Condensed/132. 

Condensed Font (132 Columns) 
Clicking on the Condensed Font (132 Columns) option causes a 
condensed font to be used, regardless of the number of columns. 
The default option is Normal/80, Condensed/132. 

Normal/BO, Condensed/132 
The default font size is Normal/80, Condensed/132. This option 
causes the font size to adjust to match the terminal width. The 
Normal Font is used when there are 80 columns or less and the 
Condensed Font is used when there are more than 80 columns. 

Window Title 
Normally, a title appears in the title bar. Entering a title of your 
choice changes the name in the title bar. 

Icon Name 
Normally, a name appears in the icon. Entering a name of your 
choice changes the name in the icon. 

Terminal Size 
The default terminal size is 24 rows and 80 columns. You can 
change the terminal size by entering a number in the row or 
column field. You can also set the column and row to be any 
number from 1 to 132 by clicking on the text entry field, deleting 
any existing numbers, and entering the new settings. 



Customizing a Display 
Choose Display... from the Customize menu to modify display 
features such as the type of cursor. DECterm displays a dialog 
box. 

DECterm: Display ~II 

11!11 Record Lines Off Top 
11!1 Vertical Scroll Bar 
D Horizontal Scroll Bar 
Ill Vertical Cursor Coupling 
D Horizontal Cursor Coupling 
D Auto Wrap 
II Display Cursor 
Ill Cursor Blink 

Batch Scroll . ~Lines 

Cl Dark Text, Light Background 
0 Light Text, Dark Background 

Cl No Status Display 
0 Host Status Display 

Cl Block Cursor 
0 Underline Cursor 

. Record I 500! Lines Off Top c:gg:JI I Apply I I cancel I 
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From the Display dialog box, you can customize the following 
features: 

Record Lines Off Top 
Normally, lines that are scrolled off the top of the DECterm 
display are saved. To view these lines, use the vertical scroll bar. 
If you do not want to save lines that are scrolled from the display, 
click on Record Lines Off Top. 

Vertical Scroll Bar 
Normally, DECterm displays vertical scroll bars. If you do not 
want vertical scroll bars, click on the Vertical Scroll Bar option. 

Horizontal Scroll Bar 
Normally, DECterm does not display horizontal scroll bars. Click 
on Horizontal Scroll Bar to display a horizontal scroll bar at the 
bottom of your DECterm window. 

Vertical Cursor Coupling 
Normally, when you vertically change the window or terminal size, 
the cursor remains visible. For example, if the display contains 24 
rows and you shrink it to 5 rows, the cursor remains visible and 
allows you to enter text. You can disable this option by clicking on 
it. 
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Horizontal Cursor Coupling 
Normally, when you horizontally change the size of your window 
or terminal (for example, from 132 columns to 80 columns), the 
cursor is not visible. You can change this default by clicking on 
the Horizontal Cursor Coupling option. 

Auto Wrap 
Normally, when the cursor reaches the right margin it stops. 
This causes each new character to delete the existing character. 
Clicking on Auto Wrap causes the cursor to move, start a new 
line, and display new characters. 

Display Cursor 
Normally, DECterm displays a cursor. Clicking on Display Cursor 
causes the cursor to be invisible. 

Cursor Blink 
Normally, the DECterm cursor is a blinking cursor. Clicking on 
Cursor Blink causes a steady cursor to be displayed. 

Batch Scroll 0 Lines 
Normally, you cannot scroll lines. Entering a number in place of 
zero ( 0) increases the number of lines you can scroll to match the 
terminal size. 

Record 500 Lines Off Top 
Normally, you can save 500 lines in the transcript. Entering a 
number from 1 to 9999 increases or decreases the number of lines 
saved in the transcript. 

Dark Text, Light Background 
Normally, DECterm displays dark text and a light screen 
background. 

Light Text, Dark Background 
Clicking on the Light Text, Dark Background option causes 
DECterm to display dark text and a light screen background. 

No Status Display 
Normally, you do not receive host status messages. Host status 
messages, when activated, appear on the bottom line of your 
terminal window display. See the DECterm Text Programming 
Manual for further information about status display. 



Host Status Display 
To receive host status messages, click on the Host Status Display 
option. This causes the messages to appear on the bottom line of 
your terminal window. You can set Host Status Display only on 
VT300-series terminals. 

Block Cursor 
Normally, the cursor displayed in your DECterm window is 
shaped like a block. 

Underline Cursor 
The default cursor for DECterm is a block. Click on the Underline 
Cursor option to get an underline cursor. 

Customizing General Features 
Choose General... from the Customize menu to change general 
features such as the terminal type. DECterm displays a dialog 
box. 

DECterm: General !illl 
D Newline 
D LockUDKs 
D Lock User Features 

<i> Normal Cursor Keys 
0 Appl Cursor Keys 

Terminal ID 
<i> DECterm ID 
0 VT3401D 
0 VT3301D 
0 VT3201D 
0 VT2401D 
0 VT2201D 
0 VT1251D 
0 VT1021D 
0 VT101 ID 
0 VT100 ID 

0 Numeric Keypad 
(j) Application Keypad 

(j) UPSS DEC Supplemental 
0 UPSS ISO Latin 1 

<i> 8-Bit Multinational Characters 
0 7-Bit NRCS Characters 

0 VT300 Mode, 8-Bit Controls 
<i> VT300 Mode, 7-Bit Controls 
0 VT100Mode 
0 VT52Mode 

COKJI I Apply I I Cancel I 
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From the General dialog box, you can set the following features: 

Newline 
Normally, when DECterm receives a line feed (LF), form feed (FF), 
or vertical tab (VT) character, the cursor moves to the first column 
of the next line. When you press Return, DECterm sends both a 
carriage return (CR) and line feed. 
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If you select the No Newline option and DECterm receives a ;LF, . 
FF, pr VT.character, the cursor moves to the current column of the 
next line. When you press Return, DECterm sends only a carriage 
return. 

Lock UDKs 
Your keyboard contains keys you· can define for your own use. 
Normally, the host system can change the function ofthe key you 
have defined back to the default. Clicking on Lock UDKs sets 
the user-defined keys so that the host system cannot change your 
definitions. 

For detailed information about defining keys, see the DECterm 
Text Programming Manual. 

Lock User Features 
DECterm lets you change the Auto Repeat option and the 
Foreground and Background Display option. The host system 
can override these options unless you click on the Lock User 
Features option. 

Normal Cursor Keys 
By default, the Normal Cursor Keys option is on. This causes the 
arrow keys to move the cursor up, down, left, and right ... 

Appl Cursor Keys 
By clicking on the Application Cursor Keys option, you can 
override the Normal Cursor Keys default and set the arrow keys 
to application-specific functions. 

Terminal ID 
You can let the host system know specific terminal operating 
attributes by clicking on the Terminal iD option. The default is 
DECterm ID. 

You can choose the following terminal IDs: 

DECterm ID 

VT220 ID 

W'340 ID 
,{ 

VT125 ID 

Numeric Keypad 

VT330 ID 

VT102 ID 

VT320 ID 

VT101 ID 

VT240 ID 

VTlOO ID 

Normally, the Numeric Keypad option is set. This means.that 
pressing a numeric key displays the characters that appear on 
that key. 



Application Keypad 
Choose the application keypad· by clicking on the Application 
Keypad option. This causes user-defined characters to be 
displayed. 

UPSS DEC Supplemental 
Normally, the UPSS DEC Supplemental option is on, causing the 
DEC Multinational Character Set to be used. 

The ASCII character set comprises the first half of the DEC 
Multinational Character Set. Figure 7-1 illustrates the A~CII 
character set (characters with decimal values 0 through 127). 

The first column identifies the character as you would enter it on 
a VT300-, VT200-, or VTl 00-series terminal or as you would see it 
on a printer (except for the nonprintable characters). The second 
half of each column identifies. the character by the binary value 
of the byte; the value is stated in three radixes: octal, decimal, 
and hexadecimal. For example, the letter A has a storage value 
of hexadecimal 41 (a bit configuration of 01000001 ), equivalent to 
101 in octal notation and 65 in decimal notation. 
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Figure 7-1 DEC Multinational Character Set, Part I 

Column 0 1 2 3 4 5 6 7 
b8 Bits 0 0 0 0 0 0 0 0 

b7 0 0 0 0 1 1 1 1 
b6 0 0 1 1 0 0 1 1 

b5 0 1 0 1 0 1 0 1 
Row b4b3b2b1 

0 20 40 60 100 120 140 160 
0 0 0 0 0 NUL 0 DLE 16 SP 32 0 48 @ 64 p 80 96 p 112 

0 10 20 30 40 so 60 70 
1 21 41 61 101 121 141 161 

1 0 0 0 1 SOH 1 DC1 17 I 33 1 49 A 65 Q 81 a 97 q 113 
1 11 21 31 41 S1 61 71 
2 22 42 62 102 122 142 162 

2 0 0 1 0 STX 2 DC2 18 .. 34 2 so B 66 R 82 b 98 r 114 
2 12 22 32 42 S2 62 72 
3 23 43 63 103 123 143 163 

3 0 0 1 1 ETX 3 DC3 19 # 36 3 j1 c 67 s 83 c 99 s 11S 
3 13 23 43 53 63 73 
4 24 44 64 104 124 144 164 

4 0 1 0 0 EOT 4 DC4 20 $ 36 4 S2 D 68 T 84 d 100 t 116 
4 14 24 34 44 54 64 74 
5 2S 45 65 105 12S 145 165 

5 0 1 0 1 ENQ s NAK 21 °lo 37 5 S3 E 69 u 8S e 101 u 117 
s 1S 2S 35 45 S6 65 7S 
6 26 46 66 106 126 146 166 

6 0 1 1 0 AOC 6 SYN 22 & 38 6 S4 F 70 v 86 f 102 v 118 
6 16 26 36 46 S6 66 76 
7 27 47 67 107 127 147 167 

7 0 1 1 1 BEL 7 ETB 23 39 7 55 G 71 w 87 g 103 w 119 
7 17 27 37 47 S7 fi7 n 
10 30 so 70 110 130 1SO 170 

8 1 0 0 0 BS 8 CAN 24 ( 40 8 S6 H 72 x 88 h 104 x 120 
8 18 28 38 48 58 68 78 
11 31 51 71 111 131 1S1 171 

9 1 0 0 1 HT 9 EM 25 ) 41 9 S7 I 73 y 89 I 105 y 121 
9 19 29 39 49 S9 69 79 
12 32 52 72 112 132 152 172 

* 10 1 0 1 0 LF 10 SUB 26 42 : 58 J 74 z 90 I 106 z 122 
A 1A 2A 3A 4A SA 6A 7A 
13 33 53 73 113 133 153 173 

11 1 0 1 1 VT 11 ESC 27 + 43 ; S9 K 7S [ 91 k 107 { 123 
B 10 20 30 40 SB 60 70 
14 34 54 74 114 134 154 174 

12 1 1 0 0 FF 12 FS 28 ' 44 < _g_g L 76 \ ~I l°l I 124 
c 1C 2C 4C 7C 
1S 35 S6 7S 11S 135 1S6 17S 

13 1 1 0 1 CR 13 GS 29 - 45 = 61 M n ] 93 m 109 } 12S 
0 10 20 30 40 so 60 70 
16 36 S6 76 116 

II 
136 1S6 176 

14 1 1 1 0 so 14 RS 30 46 > 62 N 78 94 n· 110 - 126 
E 1E 2E 3E 4E SE 6E 7E 
17 37 S7 n 117 137 1S7 1n 

15 1 1 1 1 SI t us 11 I jt ? ~ 0 : - _: 0 ~ DEL Yl 
Key j.--c0Coc1es---1"4--------1AS'&1=1c)--------

Charaderl ESC I ~! I~ 
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Figure 7-2 illustrates the second half of the DEC Multinational 
Character Set (characters with decimal values 128 through 255). 
The first half of each of the numbered columns identifies the 
character as you would see it on a VT300- or VT200-series 
terminal or printer (these characters cannot be output on a 
VTl 00-series terminal). 



Figure 7-2 DEC Multinational Character Set, Part II 

8 9 10 11 12 13 14 15 Column 

1 1 1 1 1 1 1 1 b8 Bits 
0 0 0 0 1 1 1 1 b7 

0 0 1 1 0 0 1 1 b6 
0 1 0 1 0 1 0 1 b5 

b4b3b2b1 Row 

~~~I DCS ~I ~60 . m A ~g~ ~~g a ~~~· ~ro1 0 0 0 0 0 
80 90 AO BO co DO E() FO 

m 221 r:~ m A m N 
321 341 ·~:~ PU1 145 I ± 209 a 22S n 0 0 0 1 1 

81 91 A1 B1 C1 01 E1 F1 

~~~ PU2 ~~I ¢ ~~~I z ~~~I A ~~~ 6 ~~~I a g~~I 0 m 0 0 1 0 2 
82 92 A2 B2 C2 02 E2 F2 

~g~ STS ~~~I £ ~~I 3 ~~! A ~g~ 6 m1 A ~~I 6 ~~ 0 0 1 1 3 
83 93 t>:3 B3 C3 03 E3 F3 

IND ~~ CCtl ~=I ~:i m A ~~ 0 ~~~· A ~:1 6 ~~I 0 1 0 0 4 
84 94 A4 B4 C4 04 E4 F4 

NB. ~~ MN m1 ¥ ~~I IJ m1 A ~g~ 0 ~~~I a ~~I 0 ~~ 0 1 0 1 5 
as 9S A5 BS cs OS ES FS 

SSA ~: SPA ~~g1 ~:1 11 ~=I IC ~~~ 0 ~~~I m ~;g1 0 ~: 0 1 1 0 6 
86 96 A6 B6 C6 06 E6 F6 

ESA ~g~ EPA ~~~ § m m c ~ CE 1~~ Q g;~ CB g:~ 0 1 1 1 7 
87 97 A7 B7 C7 07 E7 F7 

HTS ~~g ~;~ D ~~I ~~I E ~ 0 ~g1 e ~~~I liJ g: 1 0 0 0 8 
88 98 M B8 ca 08 ES F8 

HTS -m- m © 1: 1 Ws E 1i1 (J ~~ e ~ u ·~~ 1 0 0 1 9 
89 99 A9 B9 C9 09 E9 F9 
212 232 ~~~I ~~~ ~ ~~~ (J 

332 ~~I ~~~ VTS 138 154 I R 21S 6 u 1 0 1 0 10 
SA 9A AA BA CA DA EA FA 

PLO ~~g CSI ~fs « m1 .. m1 E 1:i~ 0 ~g1 6 g~1 (l g~~ 1 0 1 1 11 
88 9S AB BB CB DB EB FB 

PLU ~!~ ST ~rs ~ v.. m1 i ~~ 0 ~~~I l ~rs1 Q ~~~ 1 1 0 0 12 
SC 9C AC BC cc DC EC FC 

RI m osc ~~~I ~~~I Yz m1 i ~~~ '( ~~I I ~~~I 9 ~~ 1 1 0 1 13 
80 90 AD BO CD DD ED FD 

~ 236 ~: m i 316 336 ~ ~ SS2 PM 158 206 222 r 1 1 1 0 14 
SE 9E AE BE CE DE EE FE 

SS3 
~ APC ~;~ m m i ~~~ B ~~ i ~~~ ~ 1 1 1 1 15 143 l. 
SF 9F AF BF CF OF EF FF 

j.-c1 Codes--9N-------(DEC Su~~~;~Graphic) ______ _ 
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UPSS ISO Latin 1 
You can override the DEC Multinational Character Set by clicking 
on the UPSS ISO Latin 1 option. This causes the International 
Standards Organization (ISO) Latin 1 Character Set to be used. 
Figure 7-3 illustrates the ISO Latin 1 Supplemental Character 
Set. 
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Figure 7-3 ISO Latin 1 Supplemental Character Set 

8 9 10 11 12 13 14 15 Cok.lmn 

1 1 1 1 1 1 1 1 b8 Bits 
0 0 0 0 1 1 1 1 b7 

0 0 1 1 0 0 1 1 bS 
0 1 0 1 0 1 0 1 b5 

b4b3b2b1 Row 

m1 DCS ~~I NBSP ~~ 0 ~~ A ~gg1 f) ~ a ~ (> ~~I 0 0 0 0 0 
80 90 AO BO co DO E-0 FO 
201 221 241 2S1 

A 
301 

ti! 
321 341 3S1 

129 PU1 14S I 1S1 ± 1n 193 209 a ~~s n 241 0 0 0 1 1 
81 91 A1 B1 C1 01 F1 
202 222 242 2S2 

A 
302 

0 
322 342 362 

130 PU2 14S ¢ 162 2 178 194 210 4 22S C) 242 0 0 1 0 2 
82 92 A2 B2 C2 02 E2 F2 
203 223 243 

3 
263 

A 
303 

6 
323 343 363 

131 STS 147 £ 163 179 19S 211 A 227 6 243 0 0 1 1 3 
83 93 A3 B3 C3 03 E3 F3 
210 224 244 264 

A 
304 

0 
324 344 364 

IND 132 CCH 148 1:1 164 180 19S 212 A 228 6 244 0 1 0 0 4 
84 94 M B4 C4 04 E4 F4 

~gg, 22S 24S ~~~I A 
30S 

0 
32S 34S 365 

NEL flNi 149 ¥ 165 IJ 197 213 a 229 6 245 0 1 0 1 5 
as 95 A5 BS cs OS ES FS 
20S 22S 

I 
24S 266 30S 

0 
32S 346 366 

SSA 134 SPA 150 166 11 182 IE. 198 214 IB 230 6 24S 0 1 1 0 6 
as 96 

I 
AS BS cs OS ES FS 

207 227 247 2S7 307 m ~~~I ~~~ ESA 13S EPA 151 § 1S7 183 c; 199 x c; + 0 1 1 1 7 
87 97 A7 B7 C7 07 E7 F7 
210 230 .. 2SO 270 

E 
310 330 ~gg ~~ HTS 13S 1S2 168 . 184 200 ((J 21S e fJ 1 0 0 0 8 

88 98 A8 B8 ca 08 ES FS 
211 231 2S1 271 

E 
311 u 331 3S1 371 

HTS 137 153 © 1S9 1 18S 201 217 e 233 u 249 1 0 0 1 9 
89 99 A9 B9 C9 09 E9 F9 
212 232 252 m ~ 312 u ~~ ~~ ~~~ VTS 138 154 I 170 II 302 6 u 1 0 1 0 10 
BA 9A AA BA CA DA EA FA 
213 233 253 273 

E 
313 

0 
333 353 m DLP 139 CSI 15S " 171 » 187 203 219 6 23S Q 1 0 1 1 11 

SB 98 AB BB CB OB EB FB 
214 234 254 274 

i 
314 

0 
334 354 374 

PLU 140 ST 15S .., 172 v.. 188 204 220 I 236 0 252 1 1 0 0 12 
SC 9C AC BC cc DC EC FC 
21S ~~f ~~ ~~~I f 31S y ~~ ~~fl ~~ RI 141 osc - * 205 f y 1 1 0 1 13 
80 90 AO BO co 00 ED FD 
21S 236 2SS 276 

i 
316 33S 35S 37S 

SS2 142 PM 158 ® 174 ~ 190 20S I> 222 r 238 I> 254 1 1 1 0 14 
SE 9E AE BE CE OE EE FE 
217 237 ~~~ ~~I i 317 337 357 Ws SS3 143 APC 159 - I. 207 B 223 i 239 9 1 1 1 1 15 
SF 9F AF BF CF OF EF FF 

j.-c1 Codes--------iSOLatin-1 ~~ntal Graphic _____ _ 
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Note To use these character sets you must set the Character Set mode 
option to 8-Bit Characters. 
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8-Bit Multinational Characters 
Normally, the character mode is set to 8 bits for use with the DEC 
Supplemental or ISO Latin 1 Supplemental Character Set. 

7-Bit NRCS Characters 
To use National Replacement Character Sets, click on the 7-Bit 
NRCS Characters mode option. This option lets DECterm operate 
in 7 -bit mode, using the national character set selected in the 
7-Bit NRCS dialog box. The default is the 8-bit Multinational 
Character Set. Figure 7-4 shows the characters in each NRC set 
that differ from the ASCII set. 



Figure 7-4 National Replacement Character Sets 

National Replacement Character Sets 

Character 
Set 2/3 4/0 5/11 5/12 5/13 5/14 5/15 6/0 7/11 7/12 7/13 7/14 

ASCII 

United 
Kingdom 

Dutch 

# @ 
£ @ 

£ 3A y 'Y2 

I\ 

I\ 

I\ 

Finnish # @ A o A 0 
French 

French 
Canadian 

£ a c; § I\ 

# a a c; 

German ·# § A o 0 I\ 

Italian £ § c; e A 

Norwegian/ # @ If:. 0 A A 

Danish 

Portuguese # @ 

Spanish £ § 

Swedish # E 
Swiss U a 

VT300 Mode, 8-Bit Controls 

0 /\ 
;. /\ 

A 0 
e 

' 
' 

' f % 

e a o a 
' e u e 
o e u e 

' a o u 
u a o e 
' m s a 

, a c; 

' ' 
e a o 
o a o i.i 

i.i 

B 

c; 

i.i 
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Normally, DECterm emulates a VT300-series terminal, using 
7-bit control characters (codes 0 to 31). You can change this to 
VT300 Mode with· 8-bit control characters by clicking on the 
VT300 Mode, 8-Bit Controls option. This causes DECterm to 
translate 8-bit control characters (codes 128 to 159) for function 
keys, for example, CSIA for the up arrow key. Not all applications 
understand 8-bit control characters. 

VT300 Mode, 7-Bit Controls 
Normally, DECterm operates in VT300 mode with 7-bit control 
characters. This means that function keys are transmitted in 7-bit 
form, for example, ESC OA for the up arrow key. 

VT100 Mode 
You can override the VT300 Mode 8-Bit Controls option by clicking 
on the VTl 00 Mode option. This causes DECterm to emulate a 
VTl 00 terminal. 
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VT52Mode 
You can override the VT300 Mode, 8-Bit Controls option by 
clicking on the VT52 Mode option. This causes DECterm to 
emulate a VT52 terminal. 

Customizing a Keyboard 
Choose Keyboard... from the Customize menu to set keyboard 
features. DECterm displays a dialog box. 

DECterm: Keyboard [PJ] II] 

Ill Waming Bell 
0 Margin Bell 
Ill Auto Repeat 
III Ctrl-Q, Ctrl-S = Hold 

• <XJ Delete 
O <XJ Backspace 

• Comma Key Sends ,, 
O Comma Key Sends ,< 

• Tilde Key Sends ' .. 
O Tilde Key Sends ESC 

• Angle Brackets Key Sends <> 
O Angle Brackets Key Sends • .. 

ICOKJI I Apply I I cancel I 
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From the Keyboard dialog box, you can set the following keyboard 
features: 

Warning Bell 
Normally, the keyboard warning bell rings when errors occur. 
Clicking on the Warning Bell option turns off the warning bell. 

Margin Bell 
Normally, the margin bell does not ring when the cursor reaches 
the right margin. You can cause it to ring by clicking on Margin 
Bell. 

Auto Repeat 
Normally, continuing to press a key causes the character to be 
displayed repeatedly. Clicking on the Auto Repeat option causes 
only one character to be displayed. 

Ctrl-Q, Ctrl-S = Hold 
Normally, pressing Ctrl/S causes the display to stop scrolling, and 
pressing Ctrl/Q causes the display to resume scrolling. 

<KI Delete 
Normally, the <KI key functions as a delete key. 



~Backspace 
You can override the ~ Delete default by clicking on the ~ 
Backspace option. This causes the ~ key to function as a 
nondestructive backspace key. 

Comma Key Sends ,, 
On the North American and Dutch keyboards, the Comma Key 
Sends ,, option is set. This causes a comma ( , ) to be displayed 
when you press the comma key, whether or not the key is shifted. 

Comma Key Sends,< 
On the North American and Dutch keyboards, you can override 
the Comma Key Sends ,, default by clicking on the Comma Key 
Sends ,< option. This causes a comma (,) to be displayed when 
you press the comma key shifted, and a left angle bracket ( <) to 
be displayed when you press the comma key unshifted. 

Tilde Key Sends '-
On the North American and Dutch keyboards, the Tilde Key 
Sends ' - option is set. This causes the ' - key to display a left 
single quotation mark (') when unshifted and a tilde ( - ) when 
shifted. 

Tilde Key Sends ESC 
On the North American and Dutch keyboards, you can override 
the Tilde Key Sends'- default by clicking on the Tilde Key Sends 
ESC option. This causes the'- key to function as an escape (ESC) 
key. 

Angle Brackets Key Sends <> 
On the North American and Dutch keyboards, the Angle Brackets 
Key Sends <> option is set. This causes the angle bracket key to 
display a left angle bracket ( <) when unshifted and a right angle 
bracket ( > ) when shifted. 

Angle Brackets Key Sends '-
On the North American and Dutch keyboards, you can override 
the Angle Bracket Key Sends <> default by clicking on the Angle 
Brackets Key Sends '- option. This causes the <> key to display 
a left single quotation mark ( ' ) when unshifted and a tilde ( - ) 
when shifted. 
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Choosing a National Replacement Character Set 
Choose 7-Bit NRCS Selection ... from the Customize menu to 
choose a National Replacement Character Set (NRCS) that 
corresponds to your keyboard. DECterm displays a dialog box. 

The NRCS selection is used·only with the 7-Bit NRCS Character_ 
option in the General dialog box. Normally, to use a 7 -bit national 
character set you need to choose the corresponding keyboard in 
the Session Manager and also select the 7-bit NRCS in DECterm. 

DECterm: 7-Bit NRCS Selection ~-

North American 

Flemish 

Canadian (French) 

British 

Danish 

Finnish 

Austrian/German 

Dutch 

Italian 

Swiss (French) 

IL2KJI 
I Apply I 
l cancel I 
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You can select the following character sets and corresponding 
keyboards (see Appendix B for the keyboard illustrations): 

North American 

Flemish 

Canadian (French) 

British 

Danish 

Finnish 

Austrian/German 

Dutch1 

Italian 

Swiss (French) 

Swiss (German) 

Swedish 

Norwegian 

Belgian/French 

Spanish 

Portuguese 

1 Selecting the Dutch NRCS is the same as selecting the North American NRCS. 
The Dutch NRCS is not supported. 



Customizing Graphics 
Choose Graphics ... from the Customize menu to modify DECterm 
graphics features such as color map entries. DECterm displays a 
dialog box. 

Customize Graphics ~II 

Ill Share Color Map Entries 
Ill Enable Backing Store 
D Report Macrograph Contents 

ii OK II I Apply I I cancel I 

I 2!Bit Planes 
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From the· Graphics dialog box, you can customize the following 
graphics features: 

Share Color Map Entries 
Normally, this option is enabled on single-plane and true color 
systems and disabled on GPX systems. Clicking on this option 
prevents DECterm from allocating color map entries for its 
exclusive use. Instead, DECterm allocates shared, read-only 
colors out of the default color map. This means that DECterm 
does not need to create a private color map (which would prevent 
the windows from displaying in their true colors), but it also 
means that DECterm colors may not match the colors used on a 
real terminal. 

Enable Backing Store 
Normally, the Enable Backing Store option is on, causing 
DECterm to redraw graphics after the window has changed. 
Disabling this option improves performance. 

Report Macrograph Contents 
Normally, DECterm does not respond to a request by an 
application to report macrograph contents. Clicking on this 
option enables ReGIS commands to report macrograph contents. 
This feature may risk security in some environments. When 
reporting is complete, disable this feature. See the DECterm 
Graphics Programming Manual for detailed information about 
macrographs. 
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2-Bit Planes 
You can choose the number of colors available in ReGIS and sixel 
graphics by entering the number of planes supported by your 
system. With 2-bit planes DECterm can display four different 
colors at the same time; with 4-bit planes DECterm can display 
16 colors. 

Normally, DECterm uses 2-bit planes on 4-plane systems and 
4-bit planes on all other systems. This reduces the probability 
that DECterm must create a private color map. 

Applications written for the VT240 terminal require only 2-bit 
planes, while applications written for the VT340 terminal may 
require up to 4-bit planes. 

Saving and Restoring Customized Features 
Once you modify DECterm settings, you can save yQur changes. 
When you save your changes, DECterm uses these settings each 
time you create a DECterm window. If you change your mind 
and want to.use the settings that came with your system, you can 
restore the defaults. 

To save customized settings: 

• Choose Save Current Settings from the Customize menu for 
routine saving of customized features. 

• Choose Save Current Settings As... from the Customize menu 
when you want to save the current customized features with a 
new or different file name. DECterm displays a dialog box. 



DECterm: Save Current Settings As ~-

File Filter 

I DECW$USER_DEFAUL TS:DECW$TERMINAL_*.DATi 

Select Name For Configuration File: 

¢I I IJ i> 

Selection 

0 

~ 
0 
D 

I Filter I 
II OK II 
I eance1 I 

I DISK$:[JONES]DECW$TERMINAL DEFAULT.DAT;f 
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The dialog box prompts you for the name of the file you want 
to use to save your customized features. The file list box 
displays the names of any files in the current directory that 
contain customized features. By default, these files have the 
type DAT. 

To use a file name that is not listed, enter the name of that 
file in the Selection text field and click on the OK button. 

To restore customized settings: 

• Choose Use Last Saved Settings from the Customize menu to 
restore an existing file. 

• Choose Use System Defaults from the Customize menu to 
restore the system defaults. 

• Choose Use Saved Settings From... from the Customize menu 
to restore previously saved settings. DECterm displays a 
dialog box. 
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DECterm: Use Saved Settings From [pJll 

File Filter 

I DECW$USER_DEFAUL TS:DECW$TERMINAL_*.DATI 

Select Configuration File: 

0 

~ 
I Filter I 
COK] 
I cancel I 

l2. 
¢1 ~ IJ i> D 
Selection 

I DISK$:[JONES]DECW$TERMINAL DEFAULT.DAT;! 
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The dialog box prompts you for the name of the file you want 
to use to save your customized features. The file list box 
displays the names of any files in the current directory that 
contain customized features. By default, these files have the 
type DAT. Double click on the file name of the file you want to 
use. 

Or, use the File Filter text field to list a subset of files you can 
then select from. For example, to display all files in another 
directory with the file type DAT, type the complete directory 
specification-[JONES.CUSTOMIZEJ*.DAT-in the File Filter 
text field and click on the Filter button. Then double click on 
the name of the file you want to use. 

Copying Information 
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Choose the Edit menu to copy information within or between 
terminal windows. 

Paste 

Select All 

ZK-0171A-GE 



To copy information: 

Select the information you want to copy by pressing and 
holding MBl, dragging the pointer over the information, and 
releasing MBl. Or, choose the Select All menu item from the 
Edit menu to copy the entire display. 

The selected area is highlighted. 

2 Choose the Copy menu item from the Edit menu to store the 
copied information. 

3 Click on the area where you want to place the information. 

4 Choose the Paste menu item from the Edit menu. 

The selected information is copied to the new location. 

Clearing and Resizing Terminal Windows 
From the Commands menu, you can clear or resize the terminal 
window. 

Clear Lines Off Top 

Clear Display 

Resize Window 

Clear Communications 

Reset Terminal 

Quit 

Clear Lines Off Top 
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You can erase information stored in the transcript by choosing 
the Clear Lines Off Top menu item. The transcript is an area of 
memory that contains the last saved lines of your screen display 
(use the Display dialog box to change the size of the transcript). 
You can read it by using the scroll bars. The transcript exists as 
long as the Record Lines Off Top option in the Window dialog box 
is in effect. Normally, Record Lines Off Top is on. 

Clear Display 
You can clear all information displayed in a terminal window by 
choosing the Clear Display menu item. 
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Resize Window 
Choose the Resize Window menu item to resize the window to 
match the size (number of rows and columns) of DECterm. 

Clear Communications 
Choose the Clear Communications menu item to reset the 
communications buffers. This causes DECterm to read data to the 
host system even when DECterm has received an XOFF signal. 

Reset Terminal 
Enabling Reset Terminal causes a Soft Terminal Reset (STR). For 
detailed information about Soft Terminal Reset, see the DECterm 
Text Programming Manual. 

Choosing Reset Terminal also restores the default color map. On 
a 4-plane system such as the VS2000/GPX, displaying ReGIS 
or sixel graphics causes DECterm to create and load its own 
hardware color map, so that other windows do not display in their 
true colors when the DECterm window has input focus. 

To restore the default hardware color map, first erase the graphics 
from the window by choosing the Clear Display menu item from 
the Commands menu, and then reset the terminal with the Reset 
Terminal menu item. 

Normally, DECterm emulates only 2 planes of graphics on a 
4-plane system; therefore, DECterm usually does not create a 
color map. 

Composing Characters 
Use compose sequences to create special characters. A compose 
sequence is a series of keystrokes that creates characters that do 
not exist as standard keys on your keyboard. You can create any 
character from the character set DECterm is currently using. (For 
more information about choosing a character set, see the section 
Customizing DECterm.) 

For more information about composing characters, see 
Appendix A. 

Note You must simultaneously press the Compose key and space bar to 
begin a compose sequence. 
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Exiting from DECterm 
Choose Quit from the Commands menu or enter the LOGOUT 
command to exit from DECterm and close the DECterm window. 
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8 
Using EVE 

The Extensible VAX Editor (EVE) is a powerful, general-purpose 
editor created with the VAX Text Processing Utility (VAXTPU). 
Using EVE, you can create and edit text files such as business 
letters, technical documents, and program source files. 

There are three ways to execute EVE commands-menus, typed 
commands, and defined keys, including either the EDT keypad 
or WPS keypad. This chapter focuses on executing commands 
from menus. For more information about defining keys and using 
typed commands, see online help in EVE, the VMS EVE Reference 
Manual, or the Guide to VMS Text Processing. 

If you are already familiar with EVE on character cell terminals, 
you can use the same editing methods with EVE on VMS 
DECwindows. For example, you can type commands and use 
defined keys, as well as using the mouse and menus. The only 
EVE commands that do not work on DECwindows are ATTACH, 
SPAWN, and SPELL. For more information, see EVE help on New 
Features. 

This chapter describes how to 

• Begin an editing session 

• Enter text, execute EVE commands, and get online help 

• Move the cursor 

• Edit text 

• Search for and replace text 

• Format text 

• Save your edits 
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• View and edit two or more files in the same session 

• Define keys, including setting the EDT or WPS keypad, and 
save definitions in a section file 

• Set and save attributes to customize EVE 

Beginning Your Editing Session 
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To begin an EVE editing session: 

Select the file in File View you want to edit. 

If you do not select a file before starting EVE, EVE creates an 
empty buffer called MAIN. 

2 Choose Edit from File View's Files menu. File View displays a 
dialog box. 

3 Click on OK to specify EVE as your editor, because EVE is the 
default choice. 
If you have not selected a file in File View, you can enter the 
name of the file you want to edit in the Files text entry field. 
Click on Hide This Dialog if you do not want the dialog box to 
appear when you start EVE from File View. 
After you click on OK, FileView displays the VAX.TPU dialog 
box. 

4 Modify the settings if you like, and click on OK. 
This dialog box contains options that are primarily of interest 
to users writing VAXTPU procedures. You do not need to 
modify these options to use EVE. For more information about 
·the VAXTPU dialog box, see the section Setting VAX.TPU 
Preferences. 
Click on Hide Dialog if you do not want this dialog box to 
appear when you start EVE from File View. 

The EVE screen layout is displayed on your screen in its own 
window. 



Main Window' 

Command Window 
Message Window 

0End of File) 

,-status Line 
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The main window shows the buffer you are editing. A buffer 
is an area of computer memory for storing or manipulating 
data-in other words, a buffer comprises your workspace. If you 
are creating a new file or if you did not specify a file when you 
invoked EVE, the buffer is empty and you see the [End of File] 
marker in the upper left corner. You can split the main window 
into two or more smaller windows to view or edit different files or 
different parts of the same file. 

The status line shows information about the buffer you are 
viewing or editing-the name of the buffer, its status (Read-only 
or Write), the mode for entering text (Insert or Overstrike), 
and the direction for searches and other operations (Forward or 
Reverse). Each field in the status line can be changed by clicking 
on it with MBl. For example, clicking MBl on the buffer name 
returns to your next buffer. Clicking on the mode or direction 
toggles that setting. 

The command window is a single line where you type EVE 
commands. Pressing the Do key moves the cursor to the command 
window, and EVE then prompts you to type a command. The 
Command: pronipt appears just below the status line when you 
press the Do key. 

The message window is a single line where some EVE messages 
appear, such as a confirmation message when you set the margins. 
It is the bottom line in the EVE screen. 
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New 

Open Selected 

.?~~.·:: ....... . 
Include ... 

Save File 

Save File As ... 

Exit 

Quit 
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Opening a File 
When you begin an editing session, you can select the name of the 
file you want to edit in File View or type the file name in the dialog 
box you get when you choose Edit from File View's Files menu. 
If you do not supply a file name, EVE creates an empty buffer 
named MAIN. You can then begin typing and specify the file name 
on writing the buffer or on exiting. 

If you did not specify a file when you invoked EVE, or if you want 
to edit a different file in the same session, do the following steps: 

Choose Open... from the File menu. 
EVE displays a dialog box, asking you for the name of the file 
you want to edit or create. 

File Filter 

Open File: 

0 Fiiter 

~ 
OK 

Q 

<H to 

Enter New File Name 
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2 Type the name of the file-for example, TESTFILE.TXT and 
press I Return I or click on OK. 

EVE copies the specified file into a buffer and displays it in the 
main window. The buffer has the same name as the file, unless a 
buffer already exists that has the same name, in which case EVE 
prompts you to enter a new name. 

For more information about specifying files for editing, see the 
section Viewing· and Editing More Than One File. 



Entering Text 
To enter text, type characters from the keyboard. The cursor 
marks the current insertion point-the location at which the next 
character will appear or where an editing operation will occur. If 
you make a typing mistake, press the <Kl (Delete) key to erase the 
previous character. 

With EVE, you can use two different modes for entering text-­
insert mode and overstrike mode. 

With insert mode, as you type, new characters push existing text 
to the right. This is the default setting. 

With overstrike mode, each character you type replaces the 
character at the current position; using the ~ key replaces the 
previous character with a space. Overstrike mode is useful for 
correcting spelling errors or for editing column-aligned text. 

The current mode of the buffer is always shown in the status 
line. To change the mode of the buffer, click MBl on Insert or 
Overstrike in the status line (you can also press Fl 4 or Ctr I/ A). 

Moving the Cursor and Scrolling 
You can move the cursor by pointing with the mouse and clicking 
MBl or by using the scroll bars. You can also move the cursor by 
pressing the arrow keys. Holding down an· arrow key moves the 
cursor continuously in the direction of the arrow. 

There are two types of cursor motion you can use-free cursor 
and bound cursor. A free cursor enables you to move anywhere 
in the buffer and insert text regardless of whether characters are 
already there. This is the default setting. 

By contrast, a bound cursor follows the shape or flow of your text, 
as in the EDT and WPS editors. For example, if you are at the 
end of a line and press the right arrow key, the cursor moves to 
the start of the next line. 

For information about setting the type of cursor motion, see the 
section Setting Global Attributes. 

You can use invisible markers to mark your current position 
in a buffer so you can return to that location later on. This is 
particularly useful when you are making revisions to a lengthy 
document. 

To mark your current position: 

Pressing MB2 anywhere in the main window, choose Mark ... 
from the pop-up menu. 
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Note that you cannot do this while you have a selection active. 
EVE displays a dialog box. 

Mark ~II 

Mark name: I[ 

II OK II I cancel I 
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2 Type the name of the marker-for example, CHAP ONE, and 
press I Return I or click on OK. 

Later, to return to this location: 

Using MB2, choose Go To... from the pop-up menu. 
EVE displays a dialog box. 

Go To ~-

Goto: I[ 

II OK II I canceil 
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2 In the dialog box, type the marker name. 

Entering EVE Commands 
There are three ways to execute EVE commands-menus, typed 
commands, and defined keys. For more information about typed 
commands, see online help in EVE, the VMS EVE Reference 
Manual, or the Guide to VMS Text Processing. 

To type a command: 

Press !Q2]. 



The cursor moves to the command window and EVE prompts 
you to type a command. 

2 Type a command, such as Set Keypad EDT or Erase Line. 
You can abbreviate the command by using, in most cases, 
the first letter of the command. EVE is not case sensitive 
in interpreting commands. You can use any combination of 
uppercase and lowercase characters in the command line. 

3 Press~ or I Return I to complete the command. 
EVE executes the command or prompts you for further action. 

Getting Help 
EVE provides extensive online help for all menu items, commands, 
and keypad functions. 

To get help, choose. one of the following items from the Help menu: 

• List of Topics 
Displays the list of all EVE commands and other topics. You 
can then type the name of a topic you want help on. 

• Keypad 
Draws a keypad diagram. You can then press a key you want 
help on. Gold key sequences are shown in reverse video. 

• Keys 
Lists all the current key definitions, including control keys 
and Gold key sequences. You can then press a key you want 
help on. 

You can also get help by typing the HELP command and specifying 
a topic. For example, the following command gets help on the Find 
command: 

Command: HELP FIND 

Most help topics have a list of the related commands or other 
topics and a list of any key bindings, including any EDT or WPS 
keypad bindings. If you are viewing help on one topic and want 
to get help on another topic, simply type the name of that topic 
and press Return. If you want to view the list of topics, type a 
question mark (?) and press Return. 

To scroll through a lengthy help topic, press the Next Screen and 
Prev Screen keys. To exit from help and resume editing, press the 
Return key. 
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Editing Text 
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EVE lets you enter, modify, copy, delete, and restore text. In 
addition to the Edit menu, you can use pop-up menus to display 
menu items that let you perform different editing operations. 

Pressing MB2 anywhere in the main window displays a pop-up 
menu appropriate to your particular context. For example, if you 
have selected text, the pop-up menu contains the following menu 
items for operations that involve a select range: 

Reset 
Change Case 
Find Next 
Fill Range 
Cut 
Copy 
Open Selected 
Find Selected 

If there is no text selected, the pop-up menu contains these menu 
items, which do not require a select range: 

Select 
Select All 
Restore 
Find Next 
Fill Paragraph 
Center Line 
Paste 
Replace 
Mark 
Go To 
Include 

Selecting Text 
Selecting text in the buffer lets you perform an editing operation 
on or with that text alone, such as changing the case of letters, 
reformatting a block of text according to new margins, or copying 
a block of text so you can insert it elsewhere. 

To select text, you can choose the Select and Select All menu items 
from the pop-up menu, or you can use mouse clicks as follows: 

• Press MBl and drag the mouse to select a block of text. 

• Click MBl to select an amount of text, as follows: 

2 clicks selects the current word 



Restore [~ 
················· 
cut 
Copy 

Paste 

Replace ... ................. 
Select All 

3 clicks selects the current line 
4 clicks selects the current paragraph 
5 clicks selects all of the current buffer 

To cancel a selection done with mouse clicks, simply move the 
cursor out of the select range. To cancel any selection, choose 
Reset from the pop-up menu or press the Select key. 

After you select text, use MB2 to display a pop-up menu that 
contains the menu items you can use on or with the select range. 
Some of these menu items also appear in the Edit menu, Format 
menu, and other menus. The following is a list of the commands 
and menu items you can use with a select range. For more 
information about these commands, see online help. 

Capitalize Word 
Copy or Store Text 
Cut or Remove 
Fill Paragraph or Fill Range 
Find Selected 
Lowercase Word 
Open Selected 
Reset 
Uppercase Word 

You can also use some EDT and WPS keypad functions with 
selected text, such as the EDT Append key, and you can use 
pending delete. See the section Setting Global Attributes for more 
information about pending delete. See online help and the VMS 
EVE Reference Manual for more information about selecting text. 

Moving Text to Another Location 
You can move a select range by cutting it or copying it and then 
pasting the text elsewhere. To cut and paste text: 

Select the text you want to cut by choosing the Select or Select 
All menu item from the pop-up menu or by using ~ouse clicks. 

2 Choose Cut from the Edit menu. 

3 Put the cursor where you want to reinsert the text and choose 
Paste from the Edit menu. 

Copying text works the same way as cutting, except the selected 
text is not removed from its original location. To copy text, select 
the text you want to copy, choose Copy from the Edit menu, place 
the cursor where you want to insert the text, and choose Paste 
from the Edit menu. 
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Paste 
· ••. . • • • • . • • . • • Restore Character 

~~~~- :·: .. • . Restore Sentence 
Select All 

Text you cut or copy is stored in the Insert Here buffer. If you 
want to transfer text between EVE and other VMS DECwindows 
applications, you must first enable the clipboard. See the section 
Customizing EVE for more information about enabling the 
clipboard. 

Erasing and Restoring Text 
To erase text, you can use the ~ key or select and cut a block 
of text. There are also several typed EVE commands that delete 
text: 

Delete(~) 
Erase Character 
Erase Line 
Erase Start Of Line ( Ctrl/U) 
Erase Previous Word 
Erase Word (Ctrl/J or F13) 

To erase the current word, press the F13 key or Ctrl/J, each of 
which is defined as Erase Word. For more information about 
Erase commands, use online help or see the VMS EVE Reference 
Manual. 

To put back what you erased, pull down the Edit menu, display 
the Restore submenu, and choose the desired menu item on the 
submenu. You can choose one of the following menu items: 

Restore Word 
Restore Selection 
Restore Line 
Restore Character 
Restore Sentence 

Searching for and Replacing Text 

Find Next 

I Find ... 

Wlldcard Find ... 

Find Selected 

.~~?.'~::· ............ . 
Show Wlldcards 

Set Whitespace C-+ 
·s&i ·w1ieic&n;1· · · · · · i:+ 
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To find a string of text in your document: 

Choose Find... from the Search menu. 
EVE displays a dialog box. 



_ ~in_d __ ___ ____ _ _ _ ___ [!i]ll 

Forward Find: l_d_ig_1ta ..... 1I ___ _ 

II OK II I Cancel I 
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2 In the dialog box, type the text string you want to find. 

Use all lowercase to find any occurrence of the string. Use mixed 
case or uppercase to find an exact match. For example: 

You Type EVE Finds 

digital digital 
Digital 
DIGITAL 

Digital Digital 

DIGITAL DIGITAL 

EVE begins the search in the current direction of the buffer 
(forward or reverse), shown in the status line. You can change 
the direction of the buffer by clicking MBl on Forward or Reverse 
in the status line. If the text is found only in the other direction, 
EVE asks if you want to change direction and go there. 

If the text is found, EVE puts the cursor at the beginning of the 
string and highlights the found text. You can then use most of the 
same commands, menu items, and keypad functions on the found 
text that you use on a select range: 

• Case changes, such as Capitalize Word, Lowercase Word, and 
Uppercase Word 

• Copy or Store Text 

• Cut or Remove 

• Fill or Fill Range 

• Find Next 

• Open Selected (if the found range does not cross lines) 

Using EVE 8-11 



8-12 Using EVE 

For example, using Cut removes the found text and stores it in 
the Insert Here buffer or the clipboard, depending on your setting. 
To cancel the highlighting, move the cursor off the found text or 
choose Reset from the pop-up menu. 

To find another occurrence of the same string, choose Find Next 
from the Search menu or press the Find key twice. 

Replacing Strings of Text 
To search for and replace text: 

Choose Replace... from the Search menu. 
EVE displays a dialog box. 

Replace !lJll 

Old String: l._b_u_tte_r..._i ___ _ 

New String: I margarine[ 

0 All 

II OK II 
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2 Type the old string (the text you want to find and replace), 
press the Tab key to move to the New String field, and then 
enter the new string (the text you want to insert in place of 
the old string). 

EVE searches for the old string, starting first in the current 
direction of the buffer. If it is found, EVE highlights the string 
and asks you whether you want to replace it. You respond with 
one of the following by clicking on the appropriate button in the 
dialog box: 

Response 

Yes 

No 

Effects 

Replace this one and search for the next one. (Default 
choice; you need only press the Return key.) 

Skip this one and search for the next one. 



Response 

All 

Last 

Quit 

Effects 

Replace all the occurrences. No further prompting unless 
the search finds the old string in the opposite direction. 

Replace this one and stop here. 

Cancel (skip this one and stop here). 

The case of the old and new strings determines not only what 
EVE searches for (as with the Find command), but also what 
replacement text is used. If both strings are in all lowercase, 
EVE finds any occurrence of the old string, regardless of case, and 
replaces it with the new string, matching the case appropriately. 
For example, if EVE finds a capitalized version of the old string, 
it is replaced by a capitalized version of the new string. If the old 
string contains any uppercase letters, the search and replacement 
are exact (case sensitive). 

Performing Case-Exact Searches 
If you want to find or replace only lowercase occurrences, choose 
Global Attributes... from the Customize menu and click on 
Set Find Case Exact. Then, if you enter a search string in all 
lowercase, EVE searches only for lowercase occurrences, skipping 
occurrences that contain uppercase letters. The setting applies 
to Find, Replace, and Wildcard Find. You can save the setting in 
your section file or command file for future editing sessions. 

Handling Whitespace Characters 
You can modify EVE so that Find commands treat spaces and 
tabs the same (that is, as "whitespace"), and span a line break 
for strings of two or more words. For example, searching for the 
string ''Mark Twain" causes EVE to find all occurrences of the 
string if there is one or more spaces or tabs between the words, or 
if "Mark" is at the end of a line and "Twain" is at the start of the 
next line. 

To cause a search operation to treat both spaces and tabs as 
''whitespace," pull down the Search menu and display the Set 
Whitespace submenu. Choose the Set Find Whitespace menu 
item. The default is Set Find Nowhitespace. 
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Searching with Wildcards 
Wildcard searches let you find a pattern of text. For example, you 
may want to find a string only when it appears at the start of a 
line or find a combination of letters only when they are followed by 
a vowel. You can use either VMS or ULTRIX wildcards, depending 
on your setting. The default setting is VMS. You can modify the 
setting from the Set Wildcards submenu on the Search menu. 

To do a wildcard search: 

Choose Wildcard Find... from the Search menu. 
EVE displays a dialog box. 

Wildcard Find ~II 

Forward Wildcard Find: I August\>31i 

(Currently using VMS-style wildcards.) 

~ OK II I eance1 I 
ZK-0197A-GE 

2 Type the pattern of text you want to find, using both.wildcards 
and literal text. 

To get a list of the available wildcard patterns, choose Show 
Wildcards from the Search menu. 

The following examples show different search patterns, mostly 
using VMS wildcards: 

Pattern 

b%t 

b*t 

Matches 

B or b followed by any single character and a T or 
t, as in: "batch," "between," or "rabbit." A percent 
sign ( % ) matches any single character on a line. 
The ULTRIX equivalent is the period, for example, 
b.t. 

B or b followed by any characters and a T or t on 
the same line, as in: ''blast," "butler," "be still," or 
the strings found by b%t. An asterisk ( * ) matches 
any number of characters on the same line. 



Pattern 

August**31 

August\>31 

Matches 

August 31 separated by any amount of text-tabs, 
spaces, line breaks, or other text characters. 

August 31 split by a line break-that is, "August" 
at the end of one line and "31" at the start of the 
next line. A backslash and right angle bracket 
(\>)match end-of-line; backslash and left angle 
bracket (\ <) match start-of-line. The ULTRIX 
equivalent uses the caret and dollar sign, for 
example, August$31. 

If a matching pattern is found, EVE highlights the found text. 
You can then use commands such as Copy, Fill, Open Selected, 
Remove, and Uppercase Word, just as you would with a found 
range. 

To find another occurrence of the pattern, choose Find Next from 
the Search menu. 

To set the type of wildcards: 

1 Choose Set Wildcards from the Search menu. 

2 Choose either Set Wildcards VMS or Set Wildcards ULTRIX. 

You can also choose the type of wildcards and choose Set 
Whitespace or Set N owhitespace from the Search Attributes 
submenu, which is accessible from the Customize menu. 

Formatting Text -------. Fill Paragraph 

Fill Range 

CenterUne 
ChangaCasa 

Paginate 

Set Margins ... 

Set Paragraph Indent ... 

To format text, you can set the left and right margins, paragraph 
indent, and tab stops. You can also fill text and insert page 
breaks. Margins, paragraph indent, and tab stops are buffer­
specific settings. In other words, you can specify different settings 
for each of your buffers or files. 

From the Format menu, you can perform simple formatting 
operations such as centering the line the cursor is on by choosing 
the Center Line menu item. You can also change the case of 
text by displaying the Change Case submenu and choosing 
the Capitalize Word, Uppercase, or Lowercase menu item. 
Change-case operations work as follows: 

1 On the current select range 

2 On the current found range 

. 3 On the current word 
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According to this hierarchy, a select range has precedence over a 
found range, which in turn has precedence over the current word. 
For example, if you have an active select range consisting of five 
words and you choose Uppercase, every word in the select range 
becomes uppercase-not just the word the cursor is currently on. 

Setting Margins 
To set the margins of the buffer: 

Choose Set Margins... from the Format Menu. 
EVE displays a dialog box. 

Set Margin_s_______ !iJll 

Set Left Margin To: l ..... sl __ . ------

Set Right Margin To: l ... 1 ..... 0{ _____ _ 

~ OK I I Apply I I cance1 I 

ZK-0195A-GE 

2 Click MBl on Set Left Margin or Set Right Margin. 

3 Type the margin setting you want. 

For example, you can set the left margin at column 5 and the 
right margin at column 70. Then, as you type, EVE wraps text 
at the right margin of the buffer and starts new lines at the left 
margin. Existing text is not affected. The default left margin is 1, 
and the default right margin is 79. 

Filling Text 
Filling text causes the maximum number of words to fit on a line, 
based on the current margins of the buffer. This is particularly 
useful to rewrap text after you have erased words or pasted text, 
or if you change the margins. You can fill text that you have 
selected or found or fill the current paragraph. 

To fill a select range or found text: 

1 Select or find the text you want to fill. 

2 Choose Fill Range from the Format menu. 



To fill the current paragraph: 

Put the cursor anywhere on the paragraph you want to fill. 

2 Choose Fill Paragraph from the Format menu. 

"Paragraphs" in EVE are bounded by any of the following: 

• Blank line 

• Top or bottom of the buffer 

• Page break (form feed at the start of a line) 

• DIGITAL Standard Runoff (DSR) command (such as .LE; or 
.HLl) at the start of a line 

• VAX DOCUMENT tag (such as <LE> or <EMPHASIS>) at the 
start of a line 

Setting the Paragraph Indent 
Paragraph indent is the number of spaces you want added to 
or subtracted from the first line of each paragraph you create or 
reformat. For example, in writing a letter, you may want to have 
each paragraph indented five spaces or you may want to use a 
negative indent to create lists. 

To set the paragraph indent: 

~ 1 Choose Set Paragraph Indent... from the Format menu. 
EVE displays a dialog·box. 

Set Paragraph Indent: l"""I _____ _ 

II OK I I Apply I I eance1 I 

ZK-0188A-GE 

2 Type the number of spaces you want to indent new 
paragraphs. 

The paragraph indent is relative to the left margin. For example, 
if you set the left margin to 5 and the paragraph indent to 4, then 
the first line of each paragraph will start at column 9 and the 
remaining lines at column 5. The default is 0, or no indent. 
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If you want a "hanging'' paragraph, such as for making bulleted 
lists, use a negative number. For example, to format lists so that 
the counter or bullet is to the left of the text, you can set the left 
margin to 4 and the paragraph indent to -3. Make each list item 
a separate paragraph (by using blank lines between each item). 
The counter or bullet at the start of each list item will be 3 spaces 
to the left of the left margin; the other lines of a list item will 
begin in column 4. 

If you want no paragraph indent-that is, if you want paragraphs 
to start at the left margin-set the paragraph indent to zero ( 0 ), 
which is the default setting. 

Setting Tabs 
To set tab stops: 

Choose Buffer Attributes... from the Customize Jllenu. 
EVE displays a dialog box. 

2 Type the tab stops you want. 

3 Click MBl on Set Tabs At or Set Tabs Every. 

With Set Tabs At, you can specify the tabs you want at different 
intervals, for example, 5, 9, 16, 24, 31. With Set Tabs Every, you 
specify a single interval for every tab stop. The default tab stops 
are every 8 columns. Setting tab stops changes existing tabs in 
the buffer you are editing. 

You can also set the way tabs appear in the buffer and the tab 
mode, which determines the effects of pressing the Tab key. These 
are global settings, which apply to all buffers. By default, the Tab 
function inserts a tab character, which appears simply as blank 
space, and moves the cursor and any existing text to the right 
until the next tab stop. Setting the tab mode lets you make tab 
characters visible or makes the Tab function insert spaces instead 
of a tab character or move the cursor without inserting anything. 

To set the tab modes: 

Choose Global Attributes... from the Customize menu. 
EVE displays a dialog box. 

2 Click MBl on the tab mode you want-Insert, Movement, or 
Spaces. 
Tab mode does not affect tabs you have already entered. For 
example, setting the tab mode to Spaces does not convert 
existing tab characters to spaces. 



3 If you want visible tabs, click on Set Tabs Visible. 
By default, the Set Tabs Visible option is disabled, which 
causes tabs to be invisible. 

Visible tabs appear as a small JT . Setting tabs visible affects 
only tabs entered with the tab mode set to Insert-that is, 
actual tab characters. 

Setting the tab mode to Movement makes Tab a cursor-moving 
function only, so that pressing the Tab key puts the cursor at 
the next tab stop, without moving your text. Setting the tab 
mode to Spaces makes the Tab function insert the appropriate 
number of spaces rather than a tab character. This is useful if 
you are going to print or display the text on devices that have 
different tab stops, because on most devices the space character 
is a uniform size. If you set the tab mode to Insert, which is the 
default setting, the Tab function inserts a tab character. 

Setting Soft Page Breaks 
You can insert a "soft" page break every 54 lines of a file to 
produce 54-line pages. A soft page break is a form feed followed 
by the null character. It appears as a small FF and small~. 

To insert soft page breaks: 

Choose Paginate from the Format menu. 
This causes EVE to move back from the current cursor 
position to the previous page break (if any) and check ahead 
for page breaks within the next 54 lines. If soft breaks are 
found within the 54 lines, EVE erases them, then moves down 
54 lines (if there are that many), inserts a soft break, and puts 
the cursor on the next line. 

2 Choose Paginate again to continue paginating the buffer. 
If a "hard" page break is found, EVE stops on the line after 
that page break, in case you want to erase it. A hard page 
break is a form feed only, and it can be inserted with the 
INSERT PAGE BREAK command or Ctrl/L. 

With the WPS keypad, you can insert a soft break at your current 
position by pressing Gold-P. 
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Saving Your Edits 

New 

Open Selected 

Open ... 

Include ... 
················· I Save File 

Save File As ... 

Exit 

Quit 
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You can save your edits either when you exit from EVE or by 
choosing Save File from the File menu. The new file has the 
same name as the file you are editing, with a version number one 
higher or with a version number of 1 if you are creating a new 
file. 

If you are editing a buffer that does not have a file in it, for 
example, if you invoked EVE without specifying an input file, EVE 
prompts you for the name of the output file. 

To save your edits under a different file name: 

Choose Save File As... from the Edit menu. 
EVE displays a dialog box. 

Save File As [!;]II 

Save File As: ..... II _____ _ 

II OK II I Apply I I cancel I 

ZK-0190A-GE 

2 In the dialog box, type the name of the file. 
For example, if you are editing a file called ROUGH.DAT, you 
may want to save it as FINAL.TXT. 

To end the editing session, do either of the following steps: 

• Choose Exit from the File menu. 
This saves your edits, creating a new file or new version of an 
existing file. 

• Choose Quit from the File menu. 
This discards your edits. If you made any changes to the 
buffer, EVE asks you to confirm that you want to quit so that 
you wiU not accidentally discard your work. 

If you have made no changes to the buffer or no changes since you 
last saved the file, then exiting and quitting are the same. No 
duplicate files are created. 



Buffer Change Journaling 
Buffer change journaling creates a journal file for each text buffer. 
As you edit a buffer, the journal file records the changes you 
make, such as erasing, inserting, or reformatting text. When you 
exit from EVE or when you delete the buffer, the journal files are 
deleted. If a system failure interrupts your editing session, the 
journal files are saved. Your last few keystrokes before the system 
failure might be lost. 

To recover buffers after a system failure, invoke EVE and use 
the RECOVER BUFFER commands for each buffer you want to 
recover. 

The following table summarizes the EVE commands for buffer 
change journaling and recovery. 

Table 8-1 EVE Commands for Buffer Change Journaling and 
Recovery 

Command 

RECOVER BUFFER 

RECOVER BUFFER ALL 

SET JOURNALING 

SET JOURNALING ALL 

SET NOJOURNALING 

SET NOJOURNALING ALL 

Effect 

Recovers a specified buffer by using 
the journal file for the buffer. You 
can specify the name of the buffer 
or file you want to recover, or the 
name of the journal file for the 
buffer. 

Recovers all your text buffers-one 
at a time-by using the journal files 
for the buffers, if there are any. 

Enables buffer change journaling 
for a buffer that you specify. 

This is the default setting. Enables 
buffer change journaling for all your 
buffers. 

Disables buffer change journaling 
for a buffer you specify. 

Disables buffer change journaling 
for all your buffers. 

The name of the buffer change journal file derives from the 
name of the file or buffer being edited, and has the file type 
TPU$JOURNAL. For example, the text buffer JABBER.TXT 
would have the buffer change journal file name JABBER_ 
TXT.TPU$JOURNAL. To find the name of the journal file for the 
current buffer, use the SHOW command. 
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There are two ways to recover your edits with buffer change 
journal files: using the /RECOVER qualifier on the command line 
when you invoke EVE, or using RECOVER BUFFER commands 
within EVE. For example, to recover the text of JABBER.TXT 
after a system failure, you could invoke EVE with the command: 

$ EDIT/TPU jabber.txt/RECOVER 

Alternatively, you can invoke EVE and use the following command 
to recover your text: 

Command:RECOVER BUFFER jabber.txt 

If the buffer change journal file is available (in this case, a file 
named JABBER_TXT.TPU$JOURNAL), EVE shows the following 
information and asks if you want to recover that buffer: 

Name of the buffer 
Original input file for the buffer, if any 
Output file for the buffer, if any 
Source file for recovery, if any 
Starting date and time of the editing session 
Journal file creation date and time 

If you want to recover the buffer, press Return. Otherwise, type 
NO and press Return. 

If the buffer you want to recover exists-typically, the MAIN 
buffer-EVE first deletes that buffer and then does the recovery. 
If the buffer you want to recover has been modified, EVE prompts 
you whether to delete the buffer before recovering. 

If you are unsure of the buffer names or journal file names, specify 
the asterisk wildcard, as follows: 

Command: RECOVER BUFFER * 

EVE then displays a list of all your available journal files so you 
can choose the one you want. The list appears in an EVE system 
buffer named $CHOICES$ in a second window. 

For more information about buffer change journaling, see the EVE 
online help topic called Journal Files. 

Viewing and Editing More Than One File 
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During your editing session, you can create or edit more than 
one file, and you can view two or more files at the same time 
or different parts of the same file. This is useful if you want to 
compare different versions of a draft, cut and paste between files, 
or refer to a section of a long document while editing another 
section. 



Editing Another File 
To edit or create another file during your editing session: 

Choose Open ... from the File menu. EVE displays a dialog 
box. 

2 Type the name of the file you want to open. 
You can also open a file selected in EVE or in another VMS 
DECwindows application you are running concurrently. To 
open a selected file, choose Open Selected from the File menu. 

Once you open a file, EVE creates a buffer with the same name as 
the file you specified. If the file exists, EVE copies it into the new 
buffer where you can edit the text. If no file of the specified name 
exists, that is, if you are creating a new file, the buffer is empty. 

You can also create another buffer, without opening a file. 
For example, you may want to create additional buffers as 
"scratchpads" or temporary storage areas. To create a new buffer, 
choose New from the File Menu. EVE then creates a buffer named 
MAIN. If there is already a buffer named MAIN, EVE prompts 
you to type a different name for the new buffer. EVE puts the 
new buffer in the current window. 

If you want to save the edits you make in this buffer, choose Save 
File As ... from the File menu and specify the output file you want 
to create, or specify the output file when you exit from EVE. 

Moving Between Buffers 
You can move between buffers, for example, to cut text from one 
buffer and paste it in another or to search for the same string in 
another buffer. 

To move between buffers, click MBl on the buffer name in the 
status line. EVE then puts your next buffer in the current window 
and moves the cursor to your last position in that buffer~ 

To go to any of your buffers: 

Choose Show Buffers from the Display menu. 
EVE shows a list of all the buffers you have created and puts 
the cursor in this list. 

2 Move the cursor to the name of the buffer you want to view 
and choose Select from the pop-up menu or simply press the 
I Return I key. The buffer is displayed. 
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Deleting a Buffer 
To delete a buffer: 

Choose Show Buffers from the Display menu. 

2 Put the cursor on the name of the buffer you want to delete. 

3 Press I Remove I or choose Cut from the Edit menu. 

If the buffer has been modified, EVE displays a dialog box 
prompting you to click on the button to indicate your choice: 

Response 

Delete_only 

Write_first 

Quit 

Effects 

Deletes the specified buffer. 

Saves (writes out) that buffer, then deletes it. 

Cancels the operation-buffer is not deleted. 
(Default choice; you can simply press the Return 
key.) 

Viewing Multiple Files 
If you are editing two or more files in the same session, you can 
split the EVE main window into smaller windows so you can 
view the different files at the same time. You can also use split 
windows to view different parts of the same file, such as when 
editing a very long document, or to view the message buffer, which 
is useful when you are compiling VAXTPU procedures. 

To split the main window into two windows, choose Two Windows 
from the Display menu. To split the window into three or more 
windows: 

Choose Split Window... from the Display menu. 
EVE displays a dialog box. 

Split Window ~II 
~-~-----------------

Number of Windows: ... II-------

II OK I I Apply I I canceil 
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2 Type the number of windows you want. 



Defining Keys 

EVE then divides the main window into smaller, equal-sized 
windows, each with its own status line. The cursor appears in 
the lower or bottommost window. Each window shows the same 
buffer. 

To put a different file or buffer in the current window, use any of 
the following commands: 

Buffer 
New 
Next Buffer or Previous Buffer 
Open or Get File 
Open Selected 
Show Buffers or Show System Buffers 

To move between windows, click MBl where you want to put the 
cursor in another window. 

Note that your position in each window can be different even 
if the same buffer or file appears in different windows. This is 
useful if you want to view different parts of the same buffer or 
file, such as in editing a long document. 

To delete a window, do either of the following: 

• Choose Delete Window from the Display menu. 
EVE then deletes the current window and resizes the 
remaining window or windows accordingly. 

• Choose One Window from the Display menu. 
EVE then deletes all the windows except the current window. 

Deleting windows does not delete the buffers that were in the 
windows. 

EVE lets you define keys using the DEFINE KEY command. 
You can define keys to execute commands you use frequently or 
define keys that you are accustomed to using in another editor or 
application. 

For example, the following command defines the F20 key as 
Center Line: 

Command: DEFINE KEY=F20 CENTER LINE 
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Some keys cannot be defined, such as the Return key. For more 
information about defining keys, see online help for Define 
Key and Names For Keys. For information about using the 
SET FUNCTION KEYS DECWINDOWS command to enable 
DECwindows-style key definitions, see online help for Set 
Function Key DECwindows. 

To show the definition of a key, use the SHOW KEY command. 
You can specify the key by name on the command line, or you 
can let EVE prompt you to press the key you want to show. 
To undefine a key you have defined, use the UNDEFINE KEY 
command. 

Setting the Gold Key 
The Gold key is a key you specify for use with other keys so 
that you double the number of possible key definitions. For 
example, you can define F20 to execute one command and define 
the sequence of Gold and F20 to execute a different command. 
The Gold key is like a shift key in that it enables a key to perform 
a secondary function in addition to its primary function. Unlike 
a shift key, however, which you use by holding down, you press 
and release the Gold key before pressing the key whose secondary 
function you want to use. 

Both the EDT and WPS keypads use several Gold key sequences. 
For example, EDT defines the PF4 key to delete a line and defines 
the Gold-PF4 sequence to restore (or undelete) the line. 

To set the Gold key, use the SET GOLD KEY command. You 
can type the key name on the command line or let EVE prompt 
you to press the key you want to set. For example, the following 
command sets PFl as the Gold key: 

Command: SET GOLD KEY PFl 

You can then define a Gold key sequence, using a function key, 
control key, or typing key. For example, the following command 
defines the sequence of Gold and the letter F as the Fill command: 

Command: DEFINE KEY=GOLD-F FILL 

For more information about setting the Gold key, see online 
help for Set Gold Key. For a list of Gold key sequences that are 
automatically enabled when you set the Gold key or the EDT or 
WPS keypad, see online help on Gold keys. 



Creating a Learn Sequence 
A learn sequence is a series of keystrokes or commands or both 
that you assign to a single key. This is useful for performing a 
series of editing operations or for entering frequently used text. 

To create a learn sequence: 

1 Choose Learn from the Customize menu. 

2 Make the edits you want EVE to learn. 
You can type commands, text, or both, including pressing keys 
already defined. For example, you may want to find a string of 
text or move a certain number of lines and then perform some 
editing operation, such as pasting text or reformatting the 
pa:ragraph. Note that mouse operations, such as using menus, 
are not learned. 

3 To, end or "remember" the learn sequence, press Ctrl/R. 

EVE then prompts you to press the key you want to use for the 
learn sequence. You can press a function key, control key, or Gold 
key sequence, so long as that key has not been used in the learn 
sequence you are creating. If you do not want to remember the 
learn sequence, press the Return key, which cannot be redefined. 

Thereafter, to replay the learn sequence, you need only press that 
one key. EVE then replays the series of keystrokes in a kind of 
"player piano" fashion. 

Before replaying a learn sequence, you may want to check the 
definitions of any keys used within the sequence or any settings 
that apply to them. Learn sequences record keystrokes, rather 
than the key definitions at the time the sequence was created. 
Therefore, if any key definitions or settings used by the learn 
sequence are different from when the sequence was created, the 
sequence will fail or not work as expected. 

Setting the Keypad 
If you are accustomed to the EDT or WPS editor, or if you are 
accustomed to using EVE on VTl 00-series terminals, you can set 
the keypad accordingly. 

For example, to set the EDT keypad, use the Set Keypad EDT 
command. This defines the numeric keypad and some other keys 
to emulate EDT. For example, PFl is set as the Gold key, PF4 is 
defined to delete a line, and Gold-PF4 is defined as Restore Line. 
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To set the WPS keypad, use the Set Keypad WPS command. This 
defines the numeric keypad and some other keys to emulate WPS. 
For example, PFl is set as the Gold key and Gold-R is defined as 
the WPS Ruler key. Also, setting the WPS keypad automatically 
sets the cursor as bound. The WPS keypad functions do not use 
the clipboard. 

If you define keys that otherwise are defined by EDT or WPS, 
your definitions override the EDT or WPS definitions. If you 
subsequently undefine your keys, the EDT or WPS definitions 
are reactivated. Setting the EDT or WPS keypad does not fully 
implement all the EDT or WPS commands or features. For 
example, you cannot type EDT line-mode commands. For more 
information, see the following help topics: 

EDT Differences 
EDT Conversion 
WPS Differences 

Saving Key Definitions in a Section File 
To save your key definitions for future editing sessions, you 
can put the Define Key commands in an initialization file (as 
explained in the section Using Initialization Files) or you can 
create a section file. A section file is a binary file that stores key 
definitions and other extensions (such as any VAXTPU procedures 
you have compiled). Effectively, the section file you create is your 
own customized version of EVE. 

To create a section file: 

Pull down the Customize menu, display the Extend submenu, 
and choose the Save Extended EVE... menu item. 
EVE displays a dialog box. 

Save Extended EVE rJl II 
- -

File to save in:II ... _____ _ 

11 OK m I Apply I 
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2 Type the name of the section file you want to create. 



The default file type for section files is TPU$SECTION. For 
example, if you type MYEVE, you create a section file called 
MYEVE.TPU$SECTION in your current (default) directory. 

A section file is cumulative, saving your latest key definitions and 
compiled procedures and any that were saved in the section file 
you are currently using. You use one section file at a time. 

To use a section file when you invoke EVE, use the /SECTION 
qualifier or define the logical name TPU$SECTION. You must 
specify the disk and directory as well as the name of the 
section file; otherwise, VAXTPU assumes the section file is in 
SYS$SHARE. For example, the following commands invoke 
VAXTPU using a section file called MYEVE.TPU$SECTION in 
your top-level (or login) directory: 

$ DEFINE TPU$SECTION sys$login:myeve 
$ EDIT/TPU/DISPLAY=DECWINDOWS 

You may want to put the definition in your LOGIN.COM file. 

A section file saves key definitions (such as if you set the EDT 
keypad or created a learn sequence) and any VAXTPU procedures 
you compile. However, a section file does not save settings such 
as margins, tabs, and other editing values. Typically, you use 
an initialization file for these settings. See the section Using 
Initialization Files. 

Customizing EVE 

Learn 

Extend [~ 

Extend Menu ... ............................... 
Global Attributes ... 

Buffer Attributes ... 

Search Attributes ... 
······························· 
Set Width ... 

Seve Attributes ... 

Seve System Attributes ... 

You can customize EVE by setting attributes for different kinds 
of editing or by extending the editor with VAXTPU procedures. 
During an editing session, you can set attributes by using the 
Customize menu and other menus or by executing an initialization 
file. You can also set private defaults by using an initialization file 
when you invoke EVE. 

Some editing values are global settings, applying to the editor 
or to all buffers; others are buffer-specific settings, applying to 
particular buffers. For example, tab modes and wildcard patterns 
are global settings; margins and tab stops are buffer-specific 
settings. For more information, see online help for Defaults. 

Some other menus besides Customize also let you set preferences. 
For example, you can set the margins of the buffer by choosing 
Set Margins... from the Format menu and you can set search 
preferences (such as the type of wildcards) by using the Search 
menu. 
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Customizing Menus 
You can add or remove menu items by choosing Extend Menu 
from the Customize menu. Extend Menu displays a dialog box 
containing three list boxes, similar to the Verbs and Menus list 
boxes in File View, and has buttons for adding or removing a menu 
item. Lists show the available commands, the names of EVE 
menus, and the items in a particular menu. The dialog box also 
has entry lines so you can type the name of the command you 
want to add to a menu and the label you want to appear in the 
menu. You can save your menu definitions in a section file or 
command file for future editing sessions. 

To add a menu item using EVE commands, do the following steps: 

1 Enter the DEFINE MENU ENTRY command. 

2 Enter the name of the menu to which you want ,to add an 
item. The menu can be any of the following: 

File Pulldown 
Edit Pulldown 
Search Pulldown 
Display Pulldown 
Format Pulldown 
Customize Pulldown 
Help Pulldown 
Select Popup 
Noselect Popup 

Enclose the menu name in quotation marks or let EVE prompt 
you for the menu name. You need only use the first term of 
the menu name, but you cannot abbreviate this term. 

3 Enter the name of the EVE command you want the menu item 
to execute. Enclose the command name in quotation marks or 
let EVE prompt you for the command name. 

4 Enter the label or name that you want to appear on the menu. 
Put the label in quotes or let EVE prompt you for it. If you 
simply press Return at the prompt, without typing anything, 
the label is the same as the command name. 

5 Enter YES or NO to specify whether you want a separator line 
to appear above the label as a visual aid or for aesthetics. Put 
the response in quotes or let EVE prompt you for it. 



For example, the following command adds Show Buffers to the 
File menu, labeling the item Buffer List, and adds a line separator 
above the item: 

Command: DEFINE MENU "File" "Show Buffers" "Buffer List" "Yes" 

The following command removes Center Line from the pop-up 
menu that is displayed with MB2 when there is no selection: 

Command: UNDEFINE MENU "Noselect" "Center Line" 

To save your menu definitions in a section file, use the SAVE 
EXTENDED EVE command or, if section file prompting is 
enabled, use the SAVE ATTRIBUTES command. To save your 
menu definitions in a command file, use SAVE ATTRIBUTES. 

Setting Buffer Attributes 
From the buffer in which you are currently working, you can set 
buffer attributes, such as tab settings or paragraph indent, that 
apply only to that buffer. You can specify different buffer settings 
for each individual buffer during an EVE session. Note that EVE 
does not save these settings from one session to another unless 
you put the corresponding commands in an initialization file. 

To set buffer attributes, choose Buffer Attributes... from the 
Customize menu. EVE displays a dialog box. 

Settings For Buffer: MAIN 

Set Left Margin To:l.1_ Set Right Margin To:! 79. 

Ill Set Wrap • Set Tabs Every I a 
Ill Set Buffer Modifiable 0 Set Tabs At 

D Set Buffer Read Only 

Set Paragraph Indent: l.9:_ 

I! OK II I Apply I 
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Shaded buttons indicate the current settings. Click MBl on a 
button or its label to change the setting. Click on the OK button 
to apply your changes and close the dialog box. 

From the Buffer Attributes dialog box, you can customize any of 
the following features: 
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Set Left Margin To 
Unless you specify otherwise, the left margin (leftmost column) is 
set to 1. To change the setting, click on the text entry field next to 
Set Left Margin To and type the left margin you want. 

Set Right Margin To 
By default, the right margin is one column less than the width of 
the EVE screen display. For example, if the screen display is 80 
columns, the default right margin is 79. To change the setting, 
click on the text entry field next to Set Right Margin To and type 
the right margin you want. 

Set Wrap 
Normally, word wrap is set, which means that as your text reaches 
the right margin of the buffer, EVE automatically wraps the text, 
starting a new line, without your having to press the Return key. 
To disable Set Wrap, click on it. 

Set Buffer Modifiable 
Unless you specify otherwise, you can modify your buffers during 
an EVE session. If you are working with a buffer that contains 
text you do not want to change inadvertently, you can disable 
the Set Buffer Modifiable option. This overrides the mode of the 
buffer (insert or overstrike) and makes it impossible for you to 
modify the buffer. 'fuming Set Buffer Modifiable on again restores 
the previous mode of the buffer. 

Set Buffer Read Only 
Normally, when you make changes to a buffer during an EVE 
session and then exit, the buffer is saved (written out). If you turn 
on the Set Buffer Read Only option, the buffer will not be saved 
when you exit, even if you have modified it. This is useful if you 
just want to use the buffer as a scratchpad. Turning on Set Buffer 
Read Only also sets the buffer as unmodifiable, but you can then 
turn on Set Buffer Modifiable to produce a buffer that is both read 
only and modifiable. 

Set Paragraph Indent 
By default, the paragraph indent is set to 0. To change the 
setting, click on the text entry field next to Set Paragraph Indent 
and type the value you want. For more information about setting 
the paragraph indent, see the section Setting the Paragraph 
Indent, which describes how to set the paragraph indent from the 
Format menu. 



Set Tabs Every 
By default, the tab stops are set every 8 columns. You can change 
the interval for tab stops by typing the interval you want and 
clicking on the text entry field next to Set Tabs Every. For more 
information about setting tabs, see the section Setting Tabs. 

Set Tabs At 
You can set tab stops at various intervals or columns by typing the 
intervals at which you want tab stops to be used in your buffer 
(for example, 3, 5, 11, 35, 49), and then clicking on Set Tabs At. 
For more information about setting tabs, see the section Setting 
Tabs. 

The attributes you choose apply only to the current editing 
session. If there are settings you want all the time, for example, if 
you always want to have particular left margin tab stops, use an 
initialization file, as explained in the section Using Initialization 
Files. 

Setting Global Attributes 
You can make global changes to EVE, such as setting the cursor 
as free or bound, that will apply to all of your EVE buffers. You 
can save some global settings from one session to the next by 
choosing Save Attributes... from the Customize menu. 

To set global attributes, choose Global Attributes... from the 
Customize menu. EVE displays a dialog box. 

Global Attributes [!;]II 

D Set Find Case Exact Set Cursor: • Free 

D Set Clipboard 
0 Bound 

0 Set Tabs Visible Set Tabs: • Insert 
0 Movement 

D Set Pending Delete o Spaces 

I eance1 I 
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From the Global Attributes dialog box, you can customize any of 
the following features: 
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Set Find Case Exact 
Normally, when you specify a text string that is all lowercase 
in a search operation, EVE finds every occurrence of the string, 
including those that are uppercase or have mixed case. When you 
turn on Set Find Case Exact, however, even when you specify a 
lowercase text string EVE finds only those strings that match it 
exactly. 

Set Clipboard 
By default, the clipboard is not enabled. Turning it on allows you 
to transfer text between EVE and another VMS DECwindows 
application. Alternatively, you can use the Insert Here buffer, 
which is where EVE stores text when you use Copy or Cut from 
the Edit menu, unless the clipboard is enabled (in which case EVE 
stores the text in the clipboard). Using the Insert Here buffer 
can be faster, depending on the amount of text involved and the 
number of other applications you are running concurrently. WPS 
keypad functions do not use the clipboard. 

Set Pending Delete 
Pending delete, which is disabled by default, means that if you 
select text and then press the <R1 key or type new text, the 
select range is deleted. This can be useful for quickly erasing or 
replacing a block of text. 

Set Tabs Visible 
Unless you specify otherwise, the tab characters inserted in your 
buffer are invisible. Turning on Set Tabs Visible causes tabs to 
appear as a small~. See the section Setting Tabs for more 
information about setting tabs. 

Set Tabs 
Normally, the tab mode is set to Insert. This causes the Tab 
function to insert a tab character, which appears as a blank space, 
and move the cursor and any existing text to the right until the 
next tab stop. You can also set the tab mode to Movement, which 
makes the Tab a cursor-moving function only, or Spaces, which 
makes the Tab function insert the appropriate number of spaces 
rather than a tab character. See the section Setting Tabs for more 
information. 

Set Cursor 
Unless you specify otherwise, EVE uses a free cursor. A free 
cursor lets you move anywhere in the buffer and insert text 

,, _p , __ ,,_ - - _,_ - ___ ,_ _____ ---- _, _____ , __ ,_, _____ T'l-----!--.Ll...-
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up and down arrow keys moves the cursor in the same column on 
the screen, regardless of whether there is text in those columns. 

By contrast, a bound cursor follows the shape or flow of your text, 
as in the EDT and WPS editors. For example, if you are at the 
end of a line and press the right arrow key, the cursor moves to 
the start of the next line. 

Setting Width 
You can modify the width of your EVE screen layout. This does 
not affect how many characters you can put on a line (which is 
determined by the right margin), but only how many characters 
are visible. For example, if you have a file that is 132 columns 
wide, setting the screen layout width to 132 lets you view the file 
without shifting the window horizontally. 

To modify the width of your screen layout: 

Choose Set Width... from the Customize menu. 
EVE displays a dialog box. 

2 In the text entry field, type the width you want. 

3 Click on Apply or OK. 

Setting VAXTPU Preferences 
From the VAX Text Processing Utility (VAXTPU) dialog box you 
see when you start EVE from File View, you can set VAXTPU 
preferences. Many of these options are primarily of interest to 
users writing VAXTPU procedures, and you do not need to modify 
them to use EVE. If you do not want to see this dialog box when 
you start EVE from File View, click on the Hide Dialog option. 
Once you hide the dialog box, you can cause it to appear again 
by pressing and holding the Shift key while you choose Edit from 
File View's Files menu. 

VAXTPU is a programmable text processing utility that includes a 
high-level procedural language, a compiler, an interpreter, and an 
editing interface. EVE is an editing interface written in VAXTPU 
that is layered on VAXTPU. By setting VAXTPU preferences, you 
can modify the behavior of EVE. 

These modifications to EVE are called extensions, which can 
be implemented with a VAXTPU command file (VAXTPU source 
code), a VAXTPU section file (compiled VAXTPU code in a binary 
form), or with an initialization file (an ASCII file containing 
commands that are processed by EVE when you start an editing 
session). See the sections Saving Key Definitions in a Section File 
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and Using Initialization Files for more information about section 
and initialization files. For more information about VAXTPU, see 
the section Using VAXTPU Procedures to Extend EVE and the 
VAX Text Processing Utility Manual. 

When you start EVE from File View, the second dialog box you see 
is the VAXTPU dialog box. 

From the VAXTPU dialog box, you can customize any of the 
following features: 

FILE: 
Allows you to specify the input file in the text entry field you want 
to use in your editing session. 

Create 
By default, if EVE does not find the input file you specified, EVE 
creates a file. You can disable this option by clicking on Create, 
which causes EVE to abort the editing session if you specify a file 
that does not exist. 

Display 
Unless you specify otherwise, EVE uses terminal functions such 
as the screen display and the keyboard. You can disable this 
option by clicking on it. This would be useful, for example, if 
you were running VAXTPU procedures in a batch job or using 
VAXTPU on an unsupported terminal. 

Modify 
By default, EVE makes the first user buffer in an editing session 
modifiable, which means that you can make changes to it. You 
can disable this option by clicking on it. Note that any buffers 
you create in the editing session after the first user buffer will 
be modifiable. You can set subsequent buffers as unmodifiable 
from the Buffer Attributes dialog box, which is accessible from the 
Customize menu. 

Write 
Unless you specify otherwise (or quit rather than exit the editing 
session), EVE creates an output file from the current buffer if the 
contents are modified. You can disable this option by clicking on 
it. 

Start Position 
Normally, when you start EVE the cursor is positioned in the first 
row and the first column. You can specify where you want the 



cursor to be when you start an editing session by entering the 
appropriate numbers. 

Command 
By default, EVE looks for a command file (VAXTPU source code) 
with the logical name TPU$COMMAND. You can disable this 
option by clicking on Command, or you can enter the name of your 
own command file. 

Debug 
Unless you specify otherwise, when you start EVE you enter 
an editing session. If you would like to start out in the debugger, 
however, (for example, if you are debugging a VAXTPU procedure), 
you can turn on Debug by clicking on it. Once you turn on Debug, 
EVE looks for a debugger with the logical name TPU$DEBUG, 
but you can specify your own debugger in the text entry field. 

Initialization 
By default, EVE looks for an initialization file (an ASCII file 
containing commands that are processed by EVE when you start 
an editing session) when you begin an editing session. You can 
disable this option by clicking on it. In the text entry field next 
to Initialization, you can enter the name of the initialization file 
you want EVE to execute for your editing session. See the section 
Using Initialization Files for more information. 

Section 
By default, EVE looks for a section file (compiled VAXTPU code 
in a binary form) with the logical name TPU$SECTION. You can 
disable this option by clicking on Section, or you can enter the 
name of your own section file. 

Output 
Unless you specify otherwise, EVE uses the same name for the 
output file that you specified for the input file. When you modify 
a buffer and then exit from EVE, EVE writes the buffer to a file 
with the same name as the input file and assigns the new file 
a version number that is one higher than the highest existing 
version of the input file. You can either specify a different output 
file name in the text entry field next to Output, or you can disable 
the Output option by clicking on it, which means that no output 
file will be created. 
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Hide Dialog 
If you do not want to see this dialog box when you start EVE 
from File View, you can suppress it by clicking on the Hide Dialog 
option. To cause it to appear again, press and hold the Shift key 
while you choose the Edit menu item from File View's Files menu. 

Using Initialization Files 
An initialization file contains EVE commands, typically to 
set margins, tab stops, and other preferences without having to 
type every command again for each editing session. You can use 
an initialization file when you invoke EVE or you can execute 
initialization files during your editing session. 

Example 8-1 is a sample initialization file, containing commands 
for setting editing values and key definitions. 

Example 8-1 Sample EVE Initialization File 
EVE Initialization file 

Settings 

SET FIND WHITESPACE 
SET LEFT MARGIN 5 
SET PARAGRAPH INDENT 4 
SET RIGHT MARGIN 70 
SET TABS EVERY 5 
SET SCROLL MARGINS 9% 9% 

! Key definitions 
! 
SET KEYPAD EDT 
DEFINE KEY= F20 SHOW BUFFERS 
DEFINE KEY= GOLD-F20 DELETE BUFFER 
DEFINE KEY= GOLD-E2 CENTER LINE 
DEFINE KEY= GOLD-C CAPITALIZE WORD 
DEFINE KEY= CTRL/N NEXT BUFFER 
DEFINE KEY= GOLD-CTRL/L PAGINATE 

! Define a key to use the WPS Ruler 
! 
DEFINE KEY= GOLD-KP7 WPS GOLD-R 

When you start an editing session, EVE first searches your 
current (default) directory and then SYS$LOGIN for a file called 
EVE$INIT.EVE. EVE uses the first initialization file it finds, 
if any. If you want to use a different initialization file, you can 
define the logical name EVE$INIT or use the /INITIALIZATION 



qualifier. For example, the following command invokes EVE using 
an initialization file called MYEVE.EVE in your current (default) 
directory: 

$ EDIT/TPU/DISPLAY=DECWINDOWS/INITIALIZATION=myeve 

If there is an initialization file you want for all or most sessions, 
you may want to define the logical name EVE$INIT, particularly 
if you keep the initialization file in a directory different from the 
files you edit. If you put the definition in your LOGIN.COM file, 
EVE will use that initialization file for all editing sessions. 

If you are defining only a few keys-such as if you simply want 
the EDT keypad-you can put Define Key commands in an 
initialization file. If you are defining several keys, you should save 
the key definitions in a section file. A section file is in binary form 
and therefore is faster than an initialization file. See the section 
Saving Key Definitions in a Section File for more information 
about section files. 

To execute an initialization file during an editing session: 

Pull down the Customize menu, display the Extend submenu, 
and choose the @EVE file... menu item. 
EVE displays a dialog box. 

@EVE File [!'J] II 

EVE Initialization file to execute: ... II __ _ 

ll OK I Apply I cancel I 
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2 Type the name of the initialization file you want to execute, 
for example, MYEVE.EVE. 

When you execute an initialization file during a session, 
commands for buffer settings apply to the current buffer. This 
is effectively the same as typing the commands that the file 
contains. For example, you may want to create initialization files 
to reset the left and right margins for editing letters or other 
kinds of documents. 

Using EVE 8-39 



Using VAXTPU Procedures to Extend EVE 
You can extend or modify EVE by writing code in the VAXTPU 
language. The VAXTPU programming language is a structured 
language designed for creating text-processing applications, 
such as the EVE editor. You can write procedures to add new 
commands to EVE, to customize the editor, or to create your own 
application. 

Example 8-2 is a sample VAXTPU procedure to insert the current 
date. 

Example 8-2 Sample VAXTPU Procedure 
PROCEDURE date_only 

Inserts the current date only (no time) and reformats 
the text; restores overstrike mode if necessary. 

LOCAL save_mode, 
come_back; 

save mode ·= GET_INFO (CURRENT_BUFFER, "mode"); 
IF save mode OVERSTRIKE 

THEN 
SET (INSERT, CURRENT_BUFFER); ! Make sure of insert mode 

ENDIF; 

COPY TEXT (FAO (' !11%D', 0)); 
come_back := MARK (NONE); 
MOVE_HORIZONTAL (-5); 
EVE_ERASE_CHARACTER; 
COPY_TEXT (" "); 
MOVE_HORIZONTAL (-5); 
EVE_ERASE_CHARACTER; 
COPY_TEXT (II II) ; 

MOVE_HORIZONTAL (+1); 
EVE_CAPITALIZE_WORD; 
POSITION (come_back); 
SET (save_mode, CURRENT_BUFFER); 

ENDPROCEDURE; 

Insert the date only. 

Move cursor back and 
erase dash between month 
and year and between day 
and month, replacing it each 
time with space. Make sure 
cursor is on month and then 
capitalize it (first character 
uppercase, others lowercase) . 

Restore previous mode 

For more information about VAXTPU programming, see the VAX 
Text Processing Utility Manual. 
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To compile a VAXTPU procedure during your editing session: 

Put the cursor anywhere on the procedure you want to 
compile. 

2 Pull down the Customize menu and display the Extend 
submenu. 



3 Choose Extend This from the Extend submenu or, if you have 
more than one VAX.TPU procedure in the current buffer and 
you want to compile every one, choose_ Extend All. 
You can also choose Extend EVE to compile a VAX.TPU 
procedure in the current buffer. 

To execute a VAXTPU procedure you have compiled, or to execute 
a built-in procedure, use the TPU command. For example, the 
following command executes a compiled procedure called DATE_ 
ONLY: 

Corcunand: TPU date_only 

To save your compiled procedures for future editing sessions, use 
Save Extended EVE to create a section file. 

Saving Attributes 
Attributes are global settings, some of which can be saved in a 
section file or TPU command file for future editing sessions. You 
can save the default settings listed in Table 8-2 by choosing Save 
Attributes... from the Customize menu. 

Table 8-2 EVE Commands for Saving Attributes 

Command Default Setting 

SET CLIPBOARD 

SET CURSOR BOUND 

SET DEFAULT COMMAND FILE 

SET DEFAULT SECTION FILE 

SET FIND CASE EXACT 

SET NOEXIT ATTRIBUTE CHECK 

SET NOSECTION FILE PROMPTING 

SET PENDING DELETE 

SET TABS MOVEMENT 
or SET TABS SPACES 

SET TABS VISIBLE 

SET NOCLIPBOARD 

SET CURSOR FREE 

SET NODEFAULT COMMAND FILE 

SET NODEFAULT SECTION FILE 

SET FIND CASE NOEXACT 

SET EXIT ATTRIBUTE CHECK 

SET SECTION FILE PROMPTING 

SET NOPENDING DELETE 

SET TABS INSERT 

SET TABS INVISIBLE 

If you have an EVE initialization file containing commands for 
these settings, you can delete those command lines after you save 
the settings in your section file or command file. 
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Other global settings (such as scroll margins or the type of 
wildcards) and any buffer settings (such as margins or tab stops) 
are not saved. Typically, you use an initialization file for those 
settings. For a list of the EVE default settings, see the EVE 
online help topic called Defaults. 

The following tables summarizes the commands for saving 
attributes. 

Table 8-3 EVE Commands for Saving Attributes 

Command 

SAVE ATTRIBUTES 

SAVE SYSTEM ATTRIBUTES 

SAVE EXTENDED EVE 

SET DEFAULT COMMAND FILE 

SET DEFAULT SECTION FILE 

SET EXIT ATTRIBUTE CHECK 
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Usage or Effects 

Saves attributes in a section file or command 
file, depending on your responses to EVE 
prompts or settings done with other EVE 
commands. If you save attributes in a section 
file, the effect is the same as entering the 
SAVE EXTENDED EVE command. If you save 
attributes in a command file, EVE generates a 
specially marked block of VAXTPU statements 
for attribute settings and menu definitions, 
and either creates a command file or updates 
an existing command file with this block of 
statements. 

Saves EVE default attributes in a section file 
or command file. This is useful if you want to 
restore your section file or command file to the 
standard EVE settings and menu definitions. 

Creates a section file, saving attributes, 
key definitions, menu definitions, compiled 
procedures, and other extensions, such as 
global variables set with a VAXTPU statement. 
If you do not specify a section file on the 
command line, EVE prompts you for one or 
uses your default section file (if you set a 
default). 

Determines the command file for saving 
attributes. Does not determine the command 
file to be executed at startup, if any. 

Determines the section file for saving 
attributes. Does not determine the section 
file to be executed at startup. 

Default setting. If you changed attributes, 
then EVE asks if you want to save your 
changes when you exit or quit. 

(continued on next page) 



Table 8-3 (Cont.) EVE Commands for Saving Attributes 

Command Usage or Effects 

SET NODEFAULT COMMAND FILE Default setting. When you save attributes, the 
default command file is TPU$COMMAND.TPU 
in your current directory, or the command file 
that was executed at startup. 

SET NODEFAULT SECTION FILE 

SET NOEXIT ATTRIBUTE CHECK 

SET NOSECTION FILE PROMPTING 

SET SECTION FILE PROMPTING 

Default setting. When you save attributes, 
EVE asks for the name of the section file you 
want to create (unless you disabled section file 
prompting). 

Disables attribute checking, typically to speed 
up or simplify exiting or quitting. Does not 
apply to the editing session in which you enter 
the command, but only to the editing sessions 
in which you use the section file or command 
file in which you saved the setting. 

Disables prompting for a section file when 
you save attributes, typically to speed up or 
simplify saving attributes in a default section 
file or in a command file. 

Default setting. When you save attributes, 
EVE prompts you for the name of a section 
file. 

You can save attributes during your editing session by using the 
SAVE ATTRIBUTES or SAVE EXTENDED EVE command, or 
as part of exiting or quitting. By default, if you have changed 
attributes and not saved them, then on exiting, EVE prompts you 
as follows: 

Cormnand: SET CURSOR BOUND 
Cormnand: SET FIND CASE EXACT 
Cormnand: SET TABS VISIBLE 

Cormnand: EXIT 
Attributes were changed. Save them? [YES] 

If you want to save the changes, simply press Return. Effectively, 
EVE then executes the SAVE ATTRIBUTES command before 
exiting. If you do not want to save the changes, type NO and 
press Return. EVE continues exiting. 
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To disable this prompting to make exiting faster or simpler, use 
the SET NOEXIT ATTRIBUTE CHECK command. However, the 
command does not apply to the current editing session because 
exit checking is itself a global setting and can be saved in a 
section file or command file. After you save it, the setting applies 
to future editing sessions in which you use the relevant section 
file or command file. 







Starting Mail 

9 
Using Mail 

Mail allows you to exchange messages with other computer users. 
You can use Mail to send messages, read messages sent to you, 
and print, file, delete, reply to, and forward messages. 

This chapter describes how to 

• Send messages 

• Read messages 

• Reply to messages 

• Forward messages 

• Print messages 

• Create files from messages 

• Work with drawers and folders 

• Customize your Mail environment 

• Exit from Mail 

To start Mail, choose Mail from File View's Applications Menu. 
Mail displays the main window. You can also start Mail from the 
Session Manager if you customize your menu list to include Mail. 
(See the VMS DECwindows User's Guide for more information.) 
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File Edit Pick Create-Send 
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poetry reading 
dog class canceled 
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Note You can choose an alternate display style for the main window. 
See the section Using a Paned Style Main Window for more 
information. 

The main window lists your Mail drawers, folders, and messages. 
Drawers and folders help. you organize your mail messages. You 
use Mail drawers and folders as you would use drawers and 
folders in your office filing cabinet. You might file all messages 
on a related topic in one folder, and group related folders in one 
drawer. You can create as many drawers and folders as you need. 

Drawers and folders can be opened to reveal their contents, and 
closed to conceal their contents. To open a drawer or folder, double 
click MBl on the drawer or folder name. To close a drawer or 
folder, double click MBl on the name of an open drawer or folder. 

When you enter Mail for the first time, a drawer named MAIL 
is automatically created and opened. The two objects in the 
MAIL drawer, INBOX and WASTEBASKET, are listed below 
and indented to the right of the drawer name. The INBOX 
folder contains messages that have been sent to you. The 
WASTEBASKET contains messages that you have deleted. The 
icon representing this object is a trash can. 



The INBOX folder is also automatically opened when you enter 
Mail, as indicated by the open folder icon in front of INBOX. 
If there are any messages in the INBOX folder, they are listed. 
Messages are chronologically arranged by date received. 

Drawers, folders, and messages are identified by unique icons. 
These icons also indicate whether the object is open or closed. 

Note If you have used the VMS Mail Utility, Mail will automatically 
change the names of your Mail folders to correspond to VMS Mail 
folders. See the section Making Mail Perform Like the VMS Mail 
Utility for more information. 

Near the bottom of the window is a row of push buttons. These 
buttons allow you to execute the tasks you most commonly 
perform with messages. Many of the push buttons are disabled 
when you first start Mail and remain so until you select a specific 
message. 

Pressing MB2 on an object in a Mail window displays a pop-up 
menu. Pop-up menus contain many commonly performed tasks. 
The items on a pop-up menu vary according to the type of object 
(drawer, folder, or message) on which you are positioned, and act 
on the object on which you are positioned. 

Pop-up menu items and· push buttons duplicate pull-down menu 
items. Where you can choose among a push button, pop-up menu, 
or pull-down menu to execute a task, instructions in this chapter 
list one way to accomplish the task. Depending on your working 
style, you may prefer to use one of the other methods once you are 
familiar with Mail 

You can use certain key combinations, called accelerators, to 
quickly perform common Mail operations. Accelerators act on 
objects in the window with input focus. For example, one way 
to delete the message you are reading is to pull down the Read 
window's Edit menu and choose Delete. An alternate way to 
delete the message you are reading is to use the accelerator for 
this function by pressing the Compose Character key and the D 
key simultaneously. See Table 9-1 for a list of the functions that 
have corresponding accelerators. Functions that have accelerators 
also list the accelerators next to them on the menu. 

The vertical scroll bar in Mail's main window contains top and 
bottom stepping buttons and a navigation window, which are not 
present in standard VMS DECwindows scroll bars. The top and 
bottom stepping buttons, located at the top and bottom of the 
scroll bar, scroll the window to the next drawer or folder in the 
direction indicated. The navigation window is displayed in the 
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upper right corner of the main window when you drag the vertical 
slider through the scroll region of the scroll bar. This window 
shows the drawer or folder that would appear at the top of the 
index if you released the slider. 

Sending Messages 

Create-Send 

9-4 Using Mail 

You can create and send a mail message or an existing file to one 
user or many users with Mail. 

Sending a Message 
To send a mail message to any user on your system or another 
system, click on the Create-Send button in the main window. A 
Create-Send window opens. You can have multiple Create-Send 
windows open at one time. 

~ Mail: Create ~~l 
File Edit Chan_9! Editor Help 

From: THACKER ITimoth~ Thacke~ 

To: u 
CC: I THACKER 

Subject: 11 
0 
,-

'-
Q 

Close Jl Reset J l Save As ... ] l Send J 
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The Create-Send window is divided into an envelope area and a 
message area. ·The envelope area contains the following items: 



Field 

From: 

1b: 

CC: 

Subject: 

Description 

Your user name. 

If you specified a personal name in your mail profile, it 
will be displayed to the right of your user name. Your 
mail profile, available from the main window's Customize 
menu, allows you to customize specific features in Mail. 
See the section Customizing Your Mail Environment for 
more information about specifying a personal name. You 
can alter your personal name for the current message by 
entering a change in this field. 

The name of the user or users receiving the message. If 
you are sending mail to people on your node, specify only 
their user names. If you are sending mail to people on 
another node, you must enter their node names and user 
names using the following format: nodename::username. 
If you are using a message router, enter the address in 
the appropriate format for your router. 

You can send the same message to several users by 
separating their user names with commas. Press the 
Return key if you need more space. 

For information about sending a message to a 
distribution list, see the section Sending a Message to 
a Distribution List. 

The name of the user or users you want to receive a copy 
of the message (optional). If you have set the Copy Self 
on Send option in your mail profile, your user name is 
displayed. 

For information about sending a copy to a distribution 
list, see the section Sending a Message to a Distribution 
List. 

The subject of the message (optional). Press the Return 
key if you need more space. 

To enter text in a field, point to the field and click MBl. Use the 
Tab key to advance to the next field and use Shiftfrab to move 
to the previous field. Use the DECwindows Text Editor editing 
commands, described in the VMS DECwindows User's Guide, to 
correct mistakes. When the envelope is complete, press the Tab 
key to move to the message area. 

In the message area, enter the text of your message. 

By default, you can use the DECwindows Text Editor editing 
commands described in the VMS DECwindows User's Guide to 
edit your message. If there is more than one editor available 
on your system, you can use a different editor. See the section 
Changing Editors for information about changing editors. 
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To send the message, click on the Send button. Mail displays a 
message box informing you of the· progress of the send operation. 
The Send button in the Create-Send window dims after the 
message has successfully been sent to all addressees. It remains 
dimmed until you change something in the window; for example, 
if you enter text in one of the fields. 

Once a message has been sent you may edit it, resend it to other 
users, or select an option from the File pull-down menu. To 
continue to use this message, click on Acknowledged in the Send 
In Progress box. The dialog box disappears and the message 
remains in the window. 

To create another message, click on the Reset button. This clears 
the message and envelope regions in the window and allows you 
to enter information for a new message. 

To close the window, click on the Close button. This removes the 
Send In Progress box, deletes all text in the window, and closes it. 

If you change the header or text of a message in a Create-Send 
window and then close the window without sending the message, 
a caution dialog box is displayed. The message "Changes have 
been made to the Create-Send window. Do you really want to 
close it?" appears. To close the window, click on Yes. To leave the 
window open, click on No. 

You can prevent this dialog box and message from appearing by 
changing your default Send attributes. See the section Modifying 
Your Send Attributes. 

Saving a Draft of a Message 
Saving a draft of a message allows you to begin composing 
a message now, and continue working on it later. If you are 
creating a long mail message, it is advisable to save the message 
occasionally. To save a draft of a message: 

Click on the Save As... button. 
Mail displays a dialog box. 

II OK II I cance1 I 
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2 Enter the draft message name, which can be no longer than 
39 characters. 
By default, the type DRAFT is appended to the file name and 
the file is stored in your default draft directory. If you specify 
a different file type or directory, Mail will not list this file 
when you request a list of your draft files. 

3 Click on the OK button to save the draft message. 

The message can still be sent or canceled after it has been saved. 

Saved draft messages are VMS files and cannot be deleted 
through Mail. You can delete draft messages by choosing Delete 
from File View's Files menu. 

Resuming Work on a Draft Message 
You can continue working on a draft of a message that you 
previously saved. 

To resume work on a draft message: 

Choose Include Draft File ... from the Create-Send window's 
File menu. Mail displays a dialog box. 

File Fitter 

jiDECW$MAIL DRAFTS:*.DRAFT 

Files in DISK$:[MORRIS] 

IJCLASS.DRAFT;1 

IJREPORT.DRAFT;1 

IJSARAH.DRAFT;1 

¢1 I IJO 
Selection 

~ 

Q 
D 

Filter I 
II OK II 
I cancel I 
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The dialog box prompts you for the name of the draft file you 
want to continue working on. The file list box lists the names 
of any draft files in your default draft directory. 

2 Double click on the name of the draft file you want. 
The draft message is displayed in the Create-Send window, 
where you can continue working on it. 

If you want to work on a draft file that is not listed, enter the 
name of that file in the Selection text entry field and click on the 
OK button. Or, use the File Filter text entry field to list a subset 
of files that you can then select from. For example, to list all files 
in another directory with the file type DRAFT, enter the complete 
directory specification-[JONES.LETTERS]* .DRAFT-in the File 
Filter text entry field and click on the Filter button. Then double 
click on the name of the file you want to continue working on. 

Including a File in a Message 
You can insert an existing file into a mail message. If it is a text 
file you can edit it. If the file does not contain text, such as a 
DDIF file, you cannot edit the file in Mail. See the section Using 
an Existing File in a Message for information about sending a 
nontext file. 

To include a file in a message: 

Choose Include File... from the Create-Send window's File 
menu. Mail displays a dialog box. 



File Filter 

II*.* 
Files in DISK$:(JONES] 

IJACCOUNTS.DAT;4 

IJAGENDA. TXT;2 

IJDEBUG.LOG;1 

IJDECW$CAPTURE.TMP;1 

IJDECW$MAILDAT;4 

IJELISE.TXT;3 

IJSETH.DRAFT;1 

¢1 I 
Selection 

~ 

I.{= 
~ 

IJ i> D 

Filter 

II OK II 
I Cancel I 
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The dialog box prompts you for the name of the file you want 
to include. The file list box lists the names of all files in the 
current directory. 

2 Double click on the name of the file you want to include. 
The contents of the file are displayed in the Create-Send 
window. You can edit the file if desired. 
You can also use the File Filter text entry field to list 
a subset of files that you can then select from. For 
example, to list all files in another directory with the file 
type TXT, enter the complete directory specification­
[JONES.MESSAGES]*.TXT-in the File Filter text entry 
field and click on the Filter button. Then double click on the 
name of the file you want to include. 

3 Click on the Send button to send the message. 
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Using an Existing File in a Message 
You can send a file without using an editor. This function is useful 
for sending files that cannot be edited in Mail. 

To use an existing file in a message: 

Choose Use Existing File... from the Create-Send window's 
File menu. Mail displays a dialog box. 
The dialog box prompts you for the name of the file you want 
to use. The file list box lists the names of all files in the 
current directory. 

2 Double click on the name of the file you want to use. 
A message appears in the Create-Send window informing you 
of the file specification of the file being sent. 

You can also use the File Filter text entry field to list a subset of 
files that you can then select from. See the section Including a 
File in a Message for more information. 

Sending a Message to a Distribution List 
If you need to send one message to many users, you can create 
a file, called a distribution list, that contains a list of users. You 
then specify an at sign (@) and the file name in the To: field when 
you send the message (for example, @PROJECT). 

Distribution lists are not created within Mail. Use an editor, 
such as Notepad, to create your distribution lists. When creating 
distribution lists, enter one user name per line. Exclamation 
points ( ! ) delimit comments; Mail will ignore everything to the 
right of the exclamation point. You can also include the names of 
other distribution lists by specifying an at sign ( @) followed by 
the name of the distribution list. For example, a distribution list 
file could contain the following: 

MIASMA: : FORD 
YONKIN 
TUTTLE 
DARCY: : MORRIS 
@PROJECT 

Craig, project leader 

Mona, product manager 

When naming distribution list files, use a DIS file type because 
that is what Mail looks for by default. 

To send mail to the users in a distribution list: 

Move to either the To: or CC: field in the envelope area of the 
Create-Send window and press MB2. 
A pop-up menu is displayed. 



2 Choose Distribution List ... from the pop-up menu. 
Mail displays a dialog box. 

File Filter 

ITDECW$MAIL DISTRIBUTIONLISTS:*.DIS 

Files in DISK$:[MORRIS] 

IJDOGCLASS.DIS;3 ~ Filter 

IJPROJECT.DIS;1 OK 
IJSTAFF.DIS;1 I cancel I 

Q 
¢1 I Pi> D 
Selection 
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The dialog box prompts you for the name of the distribution 
list file you want to use. The file list box lists the names of 
any distribution list files (files that have the type DIS) in your 
default directory. 

3 Double click on the file name of the distribution list you want 
to use. 
The distribution list file name is displayed in the To: or CC: 
field in the Create-Send window's envelope area. 

If you want to use a distribution list file that is not listed, enter 
the name of that file in the Selection text entry field and click 
on the OK button. Or, use the File Filter text entry field to list 
a subset of files that you can then select from. For example, to 
list all files in another directory with the file type DIS, enter the 
complete directory specification-[JONES.STAFF]* .DIS-in the File 
Filter text entry field and click on the Filter button. Then double 
click on the name of the file you want to use. 
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Changing Editors 
The DECwindows Text Editor, described in the VMS DECwindows 
User's Guide, is the default editor used to create messages. If 
more than one editor is available on your system, you can choose 
a different default editor to create a message. To change your 
default editor, see the section Modifying Your Send Attributes. 

You can also change the editor for a specific message by doing the 
following: 

Choose the desired editor from the Create-Send window's 
Change Editor menu. 
A new window opens, containing any text you may have 
already entered in the message. 

2 Click on the new window to make it the active window. 

3 Enter the text of the message, using editing commands 
appropriate for your chosen editor. 

4 Exit from the editor. 
You cannot edit the message after exiting from the editor. You 
cannot extract the message to a file or create a draft of the 
message. You can edit the message envelope by clicking on a 
field in the Create-Send window. 

5 To send the message, click on the Send button in the Create­
Send window. 
To send another message, click on the Reset button. The 
DECwindows Text Editor is once again the default, and all 
Create-Send options become available. 

Selecting Messages 
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Before you work with a message, drawer, or folder, you have to 
select the desired object. 

To select a message, folder, or drawer, point to the object in the 
main window and click MBl. 

To select multiple objects, press and hold the Shift key while 
clicking MBl on each desired object. 

To select a range of drawers, folders, or messages, press MBl in 
the blank space to the left of the icon on the first object to be 
selected, drag the mouse over the icon of the last object to be 
selected, and release MBl. 



To select all messages in the open folder, choose Select All from 
the main window's Edit menu. 

To cancel the selection of one object, select another object by 
clicking MBl, or point to the selected object and press and hold 
the Shift key and click MBl. 

Reading Messages 
eS1 INBOX 

181 1 

181 2 

iii 3 

iii 4 

iii 5 

You can use Mail to read an old or new mail message. New 
messages are added to the INBOX folder; old messages (messages 
that have been read) are held in the INBOX folder until you move 
them elsewhere. (This default can be changed in your mail profile. 
See the section Customizing Your Mail Environment for more 
information about your mail profile.) 

Reading a New Message 
When you receive new mail, a message is displayed in your 
Session Manager window. The number of new messages is 
displayed in the Mail icon. 

To read a new message, start the Mail application if it is not 
already running. The messages in the INBOX folder are 
listed; unread messages are identified by an icon resembling 
an addressed envelope. Double click MBl on the message to be 
read. Mail displays the message in a Read window. 
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~ Mail:Read 1[0] MAIL INBOX #4 !l)rru:J 
File Edit Create-Send Read Help 

Date: 26-APR-1990 10:56:34.67 
From: SOIREE: :JONES 
Subj: luncheon 
To: @Staff 
CC: 

Please make sure there are 1500 lbs. of ice for today's luncheon. 
I 

Close ][ Reply ][ Fo1Ward ][ Print Jl Move ][ Delete ][ Previous ][ Next ] 
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If Mail is running on your system when you receive new mail, the 
Mail icon in your icon box darkens and the Read New Mail and 
Deliver Mail buttons in the main window become active. To read 
a new message, click on the Read New Mail button. This adds 
new messages to the INBOX folder, opens the INBOX folder, and 
displays the first message received since the INBOX folder was 
last opened. 

You cannot use the Read New Mail button if a message in the 
INBOX folder is being read in a Read window other than the 
default Read window or if you are replying to a message in the 
INBOX folder. (For a description of default Read windows, see the 
section Multiple Read Windows.) 

A Read window is divided into an envelope pane and a message 
pane. 

The envelope pane displays the name of the person who sent the 
message and other address information. Use the scroll bar to 
display additional information about the message, such as text 
indicating that the message is marked or has been replied to, 
the message size, message ID, and whether the message is in a 
forP.ien form::it._ 



Deliver Mail 

The message pane displays the mail message. Use the scroll bar 
to display any text that does not fit in this pane. 

You can adjust the relative size of the panes by using MBl to 
drag the border between the panes. Press MBl on the pane 
dividing line, drag the line to the desired location, and release 
MBl. Making one pane smaller makes the other pane larger. This 
allows you to view more text in either pane without resizing the 
window. 

If you receive a message whose contents are not text or in the 
DDIF or DTIF format, the file cannot be viewed in Mail. Mail 
displays a message informing you of the problem. You can print, 
forward, extract, or reply to the message. See the appropriate 
sections of this chapter for information about printing, forwarding, 
extracting, and replying to messages. 

A message that you have read remains in the INBOX folder until 
you move it to another folder or delete it. You can specify that 
messages be automatically placed in another folder once they are 
read. See the section Customizing Your Mail Environment for 
more information. 

To continue to read new messages, click on the Next or Previous 
button to read the next or previous message in the folder. 

If you receive new mail while reading messages in the INBOX 
folder, choose Read New Mail on the.pop-up menu in the Read 
window's message pane. This displays the first unread message in 
the INBOX folder. 

To close a Read window, click on the Close button. 

Displaying a List of New Messages 
You can add new messages to your INBOX folder and update 
the list of new messages without reading a message. To update 
the INBOX folder, click on the Deliver Mail button in the main 
window. 

If you click on the Deliver Mail button while reading a message 
in the INBOX folder, Mail will close the Read window before 
delivering your mail. If you are reading a message in the 
INBOX folder in a Read window other than the default Read 
window, Mail will not be able to deliver your messages, and will 
display a message. (See the section Multiple Read Windows for a 
description of default Read windows.) 

Mail cannot be delivered if you are replying to a message in the 
INBOX folder. 
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Read In Default 

Read In new window 
Reply using this message 
Forward with Header 
Print 
Move ••• 

Delete 
Undo Move/Delete 

Full lnfonnatlon." 
Extract ... 
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Reading an Old Message 
To read an old message (one that has already been read), open the 
drawer and folder containing the message and double click on the 
appropriate message. The message is displayed in a Read window. 

From the Read window, you can click on the Previous and 
Next buttons to read the messages before and after the current 
message. 

To read a series of old messages that are in different folders or are 
not consecutive: 

Select the messages to be read. 

2 Point to one of the selected messages, press MB2, and choose 
Read In Default or Read In New from the pop-up menu. 

3 In the Read window, choose Next Selected or Previous Selected 
from the pop-up menu in the message pane to display the next 
or previous selected message. 

Multiple Read Windows 
You can open more than one Read window at one time. This 
allows you to read multiple messages at once, or to read new mail 
without disrupting the message you are currently reading. 

The first Read window you open is your default Read window. It is 
identified by the symbol [D] in the window's title bar. Additional 
Read windows are identified by the number in their title bar, for 
example, Read 2, Read 3, and so on. 

The default Read window is used to display messages unless you 
specify another window. For example, clicking on the Read New 
Mail button or double clicking on a message in the main window 
will display the message in your default Read window. 

To read new mail in another Read window, display the main 
window's Read menu and choose New Mail in New Window from 
the In Window submenu. A new Read window is opened and the 
first message received since the INBOX folder was last opened 
is displayed. This is possible only if the default Read window is 
displaying a message from a folder other than the INBOX folder. 

To read an old message in another Read window, select the 
message, display the main window's Read menu, and choose In 
New Window from the In Window submenu. 



If you have already opened multiple Read windows, you can 
specify the window in which to read the selected message by 
pulling down the main window's Read menu, displaying the In 
Window submenu, and choosing one of the listed Read windows. 

To use a different window as the default Read window, choose 
Make Default Window from the Read window's File menu. The 
[D] default symbol will be displayed in the window's title bar, and 
will be removed from the previous default window's title bar. 

Replying to Messages 

Reply I · You can reply to a selected message or to the message currently 
displayed in a Read window. 

To reply to the first selected or currently displayed message, click 
on the Reply button in the main or Read window. 

To reply to the selected or currently displayed message using a file 
or the text of the message: 

Pull down the Create-Send menu in the main or Read window 
and display the Reply submenu. 

2 Choose Create New Reply, Using a File ... , Using a File (no 
editor), or Using This Message. 

Replying to a message opens a Create-Send window. In the To: 
field, Mail inserts the name of the sender of the original message. 
In the Subject: field, Mail inserts the subject of the original 
message preceded by RE:. 

Enter text and make any desired edits (unless you selected Using 
a File (no editor)). 

To include the original message in your reply, choose the Include 
Original menu item from the Create-Send window's File menu. 

To send the reply, click on the Send button. To close the Create­
Send window, click on the Close button. 

Forwarding Messages 

I Forward I You can forward the selected message or the message currently 
displayed in a Read window to another user. 

To forward the selected or currently displayed message, click on 
the Forward button in the main or Read window. 
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The header (address information) is included in the forwarded 
message in most cases. Headers are not included in messages 
created with editors that do not produce ASCII files, such as files 
created with the Paint application. 

To forward the selected or currently displayed message without 
including the header in the body of the message: 

Pull down the Create-Send menu in the main or Read window 
and display the Forward submenu. 

2 Choose either Without Header or Without Header (no editor). 

Forwarding a message opens a Create-Send window. In the 
Subject: field, Mail inserts the subject of the forwarded message 
preceded by FWD:. In the message area, Mail inserts the 
forwarded message unless you chose (no editor). 

If you choose (no editor), Mail displays a message in the message 
region informing you of the name of the file it is sending. 

Enter the address information, and make any desired changes to 
the text. If you change the original message and want to include 
the unedited version in your forwarded message, choose Include 
Original from the Create-Send window's File menu. 

Click on the Send button to send the message. Click on the Close 
button to close the window. 

Printing Messages 
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You can print selected messages or the message currently 
displayed in a Read window. Messages can be printed using your 
default print settings or you can modify the print settings for the 
messages being printed. 

To print the selected or currently displayed message using your 
default print settings, click on the Print button in the main or 
Read window. 

To print the selected or currently displayed message using altered 
print settings: 



Move... Alt/M 

Copy ... 

Extract ••• 
····················· I Print ... 

Print Alt/P 

Op;in-Clnsa C~ 

Elevate C~ 

Exit Ctrt/Z 

Choose Print... on the File menu in the main or Read window. 
Mail displays a dialog box. 

<e Include message header and contents OK 

0 Include message contents only 
cancel 

I Optlons ... I 
ZK-0301A-GE 

The Include Message Header and Contents button is set to 
indicate that the header (sender's name, date, subject, and 
so on) and the contents of the message are to be printed. To 
exclude the header information, click on the Include Message 
Contents Only button. 
If you are printing a nontext message, such as a message 
created with the Paint application or a message containing 
special formatting commands (such as a PostScript file), you 
must click on the Include Message Contents Only button. 

2 To change additional print settings, click on the Options ... 
button. 
You must also click on the Options... button to specify an 
appropriate print format and printer if you are printing a 
nontext message or a message containing special formatting 
commands, such as a PostScript file. 
Mail displays a dialog box. 
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Number of Copies: IL_ 
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Print Format 
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¢1 

Orientation 
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ZK-0308A-GE 

See the VMS DECwindows User's Guide for more information 
about the Print Defaults dialog box. 

3 Click on the OK button to print the messages. 

Creating a File from a Mail Message 

Move ••• 

Copy ... 

I Extract ... 

Print .•• 

Print 

Alt/M 

Alt/P 

Open-Close H 

Elevate [~ 

Denver Mau 

Exit Ctrl/Z 
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You can create a VMS file from a mail message. You can select 
an existing message to be copied to a file, or you can create a file 
from a message you are reading or creating. 

To create a file from the selected or currently displayed message: 

Choose Extract... from the File menu in the main, Create­
Send, or Read window. Mail displays a dialog box. 



Ill Include Header Information 

D Append to Existing File 

File:lI -------------
1 n put Format: I """'";::::==--.. Output Format: I ____ _ 
Conversion Options File:L...._ _______ 

8 

I[ OK JI 
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The Include Header Information button is set to indicate 
that the message's header will be included in the file you are 
creating if it is an ASCII file. You can disable this feature by 
clicking on it. 
If you want to append the extracted message to an existing 
file, turn on the Append to Existing File option by clicking on 
it. By default, this option is turned off. 

2 Enter the name of the file to be created. If you want to append 
the message to an existing file, enter the name of that file. 
The default file types are: 

TXT for text and untagged files 
DDIF for DDIF files 
DTIF for DTIF files 
DDIF or DTIF for DOTS files, depending on whether the 
primary file's type is DDIF or DTIF 

You may enter a different file type. 

3 To select a different format for the file being created, move to 
the Output Format field, press MBl, and choose one of the 
listed file formats. 
The input format is determined by the editor used to create 
the message. The output format is the same as the input 
format by default. 
If you select a different format for the file to be created, data 
converters are invoked. You may prefer to select a different 
output format only in cases where you understand the actual 
data format of the message you want to extract and the format 
in which you want the extracted file. The header information 
of the message is not converted to the new data format, only 
the body of the message. You may want to toggle off the 

Using Mail 9-21 



Include Header Information and Append to Existing File 
options. 

4 To use a conversion options file, enter the name of the file. 
Conversion options files contain special processing commands. 
They are not created within Mail. Refer to the CDA Reference 
Manual if you require more information about conversion 
options files. 

5 Click on the OK button to create the file. 

If more than one message is selected and the messages have 
different data types, non-ASCH messages will be converted to 
ASCII if possible. If they cannot be converted to ASCII, the 
messages will not be extracted. 

Deleting and Retrieving Messages 

Delete 
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You can delete mail messages, and retrieve deleted messages. 

To delete selected messages or the message currently displayed in 
the Read window, click on the Delete button in the main or Read 
window. 

The index is updated to show which messages have been marked 
for deletion. Messages are not actually deleted until the folder is 
closed. You can still perform many Mail functions on messages 
that are marked for deletion, such as moving, copying, and 
printing. When the folder is closed, the messages are deleted and 
reference to them is removed. 

Once the folder is closed, deleted messages are moved to the 
WASTEBASKET in the drawer from which the message was 
deleted. 

Deleted messages collect in the WASTEBASKET until you empty 
it. To empty the WASTEBASKET, select the WASTEBASKET 
or the drawer in which the WASTEBASKET resides and choose 
Empty Wastebasket from the main window's Maintenance menu. 
(An. option in your mail profile allows you to specify that the 
WASTEBASKET be emptied whenever the drawer is closed.) 
Once the WASTEBASKET is emptied, the deleted messages are 
irretrievable. 

You can also delete entire folders and drawers of messages. See 
the section Deleting Drawers and Folders for more information. 

To reverse the delete operation in the main window, before the 
folder is closed select the messages to be retrieved, pull down the 
~dit menu, and choose Undo Move/lJelete. 



. To reverse the delete operation in a Read window, press MB2 
in the message pane of the deleted message and choose Undo 
Move/Delete from the pop-up menu. 

To update the index of messages to reflect that the messages have 
been moved to the WASTEBASKET, either select Update Folder 
from the Maintenance menu in the main window or reopen the 
folder that contains the deleted message. 

Once a message has been moved to the WASTEBASKET, you 
can retrieve the message by moving it to another folder. See the 
section Moving and Copying Messages to Another Folder for more 
information about moving messages between folders. 

Working with Drawers and Folders 
11111111111------. You can create and delete drawers and folders, modify a drawer's 

Creete Drawer •• 

~~~~~:-:............................ file name and display name, add and remove drawers in your 

EmJ.>tt W&sl~k« 
C<iU'flr<J~ll' Omw~ 

0*1¥W Omw-.r .•• 
D«l<-t'>l'cl<k-r ... 

Scan mall directory for mall drawers 
Acid drawer to Index_ 

R«1m<>ve ll111wer fmm h11l111x ... 
Mcdlfy Of!>Wltlt ... 

index, move and copy messages between folders, and reclaim 
unused space in drawers. 

Creating New Drawers 
To create a new drawer: 

Choose Create Drawer... from the main window's Maintenance 
menu. 
Mail displays a dialog box. 

2 Type the drawer file name for the new drawer to be created in 
the appropriate text entry field. 
A drawer file name is a VMS file specification and has the 
same limitations. The prefix MAIL$ is reserved by Mail and 
should not be used as a prefix for drawer file names. All 
drawer file names must be unique. 

3 Type the drawer display name for the new drawer to be 
created in the appropriate text entry field. 
The drawer display name is listed in your main window 
index, and can be different from the drawer name. A display 
name is limited to 39 characters. It must begin with a letter 
or number, and can contain letters, numbers, underscores, 
hyphens, and dollar signs. 
Display names are case sensitive. That is, the display names 
IMPORTANT and Important are not the same. 

4 Click on the OK button to create the drawer. 
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When you create new drawers, a WASTEBASKET is automatically 
included in each new drawer. 

Creating New Folders 
To create a new folder: 

Choose Create Folder... from the main window's Maintenance 
menu. 
Mail displays a dialog box. 

2 Type the name of the new folder to be created in the 
appropriate text entry field. 
A folder name is limited to 39 characters. It must begin 
with a letter or number, and can contain letters, numbers, 
underscores, hyphens, and dollar signs. In addition, a folder 
name can contain spaces and periods. 
Folder names are case sensitive. That is, the folder names 
INBOX and lnbox are not the same. 

3 Click on the OK button to create the folder. 

Empty folders are automatically deleted by Mail when the drawer 
is closed. 

You can also create a new drawer or folder when you move or copy 
a message. If you specify a destination drawer or folder that does 
not exist, the drawer or folder will be created. 

Modifying Drawer Names 
You can enter a new file name or display name, or both, for a mail 
drawer. You can change the display name for the default MAIL 
drawer but not the file name. 

To modify the file name and display name of a drawer: 

Choose Modify Drawer... from the main window's Maintenance 
menu. 
Mail displays a dialog box. 

2 To change the drawer's file name, type the new file name for 
the drawer in the appropriate text entry field. 
A drawer file name is a VMS file specification and has the 
same limitations. The prefix MAIL$ is reserved by Mail and 
should not be used as a prefix for drawer file names. All 
drawer file names must be unique. 

3 To change the drawer's displav name. tvpe the new display 
name for the drawer in the appropriate text entry field. 



The drawer display name is listed in your main window 
index, and can be different from the drawer name. A display 
name is limited to 39 characters. It must begin with a letter 
or number, and can contain letters, numbers, underscores, 
hyphens, and dollar signs. 
Display names are case sensitive. That is, the display names 
IMPORTANT and Important are not the same. 

4 Click on the OK button to make the change. 

Deleting Drawers and Folders 
To delete drawers or folders: 

Select the drawers or folders to be deleted. 

2 Choose Delete Drawer... or Delete Folder... on the main 
window's Maintenance menu. 
Mail displays a dialog box. 

II 
Folder "REPORTS" in drawer "STATUSREPORTS" contains 2 messages. 

Press Yes to delete. 

I Yes I ICNOJI 
ZK-1308A-GE 

3 Click on the Yes button to delete the drawer or folder, or click 
on the No button to cancel the delete request. 
If multiple drawers or folders are selected, you must confirm 
or cancel the delete request for each drawer and folder 
separately. 

You cannot delete an open folder or drawer. 

When you delete a drawer, any folders that existed in the drawer 
are deleted and the messages in them cannot be retrieved. If you 
attempt to delete the MAIL drawer, all messages and all folders 
except INBOX and WASTEBASKET are deleted, but the drawer 
itself is not deleted. 

When you delete a folder, any messages that existed in the folder 
are placed in the WASTEBASKET and can be retrieved until the 
WASTEBASKET is emptied. If you attempt to delete INBOX or 
WASTEBASKET, all messages in them are deleted but INBOX 
and WASTEBASKET are not deleted. 
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If you delete all messages in a folder, the folder is automatically 
deleted when you close the drawer. 

Adding and Removing Drawers in the Index 
When you create a drawer in VMS DECwindows Mail, the drawer 
is automatically created in your default mail directory and is 
listed in your main window. If you create drawers with the VMS 
Mail Utility or if you create drawers in a different directory, they 
are not automatically added to the list in your main window. To 
access these drawers you must specifically add them to the main 
window. 

To add drawers created with the VMS Mail Utility in your default 
mail directory, choose Scan Mail Directory for Mail Drawers 
from the main window's Maintenance menu. All drawers in your 
default Mail directory will be added to the main window. 

To add drawers created in a different directory: 

Choose Add Drawer to Index... from the main window's 
Maintenance menu. 

File Filter 

li*.MAI 

Files in DISK$:[SMITH] 

I 0 Display Name IT I Fiiter 
l)MAIL$000400915C3D4025.MAl;1 
l]MAIL$00040091680959C1.MAl;1 

~ 
II OK II 

l]MAILMAl;1 

I canceil 
Q 

(Jc J JJO D 
Selection 

u 
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A file selection dialog box displays all files in your default 
directory that have a type of MAI. Ignore the files beginning 
with the prefix MAIL$. These are messages. Drawer names 
do not have this prefix. 

2 Double click on the file name of the drawer you want to add. 



If you want to add a drawer whose file name is not listed, 
enter the name of that file in the Selection text entry field 
and click on the OK button. Or, use the File Filter text entry 
field to list a subset of files that you can then select from. 
For example, to list all files in another directory with the 
file type MAI, enter the complete directory specification­
[JONES.JUNKMAIL]* .MAI-in the File Filter text entry field 
and click on the Filter button. Then double click on the name 
of the drawer you want to add. 

3 In the Display Name text entry field, enter the name to be 
displayed in the main window. If you do not enter a name, the 
name of the drawer is used by default. 

To remove a drawer from the main window, select the drawer 
and choose Remove Drawer from Index from the main window's 
Maintenance menu. 

Removing a drawer from the index does not delete the drawer. 
You can retrieve it by choosing Scan Mail Directory for Mail 
Drawers... or Add Drawer to Index... from the Maintenance 
menu. 

Moving and Copying Messages to Another Folder 
You may move or copy a message or group of messages from one 
folder to a different folder. Moving a message to another folder 
removes it from the original folder. Copying a message to another 
folder does not remove it from the original folder. 

You can move and copy messages from either the main or Read 
windows. 

To move a selected message or the message currently displayed in 
the Read window: 

Click on the Move button. 
Mail displays a dialog box. 

Enter destination drawer and folder. 

Drawer: ..... IM_A_ILI...__ _________ _ 

Folder: 

II OK II I cancel I 
ZK-0307 A-GE 
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Initially, MAIL is inserted in the drawer name field. If a 
folder is selected, the name of the drawer that contains the 
folder will be displayed in the drawer name field. If no folder 
is currently selected, the drawer and folder fields contain 
whatever was last entered in those fields. 

2 Type the name of the drawer and folder to receive the message 
in the appropriate text entry fields. 
If you specify a drawer or folder that does not exist, it will be 
created. 

3 Click on the OK button. 
A message is displayed in the message pane of a Read window, 
or in the index entry in a main window, to show which 
messages have been marked for moving. Messages are not 
actually moved until the folder is closed. You can still perform 
many Mail functions on messages that are marked for moving, 
such as deleting, copying, and printing. When the folder is 
closed, the messages are moved. 

If you are using the Outline style main window, you can also move 
messages by dragging. You may drag messages only within a 
single window. 

Press MBl on the selected message, wait one full second, and 
drag MBl to the folder you want to move the message to. 

2 Release MBl. 

You can also move multiple messages at one time. Select the 
messages by holding the Shift key down while clicking MBl on 
the messages you choose, and drag MBl to the folder you want to 
move the messages to. Release MBl. 

To reverse the move operation in the main window, select the 
messages to be retrieved and choose Undo Move/Delete from 
the main window's Edit menu. You may also reverse the move 
operation by dragging messages back to their original folders. 

To reverse the move operation in a Read window, in the message 
pane of the moved message press MB2 and choose Undo Move/ 
Delete from the pop-up menu. 

To copy a selected message or the message currently displayed in 
the Read window: 

Choose Copy from the File menu in the main or Read window. 



Mail displays a dialog box. 

Enter destination drawer and folder. 

Drawer: l .... M_Al_LI __________ _ 

Folder: i" ---------------
OK I Cancel I 
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Initially, MAIL is inserted in the drawer name field. If you 
subsequently enter text, however, the drawer and folder fields 
contain whatever was last entered in those fields. 

2 Type the name of the drawer and folder to receive a copy of 
the message in the appropriate text entry fields. 
If you specify a drawer or folder that does not exist, it will be 
created. 

3 Click on the OK button. 
The message is displayed in the destination folder when the 
destination folder is next opened. 

An alternate method for moving or copying messages is to select 
the messages, point to the destination folder, press MB2, and 
choose Move Selected Here, Copy Selected Here, Move Read 
Message Here, or Copy Read Message Here from the pop-up 
menu. The read message is the message currently displayed in 
your default Read window. 

Updating Folders 
Messages are deleted and moved when a folder is closed. If you 
have deleted or moved several messages from a folder and would 
like to have your changes take effect without leaving the folder, 
Mail can automatically close and reopen the folder for you. 

To close and reopen a folder, completing all pending delete and 
move operations, point to the folder name, press MB2, and choose 
Update Folder from the pop-up menu. 

To update several folders at once, select the folders and choose 
Update Folder from the main window's Maintenance menu. 

If a folder is updated while a message in that folder is being read 
in your default Read window, the window will be closed when 
the folder is closed. The window will not be reopened. (For a 
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description of default Read windows, see the section Multiple 
Read Windows.) 

Compressing Drawers 
When you delete messages and folders, empty space is left in 
the drawer from which the messages or folders were deleted. 
To make this space available for reuse, select the drawer to be 
compressed and choose Compress Drawer from the main window's 
Maintenance menu. 

If multiple drawers are selected, the first selected drawer will be 
compressed. 

You cannot compress an open drawer. Close the drawer before 
choosing Compress Drawer. 

When a drawer is compressed, the original (uncompressed) drawer 
is saved in a file. A message is displayed indicating that this file 
has been created and showing the name of the file. Once you 
have used the compressed drawer, the uncompressed file should 
be deleted. The file cannot be deleted within Mail; delete it from 
File View. 

Marking and Unmarking Messages 
1!!111 ______ ___ 

Undo Move/Delete Shift/Do 
Delete Alt/D 
······································ 
Copy To Clipboard ShlfVRemove 
Select All 
······································ 
Mark J 
Un mark 

Full Information •• 

Marking messages allows you to identify messages of particular 
importance to you. For example, you might mark the messages 
you want to print at the end of the day, or the messages you want 
to reread or reply to at another time. 

When a message is marked, an asterisk is displayed in the index 
entry for this message. The message itself is unaffected. 

To mark selected messages or the currently displayed message, 
choose Mark from the main or Read window's Edit menu. 

To unmark the currently displayed or selected messages, choose 
Unmark from the main or Read window's Edit menu. 

Picking Messages 
-------Pick from selected folder... Find 

Pick from open folder •• 
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Mail can search the open or selected folder for messages that have 
something in common. For example, you could pick messages 
that were sent by a specific user on a specific day, or messages 
containing a specific word in the subject field. 

Once it finds messages that meet your criteria, Mail displays 
a list of these messages. You can then perform functions such 
as copying, moving, extracting, or reading on this set of picked 
messages. 



To pick messages: 

Open or select the folder containing the messages. If multiple 
folders are selected, the first folder is used for the pick. 

2 Choose Pick from Open Folder... or Pick from Selected 
Folder... from the main window's Pick menu. 
Mail displays a dialog box. 

[JJ Mail: Pick from open folder ~II 

From: 

To: 

CC: 

subJect: _r _________ _ 

In Text: ------------
On: 0 Replied To 0 Marked 0 Opened 0 Selected 

Before: ._I _____ ...,.I 0 Yes 0 Yes 
ONo ONo 

0 Yes 0 Yes 
ONo ONo 

After: I 
[~JI I cance1 I 

ZK-031 OA-GE 

The dialog box allows you to specify the criteria for picking 
messages. Each field in the Pick dialog box is described in the 
table below. 

3 Click on the field to be used and enter the pick criteria. 

4 Click on the OK button to pick the. designated messages, or 
the Cancel button to cancel the pick. 

The following table describes the fields in the Pick dialog box. 

Field 

From: 

To: 

CC: 

Description 

The user name of the sender whose messages 
you want to pick. 

The user name of the addressee or the name 
of a distribution list whose messages you 
want to pick. 

The user name of the addressee (or the name 
of a distribution list) who received courtesy 
copies of messages you want to pick. 
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Field 

Subject: 

In text: 

On: 

Before: 

After: 

Replied to 

Marked 

Opened 

Selected 

Description 

Text included in the subject field of messages 
you want to pick. 

Any text string included in the body of 
messages you want to pick. 

The date on which messages you want to pick 
were received. Click MBl to display the Date 
dialog box. To specify the day, month, or year, 
click MBl on the appropriate box, then click 
on the up arrow or down arrow to specify the 
date. Click on the OK button to enter this 
date in the field or click on the Clear button 
to clear the date in the Pick dialog box. The 
time is ignored for this field. 

The date and, if desired, the time before 
which messages you want to pick were 
received. Click MBl to display the date 
dialog box. See the description of the On: 
field for information about the Date dialog 
box. The time can be used as a criterion in 
this field. 

The date and, if desired, the time, after which 
messages you want to pick were received. 
Click MBl to display the Date dialog box. 
See the description of the On: field for 
information about the Date dialog box. The 
time can be used as a criterion in this field. 

Messages to which you have or have not 
replied. You activate this option by clicking 
on Replied to and choosing Yes or No. 

Messages that you have or have not marked. 
You activate this option by clicking on Marked 
and choosing Yes or No. 

Messages that you have or have not read. You 
activate this option by clicking on Opened and 
choosing Yes or No. 

Messages that you have or have not selected. 
You activate this option by clicking on 
Selected and choosing Yes or No. 

Text fields (the first five fields in the dialog box) search for 
matching text anywhere in the field and are not case sensitive. 
For example, entering the text John in the From: field might pick 
messages from Jane Johnson, John Doe, Olav Bejohnesson, and 
JOHN::Smith. 



Once a set of messages has been picked, the message index is 
updated to list only the picked messages. When the folder is 
closed, the picking criteria are lost and all messages are again 
available. 

A pick operation cannot be performed if a folder is open in 
multiple windows and contains messages to be moved or deleted. 
Close the folder in all additional windows to complete the move or 
delete operation before performing a pick operation. 

Displaying Additional Index Information 

Undo Move/Delete Shift/Do 
Delete Alt/D 

Copy To Clipboard Shift/Remove 

Select All 
······································ 
Mark 
Un mark 

The main window's message index lists one line of information 
about each message. This line contains the message number, the 
date it was received, the name of the sender, and the subject of 
the message. 

To display additional information about messages, select the 
messages and choose Full Information... from the main window's 
Edit menu. The following is displayed: 

• The message number. 

• The envelope of the message. 

• The relative size of the message. For ASCII messages, the size 
is shown in records. For non-ASCII messages, such as those 
in DDIF format, the size is shown in blocks. 

• The external message ID if one exists. External message IDs 
are assigned to non-ASCII files and to messages too large to 
be stored within the Mail file. 

• The attributes of the message, which would be Replied To 
if you replied to the message, Marked if you marked the 
message, New if you have not read the message, and the 
message type of non-ASCII messages, such as DDIF. 

Opening a New Main Window 
Open 

Open In new window 

Elevate In new window 

Updete FolOOI 

Mcwe Se!ectt'IJ Here 

C'.G~'Y ~l*f.;tB<.l i-mre 

Move m.1<.l ~s.c;ag,1 tiem 

Capy !~ fllflmiaW: h<t!'l'l 

Close 

Opening folders containing numerous messages often fills the 
window, leaving no room to display other folders and messages. 
You can display additional messages by creating multiple main 
windows. You can create a new main window in which all of your 
drawers and folders are present or, by elevating a particular 
drawer or folder to a new window, you can restrict the contents of 
that window to only the drawer or folder you elevated. 
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To create a new main window, point to the folder or drawer to be 
opened in the new window, press MB2, and choose Open in New 
Window from the pop-up menu. A new main window is displayed, 
and the current folder or drawer is opened. 

You can perform all Mail functions on the drawer, folders, and 
messages displayed in this window. 

You can also create a new main window by elevating a folder or 
drawer to a new window. Elevating a folder or drawer allows you 
to work with that folder or drawer in the new window, but all 
other folders and drawers are unavailable in the new window. 
To elevate a folder or drawer, point to the folder or drawer to be 
elevated, press MB2, and choose Elevate in New Window from the 
pop-up menu. 

Sending and Receiving CDA Documents 
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You can send CDA documents as messages. The format of these 
compound documents is usually DDIF or DTIF. DDIF and DTIF 
documents cannot be edited with the DECwindows Text Editor 
used by Mail. 

To send a CDA document to another user: 

1 Choose File... from the Create-Send menu. 
Mail displays a di~og box that prompts you for the name of 
the file you want to use. 

2 Double click on the name of the file you want to use. 
The CDA document is displayed in the Create-Send window, 
but you cannot edit it. Enter the address information in the 
envelope region. 

3 Click on the Send button to send the message. 

If the recipient of a message containing a CDA document is using 
a configuration (such as a character cell terminal) that does not 
support VMS DECwindows, the recipient will receive a message 
indicating that the mail message is in a foreign format. The 
recipient can view the mail envelope (address, sender, subject), or 
forward, file, reply to, extract, or delete the message, but may not 
be able to view the message. 

If you attempt to mail a CDA document to a user whose mail 
system does not support CDA, the message will not be sent. You 
will be notified that the transmission cannot be completed. You 
can create a copy of the message in another format and send that 
file. 



To create a copy of a message in another format: 

Choose Extract... from the Create-Send window's File menu. 

2 Enter appropriate information in all text entry fields, as 
described in the section Creating a File from a Mail Message. 

3 In the Output Format field, press MBl, point to an output 
format that would be supported by the receiving system, such 
as Text, and release MBl. 

4 Click on the OK button to extract the message to a file. 

To send the file in the new format: 

Choose Include File... from the Create-Send window's File 
menu. 

2 Choose the file to be sent, as described in the section Including 
a File in a Message. 

3 Click on the OK button to include the file. 

4 Click on the Send button to send the message. 

Customizing Your Mail Environment 

User Attributes .. . 
Send Attributes .. . 
Deliver Attributes ••• 
Print Attributes ... 

Save Attributes 
Restore Attributes 
Restore System Attributes 

You can customize certain Mail features to suit your working 
environment. Modifying your default print settings allows you to 
alter the way your messages are printed. Modifying your mail 
profile allows you to alter the way your messages are sent, stored, 
and displayed. 

Modifying Your Default Print Settings 
To modify your default print settings, choose Print Attributes ... 
from the main window's Customize menu. Mail displays a dialog 
box. 
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[ffi Mail: Print Attributes ~· 
- - -- - - -- ~ 

Numberof Copies: ll____ 
Page Range: From ... li ___ To ... Ii __ _ OK II 

cancel I 
Print Format 

Text 

Line Printer 
Terminal 

ANSl2 

ANSI 

¢1 

Orientation 

ai> D 

• Default I n I 

Printer I 0 ti I .------........... p ons ... 
GEN_PRINT 0 

ARNO$LN01_1 ~ 
ARNO$LN01_3 

ARNO$LN03 

ARNO$NARROW 

¢1 ai> D 

Print After ..,ITn=ow.;;.;...._ ____ _ 

Iii Delete File When Printed 
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Refer to the VMS DECwindows User's Guide for a description of 
the fields in this dialog box. 

Changing your print defaults affects the way messages are printed 
during the current Mail session only. When you exit from Mail 
the print defaults revert to their original settings. 

Customizing Your M~il Profile 
Your mail profile allows you· to specify how messages are to be 
sent, stored, and displayed. You may change the default settings 
for your user attributes, send attributes, deliver attributes, and 
window attributes in corresponding dialog boxes. In each of the 
dialog boxes, an option is enabled when its button is shaded. To 
enable or disable an option, click on the corresponding button or 
its label. 

Note If you have used the VMS Mail Utility on your system, some of 
your VMS Mail defaults are displayed. See the section Making 
Mail Perform Like the VMS Mail Utility for more information. 



Modifying Your User Attributes To change the default settings 
for your Mail user attributes, choose User Attributes... from the 
main window's Customize menu. Mail displays a dialog box. 

W Mail: User Attributes l!lJll 
- - - - - --- --- --- -- --------------~-

Number of undelivered messages: o 
User Name: BEUTLER 

Personal Name: I System Manager 

Foiwarding Address: 

Mail Directory: NABOB$DUAO:[BEUTLER] 

Name of folder for deleted mail: I WASTEBASKET T 

• Empty wastebasket upon closing drawer 

II OK II I cancel I 
ZK-0309A-GE 

) 

The first line in the dialog box displays the current number 
of undelivered messages. The following table describes the 
remaining fields in the User Attributes dialog box. 

Option 

User Name: 

Personal Name: 

Forwarding Address: 

Mail Directory: 

Description 

Your VMS user name, which cannot be 
modified. 

A field of optionally specified text that is 
appended to the From: field of messages 
you send. Your personal name can be your 
full name or any other information, and 
must start with a letter. It cannot contain 
double spaces. 

The node and user name to which your 
messages are sent. This option is frequently 
used when you want to read your mail in a 
different account. 

The directory where your mail is being 
stored. It cannot be modified in Mail. Refer 
to Changing Your Mail Directory for more 
information. 
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Option 

Name of folder for deleted 
mail: 

Empty wastebasket upon 
closing drawer 

Description 

The name of the folder to which deleted 
messages are moved in new drawers you 
create. By default, the WASTEBASKET is 
specified. Existing drawers are unaffected 
by changing this setting. 

This option, which is set by default, causes 
the WASTEBASKET to be emptied when 
you close the drawer. 

Click on the OK button to save the profile settings for the current 
session only. To save the settings permanently, choose Save 
Attributes from the main window's Customize menu. Click on the 
Cancel button to reinstate the original profile settings. 

Modifying Your Send Attributes To change the default settings 
for mail messages that you send, choose Send Attributes... from 
the main window's Customize menu. Mail displays a dialog box. 

1E8 Mail: Send Attributes !i] II 

Default Editor: I DECwlndows Text Editor I 
Copy Self on: O Send O Reply O Forward 

D Courtesy Copy Option 

Mail Transport: _II _______ _ 

Iii Confirm closing from Create-Send window 

ii OK !I 
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The following table describes the fields in the Send Attributes ... 
dialog box. 

Option 

Default Editor: 

Description 

The DECwindows Text Editor, described 
in the VMS DECwindows User's Guide, 
is the default editor used to create 
messages. If more than one editor is 
available on your system, you can choose 
a different editor to create a message. 



Option 

Copy options 

Copy Self on: Send 

Copy Self on: Reply 

Copy Self on: Forward 

Courtesy Copy Option 

Mail Transport: 

Confirm closing from 
Create-Send window 

Description 

You can turn on the following Copy 
Self on: and Courtesy Copy options, 
which are disabled unless you specify 
otherwise: 

Includes your name as an addressee 
in Create-Send windows when sending 
a new message. You can edit out your 
name in the Create-Send window if you 
desire. · ···· 

Includes your name as an addressee in 
the Create-Send window when you reply 
to a message. You can edit out your 
name in the Create-Send window if you 
desire. 

Includes your name as an addressee 
in the Create-Send window when you 
forward a message. You can edit out 
your name in the Create-Send window if 
you desire. 

Prompts you with a courtesy copy 
prompt when using VMS Mail. This 
option does not affect VMS DECwindows 
Mail. 

The transport mechanism you want 
to use, if any. A transport mechanism 
is a product that affects when and 
how your messages are sent. Mail 
does not use a transport mechanism by 
default. Messages are sent immediately. 
Products such as Message Router or VAX 
PSI are optional. 

If you change the header or text of a 
message in a Create-Send window and 
then close the window without sending 
the message, a caution dialog box is 
displayed. The message "Changes have 
been made to the Create-Send window. 
Do you really want to close it?" appears. 
The Confirm Closing from Create-Send 
Window option allows you to suppress 
this confirmation message. 
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Modifying Your Deliver Attributes To change the default settings 
for mail messages that are delivered to you, choose Deliver 
Attributes ... from the main window's Customize menu. Mail 
displays a dialog box. 

INBOX Name of folder to deliver to: '-----------------

• Deliver mall when the deliver folder is opened 

D Automatically refile opened messages to MAIL folder 

OK I cancel I 
ZK-1360A-GE 

The following table describes the fields in the Deliver Attributes 
dialog box. 

Option 

Name of folder to deliver to: 

Deliver mail when the deliver 
folder is opened 

Automatically refile opened 
messages to MAIL folder 

Description 

The name of the folder to which new 
messages should be delivered. (If the 
folder does not exist, it will be created.) 
By default, the INBOX folder is specified. 

This option, which is set by default, 
causes new mail to be delivered 
whenever the delivery folder (INBOX 
by default) is opened. If you disable this 
option, mail is delivered only when you 
click on the Deliver Mail or Read New 
Mail buttons. 

This option, which is normally disabled, 
causes a message to be moved to the 
MAIL folder once it is read. If the MAIL 
folder does not exist, it will be created. 

This option causes messages to be moved 
immediately. If you delete or move the 
message, the delete or move operation 
will not be completed until the deliver 
folder is closed. The message will be 
held in the MAIL folder until the deliver 
folder is closed and the MAIL folder is 
reopened. 

Changes made to the Name of folder to deliver to: field will not 
take effect until you choose Save Attributes from the Customize 
Menu, and then exit from and reenter Mail. 



Modifying Your Window Attributes To change the default 
settings for your DECwindows environment, choose Windows 
Attributes... from the main window's Customize menu. Mail 
displays a dialog box. 

m Mail: Window Attributes ~II 

Main Window Style Startup State 

0 Paned 8> Window 
8> Outline O Icon 

COKJ I cancel I 
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The following table describes the fields in the Window Attributes 
dialog box. 

Option 

Main Window Style 

Startup State 

Description 

The window style, either Paned or 
Outline, used to display the index of 
messages in the main window. The 
default index style is Outline. Refer to 
the section Using a Paned Style Main 
Window for information about the Paned 
option. 

This option allows you to choose whether 
to have DECwindows Mail start as a 
window or as an icon. 

Changes made to the Main Window Style field will not take effect 
until you choose Save Attributes from the Customize Menu, and 
then exit from and reenter Mail. 

Saving and Restoring Attributes If you have changed the size or 
position of the windows, or any other user attributes except Print 
attributes, you can save these changes permanently. After you 
have made the desired changes, choose Save Attributes from the 
main window's Customize menu. Print attributes are not saved. 

To restore attributes that you have changed from their current 
state to your last saved attributes, choose Restore Attributes from 
the main window's Customize menu. 

To restore your attributes to the system default settings, choose 
Restore System Attributes from the main window's Customize 
menu. 
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Making Mail Perform Like the VMS Mail Utility 
This section is intended for users who use both the VMS Mail 
Utility and VMS DECwindows Mail. 

If you use VMS Mail and VMS DECwindows Mail to access the 
same mail messages, Mail will automatically set certain options in 
your mail profile to make Mail perform like VMS Mail. 

VMS DECwindows Mail will automatically set the following 
options in your mail profile: 

• Name of folder to deliver to: 
Mail specifies NEWMAIL in this field. 

• Automatically refile opened messages 
Mail turns on this option. 

Set the remaining options to match your VMS Mail settings. 

Once these options have been set, you will find using VMS 
DECwindows Mail very similar to using VMS Mail. Mail provides 
most VMS Mail functions with the exception of SPAWN, ATTACH, 
EDIT, and DEFINE/KEY. These functions are unnecessary in the 
VMS DECwindows environment. 

Using a Paned Style Main Window 
Mail's default main window displays your drawers, folders, and 
messages in Outline style. When an object is opened, its contents 
are revealed directly beneath it, similar to the format of a table of 
contents. 

You can choose an alternate style, called Paned style, for 
displaying the objects in your main window. A Paned style 
main window uses two panes to display your drawers, folders, and 
messages. The top pane lists your folders or drawers. The bottom 
pane lists the messages in the open folder. 

To use the Paned style, choose Window Attributes... from the 
Customize menu and click on the Paned option in the Window 
Attributes dialog box. Choose Save Attributes from the Customize 
menu. The Paned style main window takes effect when you exit 
from and reenter Mail. 



~Mail [!;)[5'1] 

Folders 1n MAIL Drawer 

eJ INBOX ftmWASTEBASKET 

cgi 1 8-APR-1990 NABOB::SMITH 
cgi 2 27-APR-1990 SOIREE: :JONES 
cgi 3 4-MAY-1990 DARCY: :MORRIS 
~ 4 16-MAY-1990 UDO: :GREEN 
~ 5 18-MAY-1990 BRONTE::BLACK 

Team Meeting, 1:00 
lunch invitation 
RE: review schedule 
poetry reading 
dog class canceled 

6 

D 

A 

6 
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In a Paned style main window, the names of your folders are 
always displayed, regardless of the number of messages in the 
open folder. (In Outline style, opening a folder frequently fills the 
window with the contents of that folder, pushing all other drawer 
and folder names out of the display.) Having folder names readily 
available is useful for certain Mail functions, such as moving and 
copying messages. 

The Paned style main window differs from the Outline style 
window in the following ways: 

• The main window is divided into two panes. The top pane 
contains the Drawer/Folder index. The folders in the open 
drawer are listed in this pane. To display a list of drawers, 
click on the Display Drawers button near the bottom of the 
Drawer/Folder index. Double clicking MBl on a drawer name 
opens the drawer and displays its folders. 
The bottom pane of the main window contains the Message 
index, which is a list of messages in the currently open folder. 
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• Only one folder may be opened at one time when using Paned 
style. To view messages in multiple folders simultaneously, 
open multiple main windows. 

• You cannot elevate a single drawer or folder to a new main 
window when using a Paned style window. Multiple main 
windows can be opened with Open Folder in New Window and 
Open Drawer in New Window on the File menu. 

• You cannot select a range of drawers or folders by clicking, 
dragging, and releasing MBl over the range of objects in 
a Paned style window. However, you can select a range of 
messages. To select multiple messages, press and hold the 
Shift key while clicking MBl on each desired message. 

Changing Your Mail Directory 
Mail stores your mail messages in the same directory used by 
the VMS Mail Utility. If you have not specified a directory to 
be used by the VMS Mail Utility, your default directory is used. 
Depending on the number of mail messages you receive and keep, 
this directory may become cluttered with mail messages. 

Using the VMS Mail Utility, you can specify a different directory 
as your Mail directory. Refer to the VMS Mail Utility Manual for 
information about the SET/SHOW MAIL_DIRECTORY command. 

Changing Directories for Drafts and Distribution Lists 
When you save a draft of a message, Mail stores the draft in your 
default directory. To specify a different directory for storage of 
draft files: 

Note The following procedures assume familiarity with your 
LOGIN. COM file. If you are unfamiliar with this file, ask your 
system manager for more information before following these 
procedures. 

1 From the Session Manager window, create a DECterm window. 

2 Edit your LOGIN.COM file to include the following command: 

$DEFINE DECW$MAIL_DRAFTS directoryspec 

where directoryspec is the name of the directory in which 
drafts are to be stored. For example, [SMITH.DRAFTS] is a 
valid directory name. 



You can also change the default directory for distribution lists. 
When you display a list of your distribution lists, Mail lists all 
files in your default directory with a DIS file type. To specify a 
different directory to be searched for DIS files: 

From the Session Manager window, create a DECterm window. 

2 Edit your LOGIN.COM file to include the following command: 

$DEFINE DECW$MAIL_DISTRIBUTIONLISTS directoryspec 

where directoryspec is the name of the directory in 
which distribution lists are stored. For example, 
[JONES.DISTLISTS] is a valid directory name. 

Exiting from Mail 
To exit from the Mail application, choose Exit from the main 
window's File menu. The main window and any open Read or 
Create-Send windows are closed. Open folders and drawers are 
closed. Your wastebasket is emptied, unless you have disabled 
that option in your user profile. If a Create-Send window is open, 
you are asked if you really want to exit. 

If multiple main windows are open, the File menu contains Close 
rather than Exit. Choosing Close closes only the main window 
from which Close is chosen. When there is only one remaining 
main window, its File menu contains the Exit menu item. 

Using Accelerators 
You can use certain key combinations, called accelerators, to 
quickly perform common Mail operations. The following table 
shows the functions and their corresponding accelerators. 

Table 9-1 

Press 

Altt/M 

Alt/P 

Alt/O 

Alt/N 

Shift/Do 

Using Accelerators 

To Produce 

Move ... 

Print 

Open 

Open in New Window 

Undo Move/Delete 

tCompose Character Key 

(continued on next page) 
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Table 9-1 (Cont.) 

Press 

Alt/D 

Shift/Remove 

Find 

Alt/B 

Alt/A 

Alt!F 

Alt!R 

Alt/U 

KP3 
KPl 
Remove 

Insert Here 

Ctrl/Z 

Help 

Alt/Q 

Ctrl/Z 

Using Accelerators 

To Produce 

Delete 

Copy to Clipboard 

Pick from Selected Folder ... 

Create a New Message 

Create a New Reply 

Forward with Header 

Read New Mail in Default Window 

Update Folder 

Read Next Message 

Read Previous Message 

Cut 

Paste 

Send 

Help 

Close 

Exit 
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10 
Using the Notepad Editor 

The Notepad is an editor that lets you do everyday tasks such as 
recording messages, writing letters, and building data files. 

The Notepad editor saves your notes in files, which you can store 
for later revision or incorporation into other files. 

This chapter describes how to 

• Start the editor 

• Enter and format text 

• Edit a file 

• Name a file 

• Open a second notepad 

• Open an existing file 

• Merge files 

• Find and replace text 

• Exit from an editing session 

Starting the Notepad Editor 
To start the Notepad editor, choose Notepad from File View's 
Applications menu. 

Notepad displays an empty editing window in which you can 
type text from the keyboard or copy in an existing file for editing. 
Notepad is interactive, so you see the changes to a file as you 
make them. 
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Typing Text 

ZK-0125A-GE 

To enter text in the Notepad window, give the window input focus 
and begin typing text from the keyboard. Notepad enters the 
text at the position marked by the cursor. Initially, the cursor is 
displayed in the upper left corner, but it moves right as you type. 

The Notepad inserts text into a temporary holding area called a 
buffer. The contents of the buffer appear in the Notepad window. 
At the beginning of an editing session, the buffer may contain very 
little text, but the buffer grows longer as you add information. 

A buffer exists only during the editing session. When you end an 
editing session, you direct the Notepad editor to save or discard 
'the contents of the buffer. 

Formatting Text 
Use the Tab key, the space bar, and the Return key to arrange 
text in the Notepad window as you want it to appear. 

You can also size the Notepad window so it has the line width you 
want. By default, Notepad wraps text lines at the right margin 
automatically, so you do not have to press the Return key at the 
end of every line. To disable word wrapping, choose Word Wrap 
from the Customize menu. When word wrapping is in effect, 
a shaded toggle button appears to the left of the Word Wrap 
menu item. When you disable word wrapping, the toggle button 
disappears. 
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Scrolling the Buffer 

Editing a File 
am 

Goto Top 

Goto Bottom 

Go to Selected Line Number 

Goto Line ••• ........................................... 
Split View 

Delete View 

As your text buffer grows, it extends beyond the frame of the 
Notepad window. To view text at the beginning or end of the 
buffer, use the vertical scroll bar along the right side of the 
window. The position of the slider indicates your position in the 
buffer. When the slider is at the top of the scroll bar, you are at 
the beginning of the buffer. When the slider is at the bottom of 
the scroll bar, you are at the end of the buffer. 

The Notepad navigation and editing commands let you move 
within a text buffer quickly and easily, adding or modifying 
information. 

Moving the Cursor 
When you insert text in the buffer, Notepad adds the text at 
the current cursor position, pushing existing text to the right. 
Therefore, the cursor is normally positioned at the spot where you 
last entered text. 

To move the cursor, position the pointer anywhere in the Notepad 
window or on your workstation screen where there is text or 
spaces and click MBl. 

Pressing the Shift key and the right arrow key at the same time 
moves the cursor one word to the right. Pressing the Shift key 
and the left arrow key at the same time moves the cursor one 
word to the left. 

With a long buffer, reposition the cursor using menu items from 
the Navigate menu. Choose Go to Top to move to the top of the 
buffer. Choose Go to Bottom to move to the bottom of the buffer. 

To reposition to a specific line in the buffer: 

Choose Go to Line... from the Navigate menu. 
Notepad displays a dialog box. 

2 Enter the line number. 

3 Press I Return I or click on OK. 

Notepad repositions the cursor to the specified line. 
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Another method of placing the cursor on a certain line is to 
select a line number in text anywhere on your workstation and 
choose Go to Selected Line Number from the Navigate menu. For 
example, if you are reading an error listing file in a DECterm 
window that contains the line number 1019 and you want to look 
at line number 1019 in a program source file you are editing in 
Notepad, select 1019 in DECterm and choose Go to Selected Line 
Number from Notepad's Navigate menu. The cursor is placed on 
line 1019 in your Notepad file. 

Note If you are correcting a program source file, you may want to start 
from the bottom and work your way up so that your edits do not 
affect how the line numbers in your source file correspond to the 
line numbers in your error listing file. 

Selecting Text 
In order to delete, move, or copy text in a buffer, you must first 
select it. Select text by pressing and holding MBl, dragging the 
pointer over the text, and releasing MBl. This highlights the 
selected text. Notepad stores this text until you tell it what to do. 

You can select text by using mouse clicks. Double clicking MBl 
selects the current word. Clicking MBl three times selects the 
current line; four clicks selects the entire document. Choosing 
Select All from the Edit menu also selects all text in a buffer. 

You can also perform an extended selection, which lets you 
select blocks of text that extend beyond the screen. To perform an 
extended selection, place the cursor at one end of the range you 
want to select. Scroll the file to the other end of the range you 
want to select, hold down the Shift key, and click MBl. The range 
of text is selected from the original cursor position to the specified 
insertion point, and the cursor is placed at the new insertion 
point. 

If you already have an active select range, Notepad starts at the 
insertion point (the place where you click MBl as you hold down 
the Shift key) and selects text from the insertion point up to the 
existing active select range. Notepad places the cursor at the 
insertion point. 
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Deleting Text 
Use the <iSJ (Delete) key to erase a few characters. To delete a line 
or a section of text, select the text and press the <iSJ key or begin 
inserting new text. Inserting new text causes the selected text to 
be deleted and the new text to take its place. 

To delete all of the text in a buffer, choose Select All and then 
Clear from the Edit menu. You can replace the deleted text by 
choosing Undo from the Edit menu. 

Canceling an Edit 
To cancel your most recent edit, choose Undo ... from the Edit 
menu. For example, if you remove text with the Cut menu item, 
you can restore the text to its former location with the Undo menu 
item. 

Notepad keeps a detailed record of all your edits so you can undo 
a series of edits. To cancel a series of edits: 

Choose Undo ... from the Edit menu. 
Notepad displays the Undo dialog box. 

2 Click on the Undo screen button to cancel the last editing 
operation. 
Each time you click on the Undo button, Notepad cancels 
another editing operation. 

3 If you undo an editing operation by mistake, reinstate the 
edits by clicking on the Redo screen button. 

4 To complete the operation, click on the Cancel screen button. 

You can cancel all the edits of an editing session in one step by 
choosing Revert from the File menu. Notepad restores the buffer 
to the state it was in when you first opened the file. 

Moving Text 
Because Notepad saves the last text you selected and deleted, 

Undo Alt/Z you can move text from one location in the text buffer to another 
Redo Alt/Shift/Z location. 
Undo ... 

Cut 

Copy 

Paste 

Clear 

Alt/X 

Alt/C 

AIW 

Select All Alt/A 

To move text in a buffer: 

Select the text you want moved to another location. 

2 Choose Cut from the Edit menu. 
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3 Move the cursor to where you want the deleted text inserted 
by positioning the pointer and clicking MBl. 

4 Choose Paste from the Edit menu. 

The deleted text is moved to the new location. 

Copying Text 
Because Notepad keeps track of your selected text, you can copy 
text from one location in a text buffer to another location. To copy 
text in the text buffer: 

1 Select the text you want copied to another location. 

2 Choose Copy from the Edit menu to store the copied text. 

3 Move the cursor to where you want the selected text copied by 
positioning the pointer and clicking MBl. 

4. Choose Paste from the Edit menu. 

The selected text is copied to the new location. 

Changing Your Font 
You can change the font Notepad uses by choosing the Font ... 
menu item from the Customize menu. 

Notepad displays a dialog box. 

Font Attributes [!.;]ii'IJ 
Family (Foundry) Size (dpl) 

10 (75) 
12 (75) 
14 (75) 
18 (75) 
24 (75) 

Alien (Spacewar) 6 
Blimp (Spacewar) ij Broom (Spacewar) 
Chopper (Spacewar) 
Crusher (Spacewar) 0 
Weight Slant Width Spacing Char Set 

6 

~ 
Sample Text 

6 Apply 

ij I cancel I 
0 

The quick brown fox jumped over the lazy dog. 6 
abcdefghi j klmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ01234 5678 9 0 

Q 
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The Font dialog box lists the fonts available on your system. To 
change your font: 

1 Click on the desired font in the Family list box. 

2 Click on the desired size in the Size list box. 

3 Click on the set of characteristics (weight, slant, width, 
spacing, and the character. set) you want your font to have. 
Once you have chosen your desired settings in the three list 
boxes, an example of what your new font looks like appears 
in the Sample Text box. To apply the new font, click on Apply 
and then Cancel to exit the dialog box. To cancel your new 
settings without applying them, click on Cancel. 

Including an Existing File 
You can include an existing file in the text buffer that you are 
currently editing. 

To include an existing file: 

1 Move the cursor to where you want the included file inserted. 

2 Choose Include ... from the File menu. 
Notepad displays a dialog box. 

3 Either select the file from the files listed in the dialog box or 
type the name of the file you want to include. 

4 Click on the OK button. 

The contents of the included file are inserted in the editing 
window at the current cursor position. 

Splitting the Screen 
You can split your Notepad screen into a number of edit windows. 
This enables you to work on different portions of the same 
file simultaneously, and to perform editing functions between 
windows, such as cutting and pasting. This is particularly helpful 
with a long file. 

To split the window in which the cursor is currently placed, choose 
Split View from the Navigate menu. 

To get rid of the window in which the cursor is currently placed, 
choose Delete View from the Navigate menu. 
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Saving Text in a File 

New AIVN 

Open... Alt/O 

Open Selected 

Include... Alt/I 

Save Alt/S 

lsaveAs ... Alt/ShlWSI 

Revert 

Quit Alt/Q 

Exit Ctrl/Z 

When you add text to Notepad, the editor records the information 
in the buffer. Because a text buffer exists only for the editing 
session, if you want to save the contents of the buffer you must 
direct Notepad to write your text to a file. 

To save the text in your buffer as a file: 

Choose Save As... from the File menu. 
Notepad displays a dialog box that prompts you for the name 
of the file. 

Save As... l!iJll 

ii OK II 
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2 Enter the name of the file, assigning a name that corresponds 
to the contents of the file so that you can easily recognize 
it. Use the <iil and arrow keys to make any necessary 
corrections. 

3 Press I Return I or click on the OK button. 

Notepad writes the contents of the buffer to the new file and posts 
the file name in the title bar of the editing window. 

When you make changes to an existing file, it is also necessary 
to save the changes. Once a file has a name, use the Save menu 
item to update the file. 

Opening a Second Notepad 
You can open a second Notepad window without closing the first 
window. To create a second Notepad window, choose New from the 
File menu. A second Notepad window opens. 

The editing you do in the second Notepad window can be 
completely independent of the first Notepad window, or you can 
copy and paste text from one Notepad window to the other. 
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Opening an Existing File 

New AIVN 

!Open... Alt/O 

Open Selected 

Include... Alt/I 

Save 

Save As ... 

Revert 

Quit 

Exit 

Alt/S 

Alt/Shift/$ 

Alt/Q 

Ctrl/Z 

When you want to edit an existing file, you direct Notepad to open 
the file and read its contents into the Notepad buffer. 

To open an existing file: 

Choose Open... from the File menu. 
Notepad displays the Open File dialog box. 

Open... [pJllJ 

File Filter 

II*.* 
Files in DISK$:[JONES] 

AGENDA.TXT 0 

MEMO.TXT 

~ PROG.LIS 

Filter 

Q 
¢1 I IJO D 
Selection 
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2 Either select the file from the files listed in the dialog box or 
enter the file name. 
You can select a file by double clicking on it or by clicking on 
it once and then clicking on OK 

3 Press I Return I or click on the OK button. 

The contents of the file appear in the editing window and Notepad 
displays the file name in the title bar. 

You can also open an existing file by selecting a file name in 
any other window (for example, DECterm or FileView) and then 
choosing the Open Selected menu item from the File menu. 

'\ 
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Merging Files 
Whether you are writing a letter or a computer program, you can 

Undo 

Redo 

Undo ••• 

Alt/Z often save time by combining pieces of information from other 
Alt/Shift/Z letters or programs that you have written. 

Cut Alt/X 

!Copy Alt/C 

Paste AIW 

Clear 

Select All Alt/A 

Copying Text from One Notepad Window to Another 
To copy text from·one Notepad window to another: 

1 Select the text that you want to copy. 

2 Choose Copy from the Edit menu. 

3 Position the pointer in the other Notepad window at the point 
you want to insert the copied text. 

4 Choose Paste from the Edit menu. 

Notepad inserts the copied text at the desired location, leaving the 
text in the other window intact. 

Searching for Text 
.----------. You can search a text buffer for any text, such as a word, a 

Next selected Shift/Find 

~~-~~-~~ ......... ~~-~~ number, or any other character that you can type on your 
Next... Aid 

Previous... C1ltlFlnd 

Next Incremental ... 

Previous Incremental." 

Replace Once". 

Replace Within Selected Area­

Replace All." 

keyboard. Because Notepad treats spaces as text, you can search 
for two or more words. Notepad searches the buffer from the 
current cursor position and highlights the first occurrence of the 
text string. 

Choose Next... from the Search menu. 
Notepad displays a dialog box. 

~-------- ~-

Next I Previous I cancel 
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2 Enter the text string you want to locate. 

3 Click on the Next screen button to initiate a search from the 
current position to the end of the file. 

You can continue to search for the text string by clicking on the 
Next screen button in the dialog box. 
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Replacing Text 

NextSelec:ted 

Previous Selec:ted 

Shift/Find 

Ctrl/Shlft/Flnd 

Next... Find 

Previous... Cb\'Flnd 

Next lncrementaL­
Prevlous Incremental ... 

Replace Once.-

Replace Within Selectad Aree... 

Replace All-

If the string you want to search for is visible anywhere on your 
workstation screen, you can also perform a search by selecting 
that word and then choosing Next Selected or Previous Selected 
from the Search menu. 

By default, Notepad performs a case-sensitive search. Choose 
Case Sensitive Searches from the Customize menu to make 
searches insensitive to case. A shaded toggle button to the 
left of the Case Sensitive Searches menu item indicates that 
case-sensitive searches are in effect. 

Notepad can also search a text buffer for a character pattern. You 
can add characters or delete characters from the search string 
during the search operation, and Notepad returns to the initial 
search position in the buffer and looks again for the modified 
pattern. Choose the Next Incremental... menu item to search for 
patterns. 

The Notepad editor can replace one text string with another 
text string. This is especially useful if you have spelled a word 
incorrectly throughout a long file and you want to fix every 
occurrence of the misspelled word. 

To replace a text string: 

Choose Replace All... from the Search menu. 

Notepad displays a dialog box. 

Replace All... rJ II 

Old &.::..II ___ _ New .... II ___ _ 

OK cancel 
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2 Enter the old text that you want Notepad to replace and press 
the Tab key to move the cursor to the next text entry field. 

3 Enter the new text that you want substituted. 

4 Click on the OK button or press I Return I to initiate the 
replacement. 
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To perform individual replacements, choose Replace Once... from 
the Search menu. Notepad searches the buffer from the current 
cursor position and highlights the first· occurrence of the text. 
Click on the Yes button to replace the old string with the new 
string. To avoid a replacement, click on the No button. To replace 
text in a selected range, select the text you want to perform a 
replace operation on and choose Replace Within Selected Area ... 
from the Search menu. 

Exiting from an Editing Session 
To end an editing session, choose Exit from the File menu. If 
you have modified text in the current buffer, Notepad produces 
a new version of the edited file and closes the Notepad window. 
The new version of the file has the same file name and file type 
as the original version, with the version number incremented by 
one. For example, if you use the EXIT command after modifying 
a file named STRATEGIES.DAT;!, the output file is named 
STRATEGIES.TXT;2. 

If you modified word wrapping or case-sensitive searches during 
your editing session and you would like to save those settings for 
future. editing sessions, choose Save Current Settings from the 
Customize menu. To restore your previous settings, choose Use 
Last Saved Settings from the Customize menu. 

To discard the edits from a session and close the editing window, 
choose Quit from the File menu. 

Using Journal Files 
The Notepad editor keeps a record of changes made to a file 
so it can reconstruct any editing session that is interrupted 
because of a system failure. (Failures occur, for example, when a 
thunderstorm interrupts the electrical power.) 

The record, called a journal file, usually exists only while an 
editing session is active. However, the file remains if the session 
ends abnormally. 

When you attempt to edit a file that has a journal file associated 
with it, Notepad displays the Recover dialog box and asks you 
whether you want the previous edits restored. 
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If a session is interrupted before you create a file, Notepad still 
saves your keystrokes in a journal file and assigns the untitled 
buffer a file name. The file name has the format nnnnnnnn.JNL, 
where nnnnnnnn is a process number that uniquely identifies the 
file. 

To recover the editing session: 

1 Choose Open... from the File menu. 

2 Look at the list of files in your current directory. Find a file 
with the nnnnnnnn.JNL format created on the appropriate 
day, and enter the process number (nnnnnnnn) in the 
Selection text entry field. Do not include the JNL file type in 
the file name. 
Notepad displays a Recover dialog box asking you to confirm 
that you want to perform the recovery. 

3 Click on the Yes button. 
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Using Paint 

Paint is a graphics program that lets you create any kind of 
simple picture, such as a sketch, an illustration, or a map. From 
an assortment of art tools, you can choose those that enhance your 
picture, adding any details and accents it requires. 

The Paint program can save your pictures for later use, print them 
on different kinds of printers, or copy them to other applications. 
You can also display these pictures on your terminal screen with 
the CDA Viewer (see Chapter 2). 

This chapter describes how to 

• Start Paint 

• Select tools and menu items 

• Erase 

• Draw lines and shapes 

• Introduce patterns into paintings 

• Use the paintbrush 

• Edit paintings 

• Insert text 

• Size and scroll the canvas 

• Print paintings 

• Exit from Paint 

Using Paint 11-1 



Starting Paint 
To start Paint, choose Paint from File View's Applications menu. 

The Paint program displays a drawing window with a tool palette 
on the left side. 
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The Paint window frames a portion of the canvas. Horizontal and 
vertical scroll bars indicate the percentage of the canvas displayed 
in the Paint window. 

Learning the Basics 

11-2 Using Paint 

Paint is a bitmap graphics program, which means that it treats 
pictures as a collection of dots called pixels. Different drawing 
tools, such as the pencil, the paintbrush, and the text tool, edit the 
color of the pixels to either the foreground color or the background 
color to create a pattern. Because the Paint canvas has so many 
pixels in every square inch, you do not actually see patterns of 
dots. Instead you see a collection of lines, shapes, and text. 

You can begin to understand Paint by modifying a sample picture 
called the Clock Tower. To display the Clock Tower: 

Choose Open... from the File menu. 
The Open Picture dialog box displays the names of any 
graphics files in the current directory. 
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2 Enter the picture file name, DECW$EXAMPLES:CLOCK.IMG 
IMG is the standard format of a Paint file. 

3 Click on the OK button or press I Return I. 

Paint displays the Clock Tower picture. You can use the Clock 
Tower picture to practice selecting tools and to experiment with 
some of the Paint menu items. Figure 11-1 illustrates the Clock 
Tower. 
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Figure 11-1 The Clock Tower 
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Picking Out Tools 
The tool palette offers a variety of art tools and basic shapes. You 
can work with a pencil, a paintbrush, a can of spray paint, or 
a paint bucket. The shapes on the tool palette let you compose 
pictures quickly and easily. 

Notice that when you first start Paint, the paintbrush tool is 
highlighted, indicating it is the current default. Only one tool on 
the tool palette is active at a time and that tool remains active 
until you make another selection. 

Try changing the time on the Clock Tower. First,. select the eraser 
to delete the current time. To use the eraser: 

Place the pointer in the tool palette, position it on the eraser 
tool, and click MBl. 

2 Move the pointer into the drawing window, position it in the 
center of the clock face, .and press and hold MBl. 
The eraser is now active in the window. 

3 Gently drag the eraser along each hand of the clock, 
eliminating the current time. 

Now, draw in the current time, using the straight line tool: 

Point to the straight line tool on the tool palette and click 
MBl. 

2 Position the pointer in the center of the clock face and press 
MBl. 
The straight line tool is now active, and one end of the line is 
anchored at the center of the clock. You can stretch and swing 
the line from the center point by moving the mouse. Try it. 

3 Drag the· pointer from the center of the clock to the current 
hour position. Once the line points to the correct time, release 
MBl. 

4 Add a second line in the same manner for the minute hand. 

If you make a mistake, choose Undo from the Edit menu. 

Inverting Images 
You can use the Invert menu item on the Edit menu to create a 
negative image of a painting. The Paint program can reverse the 
tones of the Clock Tower, switching the foreground color and the 
background color. 
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Click on the selection box tool. 

2 Move the pointer into the drawing window and select the 
Clock Tower by positioning the pointer in one comer of the 
area to be selected and dragging the pointer over the desired 
area. 

3 Choose Invert from the Edit menu. 

Paint repaints the Clock Tower, making a negative of the original 
image. 

Saving a Painting 
To save your version of the Clock Tower: 

Choose Save As... from the File menu. 
Paint displays a dialog box and prompts you for a file name. 
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2 Type a file name using the form SYS$LOGIN:filename.IMG so 
that Paint saves the picture in your login directory. 

3 Click on the OK button or press I Return I. 



Erasing 

Printing a Painting 
To print the Clock Tower, choose one of the Print menu items from 
the File menu. The first time you choose one of the Print menu 
items, Paint displays the Print dialog box so that you can see the 
defaults and change them if desired. Thereafter, the Print menu 
item sends the painting to the default printer, whereas Print ... 
always displays the Print dialog box. Complete the dialog box as 
described in the VMS DECwindows User's Guide. 

Paint supports output to both PostScript printers and sixel 
printers such as the LA50 and LAlOO. When printing on an LA50 
printer, set an aspect ratio of 2:1. All other printers have a 1 :1 
ratio. 

There are several ways to erase in Paint: 

• Use the eraser tool. 

• Select an area using the selection box tool or the scissors tool. 
Or, select the visible portion of the canvas using Select All 
from the Edit menu. Then choose Clear from the Edit menu. 

• Choose Undo from the Edit menu to erase the last Paint 
operation. 

Drawing Lines and Shapes 
The bottom half of the tool palette, shown in Figure 11-2, contains 
a collection of line and shape tools that you use in a similar way. 
Whenever you draw a straight line or a shape, the point where 
you press MBl becomes its reference point. That is, you can 
stretch and swing the line or shape from this reference point by 
dragging the pointer. When the shape is correct, anchor it in place 
by releasing MBl. 

With the polyline tool, click MBl to end one line and start 
another. Double click to terminate the tool, or, if you are back at 
the starting point of a figure, click MBl once to close the figure. 

To use the free-hand stroke tool, you press and drag MBl, and 
then release it when you are finished drawing a particular line. 
Figure 11-2 illustrates the tools for creating lines and shapes. 
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Figure 11-2 Tools for Lines and Shapes 
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For example, to draw a rectangle: 

1 Click on the rectangle tool. 

2 Position the pointer in the drawing window where you want 
one corner of the rectangle to be. Press MBl and drag the 
pointer diagonally across the drawing surface until the 
rectangle has the desired width and height. (Notice how 
you can stretch and shrink the rectangle, even flip it over.) 

3 Release MBl to anchor the shape. 
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If you want to line up a series of shapes or draw them equidistant 
to each other, choose Grid On from the Options menu. It 
superimposes a horizontal and vertical pattern of dots on the 
drawing window, as shown in Figure 11-3, that serves as a guide, 
yet does not become part of your picture. One advantage of using 



a grid is that it causes lines to "snap in place" on the dots, which 
makes drawing geometric figures easier. 

Figure 11-3 Using a Grid 
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Varying Line Width 
Lines drawn with the shape tools can be thick or thin. To change 
the current line width: 

Choose Line Width... from the Options menu. 
Paint displays a dialog box. 
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2 Click on the line thickness you want. 

For example, to draw polygons with different kinds of borders, 
choose the line width you want and then do the following: 

Click on the polyline tool to make it active. 

2 After positioning the pointer in the drawing window and 
pressing MBl, drag the pointer to create one side of the 
polygon. Drag and click to create additional sides, and click 
on the starting point to complete the figure. Double clicking 
MBl ends the polyline without closing off the polygon. 

Most of the time, geometric shapes or figures are opaque, so you 
cannot see what lies behind them. Opaque figures are the default, 
as indicated by the shaded option button next to the Opaque 
menu item on the Options menu. Choosing Transparent from 
the Options menu causes background images to show through 
foreground images. The Transparent and Opaque settings affect 
not only figures but selected images being moved, the spray can 
tool, the pamtbrush tool, and text. 
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Using Patterns 
Lines and shapes do not need to be a solid color. They can be 
striped, speckled, woven, dotted, and so on. 

The line and shape tools, the spray can tool, and the paintbrush 
tool can paint patterned lines and borders. The default border is a 
solid foreground color. To use patterned lines: 

Choose Patterns ... from the Options menu. 
Paint displays the Patterns palette, which provides a selection 
of designs. Figure 11-4 illustrates the Patterns palette. 
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Figure 11-4 
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2 Click on the border pattern button. 

3 Click on any pattern. 
Notice that the pattern you click on is displayed in the border 
pattern button, indicating it is the active pattern. 

4 Click on the shape tool you want to use. 

5 After positioning the pointer in the drawing window, drag the 
pointer to create a patterned line or border. 

To create shapes with patterned centers: 

Choose Patterns... from the Options menu. 
Paint displays the Patterns palette (illustrated in Figure 11-4). 

2 Click on the fill pattern button. 

3 Click on any pattern on the palette. 
Notice that the pattern you click on is displayed in the fill 
pattern button, indicating it is the current default pattern. 

4 Click on any tool you want to use. The geometric shape tools 
and the paint bucket tool use the current fill pattern. 

5 After positioning the pointer in the. drawing window, drag the 
pointer to create a shape with a patterned center. 



You can fill existing shapes with the paint bucket tool by 
clicking MBl inside the shape you want to fill. The shape 
must be enclosed; any opening in the border causes the paint 
to spill out onto the canvas. You can reverse filling a shape by 
choosing Undo Flood from the Edit menu. 
Clicking on a black pixel causes all ajoining black space to be 
filled with the pattern. Clicking on a white pixel causes all 
adjoining white space to be filled with the pattern. 
Filling works only on the visible part of the canvas. For 
example, if you attempt to flood the entire canvas, only the 
visible portion is affected. 
Figure 11-5 shows examples of patterns. 

Figure 11-5 Examples of Patterns 
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Creating Your Own Patterns 

Help 

With Paint, you can create your own patterns and store them 
on the pattern palette during a Paint session. You create your 
own pattern from any of the patterns on the palette except 
the solid foreground, solid background, and None patterns (see 
Figure 11-4). 

To create your own pattern: 

Decide whether you want a border or a fill pattern, then click 
on the appropriate button on the Patterns palette. 
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2 Choose a pattern from the palette that is closest to what you 
want and click on it. Paint also provides a few blank patterns 
at the end of the palette so that you can create your own 
patterns from scratch. 

3 Choose Edit Pattern ... from the Options menu. 
Paint displays a dialog box. 
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Notice that this dialog box contains two boxes. In the left­
hand box you see the pattern you chose from the palette. In 
the right-hand box you see the same pattern magnified. 
While you are editing a pattern, the Edit Pattern dialog box 
has input focus, and the pointer assumes the shape of a pencil. 

4 In the Edit Pattern dialog box, edit the magnified version of 
the pattern to create the effect you want. 
Use the pencil to draw over pixels or click on individual pixels. 
When the pencil is clicked on a pixel, that pixel inverts its 
color. The new color of the pixel becomes the pencil color, and 
until MBl is released, all pixels the pencil passes over take 
on the color of the pencil. For example, if you are working 
with a black and white canvas and you start the pencil in a 
white area, the pencil will draw black until you release MBl, 
even if it passes through a black area. Conversely, if you start 
the pencil in a black area, it will draw white until you release 
MBl, even if you pass it through a white area. 
Refer to the pattern shown in the left-hand box to see how the 
magnified pattern looks under normal conditions. 

5 Click on the OK button to complete the pattern and return to 
the drawing window. 

The edited pattern is available on the Patterns palette for the rest 
of the session, replacing the original pattern. You cannot recover 
the original pattern for that session. 



Using the Paintbrush 
For an elegant stroke, one that creates a calligraphic effect, use 
the paintbrush. The paintbrush tool applies paint along the path 
of the pointer. Initially, the paintbrush has a solid stroke, but you 
can choose a patterned stroke by changing the border pattern on 
the Patterns palette, as described in the section Using Patterns. 

To shape the tip of the paintbrush: 

Click on the paintbrush tool. 

2 Choose Brushes... from the Options menu. 
Paint displays a dialog box. 

Brushes l!i] IJ 

·D • • • 
• • • • • , / / / / 

' ' ' " " 
OK 

ZK-0123A-GE 

3 Click on the brush shape you want. 

4 Move the pointer into the drawing window and try out the 
new brush stroke. 
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With Paint's electronic canvas, you can easily rearrange images 
in the drawing window. You can delete images entirely, move 
them to another part of the window, or copy them. Paint can size 
selected images, shrinking them or enlarging them as you wish. 
It can also crop a painting, retaining one section of the canvas 
while discarding the rest. For further effect, Paint can invert the 
foreground and background colors in a selected area. 

Selecting Images 
Two selection tools, the box and the scissors, mark a portion of the 
drawing window for a graphics operation. The selection box tool 
marks a rectangular area, while the selection scissors tool marks 
an area with an arbitrary shape. You can select the visible portion 
of the canvas with Select All on the Edit menu. 

To use the selection box tool, position the pointer in one corner 
of the area to be selected and drag the pointer over the desired 
image. 

To use the selection scissors tool, drag the pointer around the 
boundary of the desired object until you reach the starting point. 

You can cancel a selection by clicking in another part of the 
window or by selecting another tool. 



Moving Images 
You can move an image from one location in the Paint window to 
another. To move an image: 

1 Select the image. 

2 Position the pointer inside the selected area and drag the 
image to the desired location. 
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You can cancel the selection by clicking in another part of the 
window or by selecting another tool. 

Copying Images 
Once you select an image on the canvas, you can copy the image, 
leaving the original image intact. Then paste the image onto the 
canvas. Paint can paste graphic images, but it cannot paste text. 

To copy an image: 

Select the image. 

2 Choose Copy from the Edit menu. 
Paint copies the image to the clipboard. 

3 Choose Paste from the Edit menu. 
Paint puts a copy of the image on the canvas, leaving it 
selected. 
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4 Position the pointer in the selected image and drag it to the 
desired location on the screen. 
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You can cancel the selection by clicking on another tool or by 
selecting another image. 
You can also use the Cut menu item to copy a selection to the 
clipboard without leaving a copy of it in the original location. 

Resizing Images 
You can also modify the proportions of selected images. Choose 
Scale... fro~ the Edit menu to enlarge or shrink a selected image. 
To scale an image: 

1 Select the image. 

2 Choose Scale... from the Edit menu. 
Paint displays a dialog box. 

3 Click on one of the percent buttons to change the scale. If 
you want to specify your own percentage, enter a number less 
than 100 to shrink the figure by the desired percentage or a 
number greater than 100 to expand the figure. 

For example, clicking on 25% reduces the selected area to 
one-fourth the original size, while clicking on 200% makes it 
twice as large as the original. 
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4 Click on the OK button to complete the operation. 

To reverse the process and return to your original picture, 
choose Undo Scale from the Edit menu. 
Choosing Scale Picture... from the Edit menu allows you to 
scale the entire canvas. This operation cannot be undone. 

Cropping a Picture 
Many times, one section of a painting develops so well that you 
decide to keep it but discard the rest of the canvas. Use Crop to 
extract a portion of the picture. To crop a picture: 

1 Select the section of the picture you want to keep. 

2 Choose Crop from the Edit menu. 
Paint repositions the cropped picture in the upper left corner 
of the window and discards the rest of the painting. You can 
restore the original picture with the Undo Crop menu item. 

Working with Full Views 
By using the Full View menu item on the Options menu, you can 
display entire figures even if they are too large to fit in the Paint 
window. The Full View dialog box enables you to display only a 
portion of your picture or to permanently crop it. 

To display an entire picture, choose Full View... from the Options 
menu. Paint displays the Full View dialog box. 
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To change modes in the Full View... dialog box, display the Mode 
option menu and choose the desired option. The default mode is 
Position. 

To designate the area of your picture that you want to display: 

Enable Position mode by choosing Position from the Mode 
option menu in the Full View dialog box. (Position mode is the 
default.) 

2 Place the pointer inside the Position window and drag it over 
the area of the canvas you want to display. 

3 Release MBl. 

4 Click on OK to display the desired portion of the canvas. 

To crop your picture: 

Enable Crop mode by choosing Crop from the Mode option 
menu in the Full View dialog box. 

2 Position the pointer in one corner of the area to be cropped 
and drag the pointer until the Crop window frames the area of 
the canvas you want to crop and save. 
Once you click on the Do Crop button, the rest of the figure 
will be discarded. 

3 Click on the Do Crop button. 
To reverse cropping, click on the Undo Crop button. 

4 Click on OK. 
Paint displays a dialog box, telling you that the crop operation 
is irreversible and asking if you want to save the picture 
before continuing. To retain only the portion of the picture you 
selected and discard the rest, click on No. To save the picture 
before it is cropped, click on Yes. 
Clicking on Cancel puts you back in the Full View dialog box, 
from which you can undo the crop by clicking on the Undo 
Crop button. 

Editing in Detail 
Not only does Paint magnify patterns in the Edit Patterns dialog 
box so you can see them better, it also magnifies portions of the 
canvas with the Zoom On menu item. The Zoom magnifying frame 
acts like a magnifying glass in the drawing window, enlarging an 
image to eight times its original size. 



To magnify a portion of a painting: 

Choose Zoom On from the Options menu. 

The Zoom window opens beside the Paint window and a 
magnifying frame is displayed in the Paint window itself. 
The magnifying frame in the Paint window demonstrates the 
size of the image that Paint magnifies in the Zoom window. 
You can resize the Zoom window to edit a larger area of the 
canvas. 
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2 Place the pointer inside the magnifying frame and drag the 
frame over the image that you want to edit. 

Notice that the Zoom window contains an enlarged version 
of the image that is defined by the magnifying frame in the 
Paint window. 

3 Select the pencil tool from the tool palette. 

4 Bring the pointer into the Zoom window and use the pencil to 
add fine details to the image. Either click on individual pixels 
or draw over them. 
Notice that the image in the drawing window changes as you 
edit in the Zoom window, so you can see how the modified 
figure looks in normal proportions. Continue editing pixels 
until you are satisfied with the overall effect. 

5 To edit other areas of the drawing window, drag the 
magnifying frame to the next location. 
Edit the pixels in the Zoom window as before. 
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To close the Zoom window, display the Options menu and click on 
Zoom Off. 

You can insert text anywhere in the Paint window. The text 
can be different fonts, sizes, and styles. You can change the 
appearance of text in the drawing window up until the moment 
you click to complete the text entry. After that, Paint incorporates 
the text into the graphic image. 

To insert text: 

Select the text tool. 

2 Position the pointer in the Paint window where you want to 
insert text and click MBl. 
Paint inserts a left corner bracket to mark the left margin of 
. the text entry and displays the text insertion cursor next to it. 

3 Type in text from the keyboard, formatting it with the Tab 
and Return keys. 

4 To modify the text font, pull down the Font menu and drag 
the pointer to the submenu icon next to the Family menu item 
to view the submenu. Release MBl over the type of font that 
you want. 

5 To change the text from normal to bold face, pull down the 
Font menu and drag the pointer to the submenu icon next to 
the Style menu item to view the submenu. Release MBl over 
the Bold menu item. 
You can also choose an italic style of font from the Style 
submenu. 

6 To adjust the size of the text, pull down the Font menu and 
drag the pointer to the submenu icon next to the Size menu 
item to view the submenu. Release MBl over the pica size 
that you want. 
Paint applies the selections you make to the text you have 
already entered. 

7 To complete the entry with its current characteristics, either 
move the pointer to another part of the window and click MBl 
or select another tool. 



The inserted text becomes part of the picture. You can no longer 
erase text with the ~ (Delete) key or change its characteristics 
with items from the Font menu. Figure 11-6 illustrates how you 
can add text to a picture. 

Figure 11-6 Adding Text 
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Sizing the Canvas 
The default Paint window shows only a portion of the canvas. The 
scroll bars along the right side and the bottom of the window let 
you view the entire canvas. The position of the slider indicates 
your position in the canvas. 

To frame a larger or smaller portion of the canvas, use the resize 
button. 

You can also tailor the size of a Paint canvas. To alter the canvas: 

Choose Picture Size... from the Customize menu. 
Paint displays a dialog box. 
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The Picture Size dialog box shows the current canvas size 
with its dimensions converted to pixels, inches, or centimeters. 

2 In the dialog box, you can set the dimensions to be in pixels, 
inches, or centimeters by clicking MBl on the appropriate 
option button. If you have chosen Non-Standard from the Size 
Option menu in the dialog box, you can also type in the height 
and width you desire. 
You can designate the size you want by pressing MBl to 
display the Size menu and choosing Non-Standard, Letter (8 
by 10) or Screen (size of the screen in pixels). Non-Standard 
enables you to supply your own value. The maximum size is 
2550 by 3300, and the minimum size is 10 by 10. Letter is the 
default. 
Additionally, you can modify the number of dots per inch 
(DPI). This allows you to manipulate high-resolution images. 
To modify the DPI, enable the Inches or Centimeters option, 
and press MBl to display the Resolution menu. Choose 75, 
100, or 300 DPI, or the Non-Standard menu item. Non­
standard allows you to supply your own resolution. The 
change will be evident when you print the picture out, rather 
than in the Paint display. 

3 Click on the OK button. 



Using Accelerators 
You can use certain key combinations, called accelerators, to 
quickly perform common Paint operations. The following table 
shows each key combination and its corresponding function. 

Press To Produce 

Altt/Z Undo 

Alt/Q Quit 

Alt/X Cut 

Alt/C Copy 

Alt/O Open 

AltN Paste 

Alt/P Print 

Alt/S Save 

Alt/W Refresh screen 

tCompose Character Key 

In addition to using accelerators to perform common DECwindows 
commands, you can also use key combinations to manipulate 
Paint tools. You can press and hold the Shift key while you drag 
MBl to produce the following results: 

Tool 

Rectangle 

Line 

Paintbrush 

Pencil 

Ellipse 

Polyline 

Eraser 

Arc 

Effect 

Causes it to be a square 

Causes it to be at an angle that is a multiple of 45 
degrees 

Causes it to be horizontal or vertical 

Causes it to be horizontal or vertical 

Causes it to be a circle 

Causes angles to be multiples of 45 degrees 

Causes it to erase vertically and horizontally only 

Causes arc to be 114 circle (instead of 1/4 ellipse) 
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Exiting from Paint 

Tool Summary 

·-- .. I I 
I I . __ .. 
1P 
't~ 

~ 

11-26 Using Paint 

To exit from Paint, choose Quit from the File menu. If you try to 
exit without saving your picture, Paint asks if you want to save 
the picture before exiting. Click on Yes, No, or Cancel to state 
your choice. 

The following list summarizes the tools available on the Paint 
palette. 

Box 
Selects a rectangular area for editing. 

Scissors 
Selects a shape for editing. 

Spray can 
Applies paint in the current border pattern. (The slower you drag 
the tool, the darker the coat.) 

Pencil 
Draws a thin line. Shift click to make the Pencil draw at a 
90-degree angle. 

Eraser 
Deletes the image in the path of the pointer. Shift click to make 
the Eraser erase at a 90-degree angle. 

Paintbrush 
Paints a free stroke. Shift click to make the Paintbrush paint at a 
90-degree angle. 

Text 
Prints what is typed at the keyboard. 

Paint bucket 
Fills a closed shape with the current fill pattern. 

Line 
Draws a straight line. You can shift click for a 45-degree or a 
90-degree line. 

Arc 
Sketches a horizontal or vertical arc, depending on the initial 
movement after the click. Shift click to make a 1/4 circle. 
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Rectangle 
Draws a rectangle. You can shift click for a square. 

Square 
Draws a square. 

Ellipse 
Draws an oval shape. You can shift click for a circle. 

Circle 
Draws a circle. 

Free-hand stroke 
Draws a free-hand line in the selected line width and pattern. 

Polyline 
Draws a multisided figure. You specify a corner by clicking, 
and you click at the starting point to complete a shape. Double 
clicking anywhere other than the starting point terminates the 
polyline. You can shift click for 45-degree or 90-degree angles. 
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12 
Puzzling 

The Puzzle is a video version of a number puzzle with slidable 
squares. 

Starting the Puzzle 

Layout. .. 

I Menu Bar ... 

Privileges •.• 

Window ... 

Exclude Files ... 

Filter by Size .•. 

Filter by Date ••• 

Filter by Owner ..• ....................... 
Save Startup View 

Save View .•• 

Unsave View ... 

Verbs and Menus •.• 

File Types ..• 

To start the Puzzle: 

Choose Menu Bar... from File View's Customize menu. 
File View displays a dialog box. 

2 Click on Games. 

3 Click on OK or Apply to add Games to FileView's menu bar. 

4 Choose Puzzle from the Games menu you added to File View's 
menu bar. 
The Puzzle is displayed. 

3 10 13 15 

12 7 1 14 

6 9 11 2 

5 4 
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Playing Around with the Puzzle 
Md!f51i·h.if .iM 
I Settings ... 

The puzzle squares are scrambled. The trick is to arrange them 
in ascending order in the fewest possible moves. The Puzzle keeps 
track of the number of moves you make. 

Click on the square you want to move. Although you can move 
only those squares that are adjacent to the blank square, you can 
slide an entire row at a time. 

To make the Puzzle easier or more challenging, choose Settings ... 
from the Customize menu and change the settings. 

Puzzle Settings [PJ] II 
4 

01'1 I 
Squares per Side 

11

,_0_K_ I cancel I 
ZK-0179A-GE 

Try increasing· the number of squares displayed per side. To 
change the number of squares on each side, place the pointer on 
the number in the slider and drag to the left or right. Click on 
the OK button to change the setti:r:igs, or on the Cancel button to 
return to the Puzzle without changing any settings. 

If you changed the size, settings, or screen position of the Puzzle 
and would like to save your changes, choose Save Settings 
from the Customize menu before exiting. To restore the system 
defaults, choose Use System Defaults from the Customize menu. 

Starting a New Game 
You do not have to win one game to start another. To start a new 
game and rescramble the squares, choose New Game from the 
File menu. 

Exiting from the Puzzle 
To exit from the Puzzle, choose Quit from the File menu. 

12-2 Puzzling 



A 
Composing Characters 

In a DECterm window, you can use compose sequences to 
create special characters. A compose sequence is a series of 
keystrokes that creates characters that do not exist as standard 
keys on your keyboard. You can create any character from the 
character set DECterm is currently using. (For more information 
about choosing a character set, see Chapter 7.) 

Depending on the keyboard type, you compose characters in either 
of the following ways: 

• Use three-stroke sequences on a VT320 keyboard, including 
the North American/United Kingdom, Dutch, and Norwegian 
/Danish keyboards. 

• Use two-stroke sequences on· other keyboards. 

To compose a character: 

Find the character you want to create in column 1 of the 
following tables. 

2 To compose a three-stroke sequence, simultaneously press and 
then release I Compose I and the space bar, and type the two 
characters in column 2. 

Note You must simultaneously press the Compose key and the space 
bar to begin a compose sequence. 

3 To compose a two-stroke sequence, type the two characters in 
column 3. The desired character is displayed. 

Composing Characters A-1 



4 Press the Compose key and space bar, ~ key, Tab key, Return 
key, or Enter key to cancel a compose sequence. 

Note The North American, United Kingdom, and Dutch keyboards do 
not have diacritical marks. If you use a diacritical mark, DECterm 
uses an equivalent character. 

Table A-1 Composing Characters in Multinational Character 
Mode 

Character 

" quotation mark 

# number sign 

apostrophe 
@ commercial at 

[ opening bracket 

\ backslash 

] closing bracket 
/\ circumflex accent 

grave accent 

opening brace 

I vertical line 

} closing brace 

tilde 

inverted! 

¢ cent sign 

£ pound sign 

¥ yen sign 

§ section sign 

c currency sign 

© copyright sign 
!! feminine ordinal 

« open angle brackets 

degree sign 

A-2 Composing Characters 

Three-Stroke 
Sequence 

··space bar 

++ 

'space bar 

AA 

(( 

I I or I< 

) ) 

"space bar 

'space bar 

( -
I " 
) -
- space bar 

!! 

CI or CI 

L- or L= 

Y- orY= 

SO or S! or SO 

XO or XO 

CO or CO 

A_ 

<< 
0 /\ 

Two-Stroke 
Sequence 

··space bar 

'space bar 

"space bar 

'space bar 

- space bar 

(continued on next page) 



Table A-1 (Cont.) Composing Characters in Multinational 
Character Mode 

Three-Stroke Two-Stroke 
Character Sequence Sequence 

± plus or minus sign +-
2 superscript 2 2A 

8 superscript 3 3A 

µ micro sign /U 

en paragraph sign P! 

middle dot A 

superscript 1 1 A 

masculine ordinal 0 -
» closed angle >> 

brackets 

* fraction one- 1 4 
quarter 

lh fraction one-half 1 2 

;, inverted? ?? 

A A grave A' 'A 

A A acute A' 'A 

A A circumflex AA "A 

A A tilde A- -A 

A A umlaut A" or .. A ··A 

A Aring A* or A0 OA 

(degree sign) 

J.E A E diphthong AE 

c C cedilla c, 
E E grave E' 'E 

:E E acute E' 'E 

E E circumflex EA "E 

E E umlaut E" or .. E ··E 

l I grave r 'I 

f I acute I' , I 

(continued on next page) 
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Table A-1 (Cont.) Composing Characters in Multinational 
Character Mode 

Three-Stroke Two-Stroke 
Character Sequence Sequence 

i I circumflex II\ /\I 

I I umlaut I" or ··1 ··1 

N N tilde N- -N 

0 0 grave O' 'O 

6 0 acute 0' '0 

6 0 circumflex QI\ l\Q 

() 0 tilde 0- -0 

0 0 umlaut 0" or··o ··o 

CE 0 E diphthong OE 

0 0 slash 01 

u U grave U' 'U 
(J U acute U' 'U 
(J U circumflex U/\ /\u 
u U umlaut U 11 or··u ··u 
y Yumlaut Y 11 or·Y ·y 

.B German small SS 
sharps 

a. a grave a' 'a 

a a acute a' 'a 

a a circumflex al\ /\a 

a a tilde a- -a 

a a umlaut a" or ··a .. a 

a a ring a* or a 0 oa 

(degree sign) 

re a e diphthong ae 

~ c cedilla c, (comma) 

e e grave e' ' e 

e e acute e' 'e 

e e circumflex el\ l\e 

(continued on next page) 
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Table A-1 (Cont.) Composing Characters in Multinational 
Character Mode 

Three-Stroke Two-Stroke 
Character Sequence Sequence 

e e umlaut e" or .. e .. e 

i grave r 'i 

i acute i' Ii 

i i circumflex iA A• 1 

i umlaut i" or ··i ""i 

ii n tilde n- -n 

0 o grave 0 ' ' 0 

6 o acute o' 'o 

0 o circumflex OA AO 

0 o tilde o- -o 

0 o umlaut o" or ··o .. 
0 

re o e diphthong oe 

0 o slash of 

u u grave u' ' u 

u u acute u' 'u 

u u circumflex UA AU 

ii u umlaut u" or··u ··u 

y y umlaut y" or··y ··y 

ISO Latin 1 Characters1 

no break space sp sp 

broken vertical bar I I or! A 

-' logical not 

SHY soft (syllable) 
hyphen 

RO registered RO 
trademark 

macron - A 

3/4 three quarters 34 

1 In the ISO Latin 1 mode, the characters re, CE, and Y are not available. 

(continued on next page) 
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Table A-1 (Cont.) Composing Characters in Multinational 
Character Mode 

Three-Stroke Two-Stroke 
Character Sequence Sequence 

-: division sign 

xx multiplication sign xx 

acute accent ' ' 
cedilla 

'' 
diereses II II ··space bar 

Y' Y acute Y' 'Y 
y' y acute Y' 'y 

TH capital Icelandic TH 
thorn 

th small Icelandic th 
thorn 

-D capital Icelandic -D 
Eth 

-d small Icelandic Eth -d 

TableA-2 Composing Characters in National Replacement 
Mode Using Typewriter Keys 

Character 

British 

£ pound sign 

grave accent 

Danish 

# 

@ 

number sign 

apostrophe 

commercial at 

grave accent 

A-6 Composing Characters 

Three-Stroke 
Sequence 

L- or L= 

'space bar 

++ 

' space bar 

AA 

'space bar 

Two-Stroke 
Sequence 

(continued on next page) 



Table A-2 (Cont.) Composing Characters in National 
Replacement Mode Using Typewriter Keys 

Three-Stroke Two-Stroke 
Character Sequence Sequence 

Dutch 

£ pound sign L- or L= 

apostrophe ' space bar 

1A one quarter 1 4 

¥2 one half 1 2 

3/4 three quarters 34 

ij i j sign ij 

fl Florin f-

grave accent 'space bar 

acute accent , , 

diereses "A 

Finnish 

# number sign ++ 

apostrophe ' space bar 

Flemish and French/Belgian 

£ pound sign L- or L= 

apostrophe ' space bar 

grave accent 'space bar 

French Canadian 

apostrophe ' space bar 

a a grave ' a ' a 

a a circumflex Aa Aa 

e e grave 'e ' e 

e e circumflex Ae Ae 

i i circumflex A' I Ai 

0 o circumflex Ao AO 

(continued on next page) 
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Table A-2 (Cont.) Composing Characters in National 
Replacement Mode Using Typewriter Keys 

Three-Stroke Two-Stroke 
Character Sequence Sequence 

u u grave ' u ' u 

ft u circumflex AU AU 

German/Austrian 

apostrophe ' space bar 

grave accent 'space bar 

Italian 

apostrophe ' space bar 

Norwegian 

apostrophe ' space bar 

grave accent 'space bar 

Portuguese 

apostrophe ' space bar 

grave accent 'space bar 

A. A tilde -A 

6 0 tilde -0 

a a tilde -a 

0 o tilde -o 

Spanish 

£ pound sign L- or L= 

apostrophe ' space bar 

§ section sign !Sor OS or OS 

grave accent 'space bar 

tilde - space bar 

(continued on next page) 
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Table A-2 (Cont.) 

Character 

Swedish 

# number sign 

apostrophe 

E E acute 

e e acute 

Composing Characters in National 
Replacement Mode Using Typewriter Keys 

Three-Stroke Two-Stroke 
Sequence Sequence 

++ 

' space bar 

'E 
' e 

Swiss (French) and Swiss (German) 

apostrophe ' space bar 

e e circumflex Ae Ae 

i circumflex A' I A' I 

0 o circumflex AO AO 

u u grave u u 

ft u circumflex AU AU 

TableA-3 Composing Characters in National Replacement 
Mode Using Data Processing Keys 

Three-Stroke 
Character Sequence 

II quotation mark 11 space bar 

# number sign ++ 

apostrophe ' space bar 
@ commercial at aa or AA or aA 

[ opening bracket (( 

\ backslash I< 
] closing bracket A space bar 

apostrophe ' space bar 

opening brace ( -
vertical bar A/ 

(continued on next page) 
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Table A-3 (Cont.) Composing Characters in National 
Replacement Mode Using Data Processing 
Keys 

Three-Stroke 
Character Sequence 

closing brace ) -

tilde character - space bar 
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B 
Keyboards 

In DECterm, you can choose a National Replacement Character 
Set (NRCS) that corresponds to the keyboard by choosing the 
7-Bit NRCS Selection... menu item from the Customize menu. 

The following National Replacement Character Sets are available: 

North American Italian 

Flemish Swiss (French) 

Canadian (French) Swiss (German) 

British ·Swedish 

Danish Norwegian 

Finnish Belgian/French 

Austrian/German Spanish 

Dutch1 Portuguese 

1Use of the Dutch Keyboard is discouraged, and it may not be supported in future 
versions of DECterm. 

The following figures illustrate the corresponding keyboards: 

Figure B-1 illustrates the North American Keyboard. 

Figure B-2 illustrates the Flemish Keyboard. 

Figure B-3 illustrates the Canadian (French) Keyboard. 

Figure B-4 illustrates the British Keyboard. 

Figure B-5 illustrates the Danish Keyboard. 

Keyboards B-1 



B-2 Keyboards 

Figure B-6 illustrates the Finnish Keyboard. 

Figure B-7 illustrates the Austrian/German Keyboard. 

Figure B-8 illustrates the Dutch Keyboard. 

Figure B-9 illustrates the Italian Keyboard. 

Figure B-10 illustrates the Swiss (French) Keyboard. 

Figure B-11 illustrates the Swiss (German) Keyboard. 

Figure B-12 illustrates the Swedish Keyboard. 

Figure B-13 illustrates the Norwegian Keyboard. 

Figure B-14 illustrates the Belgian/French Keyboard. 

Figure B-15 illustrates the Spanish Keyboard. 

Figure B-16 illustrates the Portuguese Keyboard. 
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A 
Alarm 

setting, 4-6, 6-3 
ASCII file 

displaying, 2-1 

B 
Bookreader 

book 
selecting, 1-2 

cross-reference, 1-5 
customizing, 1-6 
example 

displaying, l-5 
exiting from, 1-6 
extensions 

customizing, 1-6 
figure 

displaying, 1-5 
footnote, 1-5 
hotspots, 1-5 

customizing, 1-6 
index, 1-3 
index window, 1-4 
navigating, 1-4 
selection window, 1-2 
shelf 

selecting, 1-2 

Index 

Bookreader (cont'd.) 
starting, 1-1 
stepping arrows, 1-4 
table 

displaying, 1-5 
table of contents, 1-3 

displaying graphics, 1-5 
topic 

selecting, 1-3 
topic window, 1-2, 1-3, 1-5 
using scroll bars in, · 1-4 

Buffer, 10-2 

c 
Calculator 

accumulator display, 3-1 
copying text to other applications, 

3-7 
correcting mistakes, 3-4 
customizing, 3-8 
exiting from, 3-8 
memory display, 3-1 
order of precedence, 3-5 
pasting to another application, 3-7 
starting, 3-1 
using, 3-2 

Calendar 
clock, 4-10 
closing, 4-15 
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Calendar (cont'd.) 
creating entry, 4-3 
creating new, 4-13 
creating printable file in, 4-12 
customizing, 4-16 to 4-24 
day view, 4-2 
deleting, 4-15 
deleting entry, 4-8 
displaying, 4-2 
entry editor, 4-4 
exiting from, 4-24 
marking special days in, 4-11 
moving entry, 4-9 
multiple, 4-13 
opening a, 4-14 
options 

Date for Week No. 1, 4-17 
Fill Blank Days, 4-18 
First Day of Week, 4-1 7 
First View, 4-1 7 
Lunch Hours, 4-20 
Show AM/PM, 4-18 
Show Months, 4-22 
Show Week Numbers, 4-17 
Start Iconized, 4-1 7 
Timeslot Size, 4-19 
Working Hours, 4-20 
Work Week, 4-16 

renaming a, 4-15 
repositioning, 4-24 
resizing, 4-24 
resizing timeslot, 4-6 
setting alarms, 4-6 
starting, 4-2 

Card 
copying text in, 5-9 
creating, 5-4 
deleting text from, . 5-8 
editing, 5-7 
moving text in, 5-9 
opening existing in card file, 5-5 
renaming in card file, 5-7 
selecting in card file, 5-5 
selecting text in, 5-8 
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Card file 
creating new, 5-3 
merging with another, 5-13 
opening existing, 5-3 
opening new, 5-2, 5-3 
renaming, 5-11 
saving existing, 5-12 
saving new, 5-11 
searching, 5-6 
viewing contents of, 5-5 

Cardfiler 
customizing, 5-13 
exiting from, 5-14 
starting, 5-2 

CDA Viewer 
closing files with, 2-5 
exiting from, 2-5 
starting, 2-1 
viewing files with, 2-2 

Character 
composing, 7-22, A-1 

Clock 
Calendar 

See Calendar 
changing display, 6-2 
exiting from, 6-4 
setting alarm, 6-3 
starting, 6-1 

CREATE/TERMINAL command, 7-1 

D 

DDIF (Digital Document Interchange 
Format) 

definition, 2-1 
DDIF file 

closing, 2-5 
displaying, 2-2 

DECterm 
composing characters, 7-22, A-1 
copying information, 7-20 
customizing, 7-2, 7-3 

options, 7-3 



DECterm (cont'd.) 
display 

customizing, 7-5 
exiting from, 7-23 
general features 

customizing, 7-7 
graphics 

customizing, 7-1 7 
keyboard 

customizing, 7-14 
Keyboards, B-1 
National Replacement Character Set 

choosing, 7-16 
options 

Angle Brackets Key Sends<>, 
7-15 

Angle Brackets Key Sends '-, 
7-15 

Appl Cursor Keys, 7-8 
Application Keypad, 7-9 
Auto Driver Resize, 7-4 
Auto Repeat, 7-14 
Auto Resize Termfo.al, 7-3 
Auto Resize Window, 7-3 
Auto Wrap, 7-6 
Batch Scroll 0 Lines, 7-6 
Big Font, 7-4 
8-Bit Multinational Characters, 

7-12 
7-Bit NRCS Characters, 7-12 
2-Bit Planes, 7-18 
Block Cursor, 7-7 
Comma Key Sends ,,, 7-15 
Comma Key Sends,<, 7-15 
Condensed Font, 7-4 
Ctrl-Q, Ctrl-S =Hold, 7-14 
Cursor Blink, 7-6 
Dark Text, Light Background, 

7-6 
Delete Key, 7-14 
Delete Key Backspace, 7-15 
Display Cursor, 7-6 
Enable Backing Store, 7-1 7 
Horizontal Cursor Coupling, 7-6 

DECterm 
options (cont'd.) 

Horizontal Scroll Bar, 7":::.5 
Host Status Display, 7-7 
Icon Name, 7-4 
Light Text, Dark Background, 

7-6 
Little Font, 7-4 
Lock UDKs, 7-8 
Lock User Features, 7-8 
Margin Bell, 7-14 
Newline, 7-7 
Normal/80, Condensed/132, 7-4 
Normal Cursor Keys, 7-8 
Normal Font, 7-4 
N o Status Display, 7-6 
Numeric Keypad, 7-8 
Record 500 Lines Off Top, 7-6 
Record Lines Off Top, 7-5 
Report Macrograph Contents, 

7-17 
Share Color Map Entries, 7-1 7 
Terminal ID, 7-8 
Terminal Size, 7-4 
Tilde Key Sends ESC, 7-15 
Tilqe Key Sends' .... , 7-15 
Underline Cursor, 7-7 
UPSS DEC Supplemental, 7-9 
UPSS ISO Latin 1, 7-11 
Vertical Cursor Coupling, 7-5 
Vertical Scroll Bar, 7-5 
VTlOO Mode, 7-13 
VT300 Mode, 8-Bit Controls, 

7-13 
VT300 Terminal Mode, 7-Bit 

Controls, 7-13 
VT52 Mode, 7-14 
Warning Bell, 7-14 
Window Title, 7-4 

restoring customized settings, 7-19 
restoring system settings, 7-19 
saving customized settings, 7-18 

DECterm window 
creating, 7-1 
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E 
Editor 

EVE, 8-1 
Notepad, 10-1 

EDIT/TPU command 
See EVE 

Entry editor 
creating entry with, 4-4 

EVE, 8-1 to 8-44 
attributes, 8-41 
bound cursor motion, 8-5, 8-34 
buffer attributes 

setting, 8-31 
Buffer change journaling, 8-21 
buffers 

deleting, 8-24 
moving between, 8-23 

$CHOICES$ buffer 
with journal files, 8-22 

commands 
DEFINE MENU ENTRY, 8-30 
SAVE ATTRIBUTES, 8-42 
SAVE EXTENDED EVE, 8-42 
SAVE SYSTEM ATTRIBUTES, 

8-42 
SET DEFAULT COMMAND 

FILE, 8-42 
SET DEFAULT SECTION FILE, 

8-42 
SET EXIT ATTRIBUTE CHECK, 

8-42 
SET NODEFAULT COMMAND 

FILE, 8-43 
SET NODEFAULT SECTION 

FILE, 8-43 
SET NOEXIT ATTRIBUTE 

CHECK, 8-43, 8-44 
SET NOSECTION FILE 

PROMPTING, 8-43 
SET SECTION FILE 

PROMPTING, 8-43 
typing, 8-6 
UNDEFINE MENU ENTRY, 

8-80 
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EVE (cont'd.) 
customizing, 8-29 to 8-44 
Do key, 8-6 
EDIT/TPU command, 8-2 

/INITIALIZATION qualifier, 
8-38 

erasing text, 8-10 
exiting from, 8-20 
Extend This command, 8-41 
filling text, 8-16 
formatting text, 8-15 to 8-19 
free cursor motion, 8-5, 8-34 
getting help, 8-7 
global attributes 

setting, 8-33 
Gold key, 8-26 
initialization file, 8-38 to 8-39 
input file, 8-4 
insert mode, 8-5 
invoking, 8-2 to 8-4 
keys 

defining, 8-25 
learn sequence, 8-27 
main window, 8-3 
menus, 8-30 
moving text, 8-9 
opening file, 8-4 
options 

Command, 8-37 
Create, 8-36 
Debug, 8-37 
Display, 8-36 
FILE:, 8-36 
Hide Dialog, 8-37 
Initialization, 8-37 
Modify, 8-36 
Output, 8-37 
Section, 8-37 
Set Buffer Modifiable, 8-32 
Set Buffer Read Only, 8-32 
Set Clipboard, 8-34 
Set Cursor, 8-34 
Set Find Case Exact, 8-33 
Set Left Margin To, 8-31 



EVE 
options (cont'd.) 

Set Paragraph Indent, 8-32 
Set Pending Delete, 8-34 
Set Right Margin To, 8-32 
Set Tabs, 8-34 
Set Tabs At, 8-33 
Set Tabs Every, 8-32 
Set Tabs Visible, 8-34 
Set Wrap, 8-32 
Start Position, 8-36 
Write, 8-36 

overstrike mode, 8-5 
paragraph indent, 8-17 
pending delete, 8-9 
recovering files, 8-21 
replacing text, 8-10, 8-12 
restoring text, 8-10 
saving a file, 8-20 
searching for text, 8-10 to 8-15 

case-exact, 8-13 
section file, 8-28 
selecting text, 8-8 
setting keypad, 8-27 
setting margins, 8-16 
setting tabs, 8-18 
setting width, 8-35 
soft page break, 8-19 
starting editing session, 8-2 
status line, 8-3 
TPU command, 8-41 
VAXTPU preferences 

setting, 8-35 
VAXTPU procedures to extend, 8-40 
whitespace characters, 8-13 
wildcards, 8-14 
windows 

deleting, 8-25 
moving between, 8-2.5 
splitting, 8-24 

working with multiple files, 8-22 to 
8-25 

EVE$INIT logical name, 8-38 
EVE$SECTION logical name, 8-29 

Extensible VAX Editor 
See EVE 

F 

File 
ASCII 

displaying, 2-1 
DDIF 

displaying, 2-1 
editing 

with Notepad, 10--1 
Files 

editing 
with EVE, 8-1 

Font 
changing in Notepad, 10--6 

INBOX folder, 9-13 
Index 

selecting topics from, 1-3, 1-4 
Index topic 

changing, 5-7 

K 
Key 

defining in EVE, 8-25 to 8-29 
Keyboard 

choosing NRCS, 7-16 
Keyboards 

choosing NRCS, B-1 

M 
Mail 

changing default settings, 9-36 
changing directory, 9-44 
Create-Send window, 9-4 

opening, 9-4 
customizing, 9-35 to 9-45 
drawers 

creating, 9-23, 9-24 
modifying, 9-24 
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Mail (cont'd.) 
drawers and folders, 9-2 

adding from a different directory, 
9-26 

compressing, 9-30 
deleting, 9-25 
updating, 9-29 

exiting from, 9-45 
interaction with VMS Mail Utility, 

9-42 
Mail Profile, 9-36 
main window 

illustrated, 9-1 
opening a new, 9-33 
Paned style, 9-42 to 9-44 

Read window, 9-13, 9-14 
closing, 9-15 
default, 9-16 
illustrated, 9-13 
multiple, 9-16 
opening, 9-14 

starting, 9-1 
Mail message 

CDA documents, 9-34 
changing editors, 9-12 
copying, 9-27 
creating, 9-4 

including a draft, 9-7 
including a file, 9-8, 9-10 

creating file from a, 9-20 
creating subset of, 9-30 
deleting, 9-22 
displaying additional index 

information, 9-33 
extracting, 9-20 
forwarding, 9-17 
marking, 9-30 
moving, 9-27 
new, 9-13 
old, 9-13 
picking, 9-30 
printing, 9-18 

changing default settings, 9-35 
reading, 9-13 
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Mail message 
reading (cont'd.) 

new, 9-13 
nontext, 9-15 

replying to, 9-1 7 
resuming work on draft, 9-7 
retrieving deleted, 9-22 
selecting, 9-12 
sending, 9-4, 9-6 

changing editors, 9-12 
using a distribution list, 9-10 

unmarking, 9-30 
Memory display 

Calculator, 3-5 
storing value in, 3-5 

N 

Notepad 
canceling edits, 10-5 
copying text, 10-6 
deleting text, 10-5 
editing file, 10-3 
exiting from, 10-12 
font 

changing, 10-6 
formatting text, 10-2 
including existing file, 10-7 
merging files, 10-10 
moving text, 10-5 
navigating, 10-3 
opening existing file, 10-9 
opening new, 10-8 
recovering lost edits, 10-12 
replacing text, 10-11 
saving text, 10-8 
scrolling, 10-3 
searching for text, 10-10 
selecting text, 10-4 
starting, 10-1 
typing text, 10-2 
using journal file, 10-12 



p 

Paint 
basic functions, 11-1 to 11-5 
bitmap, 11-2 
changing line width, 11-8, 11-10 
changing scale, 11-18 
clearing window, 11-7 
copying images, 11-1 7 
cropping picture, 11-19 
erasing, 11-7 
exiting from, 11-26 
IMG file type, 11-3 
inserting text, 11-22 
inverting colors, 11-5 
magnifying, 11-20 
moving images, 11-17 
opening graphics file, 11-3 
paintbrush tool, 11-15 
patterns, 11-11 to 11-14 

creating your own, 11-13 
pixel, 11-2 
printing, 11-7 
saving painting, 11-6 
selecting images, 11-16 
sizing the canvas, 11-23 
starting, 11-2 
tool, 11-5 
tool palette, 11-2, 11-5 

summary, 11-26 
tools 

drawing lines and shapes, 11-5 
transparent background, 11-10 
using grid, 11-9 
using pattern, 11-12 
window 

scrolling the canvas, 11-23 
Zoom, 11-20 

Painting 
editing, 11-16 to 11-22 

Pattern 
adding to painting, 11-12 
creating your own, 11-13 
using in Paint, 11-8, 11-12 

Puzzle 

s 

changing settings, 12-2 
exiting from, 12-2 
starting, 12-1 

Scroll bar 
using in the Bookreader, 1-4 
using in the Cardfiler, 5-6 

Selection window 
library of books, 1-2 

T 
Table of contents 

selecting topics from, 1-3 
Terminal emulator 

creating, 7-1 
Text 

copying in card file, 5-9, 5-10 
copying to another application, 3-7 
deleting in card file, 5-8 
editing with EVE, 8-1 
editing with Notepad, 10-1 
finding in card file, 5-6 
in a painting, 11-23 
moving in card file, 5-9 
selecting in card file, 5-8 

Text cursor 
moving in card file, 5-8 

Timeslot 
changing size of, ~ 
creating entry in, 4-3 
deleting entry in, 4-8 
moving entry between, 4-9 

Tool 
choosing in Paint, 11-5 
summary of Paint palette, 11-26 
using shapes in Paint, 11-8 

Topic 
reading, 1-5 
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v 
VAX Text Processing Utility 

SeeVAXTPU 
VAXTPU 

section file, 8-28 

w 
WASTEBASKET, 9-22 
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Window 

y 

creating DECterm, 7-1 
customizing DECterm, 7-2 

Year display, 4-2 

z 
Zoom window, 11-20 



How to Order Additional Documentation 

Technical Support 
If you need help deciding which documentation best meets your needs, call 800-343-4040 
before placing your electronic, telephone, or direct mail order. 

Electronic Orders 
To place an order at the Electronic Store, dial 800-DEC-DEMO (800-332-3366) using 
a 1200- or 2400-baud modem. If you need assistance using the Electronic Store, 
call 800-DIGITAL (800-344-4825). 

Telephone and Direct Mail Orders 

Your Location 

Continental USA, 
Alaska, or Hawaii 

Puerto Rico 

Canada 

International 

Internal1 

Call 

800-DIGITAL 

809-754-7575 

800-267-6215 

Contact 

Digital Equipment Corporation 
P.O. Box CS2008 
Nashua, New Hampshire 03061 

Local Digital subsidiary 

Digital Equipment of Canada 
Attn: DECdirect Operations KA02/2 
P.O. Box 13000 
100 Herzberg Road 
Kanata, Ontario, Canada K2K 2A6 

Local Digital subsidiary or 
approved distributor 

SSB Order Processing - WMO/E15 
or 
Software Supply Business 
Digital Equipment Corporation 
Westminster, Massachusetts 01473 

1For internal orders, you must submit an Internal Software Order Form (EN-01740-07). 
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Please use this postage-paid form to comment on this manual. If you require a written 
reply to a software problem and are eligible to receive one under Software Performance 
Report (SPR) service, submit your comments on an SPR form. 

Thank you for your assistance. 

I rate this manual's: Excellent 

Accuracy (software works as manual says) D 
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Clarity (easy to understand) D 
Organization (structure of subject matter) D 
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Page Description 

Good 

D 
D 
D 
D 
D 
D 
D 
D 

Additional comments or suggestions to improve this manual: 
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Date 
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