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About This Guide vii 

About This Guide 
This guide introduces you to Microsoft Programmer's Library and provides instruc
tions for using the references and sample code included in the application. Before 
moving on, please take a minute to see how the instructions and examples in this 
guide are arranged. 

"Introducing Programmer's Library" lists each reference included in Programmer's 
Library and tells you what you need to get started. 

" Using Programmer's Library" provides step-by-step instructions for performing 
basic tasks and gives examples of how to use commands. 

"Programmer's Library Reference" includes summary information about keyboard 
and mouse functions, menus, and commands. 

Appendix A, "Technical Information," provides additional information about Pro
grammer's Library, including error messages , Setup program information, and 
details about searching. 

Microsoft products are updated regularly to keep information as current and accu
rate as possible. To ensure that you're notified when an update becomes available, 
send in the registration card that's included in your Programmer's Library package. 
As a registered owner, you'll be eligible for special update prices for future versions 
of the product. 

NOTE: A file named README.DOC is included on your Programmer's 
Library disc. Be sure to read this file (using any of the supported program 
editors or word processing applications) for additional information that 
became available after this guide was printed. 





Introducing Programmer's Library 
Programmer 's Library puts a world of technical information right where you need 
it-on your computer screen. You can use Programmer's Library to perform tasks 
such as these: 

• Instantly access and use programming instructions, reference material , and 
sample code without interrupting the task at hand. 

• Look up information on OS/2 standards while writing program code in the 
MS-DOS environment. 

• Check to see how you can add Microsoft Mouse support to the application 
you ' re designing. 

• View samples of Microsoft C program code and copy the sample code to 
your program editor. 
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About Programmer's Library 
Programmer's Library is a comprehensive collection of useful reference information 
for programmers using MS-DOS, Windows, and OS/2 environments. With Program
mer's Library you can instantly get authoritative information about programming 
from books, manuals, and sample code in any of the following reference categories: 

Microsoft OS/2 
Includes the complete programming documentation for Microsoft OS/2 and Presen
tation Manager, comprising the OS/2 Software Development Kit manuals covering 
the OS/2 kernel, OS/2 device drivers, Presentation Manager, and more. Also in
cludes "Inside OS/2" by Gordon Letwin, "Advanced OS/2" by Ray Duncan, and 
"Programming Presentation Manager" by Charles Petzold. 

Microsoft Windows 
Includes the complete documentation for programming in Microsoft Windows 2.1, 
comprising the Microsoft Windows Software Development Kit manuals (complete) 
and "Programming Microsoft Windows" by Charles Petzold. 

Network 
Includes the complete programming documentation for the SQL Server and 
Microsoft OS/2 LAN Manager. 

MS-DOS 
Includes the complete documentation for Microsoft MS-DOS version 4.0, as well as 
"Advanced MS-DOS" by Ray Duncan, "The New Peter Norton Programmer's 
Guide to the IBM PC and PS/2" by. Peter Norton and Richard Wilton, and " The 
MS-DOS Encyclopedia." 

Microsoft Systems Journal 
Includes the full text of Microsoft Systems Journal, volumes 1-4, covering 1986-
February 1989. 

Hardware 
Includes documentation for the Microsoft Mouse, Microsoft MS-DOS CD-ROM 2.1 
Extensions, Intel documentation for the 80286 and 80386 microprocessors, and 
"Programmer's Guide to PC and PS/2 Video Systems" by Richard Wilton. 
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Microsoft C Language 
Includes the complete documentation for the Microsoft C Optimizing Compiler, as 
well as Microsoft QuickC documentation, " Proficient C" by Augie Hansen, and 
" Microsoft QuickC Programming" by The Waite Group. 

Microsoft Macro Assembler 
Includes the complete documentation for Microsoft Macro Assembler. 

Microsoft BASIC Language 
Includes the complete documentation for the Microsoft BASIC Optimizing Compiler 
and "Microsoft QuickBASIC Programmer's Toolbox" by John Clark Craig. 

Microsoft Pascal Language 
Includes the complete documentation for the Microsoft Pascal compiler. 

Microsoft FORTRAN Language 
Includes the complete documentation for the Microsoft FORTRAN compiler. 

You can display a list of the reference categories or access these categories by using 
the Library command. For more information, see "Changing the Reference 
Category or Disc" later in thi s manual. 

Notational Conventions 
Programmer 's Library uses notational conventions that make it easy for you to read 
on-I ine text and program examples. These are I isted near the beginning of the on
line book or manual under the heading "Notational Conventions." To locate this in
formation in a book or manual, choose Contents from the Main menu bar, select a 
reference, and scroll forward from the title page. 

Graphics 
Programmer's Library uses character-based graphics. Wherever possible, a graphic 
from a printed book or manual has been represented on-screen by a character-based 
drawing. In the place of any graphic that is not included on the disc, Programmer's 
Library displays a cross-reference to the location of the graphic in the printed book 
or manual. 
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The Microsoft CD-ROM Library 
Programmer's Library is part of a family of Microsoft CD-ROM Library products. 
Each of the products in this family uses the MS Library (msl) software. For informa
tion on using Programmer's Library with other Microsoft CD-ROM Library prod
ucts, see "Changing the Reference Category or Disc" later in this guide. 
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What You Need 
To use Programmer's Library you need: 

• An IBM PC, PC/XT, PC/AT, or 100% compatible, or an IBM PS/2 Series 
computer 

• At least 2S6K total system memory to use Programmer's Library by itse lf, 
as a stand-alone appl ication 

• At least 640K total system memory (SI2K required for systems with hard 
disks) to use Programmer's Library as a memory-resident application 

• MS-DOS version 3.1,3.2, or 3.3 (MS-DOS 4.0 is supported by MS-DOS 
CD-ROM Extensions version 2.1 only) 

• Two double-sided disk drives or one double-sided disk drive and a hard disk 

• A CD-ROM disc drive and interface card 

• Microsoft MS-DOS CD-ROM Extensions provided with the CD-ROM disc 
drive (version 2.0 or higher if you plan to use Programmer's Library with 
other Microsoft Library products) 

You may find that the following items, although not required, increase your effi
ciency when using Programmer 's Library: 

• A hard disk drive 

• A mouse 

• A RAM drive 

• Lotus/Intel/Microsoft (LIM) version 3.2 expanded memory 

Programmer's Library is designed to be used either by itself or as a memory-resident 
application, sometimes referred to as a " TSR" ("terminate and stay resident") ap
plication. As a TSR application, Programmer's Library resides in your computer's 
memory and remains available while you're using another application. 

As a stand-alone application, Programmer 's Library can be called up by accessing 
DOS from any program editor or word processing application. More than 2S6K of 
memory is usually required to run an editor or word processor while using Program
mer's Library in stand-alone mode. See "Using Programmer's Library in Stand
alone Mode " later in this guide for specific instructions. 
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Support for Program Editors and 
Word Processing Applications 

Programmer's Library can be used in stand-alone mode with any program editor or 
word processor. When used as a TSR appl ication, it supports interactive operation 
with the following program editors and word processors in their default 
configurations. 

Program Editors 
• BRI EF versions 2.0 and 2.1 

• Epsilon Editor version 3.21 

• ME Text Editor version 2.0 

• Microsoft Editor version 1.0 

• Microsoft QuickBASIC Editor versions 4.0 and 4.5 

• Microsoft QuickC Editor versions 1.0 and 2.0 

• Multi-Edit version 3.02a 

• The Norton Editor version 1.3C 

• Turbo Pascal Editor versions 4.0 and 5.0 

• Turbo C Editor versions 1.5 and 2.0 

• VEDIT PLUS versions 2.03F and 3.0 

Word Processing Applications 
• DisplayWrite version 1.0 

• Microsoft Word version 2.0 and later* 

• Microsoft Works versions 1.0 and 1.05 

• MultiMate Advantage I (MultiMate version 3.6), II 

• PC Write versions 2.71 and 3.02 
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• Professional Write version 1.0 

• Q&A Write version 1.0 

• Volkswriter 3 version 1.0 

• WordPerfect versions 4 .2 and 5.0 

• WordStar Professional versions 4.0 and 5.0 

• XyWrite versions III and 111+ 

*Programmer's Library supports the graphics mode of Microsoft Word version 4.0. 
It supports the text mode of Microsoft Word versions 2.0, 3.0, 3.1, and 5.0. If you're 
using one of these versions of Word, you'll need to start Word in character 
(nongraphics) mode. To do so, type wardle at the DOS prompt. 

NOTE: For special instructions on using Programmer's Library with pro
gram editors and word processors, see" Using Programmer's Library in 
Stand-alone Mode" later in this guide. 



Introducing Programmer's Library 9 

Getting Started 
Getting started with Programmer's Library requires a brief setup process. In addi
tion, you must have installed your CD-ROM drive and the MS-DOS CD-ROM Ex
tensions. Following are step-by-step instructions for setting up, loading, starting, and 
exiting Programmer's Library. 

Installing the CD-ROM Drive 
Before you set up and use Programmer's Library, be sure that you've carefully fol
lowed the installation instructions provided with your CD-ROM drive. A summary 
of the installation steps is provided here. 

To install your CD-ROM drive: 

I. Be sure that both the computer and the CD-ROM drive are turned off. 

2. Check to see that the proper dip switch on the CD-ROM interface card is 
turned on. (Some interface cards do not have dip switches. See manufac
turer's specifications and documentation.) 

3. Set the CD-ROM interface card in an extension slot in your host computer. 

4. Connect the cable to the interface card in the computer and connect the 
other end to the CD-ROM drive. 

Setting Up MS-DOS CD-ROM Extensions 
A software disk with the Microsoft MS-DOS CD-ROM Extensions should have ac
companied your CD-ROM drive. When you install the extensions provided on this 
disk, your AUTOEXEC.BAT and CONFIG.SYS files are modified to work with the 
CD-ROM drive. 

To set up ,HPJ £ ' 

I. Insert the MS-DOS CD-ROM Extensions disk into drive A:. 

2. Type a:setup and press Enter. 

At this point, the setup program will ask for your drive type. (Note that 
some drives are also marketed under private labels. Please check with the 
manufacturer if you don't know your drive type.) 

3. Follow the screen prompts for the setup program. 
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To set u MS ·00' I' >I) F' ~') ,. on a 'ne or two ·drive 'iJstem: 

I. Make a copy of your MS-DOS (version 3.1,3.2, or 3.3) disk. You can use 
MS-DOS version 4.0 with MS-DOS CD-ROM Extensions version 2.1 only. 

2. Place the MS-DOS CD-ROM Extensions disk in drive A: . 

3. At the A prompt, type setup and press Enter. 

4. If you're using one drive, place the copy of your MS-DOS disk in drive A: 
when the setup program asks for the disk for drive B:. 

S. When finished, label the new MS-DOS disk "MS-DOS with CD-ROM. " 

NOTE: The setup program will set the CD-ROM drive as the next drive let
ter on your system. For example, in a system with floppy A:,floppy B: , and 
hard drive C, the setup program would make the CD-ROM drive D:. To 
change the drive specification, the CONFlG.SYS file on the MS-DOS disk 
must he edited. 

Using the Setup Program 
Before you use Programmer's Library for the first time, you need to run the Setup 
program, which installs Programmer's Library files to fit your specific computer en
vironment. The Setup program leads you through each step of installation, display
ing prompts when you need to provide information or make decisions. For example, 
you're given the choice of installing all of the reference categories in one step or 
selecting reference categories one at a time. For each reference category installed, 
Programmer's Library sets up a small file (200K-300K) on your hard disk. 

'I '" t u") Progra n "r' I 'hrarv' 

I . Turn on your' computer and boot the system (if booting with a floppy, use 
the "MS-DOS with CD-ROM" disk). The system with MS-DOS CD-ROM 
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Extensions will recognize the CD-ROM drive and treat it as a read-only 
hard drive. There is no need to manually boot the MS-DOS CD-ROM Ex
tensions each time you use your drive, since Extensions is present in your 
AUTOEXEC.BAT file. 

2. Insert the Programmer's Library disc into the CD-ROM drive. 

3. Make the CD-ROM drive (0:) the active drive. 

4. At the DOS prompt, type setup and press Enter. 

S. Follow the instructions that appear on your screen. 

For more information on the Setup program, see " Setup Information" in Appendix 
A. For manual setup instructions, see the README.DOC file located on the Pro
grammer' s Library disc. 

Starting Programmer's Library 
When you 've completed the setup procedure, you can run Programmer's Library in 
stand-a lone mode or load it into your computer's memory. Stand-alone mode can be 
used with program editors by following the instructions in " Using Programmer's 
Library in Stand-alone Mode." 

To start Programmer's Library in stand-alone mode: 

I. Make the hard disk (C:) the active drive. 

2. Use the MS-DOS command cd to change to the directory on the hard disk 
where you installed Microsoft Programmer's Library. (MSLIB is the 
default directory.) 

3. Type msl at the DOS prompt and press Enter. (The Programmer's Library 
disc must be in the CD-ROM drive.) 

The Programmer's Library title bar and Main menu bar appear at the top of 
your screen. 
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To load Programmer's Library into memory as a TSR application: 

If you plan to use Programmer's Library with a program editor or a word processing 
application, you'll want to load Progammer's Library into memory. 

I. Make the hard disk (C:) the active drive. 

2. Use the MS-DOS command cd to change to the directory on the hard disk 
where you installed Microsoft Programmer's Library. (MSLIB is the 
default directory .) 

3. Type msl It at the DOS prompt and press Enter. (The Programmer's Library 
disc must be in the CD-ROM drive.) 

A brief message appears, letting you know that Programmer's Library is 
now loaded into memory. 

4. Press Alt+left Shift (hold down the Alt key, then press the left Shift key) to 
start Programmer's Library. 

The Programmer's Library title bar and Main menu bar appear at the top of 
your screen. 

Once Programmer's Library is loaded into memory, you'll need to reload it only if 
you've used the Unload command to remove it from memory or if you've turned off 
or rebooted your computer. 

NOTE: Be sure to use the left Shift key with the Alt key (Alt+left Shift) 
when initially starting Programmer's Library. For information on changing 
the startup key combination , see "Changing the Startup Keys" later in this 
manual. 
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Microsoft C Refer ences (M icrosoft Editor ) . , I . - .. 
/ / 

A. This is the Main menu bar. 
B. This is the reference category in use when you first start Programmer's 

Library 
C. This is the name of the program editor or word processing application 

you 're using. 

Exiting Programmer's Library 
W hen you are finished usi ng Programmer's Library, you can remove it from the 
screen (if you're working in stand-a lone mode) or from memory (if you loaded it 
into memory). 

To exit Programmer's Library when it is loaded in stand-alone mode: 

I. Press Esc unti I the Ex it dia log box appears. 

2. Choose the OK button by pressing Enter. 
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When you use Programmer's Library as a TSR application, you have two options 
when you exit: You can either keep the application resident in memory as you exit or 
remove the appl ication from memory. 

To keep Programmer's Library memory-resident: 

A 

B 

• Press Esc until you exit Programmer's Library and return to your program 
editor or word processing application, or to DOS. 

Microsoft C References (Microsoft Editor) 
Search Contents Index QuickRef Options Help 

Library Alt-O 

Booklllarks 
Paste flO 
Save CI ipboard 
Date Stalllp 
Colors 
Hotkeys 

Unload 

A. Choose Save Clipboard to save the contents of the Programmer's Li
brary Clipboard before exiting. 

B. Choose Unload to remove Programmer's Library from memory while exit
ing the application. 

[0 remove Programmer's Library from memory as a TSR application: 

I. Choose the Options menu from the Main menu bar. 

2. Choose Unload from the Options menu. 

3. Select the OK button. 
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In summary, press a (Options), U (Unload), then press Enter twice to unload Pro
grammer's Library. 

Programmer's Library is now removed from your computer's memory. 

NOTE: If you want to save the contents of the Clipboard before exiting 
Programmer's Library, choose Save Clipboard from the Options menu 
(Main menu bar). The Clipboard contents are saved in a text file which can 
be used with a program editor or word processor. For more information 
about the Clipboard, see "Copying, Appending, and Pasting" later in this 
guide. 
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Using Programmer's Library 
Locating and gathering information with Programmer's Library is easy and quick. 
This part of the manual gives you the essentials you need to look up, view, copy, and 
save information. 

To get a general idea of how to move around within Programmer's Library, read the 
instructions and examples that follow. As you read, tryout the interface by experi
menting with the quick reference, searching, and browsing techniques shown here . 
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The Basics 
Programmer's Library provides a variety of ways to locate information. For ex
ample, you can search a reference category for a word or phrase, find a string of 
characters in a reference, or display and read a chapter from a reference. This section 
describes the menu bars, dialog boxes, scrolling techniques, and other tools that as
sist you in using the application. 

There are two menu bars-the Main menu bar and the Browser menu bar
featuring commands and options for looking up, displaying, and copying program
ming information. Each menu bar uses only the top few lines of your screen, leaving 
the rest of the screen for Programmer's Library reference information or displaying 
text from your program editor or word processing application. 

The Main Menu Bar 
When you first start Programmer's Library, you see the Main menu bar at the top of 
your screen. This menu bar includes menus with lists of references and commands 
that allow you to work with any of the Programmer's Library reference categories. 
From the Main menu bar you can choose commands to search a reference, to display 
tables of contents and indexes, to view quick reference manuals, to use a variety of 
special options, and to get help instructions. 

To return to the Main menu bar from the Browser menu bar at any time, press Esc. 

When you see the Main menu bar for the first time, it displays the default reference 
category- Microsoft C Language References. The following illustration shows the 
Main menu bar. 
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A 

B 

C 

Microsoft C References (Standalone) . , I . 
I I 

// I 

A. Choose commands from these menus to look for information in the refer
ence category you 're using. 

B. Choose Library from this menu to change the reference category or the 
Microsoft CO-ROM Library disc in use. 

C. Choose commands from the Help menu to view instructions on perfor
ming tasks with Programmer's Library 

To display any of the menus listed on the Main menu bar: 

~ . When using the keyboard, press the first letter of the menu name, or use the 
Right or Left key to position your cursor on the menu name. 

~ • When using the mouse, move the mouse pointer to the name of the menu 
you want to use and click the left mouse button. 

Once a menu is displayed, you can use the keyboard or the mouse to select a refer
ence or command li sted on the menu. To remove the menu that is displayed, press 
Esc. For more information, see "Choosing References and Commands" later in this 
section. 



A 

B 

Using Programmer's Library 21 

Microsoft C References (Standalone) , 
MS C 5.1 Update 
MS C 5.1 User's Guide 
MS C 5.1 Language Reference 
MS C 5.1 Run-Tihe Library Reference 
CodeView/Utilities Manual 
CodeView/Utilities Update 
MS Mixed-Language Prograhhing Guide 
MS Editor User's Guide 
QuickC 2.0 Tool Kit 
QuickC 2.0 C for Yourself 
QuickC 2.0 Up and Running 
All C 5.1 Manuals 

MS QuickC Prograhhing 
Proficient C 
C Sahple Code 

A. Use the keyboard or the mouse to select a reference or command listed 
on a menu. 

B. A group of references is available for searching and browsing in all 
reference categories. 

The Browser Menu Bar 
Once you choose one of the references from a menu, Programmer's Library displays 
the Browser menu bar. 

Paragraph MS C 5.1 Language Reference (Search) Set of 104 
A - it View Author Table Search Browse Prev Next Hel 

A. Browser menu bar 
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The Browser menu bar provides tools for viewing reference information. Each of the 
menus listed on the Browser menu bar includes commands that help you view and 
work with Programmer's Library information. The same Browser menu bar com
mands are used for viewing any text in Programmer's Library. Once you've learned 
how to use the Browser commands in one reference, you'll be able to use the same 
techniques for all of the other references. 

Choosing References and Commands 
You choose Programmer's Library references and commands by pressing keys on 
your keyboard or moving and clicking your mouse. Here are the basic steps to follow 
when choosing references and commands. 

~ To choose a reference or command with the keyboard: 

I. Press the fi rst letter of the name of the menu you want to use, or use the Left 
or Right key to select a menu title. 

2. Press the Down key to select a reference or command listed on the menu, or 
press the first letter of the reference or command name. 

3. Press Enter to view the reference or carry out the command. (You can also 
press Esc at any time to cancel the command.) 

When a menu or list of references appears, the first reference or command is high
I ighted. To use that reference or command, press Enter. 

~ To choose a reference or command with the mouse: 

I . CI ick the title of the menu you want to use. 

2. Once the menu is displayed, click the reference or command you want to 
use. 

Getting Help 
Choose commands from the Help menu on the Main menu bar or choose the Help 
command from the Browser menu bar to display instructions on using the Program
mer's Library commands. The Help menu (Main menu bar) provides commands for 
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getting Quick Help and for browsing and searching the Microsoft Programmer's 
Library User's Guide. 

A 

B 

C 

Microsoft C References (Standalone) 
Search Contents Index QuickRef Options Help 

- Quick Help F1 

J Search 
Table of Contents 
General Index 

About 

A. Press F1 to display instructions about the task at hand. 
B. Choose these commands to display information from the Microsoft Pro

grammer's Library User's Guide. 
C. Choose this command to display copyright information. 

To view instructions while performing a task-

I. Press F 1 or cI ick Help (Browser menu bar). 
Help instructions appear, replacing the current Programmer's Library 
screen. 

2. Press Enter to exit Quick Help and return to your task. 

NOTE: When a Programmer's Library dialog box is displayed, you can 
use the F 1 key to get Help, but you cannot get assistance from the Help menu 
(Main menu bar). 
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Getting Help on a Specific Topic 
You can choose a command from the Help menu to search the Microsoft Program
mer's Lihrary User's Guide for information specific to what you're doing. The 
Search command initiates a search; the Table of Contents and General Index com
mands let you browse through these sections of the Microsoft Programmer's Lihrary 
User's Guide. For more information on using these commands, see "Browsing, 
Searching, and Finding" later in this section. 

To get Help using the Search command 
The Search command provides a dialog box in which you enter the word or phrase 
you want to search for in the manual. 

I. Choose Search from the Help menu (Main menu bar) . 

2. In the Search dialog box that appears , type a word or phrase for which you 
need Help instructions. 

3. Press Enter or choose the Start Search button. 

To get Help using the Table of Contents or 
General Index command 
The Table of Contents command lets you browse the table of contents, select a topic, 
and then view the text related to that topic. The General Index command lets you 
browse the index, select an entry, and then view the text related to that entry. 

I. Choose Table of Contents or General Index from the Help menu (Main 
menu bar) . 

2. Select the topic (Table of Contents) or cross-reference (General Index) you 
want to view. 

3. Press Enter or double-c1 ick the selection to display its text. 
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Scrolling Techniques 
If you're a keyboard user, you can use the direction keys and PgUp and PgDn to 
move forward and backward through Programmer's Library text. 

~ To scroll with the keyboard: 

• Press a direction key to move the cursor one line or one character at a time. 

• Press PgUp or PgDn to move up or down one screen at a time. 

• Press Ctrl+PgUp to go to the beginning of the text in the reference you're 
viewing, or press Ctrl+PgDn to go to the end of the text in that reference. 

• Press Ctrl+Right or Ctrl+Left to move one word at a time in either direction 
across the screen. 

• Press Home to move to the left edge of the screen on the current I ine of text. 
Press End to move to the last character on the current line. 

• Press Ctrl+Home or Ctr l+End to move the cursor to either the upper-left or 
lower-left corner of the screen. 

NOTE: Be sure that NumLock is turned of/on your keyhoard when you 
use the direction keys. 

Programmer's Library provides three scrolling tools for mouse users: a right-hand 
vertical scroll bar, a left-hand scroll elevator, and a horizontal scroll bar. You can use 
these scrolling features to move through text whenever the information you ' re view
ing is too wide or too long to fit onto a single screen. 
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• A full set of loop, conditional, and transfer statements to control 
This example processes an array of uariable-Iength strings stored in lines. 
The continue statement passes control to the next iteration of the do, for, 
In this example, the statement body is executed if i is greater than O. 
In this do statement, the two statements y = f(x) ; and x--; are executed, 
6.7 The for Statement 
The body of a for statement is executed zero or more times until 
Execution of a for statement proceeds as follows: 
In this example, the loop expression of the for statement line[i++I=O 

A. Use the left-hand scroll elevator to move up and down within a 20-page 
range. 

B. Use the right-hand vertical scroll bar to move up and down. 
C. Drag the scroll box along the scroll bar in the direction in which you want 

to move. 
D. Use the horizontal scroll bar to move left and right within a table. When 

viewing tables, use the scroll box that appears in this bar 

You'll see scroll bars whenever you're viewing the text of a Programmer's Library 
reference. Certain list boxes within dialog boxes also provide a right-hand vertical 
scroll bar. 

~ To'lc-' 

• Click one of the scroll arrows on the right-hand vertical scroll bar to move 
one line at a time in the direction indicated by the arrow. Or point to one of 
the scroll arrows and hold down the left mouse button to drag the arrow in 
the direction in which you want to move . 

• Click above or below the scroll box on the right-hand vertical scroll bar to 
move up or down one screen at a time. 
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• Drag the left-hand scroll elevator up or down to an approximate location 
within a 20-page range. By dragging the elevator up about 1/4 the length of 
the screen, you'll move about five pages backward in the reference you're 
viewing. 

• In text, click one of the scroll arrows in the horizontal scroll bar to move 
five characters in the direction indicated by the arrow. 

• When viewing tables wider than your screen, use the scroll box in the hori
zontal scroll bar to bring portions of a table into view. This scrol l box is ac
tive only when you're viewing tables . 

Using Dialog Boxes 
Programmer's Library uses dialog boxes to prompt you for more information or to 
ask you to confirm an action . 

A 

B 

c 

o 

Searching MS C 5.1 Language Reference 
:. -

Match Words In 
Ter", : I 

ha ter 

Ter",: IL ________ --' 
Section / 
Subsection 
Paragraph 

Ter",: IL ________ --' / 
A",ount Searched 100% 

New Search Cancel 
___ I 

A. Enter text here. 
B. List box with scroll bar. Select from these items. 
C. Preselected item (default). Press Enter or double-click the left mouse 

button to carry out the action of a double-lined command button. 
D. Command buttons. 
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Here are a few general guidelines for making selections in dialog boxes: 

• A list box presents several options, from which you can select one. If there 
are more options in the box than those displayed, you can move up or down 
the list by using the scroll bar or the Up and Down keys. For information on 
scrolling within a list box, see " Scrolling Techniques " earlier in thi s 
section. 

• Press Tab to move forward between items in a dialog box. Press Shift+ Tab 
to move backward. 

• To make a selection in a li st box and carry out the default action of a 
double-lined command button, position your cursor or mouse pointer on the 
desi red I ist box option and then press Enter or double-cl ick that option. 

• To choose an action , tab to its command button and press Enter to carry out 
the action. Or double-click a command button with a mouse. 

• To remove the dialog box and cancel the task in process, press Esc or choose 
the Cancel button. 
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Changing the Reference Category or Disc 
When you display the Main menu bar for the first time, the reference category that is 
automatically loaded for you is Microsoft C Language References. You can change 
to any of the other Programmer 's Library reference categories by choosing the Li
brary command from the Options menu. The Library command not on ly lets you 
choose a new reference category, but it a lso gives you the option of accessing another 
previously installed Microsoft CD-ROM Library disc . 

Whenever you exit Programmer's Library, the application remembers which refer
ence category was in use when you exited. The next time you use Programmer's Li
brary, the reference category you used most recently will be selected automatically. 

To select another Programmer's Library reference category: 

I. Choose Library from the Options menu (Main menu bar). 

2. Select the reference category you want from those listed in the I ist box. 

3. Press Enter, double-click the se lection, or choose the Open button in the dia
log box. 

To change to another Microsoft CD-ROM Library disc: 

I. Choose Library from the Options menu (Main menu bar). 

2. Insert the Microsoft CD-ROM Library disc you want to use into your CO
ROM drive. 

3. Choose the New Disc button in the dialog box that appears. 

4. Select the product you want to load from those listed in the Library list box. 
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A 

B 

c 

5. Press Enter, double-click the selection, or choose the Open button in the dia-
log box. 

NOTE: You must have Microsoft MS-DOS CD-ROM Extensions version 
2.0 or higher to be able to use the Library command to change to another 
Microsoft CD-ROM Library disc. Contact your CD-ROM supplier for more 
information. 

Microsoft C References (Standalone) 
Search Contents Index QuickRef Options Help 

OS/2 References 
Windows References 
Network References 
MS-DOS References 
MS Systens Journal 

-+-----I--H Hardware References 
C References 
MASM References 
BASIC References 
Pascal References 

ORTRAN References 

Open Cancel 

A. Select a reference category or disc from those listed here. 
B. Choose this button to load the reference category or disc you selected 
C. Choose this button when you want to load a new Microsoft CO-ROM 

Library disc. 
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Browsing, Searching, and Finding 
Three of the tasks you ' ll perform most often with Programmer's Library are: 

• Browsing a reference to see what it includes 

• Searching an entire reference or group of references for information 

• Finding a specific word or character in part of a reference 

You ' ll use the menus on either the Main menu bar (Search, Contents, Index, 
QuickRef) or the Browser menu bar (View, Search , Browse) to accomplish all three 
of these tasks. Commands listed on the View, Search , and Browse menus allow you 
to perform any type of search you wish , from casual browsing of an index or table of 
contents to Boolean (and/or) searches of an entire reference or group of references. 
A group of references is available for searching and browsing in all reference 
categories. 

A 

NOTE: To return to the Main menu bar/rom the Browser menu bGl; press 
Esc. 

mm:m 
1200111 In F7 

200fll Out FB 
[ Search Alt-S 

B Find 
QuickRef Alt- Q 

Location Alt-L 

Bookfllarks !irm!m 
Footnote 
Cross- ref 
Return Alt- R C 

{ Tab Ie of Contents Alt-B 
Genera I Index 

A. Use commands on the View menu to zoom to a level within the reference 
you're viewing, to check your current location, to see a list of bookmarks, 
to display a footnote, or to go to a cross-reference. 

B. Use commands on the Search menu to look for a specific topic, to find a 
word or character, or to look up quick reference information. 

C. Use commands on the Browse menu to browse the table of contents or 
the index of the reference you're using. 
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Browsing 
T here are a variety of ways that you can view information within Programmer's Li
brary. You can browse through I ists of titles within a category, I ists of chapters 
within a reference, or text within a reference chapter or sect ion. 

To browse within a selected category: 

I. Choose Contents or Index from the Main menu bar. 

2. Select a reference or group of references from the list of titles that is 
displayed. 

3. Press Enter or cI ick the mouse to display the I ist of titles for a group of ref
erences, or to display the table of contents or index for the selected 
reference. 

4. Select the title, chapter, or cross-reference you want to display . 

5. Press Enter or double-click the mouse to display your se lection. 

Choose commands from the Browse menu on the Browser menu bar to view the list 
of chapter titles with i n the table of contents or the index of the reference you're 
using. You can then select a chapter or index entry and display the text of your 
selection. 

To begin browsing within a selected reference: 

1. Select Browse from the Browser menu bar. 

2. Choose Table of Contents or General Index. 

3. Use the direction keys or PgUp and PgOn to move through the entries listed. 

4. Select the topic (from Table of Contents) or cross-reference (from General 
Index) you want to view. 

5. Press Enter or double-click the select ion title to display the text of the 
selection. 
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Viewing Levels 
Programmer's Library references are arranged in a number of levels that correspond 
to equivalent levels in the printed version of the reference (Chapter, Section, Subsec
tion, and Paragraph). The Programmer's Library sample code references have three 
levels to reflect the hierarchical arrangement of the code on disc (Directory, File, 
and Function). Sometimes a reference does not include all these levels. 

Choose the Zoom commands from the View menu to move through the I ist of titles 
contained in each level within a reference or a sample code selection. For example, 
while viewing a table of contents, you can choose Zoom In from the View menu to 
move from a list of chapter titles to a list of section titles within one of the chapters 
listed. If you select a section title from the list and then choose Zoom In a second 
time, you'll display a list of subsection titles within the section you selected. For 
more information on viewing at different levels, see "Selecting Viewing Options" 
later in this section. 

Searching 
Use Search on the Main menu bar to select and search a reference or group of refer
ences for information . Use commands on the Search menu (Browser menu bar) to 
search the reference or group of references you ' re currently using for information. 
The Search menu provides three commands: Search, Find, and QuickRef. 

Follow these general guidelines when deciding which command to use: 

• Use the Search command when you want to search an entire reference or 
group of references for all occurrences of the word or words you specify. 
For example, you might search the Microsoft C Optimi:ing Compiler 5.1 Lan
guage Reference for all occurrences of the word' 'slash." 

• Use the Find command when you want to find occurrences of a string of 
characters within a chapter, a table of contents , or an index. Find scans the 
text sequentially for this string. For example, you might use Find to locate 
occurrences of the string "slash" in one chapter of the Microsoft C Optimiz
ing Compiler 5.1 Language Reference. Occurrences of words that contain this 
string (for example, "backslash") are found , and the substring ("slash") is 
highlighted. 
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• Use the QuickRef command to look up definitions related to the word or 
phrase you specify. The QuickRef command is available only when you're 
using one of the references listed on the QuickRef menu (Main menu bar). 
Only terms with dictionary-style explanations are indexed for access by the 
QuickRef command. 

Using the Search Command 
Use the Search command to locate all instances of your search words throughout an 
entire reference or group of references. You can start a search through a single refer
ence or group of references from either the Main menu bar or the Browser menu bar. 

To start a search from the Main menu bar: 

I. Choose Library from the Options menu (Main menu bar) to select the refer
ence category you want to use. 

2. Choose Search from the Main menu bar. 

A I ist of references in the current category is displayed. 

3. Choose the reference or group of references you want to search. 

The Search dialog box appears. 

To start a search from the Browser menu bar: 

1. Choose the Search menu from the Browser menu bar. 

2. Choose Search from the Search menu. 

The Search dialog box appears. 

The Search Dialog Box 
The Search dialog box contains Term boxes in which you can enter one or more 
words. Press Tab to move forward between Term boxes; press Shift+ Tab to move 
backward. The Match Words In list box allows you to specify the viewing level of 
your search occurrences. If you're searching for more than one word and you've 
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placed your search words in separate Term boxes, the Match Words In list box also 
allows you to specify the desired proximity of the words (for example, within the 
same paragraph or within the same chapter) . For more information, see "Selecting 
Viewing Options" later in this section. 

Follow these guidelines for using commas, spaces, and Term boxes when specifying 
search words. When you type more than one word as the basis for a search, your 
placement of commas and spaces between the words, as well as the number of Term 
boxes you use, determines the way Programmer 's Library performs the search. 

• When you place a comma between words in a single Term box (for ex
ample, "program, programming"), Programmer 's Library treats your 
comma as an "or" and searches for occurrences of either word throughout 
the reference or group of references. 

• When you place a space between two words in a single Term box (for ex
ample, " operating system"), Programmer 's Library searches for occur
rences of the two words together, in sequence, throughout the reference or 
group of references. 

• When you type words in separate Term boxes, Programmer's Library 
searches for occurrences of each word within the level or proximity (Chap
ter, Section, Subsection, Paragraph) you've specified in the Match Words In 
list box. For example, if you type "serial port" in one box and "mouse" in 
another and select the section level, Programmer's Library searches the ref
erence for sections that contain the words from both Term boxes. Your 
search results in a list of sections, each of which contains occurrences of 
both "serial port" and "mouse." 

NOTE: In TSR mode, if your cursor is located on or immediately adjacent 
to a word in the text of your program editor or word processing application, 
that word automatically appears in thefirst Term hox of the Search dialog 
box when you choose the Search command. If you press the F6 key or use 
your mouse to select a word from the text of Programmer's Library before 
choosing the Search command, that word automatically appears in the first 
Term box of the Search dialog box. There must be a space before and after 
the word you select. 



36 Programmer's Library User's Guide 

A 

B 

Searching MS C 5.1 Language Reference 
:. -

Match Words In 
Ter .. : loop 

Ter .. : Ifor 

Ter .. : IL ________ -' 

Chapter 
Section 
Subsection 
aragraph 

A .. ount Searched 

New Search 

100% 

Cance l 

A. Enter the search words here. You can type up to 80 characters in a 
single Term box. 

B. Specify a viewing level within the reference. Search results are displayed 
at this level. 

To carry out a search: 

I . Type your search word(s) in one or more Term boxes. 

2. Press Tab to go to the Match Words In list box. Then select a viewing level 
from those listed. 

For information on how the search level you specify affects your search 
when you use more than one Term box, see "The Search Dialog Box" 
earl ier in th is section. 

3. Press Enter or click the Start Search button in the dialog box. 

A moving rectangular symbol in the upper-left corner of your screen indi
cates that the search is in progress. When the search is finished, you'll see a 
I ist of titles that contain occurrences of your search word(s). Depending on 
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the level you selected from the Match Words In list box, this list contains ei
ther chapter titles, section or subsection titles, or the first line of each para
graph retrieved. If you're searching sample code, this list contains either 
directory names, filenames, or function names. 

Viewing Search Results 
Each time the Search command is used, a list or a set of selections that contains oc
currences of your search word(s) is displayed on your screen. In the upper-left corner 
of your screen, the viewing level you specified in the Match Words In list box is dis
played (for example, Section). 

To view a selection: 

I. Move your cursor to a selection in the list. 

2. Press Enter or double-cl ick the selection to display the text of that selection. 

When the selected text appears, one or more occurrences of your search word(s) are 
highlighted on your screen. Your first search word, followed by an ellipsis, is now 
displayed in the upper-left corner of your screen. 

The number in the upper-right corner of your screen indicates how many occur
rences your search found. These occurrences are contained in the list of selections on 
your screen. For example, a search done at the chapter level may result in 25 occur
rences of your search word(s), all located within the to chapters listed at the comple
tion of the search. As you move through the occurrences found in your search, the 
number in the upper-right corner of your screen changes to identify the occurrence 
you're viewing (for example, 5 of 25). 

If your search results in a very large number of occurrences, choose the Search com
mand again from the Browser menu bar. The same search word(s) will appear in the 
dialog box. Add additional words to narrow the scope of the search and select the 
Start Search button. 

For information on commands you can use when viewing search occurrences, see 
" Selecting Viewing Options" later in this section. 
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Using the Find Command 
Use the Find command when you want to find occurrences of a string of characters 
within a chapter, table of contents, or index. 

When you choose the Find command, Programmer's Library scans the text you're 
currently viewing and looks for the next occurrence of the string you specify. The 
Find command begins scanning text on the line below your current cursor position 
and stops at the end of the current chapter (or at the end of the table of contents or 
the index). 

To find a string of characters within a chapter, table of contents, or index: 

I. Choose Find from the Search menu (Browser menu bar). 

2. In the dialog box that appears, type the string of characters that you want 
to find. 

3. Press Enter or click the Next command button. 

Programmer 's Library scans the text for the next occurrence of the string of 
characters you speci fied, begi nn i ng on the line below the current cursor 
location. When Programmer's Library finds an occurrence of the string, it 
is displayed on your screen. 

4. Press Enter or click the Next command button again to move to the next 
occurrence. 

NOTE: When using the Find command to scan an entire chapter. table of 
contents. or index. position your cursor below the title of that section and 
above the first line of text. 

Using the QuickRef Command 
The QuickRef menu provides access to definitions of terms and concepts. References 
listed on the QuickRef menu contain dictionary-style definition sections or glossa
ries. Each reference on the QuickRef menu has been prepared to provide fast access 
to these definitions and to allow you to move easi ly from definition to definition. 

Unlike the Search command, which searches a reference for all occurrences of your 
search word(s), the QuickRef command uses the word(s) you place in the Term box 
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to quickly locate a related definition in the reference you've selected. For example, if 
you want to review the features of "printf" in the Microsoft C Optimizing Compiler 
Run-Time Library Reference, QuickRef takes you to the definition page rather than 
showing you every occurrence of "printf" in the reference (570 occurrences). 

The following Programmer's Library references are available through QuickRef: 

• Microsoft QuickBASICIBASIC Language Reference 

• Microsoft C Optimizing Compiler Run-Time Library Reference 

• Microsoft Mouse Programmer's Reference 

• Microsoft FORTRAN Language Reference 

• Microsoft Macro Assembler Reference 

• MS-DOS Programmer's Reference 

• The MS-DOS Encyclopedia 

• Advanced MS-DOS 

• Microsoft OS/2 Programmer's Reference 

• Microsoft OS/2 User's Reference 

• Microsoft Pascal Reference Manual 

• Microsoft Windows Programmer's Reference 

The QuickRef command is available on both the QuickRef menu (Main menu bar) 
and the Search menu (Browser menu bar). To use the QuickRef command on the 
Browser menu bar, you must first select a QuickRef reference from the Main menu 
bar. 

To use the QuickRef command on the Main menu bar: 

I. Choose QuickRef from the Main menu bar. 

2. Choose a reference from the QuickRef menu. 

3. In the Term box that appears, type the word or phrase you want to locate. 

4. Press Enter or cl ick the Look up button. 
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The first definition related to your quick reference term is displayed on the screen, 
and your cursor is positioned adjacent to the term. The number in the upper-right 
corner of your screen indicates how many occurrences of your quick reference term 
were found. For example, I of 3 indicates that you're looking at the first of three oc
currences of your quick reference term. Use the Previous and Next commands to dis
play each occurrence. For more information, see "Selecting Viewing Options" later 
in this section. 

Using Context-sensitive QuickRef 
If you're running Programmer's Library as a TSR , you can use QuickRef to look up 
any word in the text of your program editor or word processing application . 
QuickRef will search for the word where your cursor is currently located. 

To use the QuickRef command from your program editor or word process
ing application: 

I. Position your cursor on the word you want to look up. (There must be a 
space before and after the word.) 

2. Press Alt+left Shift to start Programmer' s Library. 

3. Press Alt+Q to look up the word you selected. 

To use the QuickRef command while in a QuickRef reference: 

You can also use the F6 key to look up a word in the QuickRef reference you ' re 
currently using. 

I . Position your cursor on the word you want to look up. (There must be a 
space before and after the word.) 

2. Press F6. 

3. Press AIt+Q to look up the word you selected. 
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Selecting Viewing Options 
Choose commands from the Browser menu bar to view: 

• Search and QuickRef results 

• Multiple cross-references associated with a word 

• Levels within a reference 

Using the Previous and Next Commands 
Choose the Previous and Next commands (Browser menu bar) to view Search and 
QuickRef results and to view multiple cross-references associated with a word. For 
information on viewing cross-references, see "Viewing Cross-References and Foot
notes" later in this guide. 

• Choose Previous to display the occurrence or cross-reference immediately 
preceding any appearing on your screen. 

• Choose Next to display the occurrence or cross-reference immediately fol-
lowing any appearing on your screen. 

The number in the upper-right corner of your screen initially reflects the total num
ber of occurrences or cross-references (for example, Set of 5). When you use Pre
vious or Next, this number changes to identify the occurrence or cross-reference 
currently displayed (for example, 3 of 5). When the fi rst or last occurrence or cross
reference is displayed, Previous and Next are disabled, respectively. 

To go to the previous occurrence or cross-reference: 

• Choose Previous from the Browser menu bar or use one of the shortcut key 
combinations that follow. 

To go to the next occurrence or cross-reference: 

• Choose Next from the Browser menu bar or use one of the shortcut key 
combinations that follow. 
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Shortcut Keys 
You can use the following shortcut key combinations to move through Search and 
QuickRef results and cross-references: 

To do this 

Go to the previous occurrence or cross-reference 

Go to the next occurrence or cross-reference 

Go to the first occurrence or cross-reference 

Go to the last occurrence or cross-reference 

Zooming In and Out 

Use this key combination 

Alt+P or Alt+Left 

AIt+N or AIt+Right 

AIt+Home 

Alt+End 

The Zoom In and Zoom Out commands on the View menu let you quickly go to an
other level within a selected reference. These two commands are particularly useful 
when you want to move step by step through the viewing levels in a reference. For 
example, you might use Zoom In to go from the list of chapters in a book to the list 
of sections within a chapter and then to a subsection within a particular section. 

Paragraph MS C 5 .1 Language Reference (Search) Set of 10 
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A. Choose Zoom In to go to the full text of the paragraph you've selected. 
8. Choose Zoom Out to return to the list of first lines of paragraphs. 
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Displays this on your screen 

List of chapter titles within a reference or reference titles 
within a group of references 

List of section titles within a chapter 

List of subsection titles within a section 

List of first lines of paragraphs within a subsection 

NOTE: Sometimes a reference does not include all of these levels. For ex
ample, a short section of a reference may not have subsections. In this case, 
when you choose the Zoom In command while viewing a list of section titles, 
the section title you selected continues to be displayed. Choosing Zoom In 
again will display the first lines of paragraphs within the section. As you 
zoom in and zoom out, the level currently displayed is identified in the upper
left corner of your screen. 

To zoom to a lower level within the reference you're using: 

• Choose Zoom In from the View menu or press F7 or click the right mouse 
button to zoom in on a selected item. 

NOTE: When viewing a list of titles, you can zoom in directly to the text by 
pressing Enter or by double-clicking on a title. 

To zoom to a higher level within the reference you're using: 

• Choose Zoom Out from the View menu or press F8. 
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---===========~~~-

Copying, Appending, and Pasting 
Programmer's Library has its own Clipboard, which is a temporary holding area for 
text or sample code you want to copy to your program editor or word processing ap
plication. Use the Copy command or the Append command to temporarily store text 
from any of the Programmer's Library references in the Clipboard. You can then 
paste the text into your program editor or word processing application. 

Copying Information to the Clipboard 

To copy text to the Clipboard: 

I. Place your cursor at the beginning of the text you want to copy. 

2. Hold down Shift while pressing a direction key to highlight the text you 
want to copy, or drag the mouse to highlight the text you want to select. 

You can use the Insert key as an " anchor" when selecting text. Press Insert 
when the cursor is positioned at the beginning of the text you want to copy. 
Then press Up or Down to select text. If you press Insert again , the anchor 
point moves to your current cursor location. 

3. Choose Copy from the Edit menu or press Del. 

The Copy command replaces the current contents of the Clipboard with the text 
you've selected. You can copy up to 200 lines of text into the Clipboard each time 
you use Copy. 

NOTE: Before copying table headings to the Clipboard, be sure that the 
Lock Titles command is turned off 

Appending Information to the Clipboard 
After copying something to the Clipboard, you can add other text or sample code to 
it using the Append command. You can append up to 200 lines of text to the Clip
board each time you use Append. There is no limit to the number of lines of sample 
code you can append. 
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To add text to the Clipboard: 

I. Place your cursor at the beginning of the text you want to append. 

2. Hold down Shift while pressing a direction key to highlight the text you 
want to append, or drag the mouse to highlight the text you want to select. 

3. Choose Append from the Edit menu. 

Pasting Information into Your Program 
Editor or Word Processor 
The Paste command is available only when Programmer ' s Library is loaded into 
memory as a TSR application. (For information about stand-alone operation, see 
" Saving the Clipboard" later in this section.) Two menus contain the Paste 
command - the Options menu on the Main menu bar and the Edit menu on the 
Browser menu bar. Paste always works in the same way, regardless of which menu 
you use. When you choose Paste, the entire contents of the Clipboard are copied to 
the location you specify. 

If your program editor or word processor cursor is already in the right location, you 
can choose Paste from the Edit menu without leaving Programmer' s Library. 

You can press Esc at any time to interrupt and cancel a paste operation . Clipboard 
contents that have already been pasted cannot be cancelled. 

To paste the contents of the Clipboard into your document: 

I. Be sure that the cursor in your program editor or word processi ng appl ica
tion is positioned where you want text to be inserted. 

To do this, press Esc until you return to your program editor or word 
processor. Position the cursor where you want the text to be inserted. Then 
press Alt+left Shift to return to Programmer's Library. 

2. Choose Paste from either the Options menu (Main menu bar) or the Edit 
menu (Browser menu bar). Pressing FlO or Shift+lnsert will paste the Clip
board contents as well. 
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NOTE: If your program editor or word processing application is pelform
ing a task or displaying a dialog box while you are attempting to paste, 
Programmer's Library cannot complete the paste operation. If you have a 
color monitor, Programmer's Library tells you that Paste is disabled by dis
playing the name of your program editor in red on the title bar. You cannot 
use the Paste command when running Programmer' s Library in stand-alone 
mode. 

Saving the Clipboard 
Use the Save Clipboard command on the Options menu to save the contents of the 
Clipboard. When you choose Save Clipboard, your text is saved in a file whose file
name and directory you specify. 

You can load thi s fi le into your program editor or word processor to create programs 
or documents . This a llows you to copy information from Programmer 's Library to 
another application if you normally use Programmer 's Library in stand-alone mode. 

To add the contents of the Clipboard to a file: 

I. Choose Save Clipboard from the Options menu (Main menu bar). 

2. Type the drive, directory , and filename where you want to store the Clip
board contents. 

3. Choose the Append button. 

To replace the contents of a file with the Clipboard contents: 

I . Choose Save Clipboard from the Options menu (Main menu bar). 

2. Type the drive, directory , and filename where you want to store the Clip
board contents. 

3. Choose the Copy button. 

NOTE: If you save the Clipboard contents, you cannot use Programmer's 
Library to open and view the contents of that file. You must use your pro
gram editor or word processor. 
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Using Bookmarks 

Creating Bookmarks 
You can use the Create Bookmark command on the Author menu (Browser menu 
bar) to mark your place within the text you're viewing. When you create a book
mark, you place an invisible marker at the current location of your cursor. Use the 
Bookmarks command on the Options menu (Main menu bar) or the View menu 
(Browser menu bar) to return to the location you've marked. Programmer's Library 
allows you to keep up to 80 bookmarks on fi Ie. 

: .. 

A 
rlote: Iropen L-________________________ ~ 

B II Create II Cancel 

A. Type a phrase here to describe the bookmark. 
B. Press Enter or click this button to carry out the command. 

To create a bookmark: 

I. Position your cursor at the location where you want to place the bookmark. 

2. Choose Create Bookmark from the Author menu. 

A dialog box appears, prompting you for information about the bookmark. 

3. Type a single line of text to describe the bookmark. 

4. Press Enter or cl ick the Create button. 

Viewing Bookmarks 
The Bookmarks command, listed on both the Options menu (Main menu bar) and 
the View menu (Browser menu bar), lets you display a I ist of the bookmarks you've 
created. 
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A 

B 

c 

MS C 5.1 Language Reference (Browse) 
dit View Author Table Search Browse Hel 

: .. 
SC Lang : data types 

MSC Lang 
-+1------1--+1 MSC Lang 

MSC Libr 
MSC Libr 
MSC Us 

fopen 
functions 
include files 
printf 
fIlefilory fIlodels 

D -tt----_/_ Delete Cancel 

E ~--~~~==~~~~==~ 

A. When you choose Bookmarks from either the View menu (Browser menu 
bar) or the Options menu (Main menu bar), this dialog box appears. 

B. Bookmarks for the reference category in use appear at the top of the list. 
C. Bookmarks are listed alphabetically within each reference. 
D. Choose the View button to go to the selected bookmark. 
E. Choose the Delete button to delete the selected bookmark. 

To view or delete a bookmark: 

l. Choose Bookmarks from either the Options menu (Main menu bar) or the 
View menu (Browser menu bar). 

A dialog box appears, showing a list of the bookmarks you've created. The 
bookmarks for the reference category in use appear at the top of the list, fol
lowed by bookmarks set within other reference categories and other 
Microsoft CD-ROM Library products. Bookmarks are listed alphabetically 
within each reference. 

2. Use the direction keys or the scroll bar to move to the bookmark you want. 
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3. Choose the View button in the dialog box to display the text of the book
mark you've selected. Choose the Delete button to remove the bookmark 
from the list. 

NOTE: Choosing the Bookmarks command from either the Main menu har 
or the Browser menu har lets you go to another reference category hy select
ing a hookmarkfrom that category. 
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Accessing Sample Code 

A -
while C SaMple Code (Search) 41:) of 42 
it View Author Table Search Drowse Prev Next Hel 
~ain(argc, argv) 
I ~nt argc: 
char **<lrg v : 
{ 

long atolO: 1* Alpha string to long int conversion *1 

if (argc == 1) 

forever = 1: 
1* No cOMMand-line arguMent *1 
1* So run forever *1 

else 
repeat = atol(argv[11): 1* Else, run given nUMber *1 

init I ifeoO: 
do { 

More_rounds = 1:): 
init_bufo() : 
draw_boxo(attrib): 
init_Matso() : 
rand_dist(density/11:)1:) .1:): 
pause = 1:): 
while (forever :: repeat-- ) { 

proc_key() : 
if (!pause) 

if ( 11:) 

A. Choose commands from these menus to search and display the code. 
B. Sample code written in the Microsoft C language. 

The Programmer's Library disc includes a directory of sample program code you 
can display and copy into your own programs. You can access this sample code 
through the DOS directory where it is stored or by choosing it from one of the Pro
grammer's Library menus. When you access the code through a menu, you can use 
any of the Programmer's Library commands and tools to display and search the 
code. 

When viewing sample code through Programmer's Library, you'll notice that each 
sample code file is preceded by a heading line that gives the full path name of the 
ASCII file on the disc. For example, while browsing source code in Chapter 6 of 
Programming Windows, you'll see this line at the start of the digital clock program: 

\SAMPCODE\PROGWIND\CHAP06\DIGCLOCK . C 
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This line tells you exactly where to find the "digclock.c" program on the Program
mer's Library disc. You can then load the file directly, using your program editor. 

To access the sample code while using Programmer's Library: 

l. Choose Library from the Options menu (Main menu bar). Then select the 
reference category you want to use. 

2. Choose the sample code selection from the Search menu (Main menu bar). 

3. When the dialog box is displayed, enter the appropriate search terms in the 
term boxes. 

4. In the Match Words In list box, choose the level at which you want to view 
search results-directory, file, or function. 

S. Choose the Start Search button. 

You will see all of the directories, files, or functions that include occur
rences of your terms in the code. 

6. Use the direction keys to select the entry you want. Use the Previous and 
Next commands to move through the search occurrences. 

Once you've found the sample code you want, you can use the Copy com
mand to copy the code you want to use in your program. For more informa
tion , see "Copying, Appending, and Pasting" earlier in this guide. 

To access the sample code from a DOS directory: 

I. Be sure the DOS directory or CD-ROM drive that includes the Program
mer's Library sample code is active. 

2. Type dir to display a I ist of the sample code fi les in the di rectory. 

3. Use your program editor or word processing application to load a sample 
code file directly from the CD-ROM drive. Be sure to specify the complete 
path name. 
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Viewing Cross-References and Footnotes 
Many of the references in Programmer 's Library contain cross-references a nd foot
notes. When the text you're viewing contains a cross-reference or a footnote, you' ll 
see one of these special symbols: 

A 

B 

C 
D 

o ind icates a cross-reference 

* indicates a footnote 

r-Table 1.2 MS C 5.1 Language Reference (Cross Ref) 1 of 2 . . : . 
optio our cOlllpi ler guide / 2001ll In F7 

2001ll Out F8 
Hote 

Thi Location Alt-L es the abbreuiated forllls of the type specifiers 
lis her than the long forllls, and it assullles that the 
cha Booklllarks efault. Therefore, throughout this lIlanua 1, char 

~ Footnote 

Iii 
. 

eturn Alt R 
: ~: 

Table 1 .2 
Type Spec if iers and Abbreuiations 

III ull 
Type Specifier Abbreuiations 

signed charH char 
signed int signed, int 
signed short int short, signed short 
signed long int long, signed long 
unsigned char*Z --

A. The word associated with the selected cross-reference appears in the 
upper-left corner of the screen. 

B. The number of cross-references associated with the word appears in the 
upper-right corner of your screen. As you go to these cross-references, 
the number in the upper-right corner changes to identify the cross
reference you're viewing. 

C. Choose Cross-ref from the View menu to view a cross-reference. 
D. Choose Return to return through the cross-references you've viewed 
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To view a cross-reference: 

I. Place your cursor or mouse pointer on the cross-reference symbol in the text 
you're viewing. 

2. Press Enter, double-click the cross-reference symbol, or choose Cross-ref 
from the View menu. 

When you select a cross-reference, you move to the location of the associated text. If 
a word has several cross-reference symbols, use the Previous and Next commands to 
go to these cross-references. 

To return to the text you were viewing: 

You can go to up to 18 successive cross-reference locations. 

• Choose Return from the View menu or press Alt+R to return through the 
sequence of locations. 

• Press Alt+Up to return to the original text where you started displaying 
cross-references. 

NOTE: See "Se/ecting Viewing Options" in the previous section for more 
information ahout viewing cross-references. 

To display footnote text: 

I. Place your cursor or mouse pointer on the footnote symbol that appears in 
the text you're viewing. 

2. Press Enter, double-cl ick the footnote symbol, or choose Footnote from the 
View menu. 

When you select a footnote, the associated text is displayed in a box at the bottom of 
your screen. 

To remove a footnote from the screen: 

• Press Enter, double-click the left mouse button, or choose a new command. 
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Checking Your Location 
Whenever you're viewing text or sample code, you can choose the Location com
mand from the View menu to quickly find out where you are within the reference 
you're using. When you choose Location while viewing a reference, a box appears at 
the bottom of your screen listing the chapter, section, subsection, and paragraph. 
When you choose Location while viewing sample code, the box lists the directory, 
file, and function. 

A 

ro cI 

C Sanple Code (Browse) 

int nain( argc, argu 

{ 

int argc; 
char *ilrgu[l; 

int c; 
if ( argc < Z 

{ 

else 

printf( "usage: cflow [-uH-rH-dl filelist" ); 
} 

initstatenachineo(); 
while ( --argc > a ) 

{ 

++argu; 

Directory 
File 

\SAnrCODE\nSC\EXAnrLE 
\SAnrCODE\nSC\EXAnrLE\CFLOW.C 

Function nain 

1 
i 

I 
Iii 

/* for all fL i: 

A. The Location box tells you where you are within the reference or sample 
code you 're using. 

II·' I 

• Choose Location from the View menu. 
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You can also use the following keyboard shortcut to display location information 
while viewing text: 

• Press AIt+L 

NOTE: Sometimes a reference may not include a chapter, section, suhsec
tion , or paragraph level. In these instances the Location hox repeats the title 
from the preceding level. 
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Working with Tables 

When viewing information in any Programmer's Library reference, you may occa
siona ll y encounter tables that are too wide or too long to be fully displayed on your 
screen. Programmer' s Library provides several options for viewing and working 
with such tables. These options include scrolling, hiding and revealing co lumns, and 
locking and unlocking columns. 

Scrolling Within Tables 
Scrolling within tables works in much the same way as scrolling elsewhere in Pro
grammer's Library. You can use the direction keys or PgUp and PgOn to move text 
into view horizontally or vertically. If you are using a mouse, you can use any of the 
three scrolling features (scroll bar, scroll box, and scroll elevator) to move text into 
view. 

table MS C 5.1 Language Reference (Search) 50 of 68 
I , : I 

Table '1.3 
1 

~ ~. 

Storage and Range of Values for Fundanental Types 
:,. 

A iii Ii ' 
Type Storage Range of Values (Internal) 

char 1 byte -128 to 127 

int inplenentation 
defined 

short 2 bytes -32.768 to 32.767 

long 'I bytes -2.1'17.'183.6'18 to 2.1'17.'183.6'17 

unsigned char 1 byte o to 255 

unsigned inp lenentat ion 
defined 

"'" unsigned short 2 bytes o to 65.535 ~ 
B 

A. Use the ruler to mark the location of a column you want to hide or reveal. 
B. Use the scroll bars or the direction keys to bring more of a table into view. 
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The Home and End keys provide additional viewing options when working with 
tables: 

• When your cursor is in the table ruler, press Home or End to bring the first 
or last column of a table into view, respectively . 

• When your cursor is in the table text, press Home to move your cursor to the 
left edge of the screen on the current I ine of text. Press End to move your 
cursor to the last character on the current line of text. 

For more information on scrolling, see "Scrolling Techniques" earlier in this guide. 

Hiding and Revealing Columns 
The Hide Column and Reveal Column commands can be used to compare nonadja
cent columns in a table . By choosing Hide Column from the Table menu, you can 
temporarily hide a column so that another part of the table can be brought into view. 
For example, by hiding columns you can place the data in column one of a table 
beside the data in column six of the same table. 

You can hide only one column at a time, but you can use the Hide Column command 
as many times as you like within a single table. 

To hide a column: 

I . If your cursor is within the table, use Ctrl+Home and the direction keys to 
move your cursor to the ruler. Or, click inside the ruler. 

2. Place your cursor or mouse pointer on the symbol that indicates the begin
ning of the column you want to hide. 

3. Choose Hide Column from the Table menu or double-click the symbol. 

The ruler displays a special symbol ( t) to represent a hidden column. 

To bring a hidden column back into view: 

I. If your cursor is within the table , use Ctrl+Home and the direction keys to 
move your cursor to the ruler. Or, click inside the ruler. 
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2. Move your cursor or mouse pointer to the symbol that indicates where the 
column is hidden. 

3. Choose Reveal Column from the Table menu or double-click the symbol. 

Locking and Unlocking Columns 
Use the Lock Column and Unlock Column commands on the Table menu when a 
table is too wide to view on a si ngle screen. Lock Column temporarily freezes the 
position of the leftmost column of the table while you scroll more of the table into 
view. Unlock Column unfreezes thi s column, allowing it to be scrol led with the rest 
of the table. 

To Ind th leftrnn .. t l'lIl 

1. If your cursor is within the table, use Ctrl+Home and the direction keys to 
move your cursor to the ruler. Or, click inside the ruler. 

2. Press Home to move your cursor to the symbol that indicates the beginning 
of the leftmost column of the table. 

3. Choose Lock Column from the Table menu. 

The leftmost column is locked into place. By scrolling to the right, you can bring 
other columns into view. The ruler displays a special symbol to indicate that the col
umn is locked. 

To ur In. 

I. If your cursor is within the table, use Ctrl+Home and the direction keys to 
move your cursor to the ruler. Or, cl ick inside the ruler. 

2. Press Home to move your cursor to the symbol that indicates the beginning 
of the leftmost column of the table. 

3. Choose Unlock Column from the Table menu. 
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Locking Titles 
Programmer's Library provides another feature to assist you in viewing large tables. 
When working with tables that are too long to fit onto a single screen, Programmer's 
Library automatically freezes the table headings at the top of your screen so that the 
headings remain visible as you scroll more of the table into view. The ruler remains 
locked whenever a table is displayed. 

To use the Lock 1 itles command: 

• Choose Lock Titles from the Table menu to toggle between locked and 
unlocked table headings. 

A check mark to the left of the command indicates that table headings 
are locked. 
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Adding a Date Stamp 
If Programmer 's Library is used as a TSR application, you can paste today's date 
and time into a document in your program editor or word processing application. 

To add a date stamp: 

l. Position your cursor where you want the date stamp to be inserted in your 
document. 

2. Choose Date Stamp from the Options menu. 

NOTE: The date stamp will be accurate only if your computer's system 
clock is accurate. 
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Customizing Programmer's Library 

Changing the Startup Keys 
The Hotkeys command on the Options menu allows you to choose the key combina
tion used to start Programmer's Library as a TSR. The default startup key combina
tion is Alt+left Shift, but you can change this by making selections in the Hotkeys 
dialog box. You might want to change the startup key combination for your own typ
ing convenience or because you're using another program that conflicts with the 
Alt+left Shift key combination. 

To change the startup key combination: 

A 

I. Choose Hotkeys from the Options menu (Main menu bar). 

A dialog box appears containing a list of the keys you can use to start Pro
grammer's Library. Check marks appear to the left of the keys currently 
selected. 

2. Press Tab to move to the key you want to toggle on or off. 

3. Press Spacebar to toggle a key on or off. 

4. When you 've finished indicating your preferences, press Enter. 

NOTE: The current startup key comhination is displayed on the screen 
when the MS Lihrary software is loaded into memory. 

,f L-Sh ift 

R-Shift 

B II~I I Cancel I 

A. Press Tab to go to the keys you want to use as startup keys. Then press 
Spacebar to toggle between hotkey options. 

B. Press Enter or click OK after you've indicated your preferences. 
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Changing the Screen Colors 
If you're using Programmer's Library with a color display adapter and monitor, you 
can change the standard colors used by the application. 

To adjust the colors displayed on Programmer's Library screens: 

1. Choose Colors from the Options menu (Main menu bar). 

Programmer's Library di splays a color selection screen. The right side 
shows the colors currently in use and the left side shows the available color 
choices. 

2. Use Up and Down to move within the list of choices. Use Left and Right to 
change the color selections. 

As you make color choices, you'll see your selections displayed on the right 
side of your screen. 

3. When you've finished making choices, press Enter to save your new selec
tions . Or, if you want to cancel your changes or go back to the original color 
selections, press Tab to move to the Cancel button or the Original button. 



Using Programmer's Library 63 

Configuring Memory 

Using Base Memory 
If you run Programmer's Library as a TSR application, you can allocate one addi
tional 64K block of base memory (not extended or expanded memory). This extra 
memory will make the MS Library software run faster, but the 64K block will not be 
available for use by text editors or other applications that run while the MS Library 
software is loaded. 

ro load I'rogranllnl'r'" Librar~ dnd allocate one addItional 6~K basl 
mem( 

• At the DOS prompt, type msl Ix. 

Using Expanded Memory 
The MS Library software can take advantage of one 64K block of expanded 
memory. This will make an extra 64K of base memory available for use by program 
editors or other applications that run while the MS Library software is loaded. You 
can take advantage of this feature if: 

• You have an expanded memory board that conforms to the Lotus-Intel
Microsoft (LIM) 3.2 standard, and 

• You have at least 64K of expanded memory available, or 

• You are running LIM 3.2 emulator software on an 80386-based system. 

10 load Progr,lInmcr'., I ibr.tn .tnd ,lllolate one ()~K hlod... of expanded 
mt'm(~ 

• At the DOS prompt, type msl II to load Programmer's Library into memory 
as a stand-alone application, or 
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• At the DOS prompt , type msl lIt to load Programmer's Library into memory 
as a memory-resident application. 

NOTE: If you are using LIM 4.0, you must have a LIM 3.2 compatihle 
page frame. For more information , refer to the manual thaI came with your 
expanded memory hoard. 



Programmer's Library Quick Reference 
This section provides summary information about Programmer's Library. Use this 
information as a quick reference resource for keyboard and mouse functions, as well 
as menus and commands. 
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Using the Keyboard and the Mouse 
Here are the basic keyboard and mouse operations you' 11 use frequently with Pro
grammer's Library. 

To do this 

Load Programmer' s 
Library in stand-alone 
mode 

Load Programmer's 
Library as a memory
resident program 

Start Programmer's 
Library as a memory
resident program 

Return to the Main 
menu bar from the 
Browser menu bar 

Return to your pro
gram editor or word 
processor from the 
Browser menu bar 
(TSR mode) 

View a menu 

Cancel a menu 

Choose a command 

Cancel a command 

With the mouse 

(no mouse option) 

(no mouse option) 

(no mouse option) 

Double-click right mouse button 

Double-click right mouse button 

Poi nt to the menu title and cl ick the 
left mouse button 

Click outside the menu or double-click 
the right mouse button 

Click the command name 

Click the Cancel button in a dialog box 
or double-click the right mouse button 

With the keyboard 

Type msl 

Type msl /( 

Press Alt+left Shift 

Press Esc 

Press Esc twice 

Use the direction keys to 
select the menu title or 
press the fi rst letter of the 
menu title 

Press Esc 

Use the direction keys to 
select the command and 
press Enter to carry it out; 
or press the first letter of 
the command name and 
press Enter 

Tab to the Cancel button 
in a dialog box and press 
either Enter or Esc 

(continued) 
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To do this 

Move around in a dia
log box 

Select an option in a 
dialog box 

Scroll 

Get Quick Help 

End the use of a 
reference, reference 
category, or Program
mer 's Library 

Remove Program
mer's Library from 
memory 

With the mouse 

Move the mouse pointer to the place 
you want and click the left mouse 
button 

Point to the option and double-click 
the left mouse button 

Click a scroll arrow or click above or 
below the scroll box in one of the 
scroll bars to move in the direction you 
want 

Click Help on the Browser menu bar 

Double-click the right mouse button 
until you return to the menu you want, 
to your program editor, or to DOS 

Click Options on the Main menu bar, 
click Unload, and click the OK button 

With the keyboard 

Press Tab to move for
ward between items; 
press Shift+ Tab to move 
backward 

Tab to the option (using 
Tab or Shift+Tab) and 
press Enter 

Use the direction keys to 
move in the direction you 
want 

Press Fl 

Press Esc until you return 
to the menu you want, to 
your program editor, or to 
DOS 

Press 0, U, Enter, Enter 
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Using Keyboard Shortcuts 
You can use certain keys and key combinations as shortcuts when carrying out basic 
tasks with Programmer's Library. Here's a look at the shortcuts you'll use most 
often. 

To do this 

Start Programmer's Library as a memory-resident program 

Remove Programmer's Library from memory 

Carry out a selected action or command 

Cancel the current task or move backward through levels of 
Programmer' s Library; press Esc repeatedly from within a 
reference to exit Programmer's Library 

Move forward through options in a dialog box 

Move backward through options in a dialog box 

Provide an anchor key, or starting point, when selecting a 
block of text 

Copy selected text to the Clipboard 

Paste a selected block of text 

Display Quick Help for the task at hand 

Display a document in your program editor or word 
processing application for viewing only; press F2 to view the 
document you're working on, then press any key to return to 
Programmer's Library; the view mode does not allow editing 

Select a word in Programmer's Library text and insert the 
word in the first Term box of the Search dialog box 

Zoom in 

Zoom out 

Append selected text to the Clipboard 

Paste the contents of the Clipboard into your program editor 
or word processing application 

Create a bookmark 

Use this 

Alt+left Sh i ft 

Press 0, U, Enter, Enter 

Enter 

Esc 

Tab 

Shift+Tab 

Insert 

Delete 

Shi ft+Insert 

FI 

F2 

F6 

F7 

F8 

F9 

FlO 

AIt+A 

( conrinued) 
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To do this 

Display the list of chapters (table of contents) for the refer
ence in use 

Display the Location box which describes your current loca
tion within a reference 

Choose Library from the Options menu to select another ref
erence category or another Microsoft CD-ROM Library disc 

Start a QuickRef lookup in the QuickRef manual you're cur
rently using 

Start a search 

Hide a column in a table 

Use this 

Alt+B 

Alt+L 

Alt+O 

Alt+Q 

Alt+S 

Alt+T 

Use the following shortcut key combinations to go to occurrences found by 
the Search and QuickRef commands and to go to cross-references: 

To do this 

Go to the previous occurrence or cross-reference 

Go to the next occurrence or cross-reference 

Go to the first occurrence or cross-reference 

Go to the last occurrence or cross-reference 

Go to the previous cross-reference, or, if you've viewed only 
one cross-reference, to go to your original location 

Go to your original location when you've viewed multiple 
cross-references 

Use this 

Alt+P or Alt+Left 

Alt+N or Alt+Right 

Alt+Home 

Alt+End 

Alt+R 

Alt+Up 
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Use the following shortcut key combinations to move within Programmer's 
Library text and tables: 

To do this 

Move one character in the corresponding direction 

Move one word in the corresponding direction 

Move one screen in the corresponding direction 

Move the cursor to the beginning or the end of the reference 
in use, respectively 

In text, move to the left edge of your screen on the current 
line; in the table ruler, move the first column of a table into 
view 

In text, move to the last character on the current line; in the 
table ruler, move the last column of a table into view 

Move the cursor to either the upper-left or lower-left corner 
of your text screen, respectively 

Use this 

Left, Right, Up, Down 

Ctrl+Left, Ctrl+Right 

PgUp, PgDn 

Ctrl+PgUp, Ctrl+PgDn 

Home 

End 

Ctrl+Home, Ctrl+End 
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Quick Reference: Menus and Commands 
The following list provides a brief description of all of the menus and commands 
available in Programmer' s Library. 

Main Menu Bar 

Menu: 

Search 

This menu lists the references and sample code available in the Programmer's Li
brary reference category you ' re currently using. Choose one of the references or a 
group of references to start a search for a specific word or phrase. 

Menu: 

MS C 5.1 Update 
MS C 5 .1 User's Guide 
MS C 5 .1 Language Reference 
MS C 5 .1 Run-Tine Library Reference 
CodeUiew/Utilities Manual 
CodeUiew/Utilities Update 
MS Mixed-Language Progranning Guide 
MS Editor User's Guide 
QuickC 2 .0 Tool Kit 
QuickC 2.0 C for Yourself 
QuickC 2.0 Up and Running 
All C 5 .1 Manuals 

MS QuickC Progranning 
Proficient C 
C Sanple Code 

Contents 

This menu lists the references and sample code in the current category. Choose one 
of the references or a group of references to display the Browser menu bar. 
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Index 
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MS C 5.1 Update 
MS C 5.1 User's Guide 
MS C 5.1 Language Reference 
MS C 5 .1 Run-Time Library Reference 
CodeView/Utilities Manual 
CodeView/Utilities Update 
MS Mixed-Language Programming Guide 
MS Editor User's Guide 
QuickC 2.0 Tool Kit 
QuickC 2.0 C For Yourself 
QuickC 2.0 Up and Running 
All C 5.1 Manuals 

MS QuickC Programming 
Proficient C 
C Sample Code 

This menu lists the references in the current category that contain indexes. Choose 
one of the references to display the Browser menu bar. 

Menu: 

MS C 5 .1 User's Guide 
MS C 5 .1 Language Reference 
MS C 5 .1 Run-Time Library Reference 
CodeView/Utilities Manual 
MS Mixed-Language Programming Guide 
MS Editor User's Guide 
QuickC 2.0 Tool Kit 
QuickC 2.0 C For Yourself 

MS QuickC Programming 
Proficient C 

QuickRef 

This menu lists the references in which you can look up definitions. Choose one of 
the listed references to search for the definition of a specific term. 



74 Programmer's Library User's Guide 

MPU3iAI 
MS C 5.1 Run-Tine Library Reference Alt-Q 

Menu: 

Options 

This menu lists commands that allow you to customize Programmer's Library, start 
other Microsoft CD-ROM Library products, change reference categories, and per
form other special tasks. 

Library Alt-O 

Booknarks 
Paste flO 
Save CI ipboard 
Date Stanp 
Colors 
Hotkeys 

Unload 

Lihrary allows you to select another Programmer's Library reference category or to 
open any of the Microsoft CD-ROM Library products you've set up. 

Bookmarks allows you to view all of the bookmarks you've created in any of the 
Microsoft CD-ROM Library products you've set up. You can delete any bookmarks 
you've created in Programmer's Library. 

Paste allows you to insert information you've copied from Programmer's Library 
into your program editor or word processing application. 

Save Cliphoard saves information copied to the Clipboard in a file specified by you. 

Date Stamp inserts the current date and time into your word processing document. 

Co/Drs allows you to change the colors displayed on Programmer's Library screens. 

Hotkeys allows you to change the key combination used to start Programmer's 
Library. 

Un/Dad removes the MS Library software from your computer's memory. 
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Menu: 

Help 

This menu lists commands that provide access to help information concerning 
Programmer's Library. 

Quick Help Fl 

Search 
Table of Contents 
General Index 

About 

Quick Help displays help information for the task you're currently performing; it is 
activated by pressing Fl. 

Search allows you to search the User's Guide for a specific term or topic. 

Table a/Contents displays the User's Guide table of contents. You can select a topic 
from the list for viewing. 

General Index displays the User's Guide index. You can select a cross-reference from 
the index for viewing. 

About displays copyright information for Programmer's Library. 

Browser Menu Bar 
Menu: 

Edit 

This menu lists commands that allow you to work with the Clipboard. 

Append F'l 
Copy Del 
Paste flO 

Append adds the selected text to the contents of the Clipboard. 
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Copy places the selected text in the Clipboard and overwrites any existing text in the 
Clipboard. 

Paste copies the contents of the Cl ipboard to your program editor or word processor 
if you're running Programmer's Library as a TSR application. 

Menu: 

View 

This menu provides tools that allow you to control the way information is displayed 
in Programmer 's Library. 

ZOOfil In F7 
ZOOfil Out F8 

Location Alt-L 

BookJllarks 
Footnote 
Cross-ref 
Return Alt-R 

Zoom In displays the next lower level in the reference you ' re viewing. 

Zoom Out displays the next higher level in the reference you're viewing. 

Location displays a box which indicates where you are in the reference or sample 
code you're currently viewing. 

Bookmarks allows you to view all of the bookmarks you've created in any of the MS 
Library products you 've set up. You can delete any bookmarks you 've created in 
Programmer's Library. 

Footnote displays the text of a footnote associated with a reference. 

Cross-ref goes to the text of a cross-reference associated with a word in a reference, 
table of contents, or index. 

Return goes to the cross-reference you were last viewing or, if you've viewed only 
one cross-reference, to your original location. 
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Menu: 

Author 

This menu allows you to create and delete bookmarks in a Programmer's Library 
reference. 

Create Bookmark Alt-A 
Delete Bookmark 

Create Bookmark marks your place within the text you're viewing. 

Delete Bookmark removes a bookmark you've created. 

Menu: 

Table 

This menu allows you to change the way tables are displayed on your screen. 

Hide Column Alt-T 
Reueal Column 

Lock Column 
Unlock Column 

J Lock Titles 

Hide Column temporarily hides a column so that another part of a wide table can be 
brought into view or so that nonadjacent columns can be viewed next to each other. 

Reveal Column displays a column that has been hidden. 

Lock Column freezes the leftmost column (the row labels) in a table. You can then 
scroll other parts of the table into view. 

Unlock Column unlocks the leftmost column in a table. 

Lock Titles is a toggle that locks and unlocks the table headings or titles. When 
locked, table headings remain visible while scrolling up or down in a long table. 
Locked titles is the default. 
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Menu: 

Search 

This menu allows you to locate a specific word or phrase within the current 
reference or group of references . 

Search Alt-S 
Find 
QuickRef Alt-Q 

Search allows you to locate all of the occurrences of a word or phrase within the 
current reference or group of references. 

Find allows you to locate the next occurrence of a word or phrase within a chapter, 
a table of contents, or an index. 

QuickRefallows you to locate the definition of a term within the current reference. 
To use this command, you must be using one of the QuickRef references. 

Menu: 

Browse 

This menu displays the table of contents or index for the current reference. 

Table of Contents Alt-B 
Genera I Index 

Tahle of Contents displays the I ist of chapter titles for the current reference. 

Genera/Index displays the index for the current reference. 

Command: 

Prev 

This command displays the previous Search or QuickRef occurrence or cross
reference (when multiple cross-references are associated with a word). 
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Command: 

Next 

This command displays the next Search or QuickRef occurrence or cross-reference 
(when multiple cross-references are associated with a word). 

Command: 

Help 

This command displays Quick Help for the task you're performing. You can also get 
Quick Help by pressing Fl. 
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Using Programmer's Library in 
Stand-alone Mode 

Programmer's Library can be used effectively as a stand-alone application in con
junction with most program editors and word processing applications. You simply 
access DOS from your program editor or word processor, type msl to start Program
mer 's Library, and find the information or code you need. To return to your program 
editor or word processor, press Esc repeatedly to return to the Main menu bar and 
display the Exit dialog box, and then press Enter. More than 256K of memory is 
usually required to run an editor or word processor while using Programmer's Li
brary in stand-alone mode. For more information, see " Starting Programmer's 
Library " earlier in this guide or see the text relating to the specific program editor 
you ' re using later in this section. 

You can also copy code from Programmer's Library into your program editor or 
word processing application while running in stand-alone mode. From within Pro
grammer's Library, use the Copy command to copy the code to the Clipboard. Save 
the code in a file using the Save Clipboard command. Then use your editor or word 
processor to load this file and insert the code you've saved. From outside Program
mer's Library, you can copy the ASCII file of code from the CD-ROM disc using 
your editor and specifying the source driver (for example, D:) and the pathname. For 
more information, see "Copying, Appending, and Pasting" earlier in this guide. 

The following sections describe how to use Programmer's Library as a stand-alone 
application with some of the most popular program editors and with Microsoft 
Word. Further instructions for using program editors with Programmer's Library in 
stand-alone mode may be in the README.DOC file. 

BRIEF Editor 
To loa I J-

• At the DOS prompt, type 
b -M20 
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To start Programmer's Library from within BRIEF: 

1. Press ALT+Z. 

2. Type msl, or msl II, if you're using expanded memory. Specify the complete 
path name, as appropriate. 

To exit Programmer's Library and return to BRIEF: 

I. Press Esc and then press Enter. 

2. Type exit to return to BRIEF. 

NOTE: If you're using Programmer's Library as a TSR with the BRIEF 
Editor, see the special instructions in Appendix A. 

VEDIT Editor 

To Start Prognn mer's Library from within VH)f r: 
I. Press Esc. 

2. Highlight Command mode and press Enter. 

3. Type oc c:\msl. Specify the complete pathname, as appropriate. 

To exit P cgr'llllm r 's L'brary and return to VI:DIl: 

I. Press Esc and then press Enter. 

2. Press V and then press Enter. 

Epsilon version 3.21 

To Start Progr 'll n ~ '~ Librar~ from within Ep!.ilon: 

1. Press Ctrl+X. 

2. Press Ctrl+E. 

3. Type msl. Specify the complete path name, as appropriate. 
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To exit Programmer's Library and return to Epsilon: 

1. Press Esc and then press Enter. 

2. Type exit. 

Turbo Pascal version 4.0 
To Start Programmer's Library from within Turbo Pascal: 

l. Press FlO. 

2. Press F. 

3. Press O. 

4. Type msl. Specify the complete pathname, as appropriate. 

NOTE: You can also execute these commands with a mouse by choosing 
the OS shell command from the File menu. 

To exit Programmer's l ,ibrary and return to Turbo Pascal: 

I. Press Esc and then press Enter. 

2. Type exit. 

Microsoft QuickC versions 1.0 and 2.0 
To Start Programmer's Library from within Microsoft Quicke: 

1. Press Alt. 

2. Press F. 

3. Press D. 

4. Type msl. Specify the complete path name, as appropriate. 

NOTE: You can also execute these commands with a mouse by displaying 
the File menu and clicking the DOS Shell command. 
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To exit Programmer's Library and return to Microsoft Quicke: 

I. Press Esc and then press Enter. 

2. Type exit. 

Microsoft QuickBASIC version 4.5 
To Start Programmer's Library from within QuickBASIC: 

l. Press Alt. 

2. Press F. 

3. Press D. 

4. Type msl. Specify the complete pathname, as appropriate. 

NOTE: You can also execute these commands with a mouse by displaying 
the File menu and clicking the DOS Shell command. 

To exit Programmer's Library and return to QuickBASIC: 

I. Press Esc and then press Enter. 

2. Type exit. 

Norton Editor version 1.3C 
To Start Programmer's Library from within Norton Editor: 

1. Press F9. 

2. Type msl. Specify the complete path name, as appropriate. 

To exit Programmer's Library and return to Norton Editor: 

1. Press Esc and then press Enter. 

2. Press Enter again. 
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Turbo eversion 1.5 
To Start Programmer's Library from within Turbo C: 

1. Press FlO. 

2. Press F. 

3. Press O. 

4. Type msl. Specify the complete path name, as appropriate. 

NOTE: You can also execute these commands with a mouse by choosing 
the as shell command from the File menu. 

To exit PrtlOr. mm r' '1) ~n!> cI ret rn to 'I urbo ( : 

1. Press Esc and then press Enter. 

2. Type exit. 

Microsoft Editor version 1.0 
To start Programm ~,~ Library from within Microsoft Editor ver.,ion 1.0: 

1. Press Alt+A. 

2. Type msl. Specify the complete path name, as appropriate. 

3. Press Shift+F9. 

To exit Programmer's Library and return to Microsoft Editor version 1.0: 

1. Press Esc until the Exit dialog box appears. 

2. Choose the OK button by pressing Enter or by clicking the button with the 
mouse. 
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Microsoft Word 

fo start Programmer's Librar~ from within Microsoft Word: 

I. Press Esc. 

2. Select the Library menu. 

3. Choose the Run command. 

4. Type msl. Specify the complete path name, as appropriate. 

Programmer's Library is now running in stand-alone mode on your computer. 
Microsoft Word is the inactive application. 

I. Press Esc until the Exit dialog box appears. 

2. Choose the OK button by pressing Enter or clicking it with the mouse. 

3. Press any key to return to Microsoft Word. 

Programmer's Library is removed from memory , and Microsoft Word is now the ac
tive appl ication. 





Appendix A: Technical Information 
This section provides reference information about Programmer's Library, including 
error messages, Setup program information, and details about searching. 
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Error Messages 
The following error messages may appear as you set up and use Programmer's Li
brary. Messages are listed in alphabetic order, with a brief explanation of how to re
spond to each message. 

If you see this message 

CDRIOI :Read Failed Abort, 
Retry, Ignore 

CDR 103: Disc in drive is not 
High Sierra 

Couldn ' t read virtual 
memory file 

DOS error 

Error reading resource file 
encountered 

Expanded memory not 
available 

Internal MS Library error 

Invalid drive specification 

MS Library not correctly 
installed; run Setup 

Do this 

Check to see that there is a disc in your CD-ROM drive and 
that the drive door is closed. Type R to retry access to Pro
grammer's Library. 

The MS-DOS CD-ROM Extensions will work only with com
pact disc files that are in the High Sierra format (ISO 9660). 
Be sure that the disc in your drive is the Programmer's Li
brary disc. 

Programmer's Library cannot write to either the TM P envi
ronment variable directory or the Programmer's Library exe
cutable directory . The directories may be specified as " read 
only." 

The disk operating system (DOS) is not functioning properly. 
Save any documents that are open in other applications, then 
reboot your computer and start Programmer's Library again. 

Your computer encountered a disk error while trying to read 
from the Programmer's Library resource files or the 
MSL.RES file. Rerun the Setup program or refer to the in
structions for manual setup in the README.DOC file. 

Programmer' s Library is unable to use LIM 3.2 or higher ex
panded memory because LIM is not present or is not properly 
installed. 

Press any key to exit Programmer' s Library when you receive 
an Internal MS Library error message (numbered 1,000 or 
higher). Save any documents that are open in other applica
tions, then reboot your computer and start Programmer's Li
brary again. 

Be sure that the drive letter and the directory correspond to 
the location you specified when running the Setup program. 

Rerun the Setup program or refer to the instructions for 
manual setup in the README.DOC file. 

(continued) 
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If you see this message 

MS Library product is 
already loaded 

Not enough disk space for 
virtual memory file 

Do this 

Programmer' s Library or another Microsoft CD-ROM Li
brary product is already memory-resident. Press the defined 
hotkey sequence (Alt+left Shift is the default sequence) to dis-
play the Main menu bar. 

The 300K required for the virtual memory file is not avail
able on the disk that holds the TMP environment variable 
directory or the Programmer' s Library executable directory. 
Follow these instructions to avoid any possible damage to 
your system : 

I. Unload Programmer's Library by choosing the Unload 
command from the Options menu (Main menu bar). 

2. Check to see if either the TMP environment variable 
directory or the Programmer's Library executable directory 
contains the BOOKYIRT.MEM file. If this file is found , de
lete it to free up additional disk space. 

Warning: Never delete the BOOKVIRTMEM file while Programmer's Library or any other 
Microsoft CD-ROM Library product is loaded in memory. Doing so may corrupt your hard disk. 
If you should delete the file accidentally, reboot your computer immediately. 

Not enough memory 

Not enough memory to run 
resident; try msl 

Runs only DOS 3.1, 3.2, or 
3.3 

Usage: msl ltxlfb 

Not enough memory is available to run Programmer's Li
brary. Unloading other memory-resident applications may 
release the memory required to run Programmer's Library. 

If you're using LIM 3.2 or higher, try loading Programmer's 
Library by typing msl 1/ at the DOS prompt. 

If you normally have sufficient memory to run Programmer' s 
Library, reboot your computer to reclaim any memory that 
was lost. 

Not enough memory is available to run Programmer's Li
brary as a memory-resident program, but it may be possible 
to run it in stand-alone mode. Try loading Programmer's 
Library by typing msl at the DOS prompt. 

Programmer's Library requires DOS 3.1,3.2, or 3.3. You can 
use DOS 4.0 if you're using MS-DOS CD-ROM Extensions 
2.1. 

An invalid DOS parameter has been specified. You can load 
Programmer's Library without parameters or with any of the 
following parameters: 

It memory-resident program 

Ix use extra base memory 

II use LIM 3.2 or later memory 

If increase the size of the virtual memory file 

Ib black-and-white display 
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Setup Information 

The Microsoft CD-ROM Library 
Programmer's Library is part of a family of Microsoft CD-ROM Library products. 
Each product in this family uses the same MS Library software. Whenever you ob
tain a new Microsoft CD-ROM Library product, be sure to run the Setup program 
provided with the product. By using the current Setup program, you ensure that all 
Microsoft CD-ROM Library products in use are updated to take advantage of new 
software features. 

The Library Directory 
Before Programmer's Library can be used, a directory called the Library directory 
must be created by the Setup program that resides on the CD-ROM disc. Your Li
brary directory (for example, C:\MSLIB) will contain the MS Library software 
(used by all Microsoft CD-ROM Library products) as well as software specifical ly 
designed for Programmer's Library. 

The following steps are performed by the Setup program: 

I. Setup creates your Library directory, if you don't already have one. If you 
use more than one Microsoft CD-ROM Library disc, all of the discs should 
use the same Library directory if you want all of the discs to be listed in the 
Library dialog box. 

2. Setup copies the MS Library software from your Programmer's Library 
disc to your Library directory, unless your Library directory contains a 
more recent version of the software. Each Microsoft CD-ROM Library disc 
contains a version of the MS Library software; Setup will never replace a 
version of software with another, older version. 

3. Setup copies the Programmer's Library software from your CD-ROM disc 
to your Library directory. 

4. Setup creates a file named MSL.INI in your Library directory , unless this 
file already exists. The format of this file is described later in this section. 
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5. If Programmer's Library is the first Microsoft CD-ROM Library disc that 
was set up in your Library directory, Setup will optionally modify your 
CONFIG.SYS file to increase the number specified by the "FILES=" line, 
to ensure that the MS Library software will operate properly while a pro
gram editor or word processing application is being loaded. 

Temporary Magnetic Disk Space Used by 
the MS Library Software 
Each time the MS Library software is run, it creates a file called BOOKYIRT.MEM, 
which is about 300 kilobytes in size and is used for temporary storage. If you do 
very large searches, you can increase the size of BOOKYIRT.MEM by loading the 
MS Library software with the Ifparameter. Type msl If followed by a number greater 
than 300. 

This file is created in the directory specified by the TMP environment variable. 
(Many programming tools, including the Microsoft C Optimizing Compiler, also ex
amine the TMP environment variable to determine where to create temporary files.) 
To set TM P to the name of a directory on your hard disk or floppy disk, edit your 
AUTOEXEC.BAT file and reboot your computer. For example, type: 

set tmp=c:\ temp 

This example specifies the directory c: \temp as the directory that will contain tem
porary files. 

NOTE: For more information about the TMP em'ironment variable and 
the AUTOEXEC.BAT file, see your DOS manual. 

NOTE: Never delete the BOOKVIRTMEM file while the MS Library soft
ware is loaded. 

Using a RAM Disk 
The MS Library software wi II operate faster if the di rectory speci fied by the TM P 
variable is located on a RAM disk that has at least 300K of free disk space. To use a 
RAM disk with MS Library software, set the TMP environment variable in your 
AUTOEXEC.BAT file to specify a directory on your RAM disk . 



Appendix A: Technical Information 93 

For example, to specify the root of drive E (where drive E is a RAM drive) as the 
directory that will contain temporary files, type: 

set tmp=e:\ 

Format of the MSL.INI File 
The MSL.INI file in your Library directory is read by the MS Library software each 
time it is loaded. This file contains information about each reference category or 
each Microsoft CD-ROM Library product you 've set up in your Library directory . 
You will not normally need to modify the contents of MSL.INI , since the Setup pro
gram automatically updates MSL.INI. However, if you choose to arrange your files 
in a nonstandard way, you may need to know how the MS Library software inter
prets the information in the MSL.INI file. A typical MSL.INI file looks like this : 

[msl] 

OS2, 

WINDOWS, 

NET, 

MSDOS, 

MSJ, 

HW, 

C, 

MASM, 

BASIC, 

PASCAL , 

FORTRAN, 

OS/2 References, D: \BOOKS, 1011 

Windows References, D: \BOOKS, 1012 

Network References, D:\BOOKS, 1013 

MS-DOS References, D:\BOOKS, 1014 

MS Systems Journal, D: \BOOKS, 1015 

Hardware References, D: \BOOKS, 1016 

C References, D: \BOOKS, 1017 

MASM References, D:\BOOKS , 1018 

BASIC References, D:\BOOKS, 1019 

Pascal References, D:\BOOKS, 1020 

FORTRAN References, D: \BOOKS, 1021 

Each MSL.INI file starts with a line containing " [msll. " The following lines each 
contain information about a single reference category. Each line contains the follow
ing four fields, separated by commas: 

• The first field is the short name of the reference category (for example, 
MSDOS) and is used internally by the MS Library software. The names of 
the software files used by a reference category (for example, MS-DOS Ref
erences) will be listed in a file located in your Library directory . The name 
of this file is the reference category's short name with the extension 
".FLS" (for example, "MSDOS.FLS " ). The names of the files used by the 
MS Library software itself are listed in the MSL.FLS file. 
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• The second field is the long name of the reference category. This is the 
name that is shown in the Library dialog box on the Options menu. 

• The third field contains the name of one or more directories. Multiple direc
tory names must be separated by semicolons (;), with no intervening spaces 
(just like the PATH environment variable in MS-DOS). Whenever the MS 
Library software tries to locate a file used by a reference category, it looks 
in each of the directories specified in the third field after first looking at the 
directory specified by the TMP environment variable and your Library 
directory. 

• The fourth field is the reference category number, which is used internally 
by the MS Library software. This number should never be changed. 



Appendix A: Technical Information 95 

Details About Searching 
Each Microsoft CD-ROM Library product or reference category has an associated 
search index which lists the locations of all occurrences of almost every word con
tained in the product or reference category. When you construct a query using the 
Search dialog box, the MS Library software consults the search index to quickly 
locate all of the places in the reference category that satisfy your query. Since the 
MS Library software takes care of all of the detai Is of search i ng, you normally need 
not be concerned about the contents of search indexes. However, certain common 
words, punctuation, and other characters are not indexed. You may therefore find it 
useful to know exactly what has been indexed and what has not. 

All reference category search indexes include words that meet all of the fol
lowing criteria: 

• The word must be a sequence of characters including only the following, in 
any combination: 

-Upper-case letters (A to Z) 
-Lower-case letters (a to z) 
-Certain foreign-language letters in the PC extended character set (charac-

ter codes 128 to 154, inclusive, and 160 to 165, inclusive) 
-Digits (0 to 9) 
-The underscore character C) 
-Apostrophe ( , or ' ) 
-Period (.) surrounded by letters or digits 

• The word must contain at least one letter, unless the word is a 4-digit or 
5-digit word (for example, 1980,8086, or 80386). 

• The word must be more than one character in length. 
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• The word must not be included in the following list: 

an from she 
and have that 
as he the 
at in they 
be it this 
but not to 
by of we 
do on with 
for or you 

If you type a word in the Search dialog box that is not indexed, the dialog box will 
report that zero occurrences were found. 

The Search dialog box is not sensitive to upper-case or lower-case; searching for 
"MOY" would find any occurrences of "mov" or "MOY." Words containing 
underscores, apostrophes, and periods are specially indexed to make searches as use
ful as possible. For example, searching for "NY" would find any occurrences of 
"N.Y." or "NY." Searches for "text" would find any occurrences of "TEXT" or 
"text. " 
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Using Programmer's Library as a TSR 
with the BRIEF Editor 

When you're using Programmer's Library as a TSR with the BRIEF editor, your 
cursor may disappear when you start BRIEF. This is caused by an incompatibility 
between Programmer's Library and the multiple video display pages used by 
BRIEF. When used with Programmer's Library, BRIEF uses the second video dis
play page to display your text and reserves the first video display page for your DOS 
screen. 

Use the" -p" option to tell BRIEF to use the first video display page instead of the 
second. This will ensure that your BRIEF cursor is displayed properly. 

Follow these instructions when loading BRIEF for use with Programmer' s Library. 

To load a BRIEF file: 

• At the DOS prompt, in lower-case letters, type: 
b -p -cl,J ,3,3 {filename} 

Here, b refers to the B.EXE file (BRIEF), -p and -cl refer to parameters, 
and filename is the name of the BRIEF file you want to edit. 

You can also store the parameters (-p and -cl,l,3,3) as an environment variable so 
that they are entered automatically each time you load a BRIEF file. Use the Set 
command to create the environment variable. 

To create an environment variable: 

I. At the DOS prompt, type 
set BFLAGS=-p -cl,J ,3,3 

2. Press Enter. 

To load a BRIEF file after creating the environment variable: 

• At the DOS prompt, type: 
b {filename} 
where filename is the name of the BRIEF file you want to edit. 
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Running Programmer's Library Under 
Microsoft Windows 386 

You can run Programmer's Library under Microsoft Windows 386 as a virtual ma
chine. To do so, you must create a .PIF fi Ie to describe the requirements of the 
software. 

Use the PIFEDIT program supplied with Microsoft Windows 386 to create the .PIF 
file . A screen is displayed which allows you to enter the following information: 

Name of program: msl.exe 

Default directory: c:\msl ib or the name you supplied during Setup 

Parameters: It if you plan to run Programmer' s Library as a memory-resident 
appl ication 

Required memory: At least 140K if you plan to run Programmer' s Library as a 
stand-a lone application; at least 200K if you plan to run Programmer 's Library as a 
memory-resident appl ication 

Screen exchange: Disabled 
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Append command 44, 75 
Appending information to the Clipboard 44-45, 69 
Author menu 

B 
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Delete Bookmark command 48, 77 
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Base memory 63 
Bookmarks 
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Deleting 48, 77 
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Boolean searches 31 
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Special considerations 97 

Browse menu 
General Index command 32, 78 
Quick Reference 78 
Table of Contents command 32, 78 

Browser menu bar 
Description 21-22 
Quick Reference 75-79 

Browsing 
General Index 32, 78 
in Programmer 's Library 31-32 
in selected reference categories 32 
Table of Contents 32, 78 
Viewing levels 33 

Index 99 

C 
CD-ROM drive setup 9 
CD-ROM Extensions setup see MS-DOS CD-ROM 

Extensions setup 
CD-ROM Library see Microsoft CD-ROM Library 
Choosing references and commands 

with keyboard 22, 67 
with mouse 22, 67 

Clipboard 
Adding contents to a file 46 
Appending information to 44-45, 69, 75 
Copying information to 44,69,76 
Pasting contents of 45-46,69, 76 
Replacing contents of 46 
Saving contents of 46, 74 

Colors command 62, 74 
Columns 

Hiding 57, 70, 77 
Locking 58, 77 
Revealing 57-58, 77 
Unlocking 58, 77 

Command button 27-28 
Configuring memory 63-64 
Contents menu 

Browsing within a reference category 32 
Quick Reference 72-73 

Conventions used in this manual 4 
Copy command 44, 76 
Copying information 

to the Clipboard 44, 69, 76 
to your editor or word processor 45,69, 74 
see also Appending information 

Create Bookmark command 47, 77 
Cross-ref command 52-53, 76 
Cross-references 

Returning to text 52-53 , 76 
Symbol 52 
Viewi ng 32,41, 52-53, 70, 76 
View menu 52-53 ,76 
see Next Command 
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Cross-references (continued) 
see Previous Command 
see Selecting Viewing Options 

Customizing Programmer's Library 
Changing screen colors 62 
Changing startup keys 61 
Hotkeys command 61,74 

D 
Date Stamp command 60, 74 
Default startup keys 12, 61, 67 
Delete Bookmark command 48, 77 
Dialog box 27-28, 67-69 
DOS directory, accessing sample code 50-51 

E 
Edit menu 

Append command 44-45, 75 
Copy command 44, 76 
Paste command 45-46, 76 
Quick Reference 75-76 

Epsilon program editor 7,81 
Error messages 89-90 
Exiting . 

Keeping Programmer's Library memory-resident 
13-14 

Removing Programmer's Library from memory 
14-15,68,69 

When loaded in stand-alone mode 13 
Expanded memory 63 

F 
Find command 

Description 38, 78 
Finding a string of characters 38 

Footnote command 
Displaying 53, 76 
Removing 53 
Symbol 52 
see also Selecting Viewing Options 

Function keys see Keyboard shortcut keys 

G 
General Index command 32, 78 
Graphics 4 

H 
Hardware 

Needed 6 
Optional 6 
Reference category 3 

Help 
on specific topics 24 
while performing tasks 23 

Help menu 
About command 75 
General Index command 24 
Quick Help command 23, 68 
Quick Reference 75 
Search command 24 
Table of Contents command 24 

Hide Column command 57, 77 
Hotkeys command 

I 

Changing startup keys 61, 74 
Starting with 12,74 

Index menu 

K 

Browsing within a reference category 32 
Quick Reference 73 

Keyboard 

L 

Choosing references and commands 22 
Quick Reference 67-68 
Shortcut keys 69-71 

Library 
Changing discs 29-30 
Command 29 
List box 29, 30 

List box 28 
Loading see Starting 
Location 

Box 54 
Checking 54-55 
Command 54, 76 

Lock Column command 58, 77 
Lock Titles command 59, 77 



M 
Magnetic disk space 

Used by MS Library 92 
Used by RAM disk 92 

Main menu bar 
Description 19-20 
Quick Reference 72-75 

Match Words In list box 34-37 
Memory 

Configuring 63 
Needed 6 
Optional 6 

Memory-resident status see Terminate-and-stay
resident 

Menu bar 
Browser 21-22 
Description 19 
Main 19-20 

Menus 
Description 20, 72-78 
see also individual menu name 

Microsoft CD-ROM Library 
Description 91 
Setup 91-92 

Microsoft CD-ROM Library discs, changing 29, 70, 74 
Microsoft Editor 7, 84 
Microsoft Word 

with Programmer's Library in stand-alone mode 85 
Mouse 

Choosing references and commands 22 
Quick Reference 67-68 

MS-DOS CD-ROM Extensions setup 9-10 

N 
Next command 38, 40,41 , 53, 79 
Norton program editor 7, 83 
Notational conventions 4 

o 
Options menu 

Bookmarks command 47-48, 74 
Colors command 62, 74 
Date Stamp command 60, 74 
Hotkeys command 61,74 

Options menu (continued) 
Library command 29, 74 
Paste command 45, 74 
Quick Reference 74 

p 

Save Clipboard command 46, 74 
Unload command 14, 15,74 

Paste command 
Description 45, 74 
Disabled 46 

Pasting 
in stand-alone mode 46 
into your editor or word processor 45 
Using a color monitor 46 

Previous command 40, 41 , 53, 78 
Program editors 

Supported 7 
Technical information 97 

Index 101 

with Programmer's Library in stand-alone mode 
80-84 

see also individual program editor name 

Q 
QuickBASIC program editor 7, 83 
QuickC program editor 7,82 
Quick Help command 23 , 68, 75 
QuickRef command 

Description 38-39, 78 
from a QuickRef reference 40 
from Browser menu bar 39 
from Main menu bar 39 
from program editor 40 
from word processing application 40 
References available through 39 
Viewing occurrences see Selecting viewing options 

QuickRef menu 
Selecting a reference 39 
Quick Reference 73 

Quick Reference 
Commands 74-79 
Keyboard 67-71 
Menus 72-78 
Mouse 67-68 
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R 
RAM disk 92 
README.DOC vii 
Reference categories 

Hardware reference category 3 
Microsoft BASIC Language reference category 4 
Microsoft C Language reference category 4 
Microsoft FORTRAN reference category 4 
MIcrosoft Macro Assembler reference category 4 
MIcrosoft OS/2 reference category 3 
Microsoft Pascal Language reference category 4 
Microsoft Systems Journal reference category 3 
MIcrosoft Windows reference category 3 
MS-DOS reference category 3 
Network reference category 3 

Reference category or disc 
at startup 29 
Automatic selection on restart 29 
Changing 29-30, 68, 74 

Removing Programmer's Library from memory 
when loaded in stand-alone mode 13 
when loaded as a TSR 14 15 

Return command 53, 76 ' 
Reveal Column command 57, 77 

S 
Sample code see Accessing sample code 
Save Clipboard command 46, 74 
Screen colors, customizing 62 
Scroll bar 25-27 
Scrolling techniques 

Keyboard 25-26, 68 
Mouse 26-27, 68 

Searching 
a group of references 31,33-34 
a reference 31, 33-34 
Carrying out a search 36 
Description 31,33 
Index criteria 95 
Search dialog box 34-36 
Technical information 95-96 
Viewing levels 33, 37 
Viewing search results 37 

Search menu, Browser menu bar 
Find command 33, 38, 78 
QuickRef command 34, 38-40, 78 
Quick Reference 78 
Search command 33, 34, 78 

Search menu, Main menu bar 
Selecting a group of references 34 
Selecting a reference 34 
Quick Reference 72 

Selecting viewing options 41 
Setup information 

CD-ROM drive 9 
Microsoft CD-ROM Library 91 
MS-DOS CD-ROM Extensions 9 
Technical information 91 
Temporary magnetic disk space used 92 

Setup program 
Getting started 9-12 
see a/so Appendix A 

Shortcut key combinations 42, 69-71 
Software needed 6 
Stand-alone mode 

Exiting 13 
Loading II 
With program editors and word processors 80-85 

Starting 

T 

Loading in stand-alone mode 11,67 
Loading Programmer's Library into memory as a 

TSR 12,67 
Startup keys, customizing 61 

Table 
Hiding and revealing columns 57-58, 70, 77 
Locking and unlocking columns 58, 77 
Locking titles 59, 77 
Ruler 57-59 
Scrolling within 56 
see a/so Scrolling Techniques 

Table menu 
Hide Column command 57, 77 
Lock Column command 58, 77 
Lock Titles command 59, 77 
Quick Reference 77 
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Reveal Column command 57-58, 77 
Unlock Column command 58, 77 

Table of Contents 
Command 32, 78 

Tables see Table 
Technical information 87-98 
Term boxes 34-36 
Term inate-and-stay-resident 

Loading 12 
Exiting 14 

Time stamp see Date Stamp 
TSR see Terminate-and-stay-resident 
Turbo C program editor 7, 84 
Turbo Pascal program editor 7, 82 

U 
Unload command 14,74 
Unlock Column command 58, 77 
Unlocking 

V 

Columns 58 
Titles 59 

VEDIT program editor 7, 81 
View menu 

Bookmarks command 47-49, 74, 76 
Cross-ref command 52-53, 76 
Footnote command 53, 76 
Location command 54, 76 

View menu (continued) 
Quick Reference 76 
Return command 53, 76 
Zoom In command 33, 42-43 , 76 
Zoom Out command 42-43 , 76 

Viewing levels 
Chapter 33, 43 
Directory 33 
File 33 
Function 33 
Paragraph 33, 43 
Section 33, 43 
Subsection 33, 43 
see also Selecting viewing options 

Viewing options, selecting 41 

Index 103 

Virtual machine, running Programmer's Library under 
Microsoft Windows 38698 

W 
Word processiflg applications 

Supported 7-8 
with Programmer's Library in stand-alone mode 85 

Z 
Zoom In command 

Description 42, 76 
Example 33, 42, 43 

Zoom Out command 
Description 42, 76 
Example 42, 43 
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